gnokii-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463
  1. # TODO: merge patches upstream where applicable
  2. Name: gnokii
  3. Version: 0.6.27
  4. Release: 4%{?_dist_release}
  5. Summary: Linux/Unix tool suite for various mobile phones
  6. Summary(ja): Linux/Unix tool suite for various mobile phones
  7. Group: Applications/Communications
  8. License: GPLv2+
  9. URL: http://www.gnokii.org/
  10. Source0: http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
  11. #----------------------------------------------------------------------------
  12. Source2: gnokii-smsd.init
  13. Source3: gnokii-smsd.sysconfig
  14. Source4: gnokii-smsd.logrotate
  15. Source5: gnokii-smsd2mail.sh
  16. Source6: gnokii-smsd-README.smsd2mail
  17. # Patch to make gnokii use "htmlview" instead of "mozilla" as default browser
  18. Patch0: gnokii-htmlview.patch
  19. # Patch to remove port locking and apply the system-wide /usr/sbin directory
  20. # to the path instead of the default /usr/local
  21. Patch1: gnokii-config.patch
  22. #----------------------------------------------------------------------------
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. #----------------------------------------------------------------------------
  25. BuildRequires: flex
  26. BuildRequires: gettext
  27. BuildRequires: gtk2-devel
  28. BuildRequires: desktop-file-utils
  29. BuildRequires: ImageMagick
  30. BuildRequires: postgresql-devel
  31. BuildRequires: mysql-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: bluez-libs-devel
  34. BuildRequires: libusb-devel
  35. BuildRequires: libical-devel >= 0.24
  36. # VineSeed
  37. BuildRequires: libXt-devel
  38. BuildRequires: libXpm-devel
  39. ## VineLinux-4.x
  40. ## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
  41. BuildRequires: perl(XML::Parser)
  42. Requires(pre): %{_sbindir}/groupadd
  43. #----------------------------------------------------------------------------
  44. %description
  45. Gnokii provides tools and a user space driver for use with mobile
  46. phones under Linux, various unices and Win32. With gnokii you can do
  47. such things as make data calls, update your address book, change
  48. calendar entries, send and receive SMS messages and load ring tones
  49. depending on the phone you have.
  50. #----------------------------------------------------------------------------
  51. %package -n xgnokii
  52. Summary: Graphical Linux/Unix tool suite for various mobile phones
  53. Group: Applications/Communications
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n xgnokii
  56. Xgnokii is graphical Linux/Unix tool suite for various mobile
  57. phones. It allows you to edit your contacts book, send/read SMS's
  58. from/in computer and more other features.
  59. #----------------------------------------------------------------------------
  60. %package smsd
  61. Summary: Gnokii SMS daemon
  62. Group: System Environment/Daemons
  63. Requires: %{name} = %{version}-%{release}
  64. Requires(pre): %{_sbindir}/useradd
  65. Requires(post): /sbin/chkconfig
  66. Requires(preun): /sbin/chkconfig
  67. %description smsd
  68. The Gnokii SMS daemon receives and sends SMS messages.
  69. #----------------------------------------------------------------------------
  70. %package smsd-pgsql
  71. Summary: PostgreSQL support for Gnokii SMS daemon
  72. Group: System Environment/Daemons
  73. Requires: %{name}-smsd = %{version}-%{release}
  74. Obsoletes: %{name}-smsd-postgresql < 0.6.4-0.lvn.2
  75. %description smsd-pgsql
  76. %{summary}.
  77. #----------------------------------------------------------------------------
  78. %package smsd-mysql
  79. Summary: MySQL support for Gnokii SMS daemon
  80. Group: System Environment/Daemons
  81. Requires: %{name}-smsd = %{version}-%{release}
  82. %description smsd-mysql
  83. %{summary}.
  84. #----------------------------------------------------------------------------
  85. %package devel
  86. Summary: Gnokii development files
  87. Group: Development/Libraries
  88. Requires: %{name} = %{version}-%{release}
  89. Requires: pkgconfig
  90. %description devel
  91. %{summary}.
  92. #----------------------------------------------------------------------------
  93. %prep
  94. %setup -q
  95. %patch0 -p0
  96. %patch1 -p0
  97. install -pm 644 %{SOURCE5} smsd2mail.sh
  98. install -pm 644 %{SOURCE6} README.smsd2mail
  99. %build
  100. %configure --enable-security --disable-rpath --disable-static \
  101. --enable-libical
  102. make %{?_smp_mflags}
  103. #----------------------------------------------------------------------------
  104. %install
  105. make install DESTDIR=$RPM_BUILD_ROOT
  106. # Rename smsd to gnokii-smsd
  107. mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
  108. mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
  109. sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  110. sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
  111. # Remove libtool droppings
  112. rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
  113. # Fix up the default desktop file
  114. desktop-file-install \
  115. --delete-original \
  116. --vendor "" \
  117. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  118. --mode 644 \
  119. --add-category X-VineLinux \
  120. $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
  121. # Convert the default icons to PNG
  122. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
  123. convert Docs/sample/logo/gnokii.xpm \
  124. $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  125. chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
  126. # Install the configuration files
  127. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
  128. install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
  129. install -Dpm 644 %{SOURCE4} \
  130. $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
  131. cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
  132. # Install the docs
  133. mkdir -p temporary-gnokii-docs/
  134. mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
  135. %find_lang %{name}
  136. %clean
  137. rm -rf $RPM_BUILD_ROOT
  138. #----------------------------------------------------------------------------
  139. %pre
  140. %{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
  141. %pre smsd
  142. %{_sbindir}/useradd -r -M -d / -g gnokii \
  143. -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
  144. %post -p /sbin/ldconfig
  145. %postun -p /sbin/ldconfig
  146. %post smsd
  147. /sbin/chkconfig --add gnokii-smsd
  148. %preun smsd
  149. if [ $1 -eq 0 ] ; then
  150. %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
  151. /sbin/chkconfig --del gnokii-smsd
  152. fi
  153. %postun smsd
  154. if [ $1 -ge 1 ] ; then
  155. %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
  156. fi
  157. #----------------------------------------------------------------------------
  158. %files -f %{name}.lang
  159. %defattr(-,root,root,-)
  160. %doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
  161. %config(noreplace) %{_sysconfdir}/gnokiirc
  162. %attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
  163. %{_bindir}/gnokii
  164. %{_bindir}/sendsms
  165. %{_bindir}/gnokiid
  166. %{_libdir}/libgnokii.so.*
  167. %{_mandir}/man1/gnokii.1*
  168. %{_mandir}/man1/sendsms.1*
  169. %{_mandir}/man8/gnokiid.8*
  170. %{_mandir}/man8/mgnokiidev.8*
  171. %files -n xgnokii
  172. %defattr(-,root,root,-)
  173. %doc xgnokii/ChangeLog xgnokii/README.vcard
  174. %{_bindir}/xgnokii
  175. %{_datadir}/pixmaps/xgnokii.png
  176. %{_datadir}/applications/*xgnokii.desktop
  177. %{_mandir}/man1/xgnokii.1*
  178. %{_prefix}/share/xgnokii/
  179. %files smsd
  180. %defattr(-,root,root,-)
  181. %doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
  182. %attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
  183. %config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
  184. %{_initrddir}/gnokii-smsd
  185. %{_bindir}/gnokii-smsd
  186. %{_mandir}/man8/gnokii-smsd.8*
  187. %dir %{_libdir}/smsd/
  188. %{_libdir}/smsd/libsmsd_file.so
  189. %files smsd-pgsql
  190. %defattr(-,root,root,-)
  191. %doc smsd/sms.tables.pq.sql
  192. %{_libdir}/smsd/libsmsd_pq.so
  193. %files smsd-mysql
  194. %defattr(-,root,root,-)
  195. %doc smsd/sms.tables.mysql.sql
  196. %{_libdir}/smsd/libsmsd_mysql.so
  197. %files devel
  198. %defattr(-,root,root,-)
  199. %{_includedir}/gnokii*
  200. %{_libdir}/libgnokii.so
  201. %{_libdir}/pkgconfig/gnokii.pc
  202. %{_libdir}/pkgconfig/xgnokii.pc
  203. #----------------------------------------------------------------------------
  204. # Maintainers: babasaki@mindgear.org
  205. #
  206. #----------------------------------------------------------------------------
  207. %changelog
  208. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
  209. - rebuilt with MySQL-5.1.34.
  210. * Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
  211. - Import gnokii - Packager: Babasaki
  212. - Updated specfile
  213. #----------------------------------------------------------------------------
  214. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
  215. - Fix htmlview patch
  216. * Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
  217. - Update to 0.6.27
  218. * Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
  219. - Rebuild
  220. * Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
  221. - Rebuild with libical support
  222. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
  223. - Update to 0.6.26
  224. * Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
  225. - Set empty --vendor rather none for using desktop-file-install
  226. - Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
  227. * Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
  228. - Update to 0.6.25
  229. * Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
  230. - Update to 0.6.24
  231. * Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
  232. - Rebuild for GCC 4.3.
  233. * Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
  234. - Pick up new libssl .solib version dependency.
  235. * Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
  236. - Update to 0.6.22
  237. * Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
  238. - Update to 0.6.20
  239. * Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
  240. - Even better multilib fixing (#335161)
  241. * Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
  242. - Quick fix to multilib conflict (#335161)
  243. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
  244. - New upstream release
  245. * Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
  246. - Update license field from GPL to GPLv2+
  247. * Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
  248. - New upstream release
  249. * Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
  250. - New upstream release
  251. - Update smsd name change patch
  252. - ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
  253. upstream
  254. * Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
  255. - Rebuild to pick up new libpq IF
  256. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
  257. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  258. * Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
  259. - New upstream release.
  260. * Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
  261. - Rebuild for Fedora Extras 6.
  262. * Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
  263. - Bump because tagged before committing sources and I just
  264. dont know how the f* you delete a tag in CVS at the moment
  265. and it does seem like a too big endavour to find out just
  266. in order to have a nice release tag.
  267. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
  268. - New upstream release.
  269. - New dependency on libusb for USB serial, DKU no longer needed/wanted
  270. so now we have that troublesome issue resolved once and for all.
  271. - Remove patches to SQL files: these are now fixed upstream!
  272. * Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  273. - Rebuilding due to changed interface on libbluetooth.
  274. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
  275. - Goofed up. Fixit it...
  276. * Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
  277. - Post-import updates.
  278. * Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
  279. - Updated after comments from Ville.
  280. * Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
  281. - New upstream tarball
  282. * Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
  283. - Updated after comments from Ville.
  284. * Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
  285. - 0.6.11
  286. - Modified to drop into the Fedora Extras as the nice package it now is
  287. - Based work off Ville's good olde package
  288. * Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
  289. - 0.6.10.
  290. - Clean up pkgconfig file and -devel dependencies from bits needed only
  291. for static libs.
  292. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
  293. - 0.6.9, desktop entry file included upstream.
  294. - Drop zero Epochs.
  295. * Sat Aug 6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
  296. - 0.6.8.
  297. - Don't ship static libraries.
  298. - Rename smsd to gnokii-smsd to avoid conflicts with smstools.
  299. - Remove not included files instead of using %%exclude.
  300. * Sat Jun 4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
  301. - BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
  302. * Thu Jun 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
  303. - 0.6.7.
  304. - Build unconditionally with bluetooth support.
  305. * Mon May 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
  306. - 0.6.5.
  307. * Fri Nov 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
  308. - Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
  309. packages in FC/Extras.
  310. * Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
  311. - Update to 0.6.4, perms and pgsql patches applied upstream.
  312. - Xgnokii help locale symlink hack no longer necessary.
  313. - Don't remove user/group on last erase, move smsd user to -smsd subpackage.
  314. - Add libical support (disabled), rebuild with "--with libical" to enable.
  315. * Mon Jul 5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
  316. - Update to 0.6.3.
  317. * Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
  318. - Improve Xgnokii desktop entry according to GNOME HIG.
  319. * Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
  320. - Remove duplicate gettext build dependency (bug 95).
  321. * Sun Jun 6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
  322. - Fix chown syntax in smsd init script.
  323. - Summary and description improvements.
  324. - Trim $RPM_OPT_FLAGS out from gnokii.pc.
  325. - Make -devel require XFree86-devel.
  326. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
  327. - Update to 0.6.1.
  328. * Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
  329. - Make -devel require pkgconfig.
  330. * Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
  331. - Update to 0.6.0.
  332. * Mon Feb 2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
  333. - Update to 0.5.10.
  334. * Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
  335. - Update to 0.5.9.
  336. - Specfile cleanups, small init script enhancements.
  337. * Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
  338. - Update to 0.5.7.
  339. - Move smsd man page into -smsd subpackage.
  340. * Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
  341. - Update to 0.5.6.
  342. - Include sample action script for forwarding SMSD messages to mail.
  343. - s/fedora/livna/.
  344. - Specfile and init script cleanups.
  345. * Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
  346. - Disable smp flags to prevent build failure
  347. * Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
  348. - Update to 0.5.2.
  349. * Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
  350. - Update to 0.5.1.
  351. - Include init script, sysconfig and logrotate config for smsd.
  352. * Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
  353. - Update to 0.5.0.
  354. * Sun Nov 3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
  355. - RedHat'ified PLD version.