g-wrap-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define ver 1.9.11
  2. %define rel 1%{?_dist_release}
  3. Summary: A tool for creating Scheme interfaces to C libraries.
  4. Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
  5. Name: g-wrap
  6. Version: %{ver}
  7. Release: %{rel}
  8. Group: Development/Libraries
  9. License: GPL
  10. URL: http://www.gnucash.org/
  11. Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
  12. Patch0: g-wrap-1.9.6-shaddup.patch
  13. Patch1: g-wrap-1.9.11-libffi.patch
  14. Requires: guile
  15. BuildRequires: guile-devel, libffi-devel
  16. BuildRequires: glib2-devel, slib
  17. Prereq: /sbin/install-info /sbin/ldconfig
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  23. the moment it is most heavily focused on providing access to C
  24. libraries from guile, but it also supports RScheme.
  25. The g-wrap package contains the libraries necessary to run
  26. applications built with g-wrap. If you wish to build applications
  27. that use g-wrap, you should install the g-wrap-devel package.
  28. %description -l ja
  29. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  30. guile から C言語のライブライリへのアクセスを提供することを目的
  31. としています。 RScheme もサポートしています
  32. g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
  33. 必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
  34. 作成したい場合 g-wrap-devel をinstallしてください.
  35. %package devel
  36. Summary: Include files and libraries needed for g-wrap development.
  37. Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
  38. Group: Development/Libraries
  39. Prereq: /sbin/install-info
  40. Requires: g-wrap = %{version}, guile-devel
  41. %description devel
  42. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  43. the moment it is most heavily focused on providing access to C
  44. libraries from guile, but it also supports RScheme.
  45. You can provide access to a given C API by creating a specification
  46. file describing the interface you want published at the Scheme level.
  47. g-wrap will handle generating all the lower level library interface
  48. code so that the C library shows up as a set of Scheme functions.
  49. You should install g-wrap-devel if you need to compile programs that
  50. need to use g-wrap C<->Scheme functionality
  51. %description devel -l ja
  52. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  53. guile から C言語のライブライリへのアクセスを提供することを目的
  54. としています。 RScheme もサポートしています
  55. Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
  56. することによりC PAI へのアクセスを提供します.
  57. g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
  58. できます。したがって C ライブラリには Schem 関数の集合としてみえます.
  59. g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
  60. 場合 g-wrap-devel をinstallしておかねかればなりません.
  61. %prep
  62. %setup -q
  63. %patch0 -p1 -b .shaddup
  64. # https://savannah.nongnu.org/bugs/index.php?25187
  65. %patch1 -p1 -b .libffi
  66. %build
  67. %configure --disable-static
  68. #remove Rpath
  69. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  70. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  71. #Is not parallel-build-safe
  72. %{__make}
  73. %install
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  76. #Remove unneeded file
  77. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
  78. rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
  79. mv ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
  80. cat config.old > config.scm
  81. install -p -m 644 config.scm ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post -p /sbin/ldconfig
  85. %post devel
  86. /sbin/install-info \
  87. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  88. %preun -p /sbin/ldconfig
  89. %preun devel
  90. if [ "$1" = "0" ]; then
  91. /sbin/install-info --delete \
  92. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  93. fi
  94. %files
  95. %defattr(-,root,root)
  96. %doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
  97. %dir %{_libdir}/%{name}
  98. %dir %{_libdir}/%{name}/modules
  99. %{_libdir}/%{name}/modules/*.so.*
  100. %{_libdir}/*.so.*
  101. %{_datadir}/guile/site/*
  102. %files devel
  103. %defattr(-,root,root)
  104. %{_bindir}/*
  105. %{_libdir}/*.so
  106. %{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
  107. %{_libdir}/%{name}/modules/libgw-guile-standard.so
  108. %{_includedir}/*
  109. %{_datadir}/aclocal/*
  110. %{_libdir}/pkgconfig/*
  111. %doc %{_infodir}/g-wrap.*
  112. %changelog
  113. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
  114. - new upstream release
  115. - update BuildRequires: umb-scheme -> slib
  116. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
  117. - applied new versioning policy, spec in utf-8
  118. - removed *.la
  119. * Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
  120. - added Patches from Fedora
  121. * Thu Jul 7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
  122. - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
  123. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
  124. - rebuild with new toolchains
  125. - s/Copyright/License/
  126. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
  127. - build against new guile 1.6.4
  128. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
  129. - based on rawhide 1.3.4-2
  130. - update to 1.3.4
  131. - move .la files to main package (#79068)
  132. - rebuild with new guile 1.6.3
  133. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
  134. - updated to 1.1.10
  135. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
  136. - add defattr
  137. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
  138. - japanized spec file ( add %descripsion -l ja Summary(ja)
  139. * Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
  140. - Don't destroy the build directory -- RPM can do that on its own
  141. - Properly build both g-wrap and g-wrap-devel (info file into -devel)
  142. - currently only one info file
  143. * Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
  144. - use /usr/info/* for automatic gzipping
  145. * Sat May 27 2000 Mark Horning <rip6@rip6.net>
  146. - Created spec file