bogofilter-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. Name: bogofilter
  2. Summary: fast anti-spam filtering by Bayesian statistical analysis
  3. Summary(ja): ベイジアン解析による高速アンチスパムフィルタリング
  4. Version: 1.0.2
  5. Release: 1%{?_dist_release}
  6. URL: http://bogofilter.sourceforge.net/
  7. Source0: http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
  8. Source999: filter-requires-bogofilter.sh
  9. #Patch10: http://www.ono.org/software/dist/%{name}-%{version}+kakasi-0.5.patch.gz
  10. Patch10: %{name}-%{version}+kakasi-0.5.patch
  11. License: GPL
  12. Group: Applications/Internet
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: db4-devel >= 4.3.29, kakasi-devel, gsl-devel, flex
  15. %define __find_requires %{SOURCE999}
  16. %description
  17. Bogofilter is a Bayesian spam filter. In its normal mode of
  18. operation, it takes an email message or other text on standard input,
  19. does a statistical check against lists of "good" and "bad" words, and
  20. returns a status code indicating whether or not the message is spam.
  21. Bogofilter is designed with fast algorithms (including Berkeley DB system),
  22. coded directly in C, and tuned for speed, so it can be used for production
  23. by sites that process a lot of mail.
  24. %prep
  25. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  26. %setup -q
  27. %patch10 -p1 -b .kakasi
  28. %build
  29. %configure --program-prefix=
  30. %__make
  31. %install
  32. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  33. %makeinstall
  34. %__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
  35. %{buildroot}%{_sysconfdir}/bogofilter.cf
  36. for n in xml html ; do
  37. %__install -d -m755 .inst/$n
  38. %__install -p -m644 doc/*.$n .inst/$n
  39. done
  40. for d in contrib ; do
  41. %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
  42. for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
  43. case $f in
  44. *.c|*.o|*.obj|*/Makefile*)
  45. continue
  46. ;;
  47. *.1)
  48. %__cp -p $f %{buildroot}%{_mandir}/man1
  49. ;;
  50. *)
  51. %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
  52. ;;
  53. esac
  54. done
  55. done
  56. for README in contrib randomtrain ; do
  57. %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
  58. done
  59. # drop executable bit from contrib/* to avoid unneeded dependencies
  60. #%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
  61. # -exec %__chmod -x '{}' \;
  62. %clean
  63. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  64. %files
  65. %defattr(-,root,root)
  66. %doc AUTHORS COPYING INSTALL NEWS
  67. %doc README* RELEASE.NOTES* TODO GETTING.STARTED
  68. %doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
  69. %doc doc/programmer
  70. %doc .inst/html .inst/xml
  71. %{_sysconfdir}/bogofilter.cf.example
  72. %config(noreplace) %{_sysconfdir}/bogofilter.cf
  73. %{_bindir}/bogofilter
  74. %{_bindir}/bogolexer
  75. %{_bindir}/bogotune
  76. %{_bindir}/bogoutil
  77. %{_bindir}/bogoupgrade
  78. %{_bindir}/bf_compact
  79. %{_bindir}/bf_copy
  80. %{_bindir}/bf_tar
  81. %{_datadir}/%{name}
  82. %{_mandir}/man1/bogofilter.1*
  83. %{_mandir}/man1/bogolexer.1*
  84. %{_mandir}/man1/bogotune.1*
  85. %{_mandir}/man1/bogoutil.1*
  86. %{_mandir}/man1/bogoupgrade.1*
  87. %{_mandir}/man1/bf_compact.1*
  88. %{_mandir}/man1/bf_copy.1*
  89. %{_mandir}/man1/bf_tar.1*
  90. %changelog
  91. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  92. - applied new versioning policy, spec in utf-8
  93. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
  94. - rebuild with gsl-1.9
  95. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
  96. - rebuild with db4-4.3
  97. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
  98. - add filter-requires-bogofilter.sh (source999)
  99. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  100. - rebuild
  101. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  102. - new upstream release
  103. - modified kakasi patch
  104. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
  105. - rebuild
  106. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
  107. - new upstream release
  108. - update kakasi patch
  109. - remove unneeded macro %%mydocdir
  110. - fix symlink
  111. - add Japanese summary
  112. - drop executable bit from contrib/*
  113. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
  114. - rebuild
  115. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
  116. - new upstream release
  117. - update and modify kakasi patch
  118. - fix dependencies
  119. - add BuildRequires: kakasi-devel, gsl-devel, flex
  120. - add Requires: gsl
  121. - update %%files
  122. - update %%doc
  123. - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
  124. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
  125. - rebuilt with db4-4.2.52
  126. * Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
  127. - new upstream release.
  128. - update kakasi patch.
  129. * Sun May 2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
  130. - new upstream release
  131. - add kakasi patch (http://www.ono.org/software/bogofilter/)
  132. * Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
  133. - upstream release
  134. - using --program-prefix option with configure script
  135. - update %%files section
  136. * Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
  137. - first release for Vine Linux