blender-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. %define blenderlib %{_datadir}/blender
  2. %define plugins %{_libdir}/blender/plugins
  3. Summary: 3D modeling, animation, rendering and post-production.
  4. Summary(ja): 3D モデリング、アニメーション、レンダリング、ポストプロダクション
  5. Name: blender
  6. Version: 2.49
  7. Release: 1%{?_dist_release}
  8. Group: Applications/Multimedia
  9. License: GPL
  10. URL: http://www.blender.org/
  11. Source0: http://download.blender.org/source/blender-%{version}.tar.gz
  12. Source1: http://bane.servebeer.com/programming/blender/import-3ds-0.92.py
  13. Source2: http://bane.servebeer.com/programming/blender/export-3ds-0.72.py
  14. Source3: blender.png
  15. Source4: blender.desktop
  16. Source5: blender.xml
  17. Patch1: blender-2.49-scons.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: esound-devel
  21. BuildRequires: glut-devel
  22. BuildRequires: gettext-devel
  23. BuildRequires: libjpeg-devel
  24. BuildRequires: libogg-devel
  25. BuildRequires: libpng-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libtool
  28. BuildRequires: libvorbis-devel
  29. BuildRequires: freealut-devel
  30. BuildRequires: openssl-devel
  31. BuildRequires: python-devel
  32. BuildRequires: scons
  33. BuildRequires: SDL-devel
  34. BuildRequires: zlib-devel
  35. BuildRequires: libXi-devel
  36. BuildRequires: xorg-x11-proto-devel
  37. BuildRequires: mesa-libGL-devel
  38. BuildRequires: mesa-libGLU-devel
  39. BuildRequires: freetype-devel
  40. BuildRequires: OpenEXR-devel
  41. BuildRequires: glew-devel
  42. Requires(post): desktop-file-utils
  43. Requires(post): shared-mime-info
  44. Requires(postun): desktop-file-utils
  45. Requires(postun): shared-mime-info
  46. %description
  47. Blender is an integrated suite of tools enabling the creation of a broad
  48. range of 3D content. It offers full functionality for modelling, rendering,
  49. animation, post-production, creation and playback of interactive 3D content
  50. with the singular benefits of cross-platform operability.
  51. Aimed at media professionals and artists, Blender can be used to create 3D
  52. visualizations, stills as well as broadcast quality video, while the
  53. incorporation of a real-time 3D engine allows for the creation of 3D
  54. interactive content for stand-alone playback.
  55. %description -l ja
  56. Blender は、幅広い 3D コンテンツの製作を可能にする統合ソフトウェアです。
  57. Blender は、モデリング、レンダリング、アニメーション、ポストプロダクション、
  58. インタラクティブな 3D コンテンツの製作と再生といった全機能を、複数の OS への
  59. 対応という他には類のない利点と共に提供しています。
  60. Blender は、メディアの専門家や達人もターゲットにしているので、3D の視覚化や、
  61. 良質なテレビ放送映像や静止画像の作成にも使用できます。さらに、リアルタイム
  62. 3D エンジンを統合したことにより、スタンドアロン再生用のインタラクティブな
  63. 3D コンテンツの製作も可能です。
  64. %prep
  65. %setup -q -n %{name}-%{version}
  66. #%patch1 -p1 -b .scons
  67. %build
  68. cat > user-config.py <<EOF
  69. WITH_BF_OPENAL = 'false'
  70. #BF_OPENAL = '%{_prefix}'
  71. #BF_OPENAL_INC = '%{_includedir}/AL'
  72. #BF_OPENAL_LIB = '%{_libdir}'
  73. WITH_BF_FFMPEG = 'false'
  74. BF_PYTHON = '%{_prefix}'
  75. BF_PYTHON_INC = '%{_includedir}/python%{pyver}'
  76. BF_PYTHON_LIB = 'python%{pyver}'
  77. BF_OPENEXR_INC = '%{_includedir}/OpenEXR'
  78. BF_GETTEXT = '%{_prefix}'
  79. BF_GETTEXT_INC = '%{_includedir}'
  80. BF_GETTEXT_LIB = 'gettextlib'
  81. BF_BUILDDIR = './builddir'
  82. BF_INSTALLDIR='./installdir'
  83. EOF
  84. ## don't use parallel build
  85. #scons -i -k %{?_smp_mflags} BF_QUIET=0
  86. scons BF_QUIET=0
  87. install -d release/plugins/include
  88. install -m 644 source/blender/blenpluginapi/*.h release/plugins/include
  89. chmod +x release/plugins/bmake
  90. make -C release/plugins/
  91. %install
  92. rm -rf ${RPM_BUILD_ROOT}
  93. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  94. install -D -m 755 ./builddir/bin/blender ${RPM_BUILD_ROOT}/%{_bindir}/blender
  95. install -D -m 755 ./builddir/bin/blenderplayer ${RPM_BUILD_ROOT}/%{_bindir}/blenderplayer
  96. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}
  97. pushd bin/.blender/locale
  98. rm -rf $(find -name '.svn' -print)
  99. popd
  100. cp -a bin/.blender/locale ${RPM_BUILD_ROOT}/%{_datadir}
  101. install -p -D -m0644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/blender.png
  102. install -p -D -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/mime/packages/blender.xml
  103. mkdir -p ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
  104. install -p -D -m0644 release/scripts/*.py ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
  105. install -m 644 release/VERSION ${RPM_BUILD_ROOT}/%{blenderlib}
  106. install -m 644 bin/.blender/.Blanguages ${RPM_BUILD_ROOT}/%{blenderlib}
  107. install -m 644 bin/.blender/.bfont.ttf ${RPM_BUILD_ROOT}/%{blenderlib}
  108. install -p -D -m0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/import-3ds-0.7.py
  109. install -p -D -m0644 %{SOURCE2} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/export-3ds-0.71.py
  110. install -d ${RPM_BUILD_ROOT}/%{plugins}/sequence
  111. install -d ${RPM_BUILD_ROOT}/%{plugins}/texture
  112. install -m 644 release/plugins/sequence/*.so ${RPM_BUILD_ROOT}/%{plugins}/sequence
  113. install -m 655 release/plugins/texture/*.so ${RPM_BUILD_ROOT}/%{plugins}/texture
  114. desktop-file-install --vendor "" --dir ${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE4}
  115. %find_lang %name
  116. %clean
  117. rm -rf ${RPM_BUILD_ROOT}
  118. %post
  119. update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
  120. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  121. %postun
  122. update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
  123. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  124. %files -f %name.lang
  125. %defattr(-,root,root,-)
  126. %doc COPYING README doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt
  127. %{_bindir}/*
  128. %{_libdir}/blender/
  129. %{blenderlib}/
  130. %{_datadir}/applications/blender.desktop
  131. %{_datadir}/pixmaps/*.png
  132. %{_datadir}/mime/packages/blender.xml
  133. %changelog
  134. * Wed May 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-1
  135. - updated blender to 2.49
  136. - applied new versioning policy, and spec in utf-8
  137. - built without smp option
  138. - disable OpenAL, FFMPEG at user-config.py
  139. - added BR: libXi-devel xorg-x11-proto-devel mesa-libGL-devel mesa-libGLU-devel
  140. - added BR: freetype-devel OpenEXR-devel glew-devel
  141. * Mon Jan 02 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.40-0vl2
  142. - new upstream release.
  143. * Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.35-0vl1
  144. - initial build for Vine Linux
  145. * Mon Nov 15 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.35-1
  146. - 2.35.
  147. * Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.34-0.fdr.3
  148. - Mime-type corrections for FC3.
  149. - Dropped redundent BR XFree86-devel.
  150. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.2
  151. - blender.applications file.
  152. - blender.xml file.
  153. - post/postun update-mime-database.
  154. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.1
  155. - Updated to 2.34.
  156. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.2.a
  157. - Include 3ds import/export scripts.
  158. - Added mime info.
  159. - Added mime icon (from yattacier theme).
  160. * Wed Aug 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.1.a
  161. - 2.33a.
  162. - Now building with scons.
  163. * Tue Feb 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.2
  164. - Now including scripts.
  165. * Thu Feb 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.1
  166. - Updated to 2.32.
  167. * Sun Jan 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.3.a
  168. - --enable-openal.
  169. - --disable-rpath.
  170. - remove --enable-international.
  171. - modify .desktop to execute with -w.
  172. * Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.2.a
  173. - Updated to 2.31a.
  174. * Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.1
  175. - Updated to 2.31.
  176. - enable-international.
  177. * Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.30-0.fdr.1
  178. - Updated to 2.30.
  179. * Fri Oct 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.5.c
  180. - Updated to 2.28c.
  181. * Tue Oct 07 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.4.a
  182. - Removed BuildReq smpeg-devel
  183. * Mon Sep 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.3.a
  184. - Moved 'a' out of version according to naming guidelines.
  185. * Fri Sep 12 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.2
  186. - changed file permission on tarball.
  187. - dropped redundant messages about aclocal, etc.
  188. - configure --disable-shared.
  189. - automake --foreign.
  190. - added doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt to %%doc.
  191. * Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.1
  192. - Updated to 2.28a.
  193. * Wed Aug 13 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.2
  194. - New Icon.
  195. * Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.1
  196. - Updated to 2.28.
  197. - BuildReq libvorbis-devel.
  198. - BuildReq smpeg-devel.
  199. - BuildReq esound-devel.
  200. - BuildReq libogg-devel.
  201. - BuildReq vorbis-tools.
  202. - BuildReq openal-devel
  203. - BuildReq libtool
  204. * Mon May 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.2
  205. - Removed post/postun ldconfig.
  206. - Added autoconf workaround.
  207. * Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.1
  208. - Updated to 2.27.
  209. - Removed devel package.
  210. * Wed Apr 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.9
  211. - Corrected devel Group.
  212. * Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.8
  213. - Added desktop-file-utils to BuildRequires.
  214. - Changed category to X-Fedora-Extra.
  215. * Mon Mar 31 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.7
  216. - Added Missing BuildRequires.
  217. * Sun Mar 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.6
  218. - Cleaned up BuildRequires.
  219. - Added Epoch:0.
  220. * Sat Mar 22 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-0.fdr.5
  221. - Spec file cleanup.
  222. * Sat Mar 08 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fdr.4
  223. - Spec file cleanup.
  224. * Wed Feb 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fedora.3
  225. - Spec file cleanup.
  226. * Thu Feb 20 2003 Warren Togami
  227. - Add BuildRequires python-devel
  228. * Wed Feb 19 2003 Phillip Compton
  229. - Initial RPM release.