libnma-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. %bcond_with libnma_gtk4
  2. %global gtk3_version %(pkg-config --modversion gtk+-3.0 2>/dev/null || echo bad)
  3. %global gtk4_version %(pkg-config --modversion gtk4 2>/dev/null || echo bad)
  4. %global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
  5. %global nm_version 1.10.0
  6. %global mbp_version 0.20190618
  7. %global old_libnma_version 1.8.27
  8. Name: libnma
  9. Summary: NetworkManager GUI library
  10. Version: 1.8.30
  11. Release: 2%{?_dist_release}
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # The entire source code is GPLv2+ except some files in shared/ which are LGPLv2+
  15. License: GPLv2+ and LGPLv2+
  16. URL: https://gitlab.gnome.org/GNOME/libnma/
  17. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  18. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  19. Patch1: 0001-nm-applet-no-notifications.patch
  20. Requires: mobile-broadband-provider-info >= %{mbp_version}
  21. Conflicts: libnma < %{old_libnma_version}
  22. BuildRequires: gcc
  23. BuildRequires: NetworkManager-libnm-devel >= %{nm_version}
  24. BuildRequires: ModemManager-glib-devel >= 1.0
  25. BuildRequires: glib2-devel >= 2.32
  26. BuildRequires: gtk3-devel >= 3.10
  27. %if %{with libnma_gtk4}
  28. BuildRequires: gtk4-devel >= 3.96
  29. %endif
  30. BuildRequires: gobject-introspection-devel >= 0.10.3
  31. BuildRequires: gettext-devel
  32. BuildRequires: pkgconfig
  33. BuildRequires: meson
  34. BuildRequires: gtk-doc
  35. BuildRequires: iso-codes
  36. BuildRequires: gcr-devel
  37. BuildRequires: mobile-broadband-provider-info-devel >= %{mbp_version}
  38. %description
  39. This package contains the library used for integrating GUI tools with
  40. NetworkManager.
  41. %package devel
  42. Summary: Header files for NetworkManager GUI library
  43. Requires: NetworkManager-libnm-devel >= %{nm_version}
  44. Obsoletes: NetworkManager-gtk-devel < 1.8.22
  45. Requires: libnma%{?_isa} = %{version}-%{release}
  46. Requires: gtk3-devel%{?_isa}
  47. Requires: pkgconfig
  48. Conflicts: libnma < %{old_libnma_version}
  49. %description devel
  50. This package contains header and pkg-config files to be used for integrating
  51. GUI tools with NetworkManager.
  52. %if %{with libnma_gtk4}
  53. %package gtk4
  54. Summary: Experimental GTK 4 version of NetworkManager GUI library
  55. Requires: gtk4%{?_isa} >= %{gtk4_version}
  56. Requires: mobile-broadband-provider-info >= %{mbp_version}
  57. Conflicts: libnma < %{old_libnma_version}
  58. %description gtk4
  59. This package contains the experimental GTK4 version of library used for
  60. integrating GUI tools with NetworkManager.
  61. %package gtk4-devel
  62. Summary: Header files for experimental GTK4 version of NetworkManager GUI library
  63. Requires: NetworkManager-libnm-devel >= %{nm_version}
  64. Requires: libnma-gtk4%{?_isa} = %{version}-%{release}
  65. Requires: gtk4-devel%{?_isa}
  66. Requires: pkgconfig
  67. Conflicts: libnma < %{old_libnma_version}
  68. %description gtk4-devel
  69. This package contains the experimental GTK4 version of header and pkg-config
  70. files to be used for integrating GUI tools with NetworkManager.
  71. %endif
  72. %prep
  73. %autosetup -p1 -n "%{name}-%{version}"
  74. %build
  75. %meson \
  76. -Dgcr=true \
  77. -Ddisable-static=true \
  78. -Dvapi=false \
  79. %if %{with libnma_gtk4}
  80. -Dlibnma_gtk4=true
  81. %else
  82. -Dlibnma_gtk4=false
  83. %endif
  84. %meson_build
  85. %install
  86. %meson_install
  87. %find_lang %{name}
  88. %check
  89. %meson_test
  90. %files -f %{name}.lang
  91. %{_libdir}/libnma.so.*
  92. %{_libdir}/girepository-1.0/NMA-1.0.typelib
  93. %{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
  94. %doc NEWS CONTRIBUTING
  95. %license COPYING
  96. %files devel
  97. %{_includedir}/libnma
  98. %{_libdir}/pkgconfig/libnma.pc
  99. %{_libdir}/libnma.so
  100. %{_datadir}/gir-1.0/NMA-1.0.gir
  101. %{_datadir}/gtk-doc
  102. %if %{with libnma_gtk4}
  103. %files gtk4
  104. %{_libdir}/libnma-gtk4.so.*
  105. %{_libdir}/girepository-1.0/NMA4-1.0.typelib
  106. %license COPYING
  107. %files gtk4-devel
  108. %{_includedir}/libnma
  109. %{_libdir}/pkgconfig/libnma-gtk4.pc
  110. %{_libdir}/libnma-gtk4.so
  111. %{_datadir}/gir-1.0/NMA4-1.0.gir
  112. %endif
  113. %changelog
  114. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.30-2
  115. - initial build for Vine Linux.
  116. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.30-1.2
  117. - Second attempt - Rebuilt for
  118. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  119. * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.30-1.1
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  121. * Thu Jul 9 2020 Jérôme Parmentier <jerome@prmntr.me> - 1.8.30-1
  122. - Update to 1.8.30 release
  123. * Fri Mar 6 2020 Thomas Haller <thaller@redhat.com> - 1.8.28-1
  124. - Update to 1.8.28 release
  125. - move org.gnome.nm-applet.gschema.xml from network-manager-applet to here.
  126. - introduce wireless security dialogs
  127. * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.26-4
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  129. * Thu Nov 14 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-3
  130. - Clarify licensing
  131. - Add a missing mobile-broadband-provider-info provide
  132. * Fri Nov 08 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-2
  133. - Fixes suggested in review by Matthew Krupcale (#1763285):
  134. - Add gcc BR
  135. - Fixed the libnma-gtk4 conditional
  136. - Made dependencies arch-specific where relevant
  137. - Dropped obsolete macros
  138. - Install license file with libnma-gtk4
  139. * Fri Oct 18 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-1
  140. - Initial package split from nm-connection-editor