123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209 |
- Name: libdbi
- Summary: Database Independent Abstraction Layer for C
- Version: 0.9.0
- Release: 2%{?_dist_release}
- Group: System Environment/Libraries
- License: LGPLv2+
- URL: http://libdbi.sourceforge.net/
- Vendor: Project Vine
- Distribution: Vine Linux
- Source: http://prdownloads.sourceforge.net/libdbi/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: openjade docbook-style-dsssl
- Conflicts: libdbi-dbd-mysql < 0.8
- Conflicts: libdbi-dbd-pgsql < 0.8
- %description
- libdbi implements a database-independent abstraction layer in C, similar to the
- DBI/DBD layer in Perl. Writing one generic set of code, programmers can
- leverage the power of multiple databases and multiple simultaneous database
- connections by using this framework.
- The libdbi package contains just the libdbi framework. To make use of
- libdbi you will also need one or more plugins from libdbi-drivers, which
- contains the plugins needed to interface to specific database servers.
- %package devel
- Summary: Development files for libdbi (Database Independent Abstraction Layer for C)
- Group: Development/Libraries
- Requires: pkgconfig
- Requires: %{name} = %{version}-%{release}
- %description devel
- The libdbi-devel package contains the header files and documentation
- needed to develop applications with libdbi.
- %clean
- [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
- %prep
- %setup -q -n %{name}-%{version}
- %build
- %configure --disable-static
- make %{?_smp_mflags}
- %install
- [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
- make DESTDIR=$RPM_BUILD_ROOT install
- #rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.a
- rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdbi.la
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root)
- %doc AUTHORS
- %doc ChangeLog
- %license COPYING
- %doc README
- %{_libdir}/libdbi.so.*
- %files devel
- %defattr(-,root,root)
- %doc TODO
- %doc doc/programmers-guide.pdf
- %doc doc/programmers-guide/
- %doc doc/driver-guide.pdf
- %doc doc/driver-guide/
- %{_libdir}/libdbi.so
- %{_libdir}/pkgconfig/dbi.pc
- %{_includedir}/dbi/
- %changelog
- * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.0-2
- - rebuilt with current environment.
- * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.0-1
- - update to 0.9.0
- - remove old patches
- * Mon Oct 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8.4-2
- - moved libdbi to System Environment/Libraries
- * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-1
- - initial build for Vine Linux
- * Mon Jul 23 2012 Tom Lane <tgl@redhat.com> 0.8.4-2
- - Prevent undesirable change in library soname version number
- * Sun Jul 22 2012 Tom Lane <tgl@redhat.com> 0.8.4-1
- - Update to version 0.8.4 (seems to contain only configure-support updates,
- but might as well adopt it)
- - Fix memory leak due to incorrect test in _is_row_fetched()
- Related: #733413
- * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Fri Sep 3 2010 Tom Lane <tgl@redhat.com> 0.8.3-4
- - Do not use -ffast-math; it breaks things and seems quite unlikely to offer
- any useful performance benefit for this type of package, anyway
- Resolves: #629964
- * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Mon Feb 11 2008 Tom Lane <tgl@redhat.com> 0.8.3-1
- - Update to version 0.8.3.
- * Tue Oct 30 2007 Tom Lane <tgl@redhat.com> 0.8.2-3
- - Fix package's selection of CFLAGS to include RPM_OPT_FLAGS
- Resolves: #330681
- * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 0.8.2-2
- - Fix typo in Release field.
- * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 0.8.2-1
- - Update to version 0.8.2.
- - Update License tag to match code.
- - Remove static library and .la file, per packaging guidelines.
- * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-2.1
- - rebuild
- * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 0.8.1-2
- - rebuild for -devel deps
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2.1
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.8.1-1.2
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Sat Nov 12 2005 Tom Lane <tgl@redhat.com> 0.8.1-1
- - Update to version 0.8.1.
- * Fri Mar 11 2005 Tom Lane <tgl@redhat.com> 0.7.2-2
- - Packaging improvements per discussion with sopwith.
- * Thu Mar 10 2005 Tom Lane <tgl@redhat.com> 0.7.2-1
- - Import new libdbi version, splitting libdbi-drivers into a separate SRPM
- so we can track new upstream packaging.
- * Sun Mar 6 2005 Tom Lane <tgl@redhat.com> 0.6.5-11
- - Rebuild with gcc4.
- * Mon Nov 08 2004 Tom Lane <tgl@redhat.com> 0.6.5-10
- - build against mysqlclient10, not mysql, for license reasons
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.6.5-7
- - rebuilt
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri Jan 24 2003 Tom Lane <tgl@redhat.com>
- - /usr/include/dbi should be owned
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- - rebuilt
- * Sun Dec 01 2002 Elliot Lee <sopwith@redhat.com> 0.6.5-3
- - multilibify
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Tue Jun 18 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.5-1
- - 0.6.5
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.6.4-2
- - 0.6.4
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Thu Sep 20 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.6.2-1
- - Sanitize, prepare for distribution
- * Sat Aug 4 2001 David Parker <david@neongoat.com>
- - initial spec file created
|