glade3-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. %define helpdir glade3
  2. Summary: A user interface builder for the GTK+ toolkit and GNOME
  3. Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
  4. Name: glade3
  5. Version: 3.36.0
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. URL: https://glade.gnome.org/
  11. %global shortver %(echo %{version} | cut -d . -f 1,2)
  12. Source0: https://download.gnome.org/sources/glade/%{shortver}/glade-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gnome-common
  15. BuildRequires: glib2-devel
  16. BuildRequires: gtk3-devel
  17. BuildRequires: webkitgtk4-devel
  18. BuildRequires: libxml2-devel
  19. BuildRequires: python3-devel
  20. BuildRequires: pygobject3-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: yelp-devel yelp-tools
  23. BuildRequires: gtk-doc
  24. BuildRequires: docbook-style-xsl
  25. BuildRequires: itstool
  26. Requires: gtk3
  27. Requires: libxml2
  28. Requires: pygobject3
  29. Requires: devhelp
  30. %description
  31. Glade is a RAD tool to enable quick & easy development of user interfaces
  32. for the Gtk+ toolkit and the GNOME desktop environment.
  33. The user interfaces designed in Glade are stored in XML format,
  34. enabling easy integration with external tools.
  35. In particular libglade can load the XML files and create the interfaces
  36. at runtime. The DTD for the XML files is included with libglade, and is
  37. also at http://glade.gnome.org/glade-2.0.dtd.
  38. Other tools are available which can turn the XML files into source code
  39. in languages such as C++, Perl and Python.
  40. %description -l ja
  41. Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
  42. 発する事が可能なRADツールです。
  43. Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
  44. フォーマットで保存されます。
  45. 特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
  46. ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
  47. http://glade.gnome.org/glade-2.0.dtdにもあります。
  48. このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
  49. ルも利用可能です。
  50. %package devel
  51. Summary: the Glade UI Builder core library
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. the Glade UI Builder core library to integrate Glade into your application
  56. and integrate your custom (GTK+ based) widget toolkit into the Glade
  57. UI Builder.
  58. %prep
  59. %setup -q -n glade-%{version}
  60. pushd src
  61. ## change gnome help directory
  62. mv glade-window.c glade-window.c.orig
  63. sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
  64. glade-window.c.orig > glade-window.c
  65. popd
  66. %build
  67. %configure --disable-static
  68. %__make %{_smp_mflags}
  69. %install
  70. rm -rf %{buildroot}
  71. make install DESTDIR=%{buildroot}
  72. rm -rf %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  73. rm -f %{buildroot}%{_libdir}/glade/modules/*.la
  74. rm -f %{buildroot}%{_libdir}/libgladeui-2.la
  75. %find_lang glade --all-name --with-gnome
  76. %clean
  77. rm -rf %{buildroot}
  78. %post
  79. /sbin/ldconfig
  80. touch --no-create %{_datadir}/icons/hicolor
  81. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  82. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  83. fi
  84. %postun
  85. /sbin/ldconfig
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  88. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  89. fi
  90. %files -f glade.lang
  91. %defattr(-,root,root)
  92. %{_bindir}/glade
  93. %{_bindir}/glade-previewer
  94. %{_libdir}/libgladeui-2.so.*
  95. %{_libdir}/glade/modules/*.so
  96. %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
  97. %{_datadir}/metainfo/*
  98. %{_datadir}/applications/org.gnome.Glade.desktop
  99. %{_datadir}/glade
  100. %{_datadir}/icons/hicolor/*/apps/*
  101. %{_mandir}/man1/glade-previewer.1.gz
  102. %{_mandir}/man1/glade.1.gz
  103. %files devel
  104. %defattr(-,root,root)
  105. %{_includedir}/libgladeui-2.0/gladeui/*
  106. %{_libdir}/pkgconfig/*.pc
  107. %{_libdir}/libgladeui-2.so
  108. %{_datadir}/gir-1.0/Gladeui-2.0.gir
  109. %{_datadir}/gtk-doc/html/gladeui-2
  110. %changelog
  111. * Wed Aug 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.0-1
  112. - new upstream release.
  113. * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.2-1
  114. - new upstream release.
  115. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.3-1
  116. - new upstream release.
  117. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
  118. - new upstream release
  119. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  120. - new upstream release
  121. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  122. - new upstream release
  123. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  124. - new upstream release
  125. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  126. - new upstream release
  127. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  128. - new upstream release
  129. - add BuildRequires: docbook-style-xsl
  130. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  131. - new upstream release
  132. * Mon Oct 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  133. - new upstream release
  134. - add BuildRequires: python-devel, pygobject3-devel
  135. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  136. - new upstream release
  137. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  138. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  139. - new upstream release
  140. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  141. - new upstream release
  142. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  143. - new upstream release
  144. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
  145. - new upstream release
  146. - change BuildRequires: gtk3-devel instead of gtk2-devel
  147. - delete BuildRequires: libgnomeui-devel, libbonoboui-devel
  148. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
  149. - rebuild with rpm-4.8.1 for pkg-config file
  150. - add BuildRequires: libSM-devel
  151. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
  152. - add gnome-doc-utils to BR
  153. - comment out desktop-file-install
  154. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
  155. - rebuild with gtk2-2.18.2
  156. * Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
  157. - new upstream release
  158. - care ld and icon cache
  159. - define helpdir
  160. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
  161. - new upstream release
  162. - spec in utf-8 (fixed)
  163. * Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
  164. - spec in utf-8
  165. * Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
  166. - new upstream release
  167. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
  168. - new upstream version.
  169. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
  170. - new upstream version.
  171. - update Requires.
  172. - update description.
  173. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
  174. - use macro for release
  175. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
  176. - apply new virsioning policy.
  177. - remove *.la
  178. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
  179. - new upstream version
  180. - added Requires: devhelp
  181. - added Prereq: scrollkeeper
  182. - added disable-scrollkeeper to configure
  183. - added scrollkeeper-update in %%post and %%postun sections
  184. - changed gnome help directory temporarily
  185. * Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
  186. - build for VineSeed