123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- %if %{?_dist_release} != "vl6"
- %global with_http2 1
- %endif
- Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
- Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
- Name: curl
- Version: 7.71.1
- Release: 1%{?_dist_release}
- Group: Applications/Internet
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: daisuke
- License: MIT
- URL: https://curl.haxx.se/
- Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
- # avoid reporting spurious error in the HTTP2 framing layer (#1690971)
- Patch2: 0002-curl-7.65.3-h2-framing-layer-error.patch
- # patch making libcurl multilib ready
- Patch101: 0101-curl-7.71.1-multilib.patch
- # prevent configure script from discarding -g in CFLAGS (#496778)
- Patch102: 0102-curl-7.36.0-debug.patch
- # migrate tests/http_pipe.py to Python 3
- Patch103: 0103-curl-7.59.0-python3.patch
- # use localhost6 instead of ip6-localhost in the curl test-suite
- Patch104: 0104-curl-7.19.7-localhost6.patch
- # prevent valgrind from reporting false positives on x86_64
- Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: openssl-devel
- BuildRequires: gnutls-devel
- BuildRequires: libidn-devel zlib-devel
- BuildRequires: openldap-devel
- BuildRequires: openssh-server
- BuildRequires: openssh-clients
- BuildRequires: pkgconfig
- %if "%{?_dist_release}" != "vl6"
- BuildRequires: libssh2-devel
- %endif
- %if 0%{?with_http2}
- BuildRequires: libnghttp2-devel
- %endif
- Requires: ca-certificates
- %description
- cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
- Dict servers, using any of the supported protocols. cURL is designed
- to work without user interaction or any kind of interactivity. cURL
- offers many useful capabilities, like proxy support, user
- authentication, FTP upload, HTTP post, and file transfer resume.
- %package devel
- Summary: Files needed for building applications with libcurl.
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: openssl-devel libidn-devel zlib-devel
- %description devel
- cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
- Dict servers, using any of the supported protocols. The curl-devel
- package includes files needed for developing applications which can
- use cURL's capabilities internally.
- #'
- ## to build compat32 for x86_64 architecture support
- %package -n compat32-%{name}
- Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
- Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
- Group: System Environment/Libraries
- %description -n compat32-%{name}
- cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
- Dict servers, using any of the supported protocols. cURL is designed
- to work without user interaction or any kind of interactivity. cURL
- offers many useful capabilities, like proxy support, user
- authentication, FTP upload, HTTP post, and file transfer resume.
- %package -n compat32-%{name}-devel
- Summary: Files needed for building applications with libcurl.
- Group: Development/Libraries
- %description -n compat32-%{name}-devel
- cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
- Dict servers, using any of the supported protocols. The curl-devel
- package includes files needed for developing applications which can
- use cURL's capabilities internally.
- #'
- %prep
- %setup -q
- # upstream patches
- # Fedora patches
- %patch101 -p1
- %patch102 -p1
- #patch103 -p1
- %patch104 -p1
- %patch105 -p1
- # make tests/*.py use Python 3
- sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
- # regenerate Makefile.in files
- aclocal -I m4
- automake
- # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
- # with errno 98: Address already in use' in Koji environment), and test 1801
- # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
- # and test 1900, which is flaky and covers a deprecated feature of libcurl
- # <https://github.com/curl/curl/pull/2705>
- printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
- # disable test 1319 on ppc64 (server times out)
- %ifarch ppc64
- echo "1319" >> tests/data/DISABLED
- %endif
- # temporarily disable test 582 on s390x (client times out)
- %ifarch s390x
- echo "582" >> tests/data/DISABLED
- %endif
- # adapt test 323 for updated OpenSSL
- sed -e 's/^35$/35,52/' -i tests/data/test323
- %build
- %configure \
- --with-ssl=%{_prefix} \
- --with-libidn \
- --enable-ipv6 \
- --enable-threaded-resolver \
- --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
- %if "%{?_dist_release}" != "vl6"
- --with-libssh2 \
- %endif
- %if 0%{?with_http2}
- --with-nghttp2 \
- %endif
- --enable-ldaps \
- --disable-static \
- --enable-hidden-symbols
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make DESTDIR=$RPM_BUILD_ROOT install
- rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root)
- %{!?_licensedir:%global license %%doc}
- %license COPYING
- %doc CHANGES README
- %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
- %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
- %doc docs/TheArtOfHttpScripting docs/TODO
- %{_bindir}/curl
- #{_datadir}/curl/*
- %{_libdir}/*.so.*
- %{_mandir}/man1/*.1*
- %files devel
- %defattr(-,root,root)
- %{_bindir}/curl-config
- %{_includedir}/curl
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/*.pc
- %{_mandir}/man1/curl-config.1*
- %{_mandir}/man3/*
- %{_datadir}/aclocal/libcurl.m4
- ## to build compat32 for x86_64 architecture support
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-,root,root)
- %{_libdir}/*.so.*
- %files -n compat32-%{name}-devel
- %defattr(-,root,root)
- %{_libdir}/*.so
- %endif
- %changelog
- * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
- - new upstream release.
- * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
- - new upstream release.
- * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
- - new upstream release.
- * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
- - new upstream release.
- - dropped Patch1 and 2: fixed in upstream.
- * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
- - new upstream release.
- - updated patches.
- - imported Patch1, 2 and 105 from rawhide.
- * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
- - new upstream release.
- - imported patches from rawhide.
- * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
- - new upstream release.
- - imported Patch1 and 103 from rawhide.
- * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
- - new upstream release with security fix
- - update patch101
- * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
- - new upstream release.
- - updated Patch101-104.
- - dropped Patch107.
- * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
- - new upstream release.
- * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
- - new upstream release.
- * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
- - new upstream release.
- * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
- - new upstream release.
- - disabled HTTP/2 on Vine6.
- * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
- - added HTTP/2 support.
- * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
- - new upstream release with security fix.
- * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
- - new upstream release.
- * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
- - new upstream release
- - built with openssl 1.0.2g
- * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
- - new upstream release with security fix .
- - removed Patch108 (fixed in upstream).
- * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
- - new upstream release with security fix
- * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
- - new upstream release
- - add libcurl.m4 to -devel package
- * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
- - new upstream release
- - import upstream/fedora patches
- - disable libssh2 on Vine Linux 6
- * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
- - new upstream reelase
- * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
- - update to 7.28.0
- - add configure options
- - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
- - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
-
- - use ca-certificates package
- - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
- - R: ca-certificates
- * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
- - new upstream release
- * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
- - add patch100 for fix CVE-2011-2192 (gssapi)
- - add Vendor/Distri tags
- * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
- - rebuild with openssl-1.0.0c
- * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
- - rebuilt with rpm-4.8.1 for pkg-config
- * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
- - new upstream release
- * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
- - new upstream release with security fix
- * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
- - added compat32 subpackages
- * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
- - new upstream release
- - use "_smp_mflags" flag
- * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
- - rebuild with openldap-2.4.11
- - add BR: openldap-devel
- - remove static library
- * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
- - new upstream release with security fix (CVE-2009-0037)
- * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
- - new upstream release
- * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
- - new upstream release
- * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
- - new upstream release
- * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
- - new upstream release
- * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
- - new upstream release
- * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
- - rebuilt with openssl-0.9.8e
- * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
- - new upstream release
- * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
- - new upstream release
- * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
- - new upstream release
- - add pkgconfig file to devel package
- * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
- - new upstream release
- * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
- - new upstream release
- * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
- - new upstream release
- * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
- - added libidn, zlib in Requires
- - added libidn-devel, zlib-devel in BuildPrereq
- - added zlib-devel in curl-devel's Requires
- * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
- - added openssl-devel, libidn-devel in curl-devel's Requires
- * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
- - new upstream release
- * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
- - new upstream release
- - rebuild with openssl-0.9.7d
- * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
- - upstream release
- * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
- - add %%{_datadir}/curl/* to %%files section
- * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
- - source upgrade
- * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
- - source upgrade
- - add PreReq: ldconfig
- - add %%{_libdir}/*.la to %%files devel section
- * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
- - build for VineSeed
- - add Requires: openssl
- * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
- - 7.9.2
- * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
- - include curl-config in curl-devel
- - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
- * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
- - added openssl-devel build req
- * Mon May 21 2001 Tim Powers <timp@redhat.com>
- - built for the distro
- * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
- - upgrade to curl-7.7.2.
- - enable IPv6.
- * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
- - rebuilt against openssl-0.9.6-1
- * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
- - fixed mising ldconfigs
- - updated to 7.5.2, bug fixes
- * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
- - updated to 7.5.1
- * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
- - update to 7.4.1 to fix bug #20337, problems with curl -c
- - not using patch anymore, it's included in the new source. Keeping
- for reference
- * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
- - fix bogus req in -devel package
- * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
- - devel package needed defattr so that root owns the files
- * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
- - update to 7.3
- - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
- * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
- - enable SSL support
- - fix packager tag
- - move buildroot to %%{_tmppath}
- * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
- - fixed vendor tag for bug #15028
- * Mon Jul 24 2000 Prospector <prospector@redhat.com>
- - rebuilt
- * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
- - workaround alpha build problems with optimizations
- * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
- - rebuilt
- * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
- - put man pages in correct place
- - use %%makeinstall
- * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
- - updated to 6.5.2
- * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
- - updated sources to 6.2
- - gzip man page
- * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
- - changed group
- * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
- - changelog started
- - general cleanups, changed prefix to /usr, added manpage to files section
- - including in Powertools
|