clutter-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415
  1. %define clutter_version 1.26.2
  2. %define clutter_release 1%{?_dist_release}
  3. Summary: Open Source software library for creating rich graphical user interfaces
  4. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  5. Name: clutter
  6. Version: 1.26.4
  7. Release: 1%{?_dist_release}
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://www.clutter-project.org/
  12. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  13. Source: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  14. Patch0: clutter-fixdso.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: gobject-introspection
  17. # FIXME to remove when all the bits have been merged into their
  18. # libraries
  19. BuildRequires: glib2-devel
  20. BuildRequires: mesa-libGL-devel
  21. BuildRequires: mesa-libEGL-devel
  22. BuildRequires: gdk-pixbuf2-devel
  23. BuildRequires: atk-devel
  24. BuildRequires: gtk3-devel
  25. BuildRequires: pkgconfig
  26. BuildRequires: pango-devel
  27. BuildRequires: libXdamage-devel
  28. BuildRequires: libXcomposite-devel
  29. BuildRequires: libXi-devel
  30. BuildRequires: gettext
  31. BuildRequires: gtk-doc
  32. BuildRequires: gobject-introspection-devel >= 0.9.5
  33. BuildRequires: json-glib-devel
  34. BuildRequires: cogl-devel >= 1.20.0
  35. BuildRequires: libinput-devel
  36. BuildRequires: libxkbcommon-devel
  37. BuildRequires: eudev-libudev-devel
  38. BuildRequires: libgudev-devel
  39. %description
  40. Clutter is an open source software library for creating fast,
  41. visually rich graphical user interfaces. The most obvious example
  42. of potential usage is in media center type applications.
  43. We hope however it can be used for a lot more.
  44. %description -l ja
  45. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  46. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  47. しかしながら、我々はいろいろな分野で使用されることを願っています。
  48. %package devel
  49. Summary: Clutter development environment
  50. Summary(ja): Clutterの開発環境
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  54. Requires: mesa-libGL-devel
  55. Requires: mesa-libEGL-devel
  56. Requires: gobject-introspection-devel
  57. Requires: json-glib-devel
  58. Requires: libXcomposite-devel
  59. Requires: libXi-devel
  60. %description devel
  61. Header files and libraries for building a extension library for the
  62. clutter
  63. %package docs
  64. Summary: Documentation for %{name}
  65. Summary(ja): %{name}用のドキュメント
  66. Group: Documentation
  67. Provides: %{name}-doc = %{version}-%{release}
  68. BuildArch: noarch
  69. %description docs
  70. Clutter is an open source software library for creating fast,
  71. visually rich graphical user interfaces. The most obvious example
  72. of potential usage is in media center type applications.
  73. We hope however it can be used for a lot more.
  74. This package contains documentation for clutter.
  75. %prep
  76. %setup -q
  77. %patch0 -p1 -b .dso
  78. %build
  79. #%configure --enable-gtk-doc \
  80. # --enable-introspection=yes \
  81. # --disable-silent-rules \
  82. # --enable-xinput \
  83. # --disable-static
  84. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  85. %configure $CONFIGFLAGS \
  86. --disable-static \
  87. --disable-silent-rules \
  88. --enable-introspection=yes \
  89. --enable-xinput \
  90. --enable-x11-backend=yes \
  91. --enable-gdk-backend=no \
  92. --enable-egl-backend=yes \
  93. --enable-evdev-input=yes
  94. # clutter git ships with some magic to put the git log in shipped tarballs
  95. # which gets listed in files; don't blow up if it's missing
  96. if ! test -f ChangeLog; then
  97. echo "Created from snapshot" > ChangeLog
  98. fi
  99. )
  100. make %{?_smp_mflags} V=0
  101. %install
  102. rm -rf $RPM_BUILD_ROOT
  103. #make DESTDIR=$RPM_BUILD_ROOT install
  104. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  105. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  106. %find_lang %{name}-1.0
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post -p /sbin/ldconfig
  110. %postun -p /sbin/ldconfig
  111. %files -f %{name}-1.0.lang
  112. %defattr(-,root,root,-)
  113. %license COPYING
  114. %doc AUTHORS NEWS README
  115. %{_libdir}/*.so.*
  116. %{_libdir}/girepository-1.0/*.typelib
  117. %files devel
  118. %defattr(-, root, root)
  119. %doc ChangeLog
  120. %{_includedir}/clutter-1.0
  121. %{_libdir}/*.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %{_datadir}/gir-1.0/*.gir
  124. %{_datadir}/clutter-1.0
  125. %files docs
  126. %defattr(-, root, root)
  127. %{_datadir}/gtk-doc/html/clutter
  128. %changelog
  129. * Sun Aug 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.4-1
  130. - new upstream release.
  131. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-2
  132. - disabled gdk backend.
  133. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-1
  134. - new upstream release.
  135. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.0-1
  136. - new upstream release
  137. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.24.2-1
  138. - new upstream release
  139. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
  140. - new upstream release
  141. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
  142. - new upstream release
  143. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
  144. - new upstream release
  145. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  146. - new upstream release
  147. - add BuildRequires: mesa-libEGL-devel
  148. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  149. - new upstream release
  150. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  151. - new upstream release
  152. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  153. - new upstream release
  154. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  155. - new upstream release
  156. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  157. - new upstream release
  158. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  159. - new upstream release
  160. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  161. - new upstream release
  162. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  163. - new upstream release
  164. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  165. - new upstream release
  166. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  167. - new upstream release
  168. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  169. - new upstream release
  170. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  171. - new upstream release
  172. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  173. - new upstream release
  174. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  175. - new upstream release
  176. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  177. - new upstream release
  178. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  179. - new upstream release
  180. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  181. - new upstream release
  182. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  183. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  184. - new upstream release
  185. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  186. - new upstream release
  187. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  188. - new upstream release
  189. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  190. - new upstream release
  191. - add BuildRequires: cogl-devel
  192. - add "BuildArch: noarch" to doc sub package
  193. - add Patch0 (clutter-fixdso.patch)
  194. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  195. - new upstream release
  196. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  197. - new upstream release
  198. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  199. - new upstream release
  200. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  201. - new upstream release
  202. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  203. - new upstream release
  204. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  205. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  206. - drop Patch0
  207. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  208. - new upstream release
  209. - drop Patch1
  210. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  211. - new upstream release
  212. - add BuildRequires: json-glib-devel
  213. - delete Requires: gir-repository
  214. - delete BuildRequires: gir-repository-devel
  215. - add Requires: json-glib-devel (devel package)
  216. - add Patch0, Patch1
  217. - fix %build
  218. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  219. - rebuild with rpm-4.8.1 for pkg-config file
  220. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  221. - new upstream release
  222. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  223. - new upstream release
  224. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  225. - new upstream release
  226. - add configure option (--enable-xinput)
  227. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  228. - new upstream release
  229. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  230. - new upstream release
  231. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  232. - new upstream release
  233. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  234. - new upstream release
  235. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  236. - new upstream release
  237. - build for Vine Linux
  238. - add Summary(ja)
  239. - fix BuildRoot
  240. - remove Obsolete and Provides
  241. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  242. - Update to 1.0.6
  243. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  244. - Update to 1.0.4, update gobject-introspection requirement
  245. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  246. - Update to 1.0.2
  247. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  248. - Move ChangeLog to -devel to save some space
  249. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  250. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  251. onto the live cd
  252. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  253. - Update to 1.0.0
  254. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  255. - fix bz #507389
  256. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  257. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  258. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  259. - Update to 0.9.8
  260. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  261. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  262. introspection support to clutter (#512260)
  263. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  264. - Update to 0.9.6
  265. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  266. - Update to 0.9.4
  267. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  268. - Update to 0.9.2
  269. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  270. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  271. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  272. - Remove noarch from doc subpackage
  273. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  274. - Added gtk-doc for cogl
  275. - Created doc subpackage
  276. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  277. - Update to 0.8.6
  278. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  279. - Update to 0.8.2
  280. - Removed clutter-0.8.0-clutter-fixed.patch
  281. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  282. - Update to 0.8.0
  283. - Added clutter-0.8.0-clutter-fixed.patch
  284. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  285. - Update to 0.6.4
  286. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  287. - Update to 0.6.2
  288. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  289. - Update to 0.6.0
  290. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  291. - Autorebuild for GCC 4.3
  292. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  293. - Update to 0.4.2
  294. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  295. - Update to 0.4.1
  296. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  297. - Update to 0.3.1
  298. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  299. - Update to 0.2.3
  300. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  301. - Changed buildrequires and requires
  302. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  303. - Fix .spec
  304. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  305. - Fix .spec
  306. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  307. - Initial RPM release