accountsservice-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %bcond_with systemd
  2. %define _unpackaged_files_terminate_build 1
  3. %global __global_cflags %{optflags}
  4. %global __global_ldflags ""
  5. Summary: D-Bus interfaces for querying and manipulating user account information
  6. Summary(ja): ユーザーアカウント情報の照会・処理を行うための D-Bus I/F
  7. Name: accountsservice
  8. Version: 0.6.55
  9. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Group: System Environment/Daemons
  13. License: GPLv3+
  14. URL: https://www.freedesktop.org/wiki/Software/AccountsService/
  15. #VCS: git:git://git.freedesktop.org/accountsservice
  16. Source0: https://www.freedesktop.org/software/accountsservice/accountsservice-%{version}.tar.xz
  17. # upstream patch
  18. # for Vine Linux
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: meson
  21. BuildRequires: glib2-devel
  22. BuildRequires: dbus-glib-devel
  23. BuildRequires: polkit-devel
  24. BuildRequires: intltool
  25. # BuildRequires: systemd-units
  26. BuildRequires: gobject-introspection-devel
  27. BuildRequires: python3-setuptools
  28. %if %{with systemd}
  29. BuildRequires: systemd-devel
  30. %{?systemd_requires}
  31. %else
  32. BuildRequires: elogind-devel
  33. %endif
  34. Requires: polkit
  35. Requires: shadow-utils
  36. %description
  37. The accountsservice project provides a set of D-Bus interfaces for
  38. querying and manipulating user account information and an implementation
  39. of these interfaces, based on the useradd, usermod and userdel commands.
  40. %package libs
  41. Summary: Client-side library to talk to accountsservice
  42. Summary(ja): accountsservice と対話するためのクライアント側ライブラリ
  43. Group: System Environment/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description libs
  46. The accountsservice-libs package contains a library that can
  47. be used by applications that want to interact with the accountsservice
  48. daemon.
  49. %package devel
  50. Summary: Development files for accountsservice-libs
  51. Summary(ja): accountsservice-libs の開発用ファイル
  52. Group: Development/Libraries
  53. Requires: %{name}-libs = %{version}-%{release}
  54. %description devel
  55. The accountsservice-devel package contains headers and other
  56. files needed to build applications that use accountsservice-libs.
  57. %package doc
  58. Summary: Documentation for %{name}
  59. Summary(ja): %{name} 用のドキュメント
  60. Group: Documentation
  61. Requires: %{name} = %{version}-%{release}
  62. BuildArch: noarch
  63. %description doc
  64. This package contains documentation for %{name}.
  65. %prep
  66. %autosetup -p1
  67. sed -i -e '/"gnome-initial-setup",/a "selfbuild",' src/user-classify.c
  68. %build
  69. %meson \
  70. %if %{with systemd}
  71. -Dsystemd=true \
  72. -Delogind=false \
  73. -Dsystemdsystemunitdir=%{_unitdir} \
  74. %else
  75. -Dsystemd=false \
  76. -Delogind=true \
  77. -Dsystemdsystemunitdir=no \
  78. %endif
  79. -Dadmin_group=wheel \
  80. -Dminimum_uid=500 \
  81. -Dgtk_doc=true
  82. %meson_build
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. %meson_install
  86. %find_lang accounts-service
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %if %{with systemd}
  90. %post
  91. %systemd_post accounts-daemon.service
  92. %preun
  93. %systemd_preun accounts-daemon.service
  94. %postun
  95. %systemd_postun accounts-daemon.service
  96. %endif
  97. %post libs -p /sbin/ldconfig
  98. %postun libs -p /sbin/ldconfig
  99. %files -f accounts-service.lang
  100. %defattr(-,root,root,-)
  101. %license COPYING
  102. %doc README* AUTHORS
  103. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.Accounts.conf
  104. %{_libexecdir}/accounts-daemon
  105. %{_datadir}/dbus-1/interfaces/org.freedesktop.Accounts.xml
  106. %{_datadir}/dbus-1/interfaces/org.freedesktop.Accounts.User.xml
  107. %{_datadir}/dbus-1/system-services/org.freedesktop.Accounts.service
  108. %{_datadir}/polkit-1/actions/org.freedesktop.accounts.policy
  109. %dir %{_localstatedir}/lib/AccountsService/
  110. %dir %{_localstatedir}/lib/AccountsService/users
  111. %dir %{_localstatedir}/lib/AccountsService/icons
  112. %if %{with systemd}
  113. %{_unitdir}/accounts-daemon.service
  114. %endif
  115. %files libs
  116. %defattr(-,root,root,-)
  117. %{_libdir}/libaccountsservice.so.*
  118. %{_libdir}/girepository-1.0/AccountsService-1.0.typelib
  119. %files devel
  120. %defattr(-,root,root,-)
  121. %{_includedir}/accountsservice-1.0
  122. %{_libdir}/libaccountsservice.so
  123. %{_libdir}/pkgconfig/accountsservice.pc
  124. %{_datadir}/gir-1.0/AccountsService-1.0.gir
  125. %files doc
  126. %defattr(-,root,root,-)
  127. %{_datadir}/gtk-doc/html/libaccountsservice/
  128. %changelog
  129. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.6.55-1
  130. - new upstream release.
  131. - added systemd support (disabled as default).
  132. - dropped Patch1 and 2: fixed in upstream.
  133. - dropped Patch1000: got a same effect by sed.
  134. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.6.54-1
  135. - new upstream release.
  136. - added elogind support.
  137. - updated Patch1000.
  138. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.40-1
  139. - new upstream release
  140. * Mon Nov 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.39-1
  141. - new upstream release
  142. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.37-2
  143. - moved libs package to System Environment/Libraries
  144. - added %%post, %%postun and %%clean section
  145. - added Japanese summary
  146. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.37-1
  147. - new upstream release
  148. - add Patch1000 (accountsservice-0.6.37-vine-environment.patch)
  149. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.31-2
  150. - rebuild with VineSeed environment
  151. * Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.31-1
  152. - new upstream release
  153. * Sun Jan 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
  154. - new upstream release
  155. - create subpackage (%{name}-doc)
  156. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.25-1
  157. - new upstream release
  158. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.18-1
  159. - new upstream release
  160. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-1
  161. - new upstream release
  162. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.13-1
  163. - initial build for Vine Linux
  164. * Mon Jun 06 2011 Ray Strode <rstrode@redhat.com> 0.6.12-1
  165. - Update to latest release
  166. * Wed May 18 2011 Matthias Clasen <mclasen@redhat.com> 0.6.11-1
  167. - Update to 0.6.11
  168. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-2
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  170. * Wed Feb 02 2011 Ray Strode <rstrode@redhat.com> 0.6.3-1
  171. - Update to 0.6.3
  172. * Thu Jan 27 2011 Matthias Clasen <mclasen@redhat.com> 0.6.2-1
  173. - Update to 0.6.2
  174. * Wed Jul 21 2010 Matthias Clasen <mclasen@redhat.com> 0.6.1-1
  175. - Update to 0.6.1
  176. - Install systemd unit file
  177. * Mon Apr 5 2010 Matthias Clasen <mclasen@redhat.com> 0.6-2
  178. - Always emit changed signal on icon change
  179. * Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> 0.6-1
  180. - Update to 0.6
  181. * Mon Mar 22 2010 Matthias Clasen <mclasen@redhat.com> 0.5-1
  182. - Update to 0.5
  183. * Mon Feb 22 2010 Bastien Nocera <bnocera@redhat.com> 0.4-3
  184. - Fix directory ownership
  185. * Mon Feb 22 2010 Bastien Nocera <bnocera@redhat.com> 0.4-2
  186. - Add missing directories to the filelist
  187. * Fri Jan 29 2010 Matthias Clasen <mclasen@redhat.com> 0.4-1
  188. - Initial packaging, based on work by Richard Hughes