nmap-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Network exploration tool and security scanner
  3. Summary(ja): 多機能なポートスキャナー
  4. Name: nmap
  5. Version: 7.12
  6. Release: 2%{?_dist_release}
  7. License: GPL
  8. Group: Applications/System
  9. URL: http://www.insecure.org/nmap/
  10. Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
  11. #Source1: zenmap.desktop
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libpcap-devel
  14. BuildRequires: pcre-devel
  15. BuildRequires: python-devel
  16. BuildRequires: pygtk2-devel
  17. BuildRequires: openssl-devel
  18. BuildRequires: lua-devel
  19. %description
  20. Nmap is a utility for network exploration or security auditing. It
  21. supports ping scanning (determine which hosts are up), many port
  22. scanning techniques (determine what services the hosts are offering),
  23. and TCP/IP fingerprinting (remote host operating system
  24. identification). Nmap also offers flexible target and port
  25. specification, decoy scanning, determination of TCP sequence
  26. predictability characteristics, sunRPC scanning, reverse-identd
  27. scanning, and more.
  28. %description -l ja
  29. Nmap はネットワークの調査やセキュリティ診断を行うユーティリティです。
  30. ping によるスキャン(どのホストが稼働中かの調査)、様々なポートスキャン
  31. 技術(そのホストがどのサービスを提供しているかの調査)や、TCP/IP 指紋
  32. の検査(そのホストの OS を特定)をサポートしています。Nmap は調査対象や
  33. ポートを柔軟に設計することもでき、おとりスキャン、TCP シーケンスの
  34. 予測可能な性質の測定、Sun RPC スキャン、逆 identd スキャンなどの
  35. 機能も提供します。
  36. %package frontend
  37. Summary: Gtk+ frontend for nmap
  38. Summary(ja): Nmap の GTK+ フロントエンド
  39. Group: Applications/System
  40. Requires: nmap = %{version}-%{release}
  41. Requires: python pygtk2 pysqlite
  42. Provides: zenmap = %{version}-%{release}
  43. %description frontend
  44. This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
  45. be installed before installing nmap-frontend.
  46. %description frontend -l ja
  47. Nmap の GTK+ ベースのフロントエンド(zenmap)です。このパッケージをインストール
  48. する前に、nmap パッケージをインストールする必要があります。
  49. %prep
  50. %setup -q
  51. %build
  52. export CPPFLAGS="-I%{_includedir}/pcap -I%{_includedir}/pcre"
  53. %configure
  54. make
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
  59. rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_ndiff
  60. cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  61. gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
  62. pushd $RPM_BUILD_ROOT%{_mandir}/man1
  63. ln -s zenmap.1.gz nmapfe.1.gz
  64. ln -s zenmap.1.gz xnmap.1.gz
  65. popd
  66. #pushd $RPM_BUILD_ROOT%{_datadir}/pixmaps
  67. #mkdir zenmap
  68. #mv *.svg zenmap
  69. #mv *.png zenmap
  70. #popd
  71. #desktop-file-install --vendor= \
  72. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  73. # %{SOURCE1};
  74. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/zenmap-root.desktop
  75. %find_lang %{name} --with-man
  76. %clean
  77. rm -rf %{buildroot}
  78. %files -f %{name}.lang
  79. %defattr(-,root,root)
  80. %doc COPYING CHANGELOG
  81. %doc docs/README docs/nmap.usage.txt docs/nmap.dtd
  82. %{_bindir}/nmap
  83. %{_bindir}/ncat
  84. %{_bindir}/ndiff
  85. %{_bindir}/nping
  86. %{_datadir}/nmap
  87. %{_datadir}/ncat
  88. #%{_libexecdir}/nmap
  89. %{_mandir}/man1/nmap.1*
  90. %{_mandir}/man1/ncat.1*
  91. %{_mandir}/man1/ndiff.1*
  92. %{_mandir}/man1/nping.1*
  93. %files frontend
  94. %defattr(-,root,root)
  95. %{_bindir}/nmapfe
  96. %{_bindir}/xnmap
  97. %{_bindir}/zenmap
  98. %{python_sitelib}/*
  99. %{_datadir}/applications/*.desktop
  100. #%{_datadir}/icons/*
  101. #%{_datadir}/pixmaps/zenmap
  102. %{_datadir}/zenmap
  103. %{_mandir}/man1/zenmap.1*
  104. %{_mandir}/man1/nmapfe.1*
  105. %{_mandir}/man1/xnmap.1*
  106. %changelog
  107. * Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-2
  108. - rebuild with gcc-5.4.0
  109. * Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.12-1
  110. - new upstream release
  111. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
  112. - new upstream release
  113. * Thu Dec 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.01-1
  114. - new upstream release
  115. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.47-1
  116. - new upstream release
  117. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.25-1
  118. - new upstream release
  119. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-2
  120. - rebuild with pcre-8.31
  121. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.01-1
  122. - new upstream release
  123. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-2
  124. - new upstream release
  125. * Mon Feb 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.51-1
  126. - new upstream release
  127. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.50-1
  128. - new upstream release
  129. - fix %files to add nping
  130. * Fri Jun 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.21-1
  131. - new upstream release
  132. - add BuildRequires: openssl-devel, lua-devel
  133. - fix %files to add ncat and ndiff
  134. * Fri Apr 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.76-1
  135. - new upstream release
  136. - spec in UTF-8
  137. - added BuildRequires: libpcap-devel instead of libpcap
  138. - removed BuildRequires: desktop-file-utils
  139. * Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.60-4
  140. - rebuilt with libpcap 1.0.0
  141. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 4.60-3
  142. - rebuilt with python-2.5.2
  143. * Mon Apr 28 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.60-2
  144. - updated python sitelib files path
  145. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.60-1vl5
  146. - new upstream release
  147. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.20-0vl1
  148. - new upstream release
  149. - rebuild with new environment/toolchain
  150. * Sat Jun 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.10-0vl1
  151. - new upstream release
  152. - added BuildRequires: desktop-file-utils
  153. * Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.01-0vl1
  154. - new upstream release
  155. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl2
  156. - rebuild for VineSeed Plus
  157. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.93-0vl1
  158. - new upstream release
  159. * Fri Feb 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-0vl1
  160. - new upstream release
  161. * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.75-0vl1
  162. - new upstream release
  163. - added Japanese summary to nmap-frontend
  164. * Thu Sep 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.70-0vl1
  165. - new upstream release
  166. * Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl2
  167. - rebuild with new openssl
  168. * Tue Mar 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.50-0vl1
  169. - new upstream release
  170. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.48-0vl1
  171. - new upstream release
  172. * Thu Sep 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.45-0vl1
  173. - new upstream release
  174. * Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.30-0vl1
  175. - new upstream release
  176. * Tue May 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl2
  177. - merged Vine Plus specfile and VineSeed Plus specfile (sorry...)
  178. * Sat May 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.27-0vl1
  179. - new upstream release
  180. - rebuild with new toolchains
  181. * Sun Sep 22 2002 Masaru Sato <masachan@mediaship.ne.jp> 3.00-0vl1
  182. - new upstream release
  183. - delete Version Tag from nmap-frontend package
  184. - fix BuildRoot
  185. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.54BETA34-0vl1
  186. - new upstream release
  187. - 2.54BETA is developpment release, but it is more stable than 2.53.
  188. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 2.53-1vl2
  189. - unfortunately increase release: 1vl2 from 0vl2
  190. ( 2.53-1vl1 is found in VinePlus/2.1, also breaking our packaging rule)
  191. - patch to build on current glibc22 system
  192. * Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
  193. - 2.53-0vl2: use better macros
  194. * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
  195. - rebuild for VineSeed based on the original site's srpm
  196. - add Japanese summary and description
  197. * Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
  198. - Updated description
  199. - Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
  200. - Fixed nmap distribution URL (source0)
  201. - Added this .rpm to base Nmap distribution
  202. * Mon Dec 13 1999 Tim Powers <timp@redhat.com>
  203. - based on origional spec file from
  204. http://www.insecure.org/nmap/index.html#download
  205. - general cleanups, removed lots of commenrts since it made the spec hard to
  206. read
  207. - changed group to Applications/System
  208. - quiet setup
  209. - no need to create dirs in the install section, "make
  210. prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
  211. - using defined %{prefix}, %{version} etc. for easier/quicker maint.
  212. - added docs
  213. - gzip man pages
  214. - strip after files have been installed into buildroot
  215. - created separate package for the frontend so that Gtk+ isn't needed for the
  216. CLI nmap
  217. - not using -f in files section anymore, no need for it since there aren't that
  218. many files/dirs
  219. - added desktop entry for gnome
  220. * Sun Jan 10 1999 Fyodor <fyodor@dhp.com>
  221. - Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
  222. * Tue Dec 29 1998 Fyodor <fyodor@dhp.com>
  223. - Made some changes, and merged in another .spec file sent in
  224. by Oren Tirosh <oren@hishome.net>
  225. * Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
  226. - initial build for RH 5.x