qpdf-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. Summary: Command-line tools and library for transforming PDF files
  2. Name: qpdf
  3. Version: 5.1.0
  4. Release: 2%{?_dist_release}
  5. # MIT: e.g. libqpdf/sha2.c
  6. License: Artistic 2.0 and MIT
  7. Group: System Environment/Base
  8. URL: http://qpdf.sourceforge.net/
  9. Source0: http://downloads.sourceforge.net/sourceforge/qpdf/qpdf-%{version}.tar.gz
  10. Patch0: qpdf-doc.patch
  11. BuildRequires: zlib-devel
  12. BuildRequires: pcre-devel
  13. # for fix-qdf and test suite
  14. BuildRequires: perl
  15. BuildRequires: perl(Digest::MD5)
  16. # for autoreconf
  17. BuildRequires: autoconf
  18. BuildRequires: automake
  19. BuildRequires: libtool
  20. Requires: qpdf-libs%{?_isa} = %{version}-%{release}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: tomop
  24. %package libs
  25. Summary: QPDF library for transforming PDF files
  26. Group: System Environment/Libraries
  27. %package devel
  28. Summary: Development files for QPDF library
  29. Group: Development/Libraries
  30. Requires: qpdf-libs%{?_isa} = %{version}-%{release}
  31. %package doc
  32. Summary: QPDF Manual
  33. Group: Documentation
  34. BuildArch: noarch
  35. Requires: qpdf-libs = %{version}-%{release}
  36. %description
  37. QPDF is a command-line program that does structural, content-preserving
  38. transformations on PDF files. It could have been called something
  39. like pdf-to-pdf. It includes support for merging and splitting PDFs
  40. and to manipulate the list of pages in a PDF file. It is not a PDF viewer
  41. or a program capable of converting PDF into other formats.
  42. %description libs
  43. QPDF is a C++ library that inspect and manipulate the structure of PDF files.
  44. It can encrypt and linearize files, expose the internals of a PDF file,
  45. and do many other operations useful to PDF developers.
  46. %description devel
  47. Header files and libraries necessary
  48. for developing programs using the QPDF library.
  49. %description doc
  50. QPDF Manual
  51. %prep
  52. %setup -q
  53. # fix 'complete manual location' note in man pages
  54. %patch0 -p1 -b .doc
  55. sed -i -e '1s,^#!/usr/bin/env perl,#!/usr/bin/perl,' qpdf/fix-qdf
  56. %build
  57. # work-around check-rpaths errors
  58. autoreconf --verbose --force --install
  59. %configure --disable-static \
  60. --enable-show-failed-test-output
  61. make %{?_smp_mflags}
  62. %install
  63. make install DESTDIR=%{buildroot}
  64. # https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
  65. mkdir __doc
  66. mv %{buildroot}%{_datadir}/doc/qpdf/* __doc
  67. rm -rf %{buildroot}%{_datadir}/doc/qpdf
  68. rm -f %{buildroot}%{_libdir}/libqpdf.la
  69. %check
  70. make check
  71. %post libs -p /sbin/ldconfig
  72. %postun libs -p /sbin/ldconfig
  73. %files
  74. %{_bindir}/fix-qdf
  75. %{_bindir}/qpdf
  76. %{_bindir}/zlib-flate
  77. %{_mandir}/man1/*
  78. %files libs
  79. %doc README TODO ChangeLog Artistic-2.0
  80. %{_libdir}/libqpdf*.so.*
  81. %files devel
  82. %doc examples/*.cc examples/*.c
  83. %{_includedir}/*
  84. %{_libdir}/libqpdf*.so
  85. %{_libdir}/pkgconfig/libqpdf.pc
  86. %files doc
  87. %doc __doc/*
  88. %changelog
  89. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.1.0-2
  90. - initial build for Vine Linux.
  91. * Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 5.1.0-1
  92. - 5.1.0
  93. * Mon Oct 21 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.1-1
  94. - 5.0.1
  95. * Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-4
  96. - Perl 5.18 rebuild
  97. * Mon Jul 22 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-3
  98. - change shebang to absolute path (#987040)
  99. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-2
  100. - Perl 5.18 rebuild
  101. * Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-1
  102. - 5.0.0
  103. * Mon Jul 08 2013 Jiri Popelka <jpopelka@redhat.com> - 4.2.0-1
  104. - 4.2.0
  105. * Thu May 23 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-3
  106. - fix 'complete manual location' note in man pages (#966534)
  107. * Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-2
  108. - some source files are under MIT license
  109. * Mon Apr 15 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-1
  110. - 4.1.0
  111. * Tue Mar 05 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0.1-3
  112. - work around gcc 4.8.0 issue on ppc64 (#915321)
  113. - properly handle overridden compressed objects
  114. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  116. * Fri Jan 18 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.1-1
  117. - 4.0.1
  118. * Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.0-1
  119. - 4.0.0
  120. * Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.2-1
  121. - 3.0.2
  122. * Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-3
  123. - the previously added requirement doesn't need to be arch-specific
  124. * Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-2
  125. - doc subpackage requires libs subpackage due to license file (#848466)
  126. * Wed Aug 15 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-1
  127. - initial spec file