cvs-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324
  1. %define version 1.12.13
  2. Summary: A version control system.
  3. Summary(ja): バージョン管理システム
  4. Name: cvs
  5. Version: %{version}
  6. Release: 4%{?_dist_release}
  7. License: GPL
  8. Group: Development/Tools
  9. URL: http://www.cvshome.org/
  10. Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
  11. Source100: filter-requires-getopts-pl.sh
  12. Patch2: cvs-1.12.13-authserver.patch
  13. Patch3: cvs-1.11.2-cvspass.patch
  14. Patch5: cvs-1.11.2-install.patch
  15. Patch101: can-2005-2693.patch
  16. Requires(pre): install-info
  17. Prefix: %{_prefix}
  18. Buildroot: %{_tmppath}/%{name}-%{version}-root
  19. Requires: perl, zlib
  20. BuildRequires: zlib-devel
  21. BuildRequires: openssl-devel
  22. BuildRequires: vim
  23. # for perl
  24. %define __find_requires %{SOURCE100}
  25. %description
  26. CVS (Concurrent Version System) is a version control system which can
  27. record the history of your files (usually, but not always, source
  28. code). CVS only stores the differences between versions, instead of
  29. every version of every file you've ever created. CVS also keeps a log
  30. of who, when and why changes occurred.
  31. CVS is very helpful for managing releases and controlling the
  32. concurrent editing of source files among multiple authors. Instead of
  33. providing version control for a collection of files in a single
  34. directory, CVS provides version control for a hierarchical collection
  35. of directories consisting of revision controlled files. These
  36. directories and files can then be combined together to form a software
  37. release.
  38. Install the cvs package if you need to use a version control system.
  39. #'
  40. %description -l ja
  41. CVS (Concurrent Version System) はバージョン管理システムで,
  42. ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
  43. 変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
  44. 保存しておくのではなく,バージョン間の変更差分だけを保存します.
  45. CVS はまた誰が何故変更を行ったのかのログも記録します.
  46. CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
  47. 非常に役立ちます.
  48. バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
  49. %prep
  50. %setup -q
  51. %patch2 -p1 -b .authserver
  52. %patch3 -p1 -b .cvspass
  53. %patch5 -p1 -b .install
  54. %patch101 -p1 -b .can-2005-2693
  55. %build
  56. %configure --with-external-zlib
  57. make %{?_smp_mflags}
  58. make -C doc info
  59. %install
  60. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  61. %{makeinstall}
  62. gzip %{buildroot}%{_infodir}/cvs* || true
  63. %clean
  64. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  65. %post
  66. /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
  67. /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
  68. %preun
  69. if [ $1 = 0 ]; then
  70. /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
  71. /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
  72. fi
  73. %files
  74. %defattr(-,root,root)
  75. %doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
  76. %doc doc/*.pdf
  77. %{_bindir}/cvs
  78. %{_bindir}/cvsbug
  79. %{_bindir}/rcs2log
  80. %{_mandir}/man1/cvs.1*
  81. %{_mandir}/man5/cvs.5*
  82. %{_mandir}/man8/cvsbug.8*
  83. %{_infodir}/cvs*
  84. %{_datadir}/cvs
  85. %changelog
  86. * Sat Apr 2 2011 IWAI, Masaharu <iwai@alib.jp> 1.12.13-4vl6
  87. - build with krb5-libs 1.8.2
  88. - add doc/*.pdf in %%doc
  89. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-3
  90. - rebuild with openssl-1.0.0c
  91. - add BuildRequires: openssl-devel, vim
  92. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-2
  93. - spec in utf-8
  94. * Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
  95. - rebuild with perl-5.10.0-1vl5
  96. - add filter-requires-getopts-pl.sh (Source100)
  97. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
  98. - new upstream release
  99. - drop Patch100 which are merged in upstream.
  100. * Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
  101. - rebuilt with VineSeed
  102. * Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
  103. - added a security patch for CAN-2005-2693 (CVS temporary file issue).
  104. * Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
  105. - added a security patch for can-2005-0753 (Buffer Overflow and DoS).
  106. * Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
  107. - remove unneeded dependency
  108. - change Prereq: info to install-info
  109. - add %%{_smp_mflags} to make option
  110. * Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
  111. - new upstream release
  112. - security update
  113. This release fixes several serious security issues in the CVS server
  114. executable. It also contains one minor bug fix and the cvs log' and cvs ls'
  115. commands now output times in the client's local timezone.
  116. * Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
  117. - new upstream release
  118. - security update
  119. This release fixes a serious security issue in the CVS server executable.
  120. * Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
  121. - fixed typo in description
  122. * Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
  123. - new upstream release
  124. - security update
  125. This release fixes serious security issues in both the client and
  126. server executables. It also contains many bug fixes and support for
  127. accessing CVS pservers via intervening HTTP proxies.
  128. - fixed broken description
  129. - changed Source0 URL
  130. * Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
  131. - fixed typo in changelog
  132. * Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
  133. - new upstream release
  134. - added "--with-external-zlib2" to configure option
  135. -- dropped patch4
  136. * Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
  137. - new upstream release
  138. - security update
  139. pserver can no longer be configured to run as root via the
  140. $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
  141. longer leads directly to a root hack. Attempts to root will also be logged
  142. via the syslog.
  143. * Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
  144. - new upstream release
  145. - security update
  146. This release fixes a security issue with no known exploits that could cause
  147. previous versions of CVS to attempt to create files and directories in the
  148. filesystem root.
  149. * Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
  150. - new upstream release
  151. * Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
  152. - updated to new upstream release (security update)
  153. * Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
  154. - new upstream version
  155. -- Some minor changes to allow the code to compile on Windows platforms.
  156. -- NEWS: Add dummy entry for since 1.11.3.
  157. -- configure.in: Update to dev version 1.11.3.
  158. -- configure: Regenerated.
  159. * Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
  160. - new upstream version
  161. -- When waiting for another user's lock, the message timestamps are now
  162. in UTC rather than the server's local time.
  163. -- The options.h file is no longer used. This fixes a bug that occurred when 1.11.2 was compiled on Windows platforms.
  164. -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
  165. - dropped kbr4 patch
  166. * Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
  167. - clean up patch files
  168. - added some documents files
  169. * Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
  170. - updated cvs-1.11.2
  171. -- updated cvs-1.11.2-mktemp.patch
  172. * Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
  173. - paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
  174. The most notable feature is: build with an external zlib
  175. * Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
  176. - updated cvs-1.11.1p1
  177. - removed some patches
  178. - changed contrib dir to /usr/share from /usr/lib
  179. * Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  180. - 1.11-0vl2
  181. - rebuilt with new %%{_mandir} definition
  182. - added Japanese summary and description
  183. * Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
  184. - updated 1.11
  185. - removed auth.patch
  186. - added errno.patch from rawhide's cvs-1.11-1
  187. - partially used rpmmacros
  188. * Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  189. - 1.10.8-0vl3
  190. - fixed %post and %preun section
  191. - 1.10.8-0vl2
  192. - removed gzip and strip in %install
  193. * Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
  194. - updated 1.10.8
  195. - switch to using the system's zlib instead of built-in
  196. - removed kerberos
  197. * Wed Mar 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  198. - make kerberos support conditional at build-time
  199. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  200. - integrate kerberos support into main tree
  201. * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  202. - build with gssapi auth (--with-gssapi, --with-encryption)
  203. - apply patch to update libs to krb5 1.1.1
  204. * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
  205. - fix the damn info pages too while we're at it.
  206. - fix description
  207. - man pages are compressed
  208. - make sure %post and %preun work okay
  209. * Sun Jan 9 2000 Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
  210. - update to 1.10.7.
  211. * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
  212. - add the patch to make 1.10.6 usable
  213. (http://www.cyclic.com/cvs/dev-known.html).
  214. * Tue Jun 1 1999 Jeff Johnson <jbj@redhat.com>
  215. - update to 1.10.6.
  216. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  217. - auto rebuild in the new build environment (release 2)
  218. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  219. - updated text in spec file.
  220. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  221. - update to 1.10.5.
  222. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  223. - update to 1.10.4.
  224. * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
  225. - update to 1.10.3.
  226. * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
  227. - update to 1.10.2.
  228. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  229. - remove trailing characters from rcs2log mktemp args
  230. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  231. - update to 1.10.1
  232. * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
  233. - fix race conditions in cvsbug/rcs2log
  234. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  235. - update to 1.10.
  236. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  237. - update to 1.9.30.
  238. * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
  239. - translations modified for de, fr
  240. * Mon Jun 8 1998 Jeff Johnson <jbj@redhat.com>
  241. - build root
  242. - update to 1.9.28
  243. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  244. - translations modified for de, fr, tr
  245. * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
  246. - added install-info stuff
  247. - added changelog section