zlib-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The zlib compression and decompression library.
  3. Summary(ja): zlib 圧縮/展開ライブラリ
  4. Name: zlib
  5. Version: 1.2.11
  6. Release: 3%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Source: http://www.zlib.net/zlib-%{version}.tar.xz
  9. # Patch0: zlib-1.2.5-lfs-decls.patch
  10. Requires(post): /sbin/ldconfig
  11. Requires(postun): /sbin/ldconfig
  12. URL: http://www.zlib.net/
  13. License: zlib and Boost
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  18. %description
  19. The zlib compression library provides in-memory compression and
  20. decompression functions, including integrity checks of the
  21. uncompressed data. This version of the library supports only one
  22. compression method (deflation), but other algorithms may be added
  23. later, which will have the same stream interface. The zlib library is
  24. used by many different system programs.
  25. %description -l ja
  26. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  27. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  28. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  29. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  30. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  31. 用されています。
  32. %package devel
  33. Summary: Header files and libraries for developing apps which will use zlib.
  34. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Provides: pkgconfig(zlib) = %{version}
  38. %description devel
  39. The zlib-devel package contains the header files and libraries needed
  40. to develop programs that use the zlib compression and decompression
  41. library.
  42. %package static
  43. Summary: Static libraries for %{name}
  44. Summary(ja): %{name} のスタティックライブラリ
  45. Group: Development/Libraries
  46. Requires: %{name}-devel = %{version}-%{release}
  47. %description static
  48. The zlib-static package contains the static library for %{name}
  49. ## to build compat32 for x86_64 architecture support
  50. %package -n compat32-%{name}
  51. Summary: The zlib compression and decompression library.
  52. Summary(ja): zlib 圧縮/展開ライブラリ
  53. Group: System Environment/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires(post): /sbin/ldconfig
  56. Requires(postun): /sbin/ldconfig
  57. %description -n compat32-%{name}
  58. The zlib compression library provides in-memory compression and
  59. decompression functions, including integrity checks of the
  60. uncompressed data. This version of the library supports only one
  61. compression method (deflation), but other algorithms may be added
  62. later, which will have the same stream interface. The zlib library is
  63. used by many different system programs.
  64. %description -n compat32-%{name} -l ja
  65. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  66. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  67. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  68. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  69. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  70. 用されています。
  71. %package -n compat32-%{name}-devel
  72. Summary: Header files and libraries for developing apps which will use zlib.
  73. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  74. Group: Development/Libraries
  75. Requires: %{name} = %{version}-%{release}
  76. Requires: %{name}-devel = %{version}-%{release}
  77. %description -n compat32-%{name}-devel
  78. The zlib-devel package contains the header files and libraries needed
  79. to develop programs that use the zlib compression and decompression
  80. library.
  81. Install the zlib-devel package if you want to develop applications that
  82. will use the zlib library.
  83. %prep
  84. %setup -q
  85. # %patch0 -p1
  86. %build
  87. mkdir static shared
  88. # build shared lib
  89. CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
  90. make %{?_smp_mflags}
  91. mv -f Makefile zconf.h *.o *.so* shared/
  92. # build static lib
  93. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
  94. make %{?_smp_mflags}
  95. mv -f Makefile zconf.h *.o *.a static/
  96. %install
  97. rm -rf ${RPM_BUILD_ROOT}
  98. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
  99. mv -f shared/* .
  100. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  101. mv -f Makefile zconf.h *.o *.so* shared/
  102. mv -f static/* .
  103. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  104. install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
  105. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
  106. install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
  107. if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
  108. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  109. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
  110. rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
  111. fi
  112. cat %{buildroot}/usr/include/zlib.h | sed -n '1,/*\//p' > LICENSE
  113. %clean
  114. rm -rf ${RPM_BUILD_ROOT}
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %post -n compat32-%{name} -p /sbin/ldconfig
  118. %postun -n compat32-%{name} -p /sbin/ldconfig
  119. %files
  120. %defattr(-,root,root)
  121. %license LICENSE
  122. %doc README
  123. %{_libdir}/*.so
  124. %{_libdir}/libz.so.*
  125. %files devel
  126. %defattr(-,root,root)
  127. %doc ChangeLog doc/algorithm.txt
  128. %{_libdir}/pkgconfig/zlib.pc
  129. %{_includedir}/*
  130. %{_mandir}/man3/zlib.3*
  131. %files static
  132. %defattr(-,root,root)
  133. %{_libdir}/*.a
  134. %if %{build_compat32}
  135. %files -n compat32-%{name}
  136. %defattr(-,root,root)
  137. %{_libdir}/libz.so.*
  138. %files -n compat32-%{name}-devel
  139. %defattr(-,root,root)
  140. %{_libdir}/*.so
  141. %{_libdir}/pkgconfig/zlib.pc
  142. %endif
  143. %changelog
  144. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-3
  145. - fixed "Provides:".
  146. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-2
  147. - dropped "Provides:pkgconfig(zlib)" from compat32-zlib-devel.
  148. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-1
  149. - new upstream release.
  150. - added license text.
  151. - reverted moving libz.so for compat32 package.
  152. * Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
  153. - moved libz.so into the main package.
  154. * Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
  155. - new upstream release
  156. - changed archive type bz2 to xz
  157. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
  158. - new upstream release
  159. - drop patch0 (resolved by upstream)
  160. - use smp flag in make section
  161. * Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
  162. - added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
  163. * Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
  164. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  165. - changed License: BSD to zlib and Boost
  166. - added %%{_libdir}/pkgconfig/zlib.pc in -devel package
  167. - fixed %%doc files in -devel package
  168. * Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
  169. - add Requires(post,pre): /sbin/ldconfig
  170. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
  171. - rebuilt with gcc-4.4.3-3 on ppc
  172. * Mon Feb 8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
  173. - rebuilt with new toolchain
  174. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
  175. - split static library to zlib-static
  176. - needed by tuxonice-userui
  177. * Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
  178. - change spec into UTF-8
  179. * Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
  180. - removed %%if !%%{build_compat32} case condition
  181. * Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  182. - applied new versioning policy
  183. - rebuilt with new toolchains
  184. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
  185. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  186. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
  187. - added compat32-* packages for x86_64 architecture support
  188. * Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
  189. - added compat32- packages for x86_64 architecture support
  190. * Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
  191. - clean up specfile (do not build twice..)
  192. * Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  193. - new upstream release
  194. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
  195. - new upstream release
  196. - add Patch1 for CAN-2005-2096
  197. * Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  198. - new upstream version
  199. - add translated descriptions (thanks to spec file translation project)
  200. * Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
  201. - fixed buffer overrun on gzprintf
  202. -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
  203. * Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
  204. - changed URL to more preferable site
  205. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
  206. - upstream release
  207. * Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  208. - 1.1.3-14vl1
  209. - based on 1.1.3-14 from Rawhide
  210. - added Japanese summary
  211. * Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  212. - add -fPIC for shared libs (patch by Fritz Elfert)
  213. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  214. - on 64bit systems, make sure libraries are located correctly.
  215. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  216. - summaries from specspo.
  217. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  218. - automatic rebuild
  219. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  220. - rebuild
  221. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  222. - FHS packaging to build on solaris2.5.1.
  223. * Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
  224. - use %%{_mandir} and %%{_tmppath}
  225. * Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
  226. - updated URL and source location
  227. - moved README to main package
  228. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  229. - compress man page.
  230. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  231. - auto rebuild in the new build environment (release 5)
  232. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  233. - link against glibc
  234. * Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
  235. - upgrade to 1.1.3
  236. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  237. - translations modified for de, fr, tr
  238. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  239. - upgraded to 1.1.2
  240. - buildroot
  241. * Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
  242. - added URL tag (down at the moment so it may not be correct)
  243. - made zlib-devel require zlib
  244. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  245. - built against glibc