ntfs-3g-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296
  1. %bcond_with externalfuse
  2. Summary: Linux NTFS userspace driver
  3. Summary(ja): Linux NTFS ユーザ空間ドライバ
  4. Name: ntfs-3g
  5. Version: 2016.2.22
  6. Release: 1%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Base
  9. URL: http://www.ntfs-3g.org/
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Source0: http://tuxera.com/opensource/%{name}_ntfsprogs-%{version}.tgz
  13. Source1: 20-ntfs-config-write-policy.fdi
  14. Patch0: ntfs-3g_ntfsprogs-2011.10.9-RC-ntfsck-unsupported-return-0.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: libtool
  17. BuildRequires: libattr-devel
  18. %if %{?_dist_release} != "vl6"
  19. BuildRequires: libconfig-devel
  20. %endif
  21. BuildRequires: libgcrypt-devel
  22. BuildRequires: gnutls-devel
  23. BuildRequires: libuuid-devel
  24. %if %{with externalfuse}
  25. BuildRequires: fuse-devel
  26. Requires: fuse
  27. %endif
  28. %description
  29. NTFS-3G is a stable, open source, GPL licensed, POSIX, read/write NTFS
  30. driver for Linux and many other operating systems. It provides safe
  31. handling of the Windows XP, Windows Server 2003, Windows 2000, Windows
  32. Vista, Windows Server 2008 and Windows 7 NTFS file systems. NTFS-3G can
  33. create, remove, rename, move files, directories, hard links, and streams;
  34. it can read and write normal and transparently compressed files, including
  35. streams and sparse files; it can handle special files like symbolic links,
  36. devices, and FIFOs, ACL, extended attributes; moreover it provides full
  37. file access right and ownership support.
  38. %package devel
  39. Summary: Development files and libraries for ntfs-3g
  40. Summary(ja): ntfs-3g の開発ファイルとライブラリ
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: pkgconfig
  44. Provides: ntfsprogs-devel = %{version}-%{release}
  45. Obsoletes: ntfsprogs-devel < 2.0.0-3
  46. %description devel
  47. Headers and libraries for developing applications that use ntfs-3g
  48. functionality.
  49. %package -n ntfsprogs
  50. Summary: NTFS filesystem libraries and utilities
  51. Summary(ja): NTFS ファイルシステム用ライブラリおよびユーティリティ
  52. Group: System Environment/Base
  53. Provides: ntfsprogs-gnomevfs = %{version}-%{release}
  54. Obsoletes: ntfsprogs-gnomevfs < 2.0.0-3
  55. %description -n ntfsprogs
  56. The ntfsprogs package currently consists of a library and utilities
  57. such as mkntfs, ntfscat, ntfsls, ntfsresize, and ntfsundelete
  58. (for a full list of included utilities see man 8 ntfsprogs after
  59. installation).
  60. %prep
  61. %setup -q -n %{name}_ntfsprogs-%{version}
  62. %patch0 -p1 -b .unsupported
  63. %build
  64. %configure --disable-static \
  65. --disable-ldconfig \
  66. %{?with_ externalfuse:--with-fuse=external} \
  67. --exec-prefix=/ \
  68. --bindir=/bin \
  69. --sbindir=/sbin \
  70. --libdir=/%{_lib} \
  71. --enable-crypto \
  72. --enable-extras \
  73. --enable-quarantined
  74. make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=%{_bindir}/libtool install
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
  79. rm -f $RPM_BUILD_ROOT/%{_lib}/libntfs-3g.{la,a}
  80. mkdir -p $RPM_BUILD_ROOT/sbin
  81. # make the symlink an actual copy to avoid confusion
  82. rm -rf $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  83. cp -a $RPM_BUILD_ROOT/bin/ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-3g
  84. # make compatibility symlinks
  85. ln -s ntfs-3g $RPM_BUILD_ROOT/bin/ntfsmount
  86. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs-fuse
  87. ln -s mount.ntfs-3g $RPM_BUILD_ROOT/sbin/mount.ntfs
  88. ln -s ../bin/ntfsck $RPM_BUILD_ROOT/sbin/fsck.ntfs
  89. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  90. ln -s /bin/ntfs-3g $RPM_BUILD_ROOT%{_bindir}/ntfs-3g
  91. ln -s /bin/ntfsmount $RPM_BUILD_ROOT%{_bindir}/ntfsmount
  92. # Put the .pc file in the right place.
  93. mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  94. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig/libntfs-3g.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/
  95. %if %{?_dist_release} == "vl6"
  96. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  97. cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor/
  98. %endif
  99. # We get this on our own, thanks.
  100. rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/README
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files
  106. %defattr(-,root,root,-)
  107. %doc AUTHORS ChangeLog COPYING CREDITS NEWS README
  108. /sbin/mount.ntfs
  109. %attr(4754,root,root) /sbin/mount.ntfs-3g
  110. /sbin/mount.ntfs-fuse
  111. /sbin/mount.lowntfs-3g
  112. /bin/lowntfs-3g
  113. /bin/ntfs-3g
  114. /bin/ntfs-3g.probe
  115. /bin/ntfs-3g.secaudit
  116. /bin/ntfs-3g.usermap
  117. /bin/ntfsmount
  118. %{_bindir}/ntfs-3g
  119. %{_bindir}/ntfsmount
  120. /%{_lib}/libntfs-3g.so.*
  121. %{_mandir}/man8/mount.lowntfs-3g.*
  122. %{_mandir}/man8/mount.ntfs-3g.*
  123. %{_mandir}/man8/ntfs-3g*
  124. %if %{?_dist_release} == "vl6"
  125. %{_datadir}/hal/fdi/policy/10osvendor/20-ntfs-config-write-policy.fdi
  126. %endif
  127. %files devel
  128. %defattr(-,root,root,-)
  129. %{_includedir}/ntfs-3g/
  130. /%{_lib}/libntfs-3g.so
  131. %{_libdir}/pkgconfig/*.pc
  132. %files -n ntfsprogs
  133. %doc AUTHORS COPYING CREDITS ChangeLog NEWS README
  134. /bin/ntfscat
  135. /bin/ntfscluster
  136. /bin/ntfscmp
  137. /bin/ntfsfix
  138. /bin/ntfsinfo
  139. /bin/ntfsls
  140. # extras
  141. /bin/ntfsck
  142. /bin/ntfsdecrypt
  143. /bin/ntfsdump_logfile
  144. /bin/ntfsfallocate
  145. /bin/ntfsmftalloc
  146. /bin/ntfsmove
  147. /bin/ntfsrecover
  148. /bin/ntfstruncate
  149. /bin/ntfswipe
  150. /sbin/fsck.ntfs
  151. /sbin/mkfs.ntfs
  152. /sbin/mkntfs
  153. /sbin/ntfsclone
  154. /sbin/ntfscp
  155. /sbin/ntfslabel
  156. /sbin/ntfsresize
  157. /sbin/ntfsundelete
  158. %{_mandir}/man8/mkntfs.8*
  159. %{_mandir}/man8/mkfs.ntfs.8*
  160. %{_mandir}/man8/ntfs[^m][^o]*.8*
  161. %exclude %{_mandir}/man8/ntfs-3g*
  162. %changelog
  163. * Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016.2.22-1
  164. - new upstream release.
  165. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015.3.14-3
  166. - rebuilt with gnutls-3.4.x.
  167. * Fri May 8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-2
  168. - reverted file location <Vine Linux:2914>
  169. * Fri Apr 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2015.3.14-1
  170. - new upstream release
  171. - dropt hal files, since hal is very old
  172. * Sun Mar 02 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2014.2.15-1
  173. - new upstream release
  174. * Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2013.1.13-2
  175. - rebuilt with gnutls-3.2 and libgcrypt-1.6
  176. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.13-1
  177. - new upstream release
  178. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.1.15-1
  179. - new upstream release
  180. - merge ntfsprogs
  181. - add Obsoletes and Provides ntfsprogs*
  182. - add BR: for ntfsprogs
  183. * Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2011.1.15-1
  184. - new upstream release
  185. - fix %%files (add lowntfs-3g)
  186. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.4.4-1
  187. - new upstream release
  188. - use internal fuse-lite, remove BR: fuse-devel and R: fuse
  189. - move binaries to /bin
  190. - move libraries to /%%{_lib}
  191. - add fdi file to enable hal automounting
  192. * Sun Jan 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009.1.1-1
  193. - new upstream release
  194. * Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2812-1
  195. - new upstream release
  196. * Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2712-1
  197. - new upstream release
  198. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2412-1
  199. - new upstream release
  200. * Tue Jun 05 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.516-0vl1
  201. - initial build for Vine Linux
  202. * Tue May 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.516-1
  203. - bump to 1.516
  204. - fix bugzilla 232031
  205. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.417-1
  206. - bump to 1.417
  207. * Sun Apr 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.416-1
  208. - bump to 1.416
  209. - drop patch0, upstreamed
  210. * Wed Apr 4 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-2
  211. - allow non-root users to mount/umount ntfs volumes (Laszlo Dvornik)
  212. * Sat Mar 31 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.328-1
  213. - bump to 1.328
  214. - drop patch, use --disable-ldconfig instead
  215. * Wed Feb 21 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:1.0-1
  216. - 1.0 release!
  217. * Fri Jan 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.9.20070118
  218. - symlink to mount.ntfs
  219. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.8.20070118
  220. - bump to 20070118
  221. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 2:0-0.7.20070116
  222. - bump to latest version for all active dists
  223. * Wed Jan 3 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.6.20070102
  224. - bump to latest version (note that upstream fixed their date mistake)
  225. * Wed Nov 1 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.5.20070920
  226. - add an obsoletes for ntfsprogs-fuse
  227. - make some convenience symlinks
  228. * Wed Oct 25 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.4.20070920
  229. - add some extra Provides
  230. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.3.20070920
  231. - add explicit Requires on fuse
  232. * Mon Oct 16 2006 Tom "spot" Callaway <tcallawa@redhat.com> 1:0-0.2.20070920
  233. - fixed versioning (bumped epoch, since it now shows as older)
  234. - change sbin symlink to actual copy to be safe
  235. * Sun Oct 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.20070920-1
  236. - Initial package for Fedora Extras