librsvg2-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433
  1. %define __libtoolize :
  2. %define libxml2_version 2.7.8
  3. %define gdk_pixbuf2 2.26.1
  4. %define gtk3_version 3.4.1
  5. %define freetype_version 2.4.2
  6. %define popt_version 1.14
  7. %define libart_version 2.3.21
  8. %define cairo_version 1.12.0
  9. %define dbus_version 1.4.0
  10. %define dbus_glib_version 0.88
  11. %define avahi_glib_version 0.6.23
  12. %define libcroco_version 0.6.2
  13. %define libgsf_version 1.14.19
  14. Name: librsvg2
  15. Summary: An SVG library based on libart.
  16. Summary(ja): libart ベースの SVG ライブラリ
  17. Version: 2.46.4
  18. Release: 1%{?_dist_release}
  19. License: LGPL
  20. Group: System Environment/Libraries
  21. %global shortver %(echo %{version} | sed -e 's/\\.[0-9]*$//')
  22. Source: https://download.gnome.org/sources/librsvg/%{shortver}/librsvg-%{version}.tar.xz
  23. Requires(post,postun): gtk3 >= %{gtk3_version}
  24. Requires(post): dbus-glib >= %{dbus_glib_version}
  25. Requires(post): avahi-glib >= %{avahi_glib_version}
  26. Requires(post): libgsf, libcroco
  27. Requires: gtk3 >= %{gtk3_version}
  28. Requires: libxml2 >= %{libxml2_version}
  29. Requires: popt >= %{popt_version}
  30. Requires: freetype2 >= %{freetype_version}
  31. Requires: libpng
  32. BuildRequires: libpng-devel
  33. BuildRequires: gtk3-devel >= %{gtk3_version}
  34. BuildRequires: gobject-introspection-devel
  35. BuildRequires: libxml2-devel >= %{libxml2_version}
  36. BuildRequires: freetype2-devel >= %{freetype_version}
  37. BuildRequires: cairo-devel >= %{cairo_version}
  38. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  39. BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
  40. BuildRequires: libcroco-devel >= %{libcroco_version}
  41. BuildRequires: libgsf-devel >= %{libgsf_version}
  42. BuildRequires: autoconf
  43. BuildRequires: gtk-doc
  44. BuildRequires: vala-devel
  45. BuildRequires: vala-tools
  46. BuildRequires: rust
  47. BuildRequires: cargo
  48. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. %description
  52. An SVG library based on libart.
  53. %description -l ja
  54. libart ベースの SVG ライブラリです
  55. %package devel
  56. Summary: Libraries and include files for developing with librsvg.
  57. Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}
  60. Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
  61. Requires: cairo-devel >= %{cairo_version}
  62. %description devel
  63. This package provides the necessary development libraries and include
  64. files to allow you to develop with librsvg.
  65. %package docs
  66. Summary: Documentation for %{name}
  67. Summary(ja): %{name} 用のドキュメント
  68. Group: Documentation
  69. Requires: %{name} = %{version}-%{release}
  70. BuildArch: noarch
  71. %description docs
  72. This package contains documentation for %{name}.
  73. %package vala
  74. Summary: Vala bindings for %{name}
  75. Summary(ja): %{name} の Vala バインディング
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: vala
  79. %description vala
  80. Vala bindings for %{name}.
  81. %prep
  82. %setup -q -n librsvg-%{version}
  83. %build
  84. %configure --enable-gtk-doc \
  85. --enable-introspection=yes \
  86. --enable-vala=yes \
  87. --with-svgz \
  88. --enable-gtk-theme \
  89. --with-croco \
  90. --disable-static
  91. %__make %{?_smp_mflags}
  92. %install
  93. rm -rf %{buildroot}
  94. make install DESTDIR=%{buildroot}
  95. rm -f %{buildroot}%{_libdir}/*.{a,la}
  96. rm -f %{buildroot}%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
  97. rm -f %{buildroot}%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
  98. rm -rf %{buildroot}%{_docdir}/librsvg
  99. %find_lang librsvg
  100. %clean
  101. rm -rf %{buildroot}
  102. %post
  103. /sbin/ldconfig
  104. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  105. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  106. fi ||:
  107. %postun
  108. /sbin/ldconfig
  109. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  110. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  111. fi ||:
  112. %files -f librsvg.lang
  113. %defattr(-,root,root,-)
  114. %license COPYING.LIB
  115. %doc AUTHORS NEWS README.md
  116. %{_bindir}/rsvg-convert
  117. %{_libdir}/librsvg-2.so.*
  118. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
  119. %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
  120. %dir %{_datadir}/thumbnailers
  121. %{_datadir}/thumbnailers/librsvg.thumbnailer
  122. %{_mandir}/man1/rsvg-convert.1.gz
  123. %files devel
  124. %defattr(-,root,root,-)
  125. %{_libdir}/librsvg-2.so
  126. %{_includedir}/librsvg-2.0/librsvg
  127. %{_libdir}/pkgconfig/librsvg-2.0.pc
  128. %{_datadir}/gir-1.0/Rsvg-2.0.gir
  129. %files docs
  130. %defattr(-,root,root,-)
  131. %{_datadir}/gtk-doc/html/rsvg-2.0
  132. %files vala
  133. %defattr(-,root,root,-)
  134. %{_datadir}/vala/vapi/librsvg-2.0.vapi
  135. %changelog
  136. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.46.4-1
  137. - new upstream release.
  138. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.16-1
  139. - new upstream release
  140. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.12-1
  141. - new upstream release
  142. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.11-1
  143. - new upstream release
  144. - remove Patch0
  145. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
  146. - new upstream release
  147. - add Patch0 (librsvg-2.40.10-git20150811.patch)
  148. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
  149. - new upstream release
  150. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
  151. - new upstream release
  152. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
  153. - new upstream release
  154. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
  155. - new upstream release
  156. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
  157. - new upstream release
  158. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
  159. - new upstream release
  160. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
  161. - rebuild with libpng-1.6.12
  162. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
  163. - new upstream release
  164. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
  165. - fix typo
  166. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  167. - new upstream release
  168. - remove BuildRequires: gtk2-devel
  169. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
  170. - add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
  171. - create %%{name}-docs and %%{name}-vala subpackages
  172. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  173. - new upstream release
  174. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  175. - new upstream release
  176. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  177. - new upstream release
  178. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  179. - new upstream release
  180. - add BuildRequires: gobject-introspection-devel
  181. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  182. - new upstream release
  183. - remove Patch0
  184. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  185. - new upstream release
  186. - add Patch0 (librsvg2-2.34.0-git20110728.patch)
  187. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  188. - new upstream release
  189. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  190. - new upstream release
  191. - remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
  192. - remove Requires: libart_lgpl
  193. - add configure option (--disable-static)
  194. - remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
  195. - fix %install, %files, %post and %postun
  196. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
  197. - build with rpm-4.8.1-1 for pkg-config file
  198. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
  199. - new upstream release
  200. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  201. - new upstream release
  202. - remove static libs
  203. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
  204. - new upstream release
  205. - spec in UTF-8
  206. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
  207. - new upstream release
  208. * Sat Mar 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
  209. - rebuilt with libgsf-1.14.8
  210. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  211. - new upstream release
  212. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
  213. - new upstream release
  214. - add BuildRequires: dbus-glib-devel, avahi-glib-devel
  215. - add BuildRequires: libgsf-devel, libcroco-devel
  216. - add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
  217. - add Requires(post,postun): glib2
  218. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
  219. - rebuild with gtk+-2.10
  220. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
  221. - rebuilt without libgsf-devel
  222. * Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
  223. - update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
  224. for biarch support. (TODO: add compat32)
  225. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
  226. - rebuild
  227. * Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
  228. - new upstream release
  229. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  230. - new upstream release
  231. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  232. - new upstream release
  233. * Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
  234. - new upstream release
  235. - added --disable-gtk-doc option
  236. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  237. - new upstream release
  238. - added gtk-doc to devel package
  239. * Sun Oct 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  240. - new upstream release
  241. - added Japanese description
  242. - added --without-svgz option (because it requires libgsf)
  243. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  244. - new upstream release
  245. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  246. - new upstream release
  247. * Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
  248. - rebuilt to avoid unwanted dependency (libgsf)
  249. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
  250. - add gdk-pixbuf-query-loaders to post/postun script.
  251. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
  252. - rebuild with gtk+-2.4.0
  253. * Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  254. - new upstream release
  255. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
  256. - fix kanji code of spec file
  257. - fix file entry, add missing files
  258. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  259. - new upstream release
  260. * Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
  261. - added --without-svgz and --without-gimp to %configure
  262. * Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
  263. - new upstream release
  264. - added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
  265. - added %{_libdir}/gtk-2.0/* to devel package
  266. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  267. - new upstream release
  268. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  269. - new upstream release
  270. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  271. - new upstream release
  272. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
  273. - build for Vine Linux
  274. - new upstream release from gnome-2.1.4
  275. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  276. - 2.0.1
  277. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  278. - automated rebuild
  279. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  280. - automated rebuild
  281. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  282. - rebuild in different environment
  283. * Thu May 02 2002 Havoc Pennington <hp@redhat.com>
  284. - rebuild in different environment
  285. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  286. - 1.1.6
  287. * Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
  288. - Update to 1.1.3
  289. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  290. - automated rebuild
  291. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  292. - new CVS snap 1.1.0.91
  293. - remove automake/autoconf calls
  294. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  295. - convert to librsvg2 RPM
  296. * Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
  297. - 1.0.2
  298. * Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
  299. - Add a patch that moves the includes to librsvg-1/librsvg
  300. - in preparation for a later librsvg 2 library.
  301. * Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
  302. - build requires gnome-libs-devel, #49509
  303. * Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
  304. - own /usr/include/librsvg
  305. * Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
  306. - fixed the linefeed problem in multibyte environment. (Bug#49310)
  307. * Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
  308. - put .la file back in package
  309. * Fri Jul 6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  310. - Put changelog at the end
  311. - Move .so files to devel subpackage
  312. - Don't mess with ld.so.conf
  313. - Don't use %%{prefix}, this isn't a relocatable package
  314. - Don't define a bad docdir
  315. - Add BuildRequires
  316. - Use %%{_tmppath}
  317. - Don't define name, version etc. on top of the file (why do so many do that?)
  318. - s/Copyright/License/
  319. * Wed May 9 2001 Jonathan Blandford <jrb@redhat.com>
  320. - Put into Red Hat Build system
  321. * Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
  322. - removed obsoletes from sub packages and added mozilla and trilobite
  323. subpackages
  324. * Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
  325. - created this thing