libgit2-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. Summary: C implementation of the Git core methods as a library with a solid API
  2. Name: libgit2
  3. Version: 0.27.8
  4. Release: 2%{?_dist_release}
  5. License: GPLv2
  6. Group: System Environment/Libraries
  7. URL: https://libgit2.github.com/
  8. # https://github.com/libgit2/libgit2/archive/v0.23.3.tar.gz
  9. Source0: %{name}-%{version}.tar.gz
  10. BuildRequires: cmake
  11. BuildRequires: openssl-devel
  12. BuildRequires: http-parser-devel
  13. BuildRequires: curl-devel
  14. BuildRequires: libssh2-devel
  15. BuildRequires: zlib-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Takemikaduchi
  20. %description
  21. libgit2 is a portable, pure C implementation of the Git core methods
  22. provided as a re-entrant linkable library with a solid API, allowing
  23. you to write native speed custom Git applications in any language
  24. which supports C bindings.
  25. %package devel
  26. Summary: Development tools for %{name}
  27. Summary(ja): %{name} の開発環境
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: pkgconfig
  31. Requires: openssl-devel
  32. Requires: http-parser-devel
  33. Requires: libssh2-devel
  34. Requires: zlib-devel
  35. %description devel
  36. Header files and libraries for building a extension library for the %{name}.
  37. %prep
  38. %setup -q
  39. %build
  40. rm -rf build && mkdir build && pushd build
  41. %cmake -DINSTALL_DOCS=OFF \
  42. ../
  43. make %{?_smp_mflags}
  44. popd
  45. %install
  46. rm -rf ${RPM_BUILD_ROOT}
  47. pushd build
  48. make install DESTDIR=${RPM_BUILD_ROOT}
  49. popd
  50. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  51. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  52. %clean
  53. %{__rm} -rf ${RPM_BUILD_ROOT}
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %files
  57. %defattr(-,root,root,-)
  58. %doc COPYING CHANGELOG.md README.md
  59. %{_libdir}/%{name}.so.*
  60. %files devel
  61. %defattr(-,root,root,-)
  62. %{_includedir}/git2/
  63. %{_includedir}/git2.h
  64. %{_libdir}/%{name}.so
  65. %{_libdir}/pkgconfig/%{name}.pc
  66. %changelog
  67. * Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-2
  68. - correct date
  69. * Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-1
  70. - update to 0.27.8
  71. - add BuildRequires: curl-devel
  72. * Thu Nov 01 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-2
  73. - rebuild with openssl-1.1.1
  74. * Mon Aug 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-1
  75. - new upstream release
  76. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.1-1
  77. - new upstream release
  78. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.3-1
  79. - new upstream release
  80. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-2
  81. - add BuildRequires: openssl-devel, http-parser-devel, libssh2-devel, zlib-devel
  82. * Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
  83. - initial build