pcre-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254
  1. Name: pcre
  2. Version: 8.36
  3. Release: 1%{?_dist_release}
  4. Summary: Perl-compatible regular expression library
  5. Summary(ja): Perl 互換の正規表現ライブラリ
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://www.pcre.org/
  9. Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
  10. # Upstream thinks RPATH is good idea.
  11. Patch0: pcre-8.21-multilib.patch
  12. # Refused by upstream, bug #675477
  13. Patch1: pcre-8.32-refused_spelling_terminated.patch
  14. # Reset non-matched groups within capturing group up to forced match,
  15. # bug #1161587, in upstream after 8.36
  16. Patch2: pcre-8.36-Fix-bug-when-there-are-unset-groups-prior-to-ACCEPT-.patch
  17. # Fix unused memory usage on zero-repeat assertion condition, bug #1165626,
  18. # CVE-2014-8964, in upstream after 8.36
  19. Patch3: pcre-8.36-Fix-zero-repeat-assertion-condition-bug.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: zlib-devel
  22. BuildRequires: bzip2-devel
  23. BuildRequires: libedit-devel
  24. # New libtool to get rid of rpath
  25. BuildRequires: autoconf, automake, libtool
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: inagaki
  29. %description
  30. Perl-compatible regular expression library.
  31. PCRE has its own native API, but a set of "wrapper" functions that are based on
  32. the POSIX API are also supplied in the library libpcreposix. Note that this
  33. just provides a POSIX calling interface to PCRE: the regular expressions
  34. themselves still follow Perl syntax and semantics. The header file
  35. for the POSIX-style functions is called pcreposix.h.
  36. %package devel
  37. Summary: Development files for %{name}
  38. Summary(ja): %{name} の開発用ファイル
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description devel
  42. Development files (Headers, libraries for static linking, etc) for %{name}.
  43. %prep
  44. %setup -q
  45. # Get rid of rpath
  46. %patch0 -p1 -b .multilib
  47. %patch1 -p1 -b .terminated_typos
  48. %patch2 -p1 -b .reset_groups
  49. %patch3 -p1 -b .zero_repeat_assertion
  50. # Because of rpath patch
  51. libtoolize --copy --force && autoreconf -vif
  52. # One contributor's name is non-UTF-8
  53. for F in ChangeLog; do
  54. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  55. touch --reference "$F" "${F}.utf8"
  56. mv "${F}.utf8" "$F"
  57. done
  58. %build
  59. %configure \
  60. --enable-jit \
  61. --disable-static \
  62. --enable-utf8 \
  63. --enable-unicode-properties \
  64. --enable-pcregrep-libz \
  65. --enable-pcregrep-libbz2 \
  66. --enable-pcretest-libedit \
  67. --enable-pcre8 \
  68. --enable-pcre16 \
  69. --enable-pcre32
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT
  74. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  76. %check
  77. %ifarch s390 s390x ppc
  78. # larger stack is needed on s390, ppc
  79. ulimit -s 10240
  80. %endif
  81. make %{?_smp_mflags} check VERBOSE=yes
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %files
  87. %defattr(-,root,root)
  88. %doc AUTHORS COPYING ChangeLog LICENCE NEWS README
  89. %{_bindir}/pcregrep
  90. %{_libdir}/*.so.*
  91. %{_mandir}/man1/pcregrep.*
  92. %files devel
  93. %defattr(-,root,root)
  94. %doc doc/html/*
  95. %{_bindir}/pcre-config
  96. %{_bindir}/pcretest
  97. %{_includedir}/*
  98. %{_libdir}/*.so
  99. %{_libdir}/pkgconfig/*.pc
  100. %{_mandir}/man1/pcre-config.*
  101. %{_mandir}/man1/pcretest.*
  102. %{_mandir}/man3/*
  103. %changelog
  104. * Thu Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  105. - new upstream release
  106. - added patches including security fix from Fedora (CVE-2014-8964)
  107. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  108. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  109. (bug #1165626)
  110. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  111. - Reset non-matched groups within capturing group up to forced match
  112. (bug #1161587)
  113. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  114. - Fix typos in manual pages (bugs #675476, #675477)
  115. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  116. - new upstream release
  117. - add --enable-pcre32 and --enable-pcretest-libedit
  118. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  119. - new upstream release
  120. - add --enable-pcre16 --enable-pcre8 --enable-jit
  121. - API change
  122. - change includedir to /usr/include
  123. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  124. - new upstream release
  125. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  126. - new upstream release
  127. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  128. - rebuilt with rpm-4.8.1 for pkg-config
  129. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  130. - new upstream release
  131. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  132. - new upstream release with security fix
  133. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  134. - new upstream release
  135. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  136. - new upstream release
  137. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  138. - add --enable-unicode-properties to configure option
  139. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  140. - new upstream release
  141. - added BR: zlib-devel, bzip2-devel
  142. - removed static libraries from devel package
  143. - added Packager tag
  144. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  145. - new upstream release
  146. - spec in UTF-8
  147. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  148. - new upstream release
  149. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  150. - use macro for Release
  151. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  152. - apply new virsioning policy.
  153. - remove *.la
  154. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  155. - new upstream release
  156. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  157. - new upstream release
  158. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  159. - new upstream release
  160. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  161. - rebuild with new environment/toolchain
  162. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  163. - new upstream release
  164. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  165. - added --enable-utf8 option
  166. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  167. - new upstream release
  168. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  169. - new upstream release
  170. - added Japanese summary
  171. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  172. - new upstream release
  173. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  174. - new upstream release
  175. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  176. - skip 'make check' on alpha
  177. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  178. - change install section
  179. - change files section
  180. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  181. - update to 4.1
  182. - add %{_bindir}/pcretest
  183. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  184. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  185. - rebuild with new toolchains
  186. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  187. - Update to 3.9
  188. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  189. - Update to 3.7
  190. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  191. - Update to 3.5
  192. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  193. - Build for VineSeed
  194. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  195. - Move libpcre to /lib, grep uses it these days (#41104)
  196. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  197. - Move this to a separate package, used to be in kdesupport, but it's
  198. generally useful...