opencv-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637
  1. #global indice a
  2. Name: opencv
  3. Version: 2.4.9
  4. Release: 6%{?_dist_release}
  5. Summary: Collection of algorithms for computer vision
  6. Summary(ja): コンピュータビジョン用のアルゴリズム集
  7. Group: System Environment/Libraries
  8. # This is normal three clause BSD.
  9. License: BSD
  10. URL: http://opencv.org
  11. # Need to remove SIFT/SURF from source tarball, due to legal concerns
  12. # rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
  13. # rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
  14. # Removed because we don't use pre-built contribs
  15. # rm -rf 3rdparty
  16. #Source0: http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
  17. Source0: %{name}-clean-%{version}%{?indice}.tar.xz
  18. Source1: opencv-samples-Makefile
  19. Patch0: opencv-pkgcmake.patch
  20. #http://code.opencv.org/issues/2720
  21. Patch2: OpenCV-2.4.4-pillow.patch
  22. Patch3: opencv-2.4.9-ts_static.patch
  23. # fix/simplify cmake config install location (upstreamable)
  24. # https://bugzilla.redhat.com/1031312
  25. Patch4: opencv-2.4.7-cmake_paths.patch
  26. # relevant gst1-related patches from upstream master branch
  27. # 0550 needed slight rebasing -- rex
  28. Patch10: 0550-bomb-commit-of-gstreamer-videocapture-and-videowrite.patch
  29. Patch11: 0552-eliminated-warnings.patch
  30. Patch12: 0587-Fix-build-with-gstreamer-0.10.28.patch
  31. Patch13: 0865-gstreamer-cleaning-up-resources.patch
  32. Patch14: 0871-allow-for-arbitraty-number-of-sources-and-sinks.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: libtool
  35. BuildRequires: cmake >= 2.6.3
  36. BuildRequires: chrpath
  37. BuildRequires: eigen3-devel
  38. BuildRequires: gtk2-devel
  39. BuildRequires: libtheora-devel
  40. BuildRequires: libvorbis-devel
  41. BuildRequires: libraw1394-devel
  42. BuildRequires: libdc1394-devel
  43. BuildRequires: jasper-devel
  44. BuildRequires: libpng-devel
  45. BuildRequires: libjpeg-devel
  46. BuildRequires: libtiff-devel
  47. BuildRequires: libv4l-devel
  48. BuildRequires: mesa-libGL-devel
  49. BuildRequires: gtkglext-devel
  50. BuildRequires: OpenEXR-devel
  51. #ifarch %{ix86} x86_64
  52. #BuildRequires: openni-devel
  53. #BuildRequires: openni-primesense
  54. #endif
  55. %ifarch %{ix86} x86_64 ia64 ppc ppc64
  56. BuildRequires: tbb-devel
  57. %endif
  58. BuildRequires: zlib-devel pkgconfig
  59. BuildRequires: python-devel
  60. BuildRequires: numpy
  61. BuildRequires: swig >= 1.3.24
  62. BuildRequires: python-sphinx
  63. #BuildRequires: ffmpeg-devel >= 0.4.9
  64. BuildRequires: gstreamer1-devel
  65. BuildRequires: gstreamer1-plugins-base-devel
  66. #BuildRequires: xine-lib-devel
  67. #BuildRequires: opencl-headers
  68. Requires: opencv-core = %{version}-%{release}
  69. %description
  70. OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
  71. C functions and a few C++ classes that implement some popular Image Processing
  72. and Computer Vision algorithms.
  73. %package core
  74. Summary: OpenCV core libraries
  75. Summary(ja): OpenCV コアライブラリ
  76. Group: System Environment/Libraries
  77. %description core
  78. This package contains the OpenCV C/C++ core libraries.
  79. %package devel
  80. Summary: Development files for using the OpenCV library
  81. Summary(ja): OpenCV ライブラリを使用するための開発用ファイル
  82. Group: Development/Libraries
  83. Requires: opencv = %{version}-%{release}
  84. %description devel
  85. This package contains the OpenCV C/C++ library and header files, as well as
  86. documentation. It should be installed if you want to develop programs that
  87. will use the OpenCV library. You should consider installing opencv-devel-docs
  88. package.
  89. %package devel-docs
  90. Summary: Development files for using the OpenCV library
  91. Summary(ja): OpenCV ライブラリを使用するための開発用ドキュメント
  92. Group: Documentation
  93. Requires: opencv-devel = %{version}-%{release}
  94. BuildArch: noarch
  95. %description devel-docs
  96. This package contains the OpenCV documentation and examples programs.
  97. %package python
  98. Summary: Python bindings for apps which use OpenCV
  99. Summary(ja): OpenCV 使用するアプリケーション用の Python バインディング
  100. Group: Development/Libraries
  101. Requires: opencv = %{version}-%{release}
  102. Requires: numpy
  103. %description python
  104. This package contains Python bindings for the OpenCV library.
  105. %prep
  106. %setup -q
  107. %patch0 -p1 -b .pkgcmake
  108. %patch2 -p1 -b .pillow
  109. %patch3 -p1 -b .ts_static
  110. %patch4 -p1 -b .cmake_paths
  111. # for gst1
  112. %patch10 -p1 -b .10
  113. %patch11 -p1 -b .11
  114. %patch12 -p1 -b .12
  115. %patch13 -p1 -b .13
  116. %patch14 -p1 -b .14
  117. # fix dos end of lines
  118. sed -i 's|\r||g' samples/c/adaptiveskindetector.cpp
  119. %build
  120. # enabled by default if libraries are presents at build time:
  121. # GTK, GSTREAMER, UNICAP, 1394, V4L
  122. # non available on Fedora: FFMPEG, XINE
  123. mkdir -p build
  124. pushd build
  125. %cmake CMAKE_VERBOSE=1 \
  126. -DPYTHON_PACKAGES_PATH=%{python_sitearch} \
  127. -DCMAKE_SKIP_RPATH=ON \
  128. -DENABLE_PRECOMPILED_HEADERS:BOOL=OFF \
  129. %ifnarch x86_64 ia64
  130. -DENABLE_SSE=0 \
  131. -DENABLE_SSE2=0 \
  132. %endif
  133. -DENABLE_SSE3=0 \
  134. -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
  135. -DBUILD_TEST=1 \
  136. -DBUILD_opencv_java=0 \
  137. -DBUILD_opencv_nonfree=0 \
  138. -DBUILD_opencv_gpu=0 \
  139. -DWITH_FFMPEG=0 \
  140. -DWITH_GSTREAMER_1_X=1 \
  141. -DWITH_OPENGL=1 \
  142. -DWITH_OPENMP=1 \
  143. %ifarch %{ix86} x86_64 ia64
  144. -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
  145. %endif
  146. -DWITH_XINE=0 \
  147. -DINSTALL_C_EXAMPLES=1 \
  148. -DINSTALL_PYTHON_EXAMPLES=1 \
  149. ..
  150. #{?_without_gstreamer:-DWITH_GSTREAMER=0} \
  151. #%{?_with_cuda: \
  152. # -DCUDA_TOOLKIT_ROOT_DIR=%{?_cuda_topdir} \
  153. # -DCUDA_VERBOSE_BUILD=1 \
  154. # -DCUDA_PROPAGATE_HOST_FLAGS=0 \
  155. #} \
  156. #%ifarch %{ix86} x86_64
  157. #%{?_with_openni: \
  158. # -DWITH_OPENNI=ON \
  159. #} \
  160. #%endif
  161. # -DOPENCL_INCLUDE_DIR=${_includedir}/CL \
  162. make VERBOSE=1 %{?_smp_mflags}
  163. popd
  164. %install
  165. rm -rf %{buildroot}
  166. rm -rf __devel-doc
  167. pushd build
  168. make install DESTDIR=%{buildroot} INSTALL="install -p" CPPROG="cp -p"
  169. find %{buildroot} -name '*.la' -delete
  170. rm -f %{buildroot}%{_datadir}/OpenCV/samples/c/build_all.sh \
  171. %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.dsp \
  172. %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.vcproj \
  173. %{buildroot}%{_datadir}/OpenCV/samples/c/facedetect.cmd
  174. install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/OpenCV/samples/c/GNUmakefile
  175. # remove unnecessary documentation
  176. rm -rf %{buildroot}%{_datadir}/OpenCV/doc
  177. popd
  178. %check
  179. # Check fails since we don't support most video
  180. # read/write capability and we don't provide a display
  181. # ARGS=-V increases output verbosity
  182. # Make test is unavailble as of 2.3.1
  183. %if 0
  184. #ifnarch ppc64
  185. pushd build
  186. LD_LIBRARY_PATH=%{_builddir}/%{tar_name}-%{version}/lib:$LD_LIBARY_PATH make test ARGS=-V || :
  187. popd
  188. %endif
  189. %clean
  190. rm -rf %{buildroot}
  191. %post core -p /sbin/ldconfig
  192. %postun core -p /sbin/ldconfig
  193. %post -p /sbin/ldconfig
  194. %postun -p /sbin/ldconfig
  195. %files
  196. %doc LICENSE README.md
  197. %{_bindir}/opencv_*
  198. %{_libdir}/libopencv_calib3d.so.2.4*
  199. %{_libdir}/libopencv_contrib.so.2.4*
  200. %{_libdir}/libopencv_features2d.so.2.4*
  201. %{_libdir}/libopencv_highgui.so.2.4*
  202. %{_libdir}/libopencv_legacy.so.2.4*
  203. %{_libdir}/libopencv_objdetect.so.2.4*
  204. #{_libdir}/libopencv_ocl.so.2.4*
  205. %{_libdir}/libopencv_stitching.so.2.4*
  206. %{_libdir}/libopencv_superres.so.2.4*
  207. %{_libdir}/libopencv_ts.so.2.4*
  208. %{_libdir}/libopencv_videostab.so.2.4*
  209. %dir %{_datadir}/OpenCV
  210. %{_datadir}/OpenCV/haarcascades
  211. %{_datadir}/OpenCV/lbpcascades
  212. %files core
  213. %{_libdir}/libopencv_core.so.2.4*
  214. %{_libdir}/libopencv_flann.so.2.4*
  215. %{_libdir}/libopencv_imgproc.so.2.4*
  216. %{_libdir}/libopencv_ml.so.2.4*
  217. %{_libdir}/libopencv_photo.so.2.4*
  218. %{_libdir}/libopencv_video.so.2.4*
  219. %files devel
  220. %{_includedir}/opencv
  221. %{_includedir}/opencv2
  222. %{_libdir}/lib*.so
  223. %{_libdir}/pkgconfig/opencv.pc
  224. %dir %{_libdir}/OpenCV/
  225. %{_libdir}/OpenCV/*.cmake
  226. %files devel-docs
  227. %doc doc/*.{htm,png,jpg}
  228. %doc %{_datadir}/OpenCV/samples
  229. %files python
  230. %{python_sitearch}/cv.py*
  231. %{python_sitearch}/cv2.so
  232. %changelog
  233. * Wed Mar 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
  234. - built with tbb
  235. - moved main package to System Environment/Libraries Group
  236. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
  237. - Initial build for Vine Linux
  238. * Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
  239. - rebuild (openexr)
  240. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  242. * Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
  243. - backport support for GStreamer 1 (#1123078)
  244. * Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
  245. - Update to 2.4.9
  246. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
  247. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  248. * Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
  249. - revert pkgcmake2 patch (#1070428)
  250. * Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
  251. - Fix opencv_ocl isn't part of -core
  252. * Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
  253. - Enable OpenCL support.
  254. - SPEC small cleanup.
  255. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
  256. - rebuild (openexr)
  257. * Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
  258. - OpenCV cmake configuration broken (#1031312)
  259. * Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
  260. - Update to 2.4.7
  261. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
  262. - rebuild (openexr)
  263. * Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
  264. - Update to 2.4.6.1
  265. * Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
  266. - Update to 2.4.5-clean
  267. - Spec file clean-up
  268. - Split core libraries into a sub-package
  269. * Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
  270. - change project URL.
  271. * Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
  272. - make clean source without SIFT/SURF
  273. * Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
  274. - Update to 2.4.4a
  275. - Fix ttb-devel architecture conditionals
  276. * Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
  277. - rebuild (OpenEXR)
  278. * Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
  279. - Update to 2.4.4 beta
  280. - Drop python-imaging also from requires
  281. - Drop merged patch for additionals codecs
  282. - Disable the java binding for now (untested)
  283. * Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
  284. - Do not build with 1394 libs in rhel
  285. * Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
  286. - rebuild due to "jpeg8-ABI" feature drop
  287. * Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
  288. - Add more FourCC for gstreamer - rhbz#812628
  289. - Allow to use python-pillow - rhbz#895767
  290. * Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
  291. - Switch Build Type to ReleaseWithDebInfo to avoid -03
  292. * Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
  293. - Disable SSE3 and allow --with sse3 build conditional.
  294. - Disable gpu module as we don't build cuda
  295. - Update to 2.4.3
  296. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
  297. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  298. * Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
  299. - Update to 2.4.2
  300. * Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
  301. - Fixed cmake script for generating opencv.pc file
  302. - Fixed OpenCVConfig script file
  303. * Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
  304. - Update to 2.4.1
  305. - Rework dependencies - rhbz#828087
  306. Re-enable using --with tbb,opennpi,eigen2,eigen3
  307. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
  308. - Rebuilt for c++ ABI breakage
  309. * Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
  310. - Update gcc46 patch for ARM FTBFS
  311. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
  312. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  313. * Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
  314. - Rebuild for new libpng
  315. * Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
  316. - Rebuilt for tbb silent ABI change
  317. * Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
  318. - Update to 2.3.1a
  319. * Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
  320. - openni is exclusive for x86/x86_64
  321. * Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
  322. - Update to 2.3.1
  323. - Add BR openni-devel python-sphinx
  324. - Remove deprecated cmake options
  325. - Add --with cuda conditional (wip)
  326. - Disable make test (unavailable)
  327. * Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
  328. - Backport fixes from branch 2.2 to date
  329. * Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
  330. - Re-enable v4l on f15
  331. - Remove unused cmake options
  332. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
  333. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  334. * Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
  335. - Fix with gcc46
  336. - Disable V4L as V4L1 is disabled for Fedora 15
  337. * Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
  338. - Update to 2.2.0
  339. - Disable -msse and -msse2 on x86_32
  340. * Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
  341. - -devel: include OpenCVConfig.cmake (#627359)
  342. * Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
  343. - TBB is available only on x86/x86_64 and ia64
  344. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
  345. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  346. * Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
  347. - Move samples from main to -devel
  348. - Fix spurious permission
  349. - Add BR tbb-devel
  350. - Fix CFLAGS
  351. * Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
  352. - Update to 2.1.0
  353. - Update libdir patch
  354. * Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
  355. - Fix nonstandard executable permissions
  356. * Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
  357. - apply the previously added patch
  358. * Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
  359. - re-enable testing on CMake build system
  360. - fix memory corruption in the gaussian random number generator
  361. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
  362. - replaced BR unicap-devel by libucil-devel (unicap split)
  363. * Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
  364. - use cmake build system
  365. - applications renamed to opencv_xxx instead of opencv-xxx
  366. - add devel-docs subpackage #546605
  367. - add OpenCVConfig.cmake
  368. - enable openmp build
  369. - enable old SWIG based python wrappers
  370. - opencv package is a good boy and use global instead of define
  371. * Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
  372. - Set CXXFLAXS without -match=i386 for i386 architecture #565074
  373. * Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
  374. - Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
  375. * Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
  376. - Fixed spec file issues detected by rpmlint
  377. * Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
  378. - Fix autotools scripts (missing LBP features) - #544167
  379. * Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
  380. - Updated to 2.0.0
  381. - Removed upstream-ed patches
  382. - Ugly hack (added cvconfig.h)
  383. - Disable %%check on ppc64
  384. * Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
  385. - fix build on s390x where we don't have libraw1394 and devel
  386. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
  387. - Fix typo I introduced that prevented build on i386/i586
  388. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
  389. - Added 1394 libs and unicap support
  390. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
  391. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  392. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
  393. - Build with gstreamer support - #491223
  394. - Backport gcc43 fix from trunk
  395. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
  396. - Fix FTBFS #511705
  397. * Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
  398. - Update to 1.1pre1
  399. - Disable CXXFLAGS hardcoded optimization
  400. - Add BR: python-imaging, numpy
  401. - Disable make check failure for now
  402. * Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
  403. - Fix for gcc44
  404. - Enable BR jasper-devel
  405. - Disable ldconfig run on python modules (uneeded)
  406. - Prevent timestamp change on install
  407. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
  408. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  409. * Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
  410. - fix URL field
  411. * Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
  412. - Adopt latest python spec rules.
  413. - Rebuild for Python 2.6 once again.
  414. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
  415. - Rebuild for Python 2.6
  416. * Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
  417. - fix license tag
  418. * Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
  419. - Adjust library order in opencv.pc.in (BZ 445937).
  420. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
  421. - Autorebuild for GCC 4.3
  422. * Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
  423. - Rebuild for gcc43.
  424. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
  425. - Rebuild for selinux ppc32 issue.
  426. * Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
  427. - Mass rebuild.
  428. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
  429. - Fix %%{_datadir}/opencv/samples ownership.
  430. - Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
  431. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
  432. - Move all of the python module to pyexecdir (BZ 233128).
  433. - Activate the testsuite.
  434. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
  435. - Upstream update.
  436. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
  437. - Remove python-abi.
  438. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
  439. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  440. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
  441. - Stop configure.in from hacking CXXFLAGS.
  442. - Activate testsuite.
  443. - Let *-devel require pkgconfig.
  444. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
  445. - Upstream update.
  446. - Don't BR: autotools.
  447. - Install samples' Makefile as GNUmakefile.
  448. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
  449. - Un'%%ghost *.pyo.
  450. - Separate %%{pythondir} from %%{pyexecdir}.
  451. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
  452. - Rebuild for FC6.
  453. - BR: libtool.
  454. * Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
  455. - Rebuild.
  456. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
  457. - Force a re-run of Autotools by calling autoreconf.
  458. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
  459. - Added build dependency on Autotools.
  460. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
  461. - Changed intrinsics patch so that it matches upstream.
  462. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
  463. - More intrinsics patch fixing.
  464. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
  465. - Don't do "make check" because it doesn't run any tests anyway.
  466. - Back to main intrinsics patch.
  467. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
  468. - Using simple intrinsincs patch.
  469. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
  470. - Still more fixing of intrinsics patch for Python bindings on x86_64.
  471. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
  472. - Again fixed intrinsics patch so that Python modules build on x86_64.
  473. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
  474. - Fixed intrinsics patch so that it works.
  475. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
  476. - Fixed Python bindings location on x86_64.
  477. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
  478. - SSE2 support on x86_64.
  479. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
  480. - Rebuild
  481. * Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
  482. - Removed useless sample compilation makefiles/project files and replaced them
  483. with one that works on Fedora Core.
  484. - Removed shellbang from Python modules.
  485. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
  486. - Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
  487. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
  488. - Initial package.