mdadm-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312
  1. %define _tmpfilesdir %{_sysconfdir}/tmpfiles.d
  2. %define _udevrulesdir /lib/udev/rules.d
  3. Summary: Utilities for Linux md devices (software RAID arrays)
  4. Summary(ja): Linux の MD デバイス(ソフトウエアRAIDアレイ)用のユーティリティ
  5. Name: mdadm
  6. Version: 3.3
  7. Release: 1%{?_dist_release}
  8. Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.xz
  9. Source1: mdmonitor.init
  10. Source2: raid-check
  11. Source3: mdadm.rules
  12. Source4: mdadm-raid-check-sysconfig
  13. Source5: mdadm-cron
  14. Source6: mdmonitor.service
  15. Source7: mdadm.conf
  16. Source8: mdadm_event.conf
  17. Patch1: mdadm-3.3-Be-consistent-in-return-types-from-byteswap-macros.patch
  18. Patch93: mdadm-3.2.6-Remove-offroot-argument-and-default-to-always-settin.patch
  19. Patch94: mdadm-3.2.6-Add-support-for-launching-mdmon-via-systemctl-instea.patch
  20. Patch95: mdadm-3.2.6-In-case-launching-mdmon-fails-print-an-error-message.patch
  21. Patch96: mdadm-3.2.6-mdmon-add-foreground-option.patch
  22. # Fedora customization patches
  23. Patch97: mdadm-3.3-udev.patch
  24. Patch98: mdadm-2.5.2-static.patch
  25. URL: http://www.kernel.org/pub/linux/utils/raid/mdadm/
  26. License: GPL
  27. Group: System Environment/Base
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Obsoletes: mdctl,raidtools
  30. Requires: smtpdaemon
  31. BuildRequires: glibc-static
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. mdadm is used to create, manage, and monitor Linux MD (software RAID)
  36. devices. As such, it provides similar functionality to the raidtools
  37. package. However, mdadm is a single program, and it can perform
  38. almost all functions without a configuration file, though a configuration
  39. file can be used to help with some common tasks.
  40. %prep
  41. %setup -q
  42. %patch1 -p1 -b .types
  43. # Fedora customization patches
  44. %patch97 -p1 -b .udev
  45. %patch98 -p1 -b .static
  46. %build
  47. make %{?_smp_mflags} CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}" mdadm mdmon
  48. %install
  49. rm -rf %{buildroot}
  50. #make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=%{_sbindir} SYSTEMD_DIR=%{_unitdir} install install-systemd
  51. make DESTDIR=%{buildroot} MANDIR=%{_mandir} BINDIR=/sbin install
  52. install -Dp -m 755 %{SOURCE2} %{buildroot}%{_sbindir}/raid-check
  53. install -Dp -m 644 %{SOURCE3} %{buildroot}%{_udevrulesdir}/65-md-incremental.rules
  54. install -Dp -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/raid-check
  55. install -Dp -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/cron.d/raid-check
  56. # tmpfile
  57. mkdir -p %{buildroot}%{_tmpfilesdir}
  58. install -m 0644 %{SOURCE7} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  59. mkdir -p %{buildroot}%{_localstatedir}/run/
  60. install -d -m 0710 %{buildroot}%{_localstatedir}/run/%{name}/
  61. # initscript
  62. mkdir -p %{buildroot}%{_initdir}
  63. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/mdmonitor
  64. # systemd
  65. #mkdir -p %{buildroot}%{_unitdir}
  66. #install -m644 %{SOURCE6} %{buildroot}%{_unitdir}
  67. # abrt
  68. #mkdir -p %{buildroot}/etc/libreport/events.d
  69. #install -m644 %{SOURCE8} %{buildroot}/etc/libreport/events.d
  70. %clean
  71. rm -rf %{buildroot}
  72. %post
  73. /sbin/chkconfig --add mdmonitor
  74. %preun
  75. if [ "$1" = 0 ]; then
  76. service mdmonitor stop > /dev/null 2>&1 ||:
  77. /sbin/chkconfig --del mdmonitor
  78. fi
  79. if [ -e %{_initrddir}/mdmpd ]; then
  80. service mdmpd stop > /dev/null 2>&1 ||:
  81. /sbin/chkconfig --del mdmpd
  82. fi
  83. %postun
  84. if [ "$1" -ge "1" ]; then
  85. service mdmonitor condrestart > /dev/null 2>&1
  86. fi
  87. %files
  88. %defattr(-,root,root)
  89. %doc TODO ChangeLog mdadm.conf-example COPYING misc/*
  90. /sbin/*
  91. %{_sbindir}/*
  92. %{_initdir}/*
  93. %{_mandir}/man*/md*
  94. %{_udevrulesdir}/*
  95. %config(noreplace) %{_sysconfdir}/sysconfig/*
  96. %config(noreplace) %{_sysconfdir}/cron.d/*
  97. %dir %{_localstatedir}/run/%{name}/
  98. %config(noreplace) %{_tmpfilesdir}/%{name}.conf
  99. %changelog
  100. * Fri Jan 10 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3-1
  101. - new upstream release.
  102. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-4
  103. - rebuild with VineSeed environment
  104. * Mon Apr 18 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-3
  105. - added BR: glibc-static
  106. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.9-2
  107. - rebuilt with rpm-4.8.1-3
  108. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.9-1
  109. - new upstream release
  110. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1vl5
  111. - applied new versioning policy, spec in utf-8
  112. * Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  113. - new upstream release
  114. * Wed Aug 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
  115. - initial build for Vine Linux
  116. * Mon Aug 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.3-1
  117. - Update to 2.5.3 which upstream calls a "bug fix" release
  118. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.2-1.1
  119. - rebuild
  120. * Fri Jul 7 2006 Doug Ledford <dledford@redhat.com> - 2.5.2-1
  121. - Update to 2.5.2
  122. - Remove auto default patch as upstream now has a preferred default auto method
  123. * Wed Mar 8 2006 Peter Jones <pjones@redhat.com> - 2.3.1-3
  124. - fix build on ppc64
  125. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-2
  126. - fix build on ppc
  127. * Wed Mar 8 2006 Jeremy Katz <katzj@redhat.com> - 2.3.1-1
  128. - update to 2.3.1 to fix raid5 (#184284)
  129. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2.1
  130. - bump again for double-long bug on ppc(64)
  131. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2-1.fc5.2
  132. - rebuilt for new gcc4.1 snapshot and glibc changes
  133. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  134. - rebuilt
  135. * Mon Dec 05 2005 Warren Togami <wtogami@redhat.com> 2.2-1
  136. - 2.2 upgrade (#167897)
  137. - disable diet because we don't ship it anymore
  138. and we don't actually use mdassemble now
  139. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-4.fc4
  140. - Make the mdmonitor init script use the pid-file option, major cleanup
  141. of the script now possible (#134459)
  142. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-3.fc4
  143. - Put back the obsoletes: raidtools that was present in 1.11.0-1.fc4
  144. * Mon May 16 2005 Doug Ledford <dledford@redhat.com> 1.11.0-2.fc4
  145. - Change the default auto= mode so it need not be on the command line to
  146. work with udev, however it is still supported on the command line (#132706)
  147. - Add a man page (from Luca Berra) for mdassemble
  148. * Wed May 11 2005 Doug Ledford <dledford@redhat.com> - 1.11.0-1.fc4
  149. - Upgrade to 1.11.0
  150. * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.9.0-3.fc4
  151. - fix mdmonitor initscript (#144717)
  152. * Mon Mar 21 2005 Doug Ledford <dledford@redhat.com> 1.9.0-2
  153. - Build mdadm.static and mdassemble (static as well) to be used in initrd
  154. images
  155. * Wed Mar 09 2005 Doug Ledford <dledford@redhat.com> 1.9.0-1
  156. - Initial upgrade to 1.9.0 and update of doc files
  157. - Fix an s390 build error
  158. * Mon Oct 04 2004 Doug Ledford <dledford@redhat.com> 1.6.0-2
  159. - Remove /etc/mdadm.conf from the file list. Anaconda will write one out
  160. if it's needed.
  161. * Fri Oct 01 2004 Doug Ledford <dledford@redhat.com> 1.6.0-1
  162. - Update to newer upstream version
  163. - Make mdmpd work on kernels that don't have the event interface patch
  164. * Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.5.0-11
  165. - Create a directory /var/run/mdadm to contain mdadm.pid
  166. - This cleans up SELinux problem
  167. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  168. - rebuilt
  169. * Sat May 22 2004 Doug Ledford <dledford@redhat.com> - 1.5.0-9
  170. - Fix Makefile and build method to satisfy bz #123769
  171. - Add mdmpd man page, update mdmpd version to 0.3 - bz #117160
  172. - Make sure mdadm --monitor closes all md device files so that md devices
  173. can be stopped while mdadm is still running - bz #119532
  174. * Thu May 20 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-8
  175. - remove unneeded patch, can use --run instead
  176. * Wed May 19 2004 Jeremy Katz <katzj@redhat.com> - 1.5.0-7
  177. - add patch with reallyforce mode on creation to be used by anaconda
  178. * Wed May 12 2004 Doug Ledford <dledford@redhat.com> 2.5.0-6
  179. - Fix a bug in the %postun scriptlet related to downgrading to a version
  180. of mdadm that doesn't include the mdmpd daemon.
  181. * Fri May 07 2004 Doug Ledford <dledford@redhat.com> 1.5.0-5
  182. - Disable service mdmpd by default to avoid [Failed] messages on
  183. current 2.6 kernels. Possibly re-enable it by default once the
  184. 2.6 kernels have the md event interface.
  185. * Thu Apr 22 2004 Doug Ledford <dledford@redhat.com> 1.5.0-4
  186. - Update mdmonitor script to start daemon more cleanly
  187. - Repackage mdmpd tarball to include gcc-3.4 changes and to make
  188. mdmpd properly daemonize at startup instead of forking and leaving
  189. the child attached to the terminal.
  190. * Thu Mar 4 2004 Bill Nottingham <notting@redhat.com> 1.5.0-3
  191. - ship /var/run/mpmpd (#117497)
  192. * Thu Feb 26 2004 Doug Ledford <dledford@redhat.com> 1.5.0-2
  193. - Add a default MAILADDR line to the mdadm.conf file installed by default
  194. (Bugzilla #92447)
  195. - Make it build with gcc-3.4
  196. * Mon Feb 23 2004 Doug Ledford <dledford@redhat.com> 1.5.0-1
  197. - Update to 1.5.0 (from Matthew J. Galgoci <mgalgoci@redhat.com>)
  198. * Sun Nov 16 2003 Doug Ledford <dledford@redhat.com> 1.4.0-1
  199. - fix problem with recovery thread sleeping in mdmpd
  200. * Fri Nov 14 2003 Doug Ledford <dledford@redhat.com>
  201. - sync upstream
  202. - add mdmpd package into mdadm package
  203. * Wed Sep 10 2003 Michael K. Johnson <johnsonm@redhat.com> 1.3.0-1
  204. - sync upstream
  205. * Tue Mar 11 2003 Michael K. Johnson <johnsonm@redhat.com> 1.1.0-1
  206. - sync upstream
  207. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 1.0.1-1
  208. - update for rebuild
  209. * Wed Dec 25 2002 Tim Powers <timp@redhat.com> 1.0.0-8
  210. - fix references to %%install in the changelog so that it will build
  211. * Fri Dec 13 2002 Elliot Lee <sopwith@redhat.com> 1.0.0-7
  212. - Rebuild
  213. * Fri Jul 12 2002 Michael K. Johnson <johnsonm@redhat.com>
  214. - Changed RPM Group to System Environment/Base
  215. * Wed May 15 2002 Michael K. Johnson <johnsonm@redhat.com>
  216. - minor cleanups to the text, conditionalize rm -rf
  217. - added mdmonitor init script
  218. * Fri May 10 2002 <neilb@cse.unsw.edu.au>
  219. - update to 1.0.0
  220. - Set CXFLAGS instead of CFLAGS
  221. * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
  222. - change %%install to use "make install"
  223. * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
  224. - beautification
  225. - made mdadm.conf non-replaceable config
  226. - renamed Copyright to License in the header
  227. - added missing license file
  228. - used macros for file paths
  229. * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
  230. - Added Obsoletes: mdctl
  231. - missingok for configfile
  232. * Tue Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
  233. - Add md.4 and mdadm.conf.5 man pages
  234. * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
  235. - builds properly as non-root.
  236. * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
  237. - updated for 0.7, fixed /usr/share/doc and added manpage
  238. * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
  239. - initial RPM build