ldns-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349
  1. %{?!with_python: %global with_python 1}
  2. %{?!enable_gost: %global enable_gost 0}
  3. %{?!enable_dane: %global enable_dane 0}
  4. %if %{with_python}
  5. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  6. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  7. %endif
  8. %if %{enable_gost}
  9. %define subdir_conf_opt --disable-rpath --disable-static
  10. %else
  11. %define subdir_conf_opt --disable-rpath --disable-static --disable-gost
  12. %endif
  13. Summary: Lowlevel DNS(SEC) library with API
  14. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  15. Name: ldns
  16. Version: 1.7.0
  17. Release: 1%{?_dist_release}
  18. License: BSD
  19. Url: http://www.nlnetlabs.nl/%{name}/
  20. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  21. Group: System Environment/Libraries
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  24. BuildRequires: perl, libpcap-devel
  25. %if %{enable_gost}
  26. BuildRequires: openssl-devel >= 1.0.0
  27. %else
  28. BuildRequires: openssl-devel
  29. %endif
  30. Requires: libpcap, openssl
  31. Distribution: Vine Linux
  32. Vendor: Project Vine
  33. Packager: iwaim
  34. %if %{with_python}
  35. BuildRequires: python-devel, swig
  36. %endif
  37. %description
  38. ldns is a library with the aim to simplify DNS programing in C. All
  39. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  40. level API which allows a programmer to (for instance) create or sign
  41. packets.
  42. %package devel
  43. Summary: Development package that includes the ldns header files
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. The devel package contains the ldns library and the include files
  48. %if %{with_python}
  49. %package python
  50. Summary: Python extensions for ldns
  51. Group: Applications/System
  52. Requires: %{name} = %{version}-%{release}
  53. %description python
  54. Python extensions for ldns
  55. %endif
  56. %prep
  57. %setup -q
  58. %build
  59. %configure --disable-rpath --disable-static \
  60. %if %{with_python}
  61. --with-pyldns \
  62. %endif
  63. %if !%{enable_gost}
  64. --disable-gost \
  65. %endif
  66. %if !%{enable_gost}
  67. --disable-dane-verify \
  68. %endif
  69. --with-sha2
  70. (cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  71. (cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
  72. make %{?_smp_mflags}
  73. ( cd drill ; make %{?_smp_mflags} )
  74. ( cd examples ; make %{?_smp_mflags} )
  75. make %{?_smp_mflags} doc
  76. %install
  77. rm -rf %{buildroot}
  78. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  79. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  80. %if %{with_python}
  81. # remove execute perms from python files
  82. chmod a-x %{buildroot}%{python_sitearch}/*py
  83. %endif
  84. # don't package building script in doc
  85. rm doc/doxyparse.pl
  86. #remove doc stubs
  87. rm -rf doc/.svn
  88. #remove double set of man pages
  89. rm -rf doc/man
  90. # remove .la files
  91. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
  92. (cd drill ; make DESTDIR=%{buildroot} install)
  93. (cd examples; make DESTDIR=%{buildroot} install)
  94. %clean
  95. rm -rf %{buildroot}
  96. %files
  97. %defattr(-,root,root)
  98. %{_libdir}/libldns*so.*
  99. %{_bindir}/drill
  100. %{_bindir}/ldnsd
  101. #%{_bindir}/ldns-*
  102. %{_bindir}/ldns-chaos
  103. %{_bindir}/ldns-compare-zones
  104. %{_bindir}/ldns-[d-z]*
  105. %doc README LICENSE
  106. %{_mandir}/*/*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_libdir}/libldns*so
  110. %{_bindir}/ldns-config
  111. %dir %{_includedir}/ldns
  112. %{_includedir}/ldns/*.h
  113. %doc doc Changelog README
  114. %if %{with_python}
  115. %files python
  116. %defattr(-,root,root)
  117. %{python_sitearch}/*
  118. %endif
  119. %post -p /sbin/ldconfig
  120. %postun -p /sbin/ldconfig
  121. %changelog
  122. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.0-1
  123. - update to 1.7.0
  124. - add enable_dane option
  125. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
  126. - rebuilt with openssl-1.0.2g.
  127. * Mon Mar 9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
  128. - update to 1.6.17
  129. - drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  130. - upstream merged
  131. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
  132. - add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  133. - from Fedora ldns-1.6.16-6.fc20
  134. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
  135. - new upstream release
  136. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
  137. - new upstream release
  138. - move python files to sitearch from sitelib
  139. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
  140. - rebuild with python-2.7.2
  141. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
  142. - new upstream release
  143. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  144. - new upstream release
  145. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
  146. - new upstream release
  147. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
  148. - new upstream release
  149. - add enable_gost flag: default disable
  150. - defined subdir_conf_opt rpm macro
  151. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  152. - new upstream release
  153. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  154. - new upstream release
  155. - drop unnecessary installfix patch (Patch1): upstream merged
  156. - drop unnecessary rpathfix patch (Patch2): upstream merged
  157. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  158. - rebuild with libpcap 1.1.1 on VineSeed
  159. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  160. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  161. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  162. - Fix missing _ldns.so causing ldns-python to not work
  163. - Patch for installing ldns-python files
  164. - Patch for rpath in ldns-python
  165. - Don't install .a file for ldns-python
  166. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  167. - Upgraded to 1.6.4.
  168. - Added ldns-python sub package
  169. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  170. - Upgraded to 1.6.3, which has minor bugfixes
  171. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  172. - Upgraded to 1.6.2. This fixes various bugs.
  173. (upstream released mostly to default with sha2 for the imminent
  174. signed root, but we already enabled that in our builds)
  175. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  176. - rebuilt with new openssl
  177. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  178. - Added openssl dependancy back in, since we get more functionality
  179. when using openssl. Especially in 'drill'.
  180. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  181. - Updated to 1.6.1
  182. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  184. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  185. - Fixed the ssl patch so it can now compile --without-ssl
  186. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  187. - Added patch to compile with --without-ssl
  188. - Removed openssl dependancies
  189. - Recompiled with --without-ssl
  190. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  191. - Updated to 1.6.0
  192. - (did not yet compile with --without-ssl due to compile failures)
  193. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  194. - Updated to 1.6.0
  195. - Compile without openssl
  196. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  197. - Memory management bug when generating a sha256 key, see:
  198. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  199. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  200. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  201. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  202. - Updated to new version, 1.5.0 had a bug preventing
  203. zone signing.
  204. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  205. - Updated to new version
  206. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  207. - fixed configure flags
  208. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  209. - rebuild with new openssl
  210. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  211. - Updated to 1.4.0
  212. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  213. - enable SHA2 functionality
  214. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  215. - re-tag (don't do builds while renaming local repo dirs)
  216. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  217. - Updated to latest release
  218. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  219. - Autorebuild for GCC 4.3
  220. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  221. - Rebuild for new libcrypto
  222. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  223. - Upgraded to 1.2.2. Removed no longer needed race workaround
  224. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  225. - Try to fix racing ln -s statements in parallel builds
  226. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  227. - Added patch for ldns-read-zone that does not put @. in RRDATA
  228. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  229. - Use install -p to work around multilib conflicts for .h files
  230. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  231. - Updated to 1.2.1
  232. - Removed patches that got moved into upstream
  233. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  234. - Patch for ldns-key2ds to write to stdout
  235. - Again remove extra set of man pages from doc
  236. - own /usr/include/ldns (bug 233858)
  237. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  238. - Added sha256 DS record patch to ldns-key2ds
  239. - Minor tweaks for proper doc/man page installation.
  240. - Workaround for parallel builds
  241. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  242. - Own the /usr/include/ldns directory (bug #233858)
  243. - Removed obsoleted patch
  244. - Remove files form previous libtool run accidentally packages by upstream
  245. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  246. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  247. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  248. - Fixed changelog typo in date
  249. - Rebuild requested for PT_GNU_HASH support from gcc
  250. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  251. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  252. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  253. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  254. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  255. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  256. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  257. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  258. - added a make clean for 2.3.3 since .o files were left behind upstream,
  259. causing failure on ppc platform
  260. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  261. - minor cleanups
  262. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  263. - reworked for svn version
  264. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  265. - Initial version