tracker-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. Summary: An object database, tag/metadata database, search tool and indexer
  2. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  3. Name: tracker
  4. Version: 0.8.18
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. URL: http://www.gnome.org/projects/tracker/
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
  10. Patch0: tracker-0.8.18-tracker_spawn.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: glib2-devel >= 2.24.0
  13. BuildRequires: gtk2-devel >= 2.20.0
  14. BuildRequires: gnome-panel-devel
  15. BuildRequires: gmime-devel >= 2.4
  16. BuildRequires: poppler-devel
  17. BuildRequires: gettext
  18. BuildRequires: file
  19. BuildRequires: gnome-desktop-devel, gamin-devel
  20. BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
  21. BuildRequires: gstreamer-devel
  22. BuildRequires: desktop-file-utils, intltool
  23. BuildRequires: raptor-devel >= 1.4.18
  24. BuildRequires: sqlite3-devel
  25. BuildRequires: dbus-devel >= 1.0
  26. BuildRequires: dbus-glib-devel >= 0.78
  27. BuildRequires: libgnome-devel >= 2.13.2
  28. BuildRequires: libgnomeui-devel >= 2.13.7
  29. BuildRequires: libSM-devel
  30. BuildRequires: libnotify-devel >= 0.4.3
  31. BuildRequires: libuuid-devel
  32. BuildRequires: vala-devel
  33. BuildRequires: libgee-devel
  34. BuildRequires: upower-devel
  35. BuildRequires: gnome-applets
  36. BuildRequires: libgee-devel >= 0.3
  37. BuildRequires: nautilus-devel
  38. ## BuildRequires: autoconf, automake
  39. %description
  40. Tracker is a powerful desktop-neutral first class object database,
  41. tag/metadata database, search tool and indexer.
  42. It consists of a common object database that allows entities to have an
  43. almost infinte number of properties, metadata (both embedded/harvested as
  44. well as user definable), a comprehensive database of keywords/tags and
  45. links to other entities.
  46. It provides additional features for file based objects including context
  47. linking and audit trails for a file object.
  48. It has the ability to index, store, harvest metadata. retrieve and search
  49. all types of files and other first class objects
  50. %package devel
  51. Summary: Headers for developing programs that will use %{name}
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: pkgconfig
  55. Requires: dbus-glib-devel
  56. %description devel
  57. This package contains the static libraries and header files needed for
  58. developing with tracker
  59. %package search-tool
  60. Summary: Tracker search tool(s)
  61. Group: User Interface/Desktops
  62. Requires: %{name} = %{version}-%{release}
  63. %description search-tool
  64. Graphical frontend to tracker search facilities. This has dependencies on
  65. GNOME libraries
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b .spawn
  69. # remove shebangs from the python files as none should be executable scripts
  70. ## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
  71. %build
  72. ## libtoolize --force --copy
  73. ## intltoolize --copy --force
  74. ## autoreconf -i -f
  75. %configure --disable-static \
  76. --enable-video-extractor=external \
  77. --enable-tracker-search-tool=yes \
  78. --enable-tracker-search-bar=yes
  79. # Disable rpath
  80. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  81. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf %{buildroot}
  85. make DESTDIR=%{buildroot} install
  86. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  87. echo "%{_libdir}/tracker-0.8" \
  88. > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  89. desktop-file-install --delete-original \
  90. --vendor="" \
  91. --dir=%{buildroot}%{_datadir}/applications \
  92. %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
  93. rm -rf %{buildroot}%{_libdir}/*.{a,la}
  94. rm -f %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
  95. rm -rf %{buildroot}%{_datadir}/tracker-tests
  96. %find_lang %{name}
  97. %clean
  98. rm -rf %{buildroot}
  99. %post
  100. /sbin/ldconfig
  101. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  102. %posttrans
  103. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  104. %postun
  105. /sbin/ldconfig
  106. if [ $1 -eq 0 ] ; then
  107. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  108. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  109. fi
  110. %files -f %{name}.lang
  111. %defattr(-, root, root, -)
  112. %doc AUTHORS ChangeLog COPYING NEWS README
  113. ### %doc %{_datadir}/gtk-doc/html/libtracker-common/
  114. ### %doc %{_datadir}/gtk-doc/html/libtracker-module/
  115. %{_bindir}/tracker*
  116. %exclude %{_bindir}/tracker-search-tool
  117. %exclude %{_bindir}/tracker-preferences
  118. ### %exclude %{_bindir}/tracker-applet
  119. %{_libexecdir}/tracker*
  120. %{_libdir}/*.so.*
  121. %{_libdir}/tracker-0.8/
  122. %{_datadir}/tracker/
  123. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  124. %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  125. %{_sysconfdir}/xdg/autostart/tracker*.desktop
  126. %{_mandir}/*/tracker*.gz
  127. %exclude %{_mandir}/man1/tracker-search-bar.1.gz
  128. %exclude %{_mandir}/man1/tracker-preferences.1.gz
  129. %exclude %{_mandir}/man1/tracker-search-tool.1.gz
  130. %files devel
  131. %defattr(-, root, root, -)
  132. %{_includedir}/tracker-0.8/
  133. ### %{_includedir}/libtracker-gtk/*
  134. %{_libdir}/*.so
  135. %{_libdir}/pkgconfig/*.pc
  136. %{_datadir}/vala/vapi/tracker*.vapi
  137. %{_datadir}/vala/vapi/tracker*.deps
  138. %files search-tool
  139. %defattr(-, root, root, -)
  140. %{_bindir}/tracker-search-tool
  141. %{_bindir}/tracker-preferences
  142. %{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
  143. %{_libdir}/nautilus/extensions-2.0/*.so
  144. %{_datadir}/icons/*/*/apps/tracker.*
  145. %{_datadir}/applications/*.desktop
  146. %{_mandir}/man1/tracker-search-bar.1.gz
  147. %{_mandir}/man1/tracker-preferences.1.gz
  148. %{_mandir}/man1/tracker-search-tool.1.gz
  149. %changelog
  150. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
  151. - new upstream release
  152. - add Patch0 (tracker-0.8.18-tracker_spawn.patch)
  153. - delete Patch1
  154. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
  155. - rebuilt with poppler-0.16.3
  156. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
  157. - rebuild with poppler-0.14.2
  158. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
  159. - new upstream release
  160. - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
  161. - add configure option (--enable-tracker-search-bar)
  162. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  163. - new upstream release
  164. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  165. - new upstream release
  166. - fix URL of Source0
  167. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  168. - new upstream release
  169. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  170. - new upstream release
  171. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  172. - new upstream release
  173. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  174. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  175. - new upstream release
  176. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  177. - new upstream release
  178. - add BuildRequires: upower-devel, gnome-applets
  179. - change BuildRequires: dbus-glib -> dbus-glib-devel
  180. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  181. - new upstream release
  182. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  183. - fix BuildRequires: gmime-devel >= 2.4
  184. - add configure option (--enable-tracker-search-tool)
  185. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  186. - new upstream release
  187. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  188. - rebuild with poppler-0.10.2
  189. - spec in UTF-8
  190. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  191. - new upstream release
  192. - update Patch1
  193. - drop Patch10 (no more necessary)
  194. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  195. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  196. - apply new versioning policy
  197. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  198. - new upstream release
  199. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  200. - add Patch10 to fix selecting video-extractor
  201. - use external video extractor(totem) instead of gstreamer/xine
  202. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  203. - initial build for Vine Linux
  204. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  205. - Ship both autostart desktop files in the main package (BZ #233323)
  206. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  207. - Package the deskbar plugin properly (BZ #228308)
  208. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  209. - Split out tracker-search-tool sub-packages, for the GUI facility
  210. - Add proper requires for the -devel subpackage
  211. - Deal with the rpmlint complaints on rpath
  212. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  213. - Update to 0.5.4
  214. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  215. - Update to 0.5.3
  216. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  217. - Apply patch on Makefile.am instead of Makefile.in
  218. - Add libtool to BR
  219. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  220. - Update to 0.5.2
  221. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  222. - Update to new version
  223. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  224. - Have the devel subpackage require pkgconfig
  225. - Make the description field not have more than 76 characters on a line
  226. - Fix up the RPM group
  227. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  228. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  229. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  230. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  231. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  232. - Add autostart desktop file.
  233. - Edit the package description as suggested in review
  234. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  235. - More cleaups to the spec file.
  236. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  237. - Add needed BRs
  238. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  239. - Initial packaging for Fedora Extras