webkitgtk4-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. ## NOTE: Lots of files in various subdirectories have the same name (such as
  2. ## "LICENSE") so this short macro allows us to distinguish them by using their
  3. ## directory names (from the source tree) as prefixes for the files.
  4. %global add_to_license_files() \
  5. mkdir -p _license_files ; \
  6. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  7. Name: webkitgtk4
  8. Version: 2.6.3
  9. Release: 1%{?_dist_release}
  10. Summary: GTK+ Web content engine library
  11. License: LGPLv2
  12. URL: http://www.webkitgtk.org/
  13. Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  14. Patch0: webkit-1.1.14-nspluginwrapper.patch
  15. Patch2: webkitgtk-2.5.90-cloop_fix.patch
  16. Patch3: webkitgtk-2.5.2-commit_align.patch
  17. BuildRequires: at-spi2-core-devel
  18. BuildRequires: bison
  19. BuildRequires: cairo-devel
  20. BuildRequires: cmake
  21. BuildRequires: enchant-devel
  22. BuildRequires: flex
  23. BuildRequires: fontconfig-devel
  24. BuildRequires: freetype-devel
  25. BuildRequires: geoclue2-devel
  26. BuildRequires: gettext
  27. BuildRequires: glib2-devel
  28. BuildRequires: gobject-introspection-devel
  29. BuildRequires: gperf
  30. BuildRequires: gstreamer1-devel
  31. BuildRequires: gstreamer1-plugins-base-devel
  32. BuildRequires: gtk2-devel
  33. BuildRequires: gtk3-devel
  34. BuildRequires: harfbuzz-icu-devel
  35. BuildRequires: libicu-devel
  36. BuildRequires: libjpeg-turbo-devel
  37. BuildRequires: libpng-devel
  38. BuildRequires: libsecret-devel
  39. BuildRequires: libsoup-devel
  40. BuildRequires: libwebp-devel
  41. BuildRequires: libxslt-devel
  42. BuildRequires: libXt-devel
  43. BuildRequires: mesa-libGL-devel
  44. BuildRequires: pcre-devel
  45. BuildRequires: ruby
  46. BuildRequires: sqlite3-devel
  47. %ifarch ppc
  48. BuildRequires: libatomic
  49. %endif
  50. Requires: geoclue2
  51. # Obsolete libwebkit2gtk from the webkitgtk3 package
  52. Obsoletes: libwebkit2gtk < 2.4.5-3
  53. Provides: libwebkit2gtk = %{version}-%{release}
  54. # Filter out provides for private libraries
  55. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  56. %description
  57. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  58. GTK+ platform.
  59. This package contains WebKitGTK+ for GTK+ 3.
  60. %package devel
  61. Summary: Development files for %{name}
  62. Requires: %{name} = %{version}-%{release}
  63. %description devel
  64. The %{name}-devel package contains libraries, build data, and header
  65. files for developing applications that use %{name}.
  66. %prep
  67. %setup -q -n webkitgtk-%{version}
  68. %patch0 -p1 -b .nspluginwrapper
  69. %patch2 -p1 -b .cloop_fix
  70. %ifarch %{power64} aarch64 ppc
  71. %patch3 -p1 -b .commit_align
  72. %endif
  73. # Remove bundled libraries
  74. rm -rf Source/ThirdParty/leveldb/
  75. rm -rf Source/ThirdParty/gtest/
  76. rm -rf Source/ThirdParty/qunit/
  77. %build
  78. # Use linker flags to reduce memory consumption
  79. %global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  80. %ifarch s390 %{arm}
  81. # Decrease debuginfo verbosity to reduce memory consumption even more
  82. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  83. %endif
  84. %ifarch ppc
  85. # Use linker flag -relax to get WebKit build under ppc(32) with JIT disabled
  86. %global optflags %{optflags} -Wl,-relax -latomic
  87. %endif
  88. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  89. mkdir -p %{_target_platform}
  90. pushd %{_target_platform}
  91. %cmake \
  92. -DPORT=GTK \
  93. -DCMAKE_BUILD_TYPE=Release \
  94. -DENABLE_JIT=OFF \
  95. -DENABLE_LLINT_C_LOOP=ON \
  96. ..
  97. popd
  98. make %{?_smp_mflags} -C %{_target_platform}
  99. %install
  100. %make_install -C %{_target_platform}
  101. %find_lang WebKit2GTK-4.0
  102. # Finally, copy over and rename various files for %%license inclusion
  103. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  104. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  105. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  106. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  107. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/murmurhash/LICENSE
  108. %add_to_license_files Source/WebCore/icu/LICENSE
  109. %add_to_license_files Source/WebCore/LICENSE-APPLE
  110. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  111. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  112. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  113. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  114. %add_to_license_files Source/WTF/icu/LICENSE
  115. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  116. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  117. %post -p /sbin/ldconfig
  118. %postun -p /sbin/ldconfig
  119. %files -f WebKit2GTK-4.0.lang
  120. %license _license_files/*
  121. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  122. %{_libdir}/libwebkit2gtk-4.0.so.*
  123. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  124. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  125. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  126. %{_libdir}/webkit2gtk-4.0/
  127. %{_libexecdir}/webkit2gtk-4.0/
  128. %files devel
  129. %{_bindir}/jsc
  130. %{_includedir}/webkitgtk-4.0/
  131. %{_libdir}/libjavascriptcoregtk-4.0.so
  132. %{_libdir}/libwebkit2gtk-4.0.so
  133. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  134. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  135. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  136. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  137. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  138. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  139. %changelog
  140. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  141. - new upstream release
  142. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  143. - initial build for Vine Linux
  144. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  145. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  146. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  147. - Update to 2.6.0
  148. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  149. - Update to 2.5.90
  150. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  151. - Obsolete libwebkit2gtk from the webkitgtk3 package
  152. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  153. - rebuild for ICU 53.1
  154. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  155. - Add support for secondary arches
  156. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  157. - Add webkitgtk-2.5.3-toggle-buttons.patch
  158. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  159. - More package review fixes (#1131284)
  160. - Correct the license tag to read LGPLv2
  161. - Filter out provides for private libraries
  162. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  163. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  164. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  165. - Update to 2.5.3
  166. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  167. - Initial Fedora packaging, based on the webkitgtk3 package