libwvstreams-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. Name: libwvstreams
  2. Version: 4.6.1
  3. Release: 5%{?_dist_release}
  4. Summary: WvStreams is a network programming library written in C++
  5. Summary(ja): WvStreams - C++ で記述されたネットワークプログラミングライブラリ
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. URL: https://code.google.com/p/wvstreams/
  9. Source: http://wvstreams.googlecode.com/files/wvstreams-%{version}.tar.gz
  10. #fixed multilib issue (bug #192717)
  11. Patch1: wvstreams-4.2.2-multilib.patch
  12. #install-xplc target was missing
  13. Patch2: wvstreams-4.5-noxplctarget.patch
  14. #Fix parallel build (#226061)
  15. Patch3: wvstreams-4.6.1-make.patch
  16. #sys/stat.h is missing some files in rawhide build
  17. Patch4: wvstreams-4.6.1-statinclude.patch
  18. #const X509V3_EXT_METHOD * -> X509V3_EXT_METHOD * conversion not allowed
  19. #by rawhide gcc
  20. Patch5: wvstreams-4.6.1-gcc.patch
  21. # fix missing unistd.h header for gcc 4.7
  22. Patch6: wvstreams-4.6.1-gcc47.patch
  23. Patch7: wvstreams-4.6.1-magic.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. BuildRequires: openssl-devel, pkgconfig, zlib-devel, readline-devel, dbus-devel
  26. %description
  27. WvStreams aims to be an efficient, secure, and easy-to-use library for
  28. doing network applications development.
  29. %package devel
  30. Summary: Development files for WvStreams
  31. Summary(ja): WvStreams の開発用ファイル
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. WvStreams aims to be an efficient, secure, and easy-to-use library for
  36. doing network applications development. This package contains the files
  37. needed for developing applications which use WvStreams.
  38. %prep
  39. %setup -q -n wvstreams-%{version}
  40. %patch1 -p1 -b .multilib
  41. %patch2 -p1 -b .xplctarget
  42. %patch3 -p1 -b .make
  43. %patch4 -p1 -b .statinclude
  44. %patch5 -p1 -b .gcc
  45. %patch6 -p1 -b .gcc47
  46. %patch7 -p1 -b .magic
  47. %build
  48. export CXXFLAGS="$RPM_OPT_FLAGS -fPIC -fpermissive -fno-strict-aliasing -fno-tree-dce -fno-optimize-sibling-calls"
  49. export CFLAGS="$RPM_OPT_FLAGS -fPIC -fno-strict-aliasing"
  50. # --without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
  51. # --with-dbus DBUS
  52. # --with-openssl OpenSSL >= 0.9.7 (required)
  53. # --with-pam PAM
  54. # --with-tcl Tcl
  55. # --with-qt Qt
  56. # --with-zlib zlib (required)
  57. touch configure
  58. %configure --with-dbus --with-pam --with-openssl --without-tcl --without-qt --with-zlib
  59. make COPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" CXXOPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" VERBOSE=1
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make install DESTDIR=$RPM_BUILD_ROOT
  63. chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so.*
  64. rm -fr $RPM_BUILD_ROOT/usr/bin
  65. pushd $RPM_BUILD_ROOT
  66. rm -f \
  67. ./etc/uniconf.conf \
  68. .%{_bindir}/uni \
  69. .%{_libdir}/pkgconfig/liboggspeex.pc \
  70. .%{_libdir}/pkgconfig/liboggvorbis.pc \
  71. .%{_libdir}/pkgconfig/libwvfft.pc \
  72. .%{_libdir}/pkgconfig/libwvqt.pc \
  73. .%{_sbindir}/uniconfd \
  74. .%{_mandir}/man8/uni.8* \
  75. .%{_mandir}/man8/uniconfd.8* \
  76. .%{_var}/lib/uniconf/uniconfd.ini
  77. popd
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %files
  81. %defattr(-,root,root)
  82. %doc LICENSE README
  83. %{_libdir}/*.so.*
  84. %files devel
  85. %defattr(-,root,root)
  86. %{_includedir}/wvstreams
  87. %{_libdir}/*.so
  88. %{_libdir}/*.a
  89. %{_libdir}/valgrind/*.supp
  90. %{_libdir}/pkgconfig/*.pc
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %changelog
  94. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-5
  95. - rebuild with gcc-5.4.0
  96. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-4
  97. - rebuild with openssl-1.0.2
  98. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-3
  99. - rebuild with readline-6.3
  100. * Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.6.1-2
  101. - added Patch6 and 7 from Feroda
  102. * Mon Jun 04 2012 Michal Sekletar <msekleta@redhat.com> - 4.6.1-5
  103. - Fix crashes caused by compiler optimizations, #812651
  104. * Thu Jan 05 2012 Jan Synáček <jsynacek@redhat.com> - 4.6.1-4
  105. - Fix missing unistd.h header for gcc 4.7
  106. - updated URL
  107. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-1
  108. - update to 4.6.1
  109. - fix Patch1 (wvstreams-4.2.2-multilib.patch)
  110. - add Patch2 (wvstreams-4.5-noxplctarget.patch) from FC package
  111. - add Patch3 (wvstreams-4.6.1-make.patch) from FC package
  112. - add Patch4 (wvstreams-4.6.1-statinclude.patch) from FC package
  113. - add Patch5 (wvstreams-4.6.1-gcc.patch) from FC package
  114. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 4.4-1vl5
  115. - applied new versioning policy, spec in utf-8
  116. * Mon Nov 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4-0vl1
  117. - initial build for Vine Linux
  118. * Fri Aug 17 2007 Harald Hoyer <harald@rawhide.home> - 4.4-1
  119. - version 4.4
  120. - changed license tag to LGPLv2+
  121. * Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-2
  122. - added static libs, esp. xplc-cxx
  123. * Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-1
  124. - version 4.3
  125. * Wed Apr 18 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-4
  126. - specfile review
  127. * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-3
  128. - fixed code for new g++ version
  129. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.2.2-2.1
  130. - rebuild
  131. * Fri Jun 02 2006 Harald Hoyer <harald@redhat.com> 4.2.2-2
  132. - more corrections to multilib patch (bug #192717)
  133. * Wed May 24 2006 Harald Hoyer <harald@redhat.com> 4.2.2-1
  134. - version 4.2.2
  135. - fixed multilib issue (bug #192717)
  136. * Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 4.2.1-2
  137. - rebuild for ppc TLS issue (#184446)
  138. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.2
  139. - bump again for double-long bug on ppc(64)
  140. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.1
  141. - rebuilt for new gcc4.1 snapshot and glibc changes
  142. * Mon Dec 19 2005 Harald Hoyer <harald@redhat.com> 4.2.1-1
  143. - version 4.2.1
  144. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  145. - rebuilt
  146. * Wed Nov 9 2005 Tomas Mraz <tmraz@redhat.com> 3.75.0-6
  147. - rebuilt against new openssl
  148. - the gcc4 patch shouldn't be used anymore
  149. * Mon Mar 14 2005 Harald Hoyer <harald@redhat.com> 3.75.0-5
  150. - gcc4 patch added
  151. * Wed Mar 2 2005 Jindrich Novy <jnovy@redhat.com> 3.75.0-4
  152. - rebuilt
  153. * Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
  154. - rebuilt
  155. * Mon Jun 28 2004 Harald Hoyer <harald@redhat.com> 3.75.0-2
  156. - added libwvstreams-3.75.0-stringbuf.patch (114996)
  157. * Mon Jun 21 2004 Harald Hoyer <harald@redhat.com> 3.75.0-1
  158. - version 3.75.0
  159. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  160. - rebuilt
  161. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  162. - rebuilt
  163. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  164. - rebuilt
  165. * Fri Oct 10 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-12
  166. - link libwvstreams shared libs against libcrypt, upon which they depend
  167. * Mon Sep 8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-11
  168. - rebuild
  169. * Mon Sep 8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-10
  170. - rebuild
  171. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  172. - rebuilt
  173. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  174. - rebuilt
  175. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-7
  176. - rebuild
  177. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  178. - correct an const/not-const type mismatch that breaks compilation with newer
  179. OpenSSL
  180. - add flags from pkgconfig so that OpenSSL is always found
  181. * Tue Sep 10 2002 Mike A. Harris <mharris@redhat.com> 3.70-6
  182. - use FHS macros for multilib systems
  183. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  184. - rebuilt with gcc-3.2 (we hope)
  185. * Mon Jul 22 2002 Tim Powers <timp@redhat.com>
  186. - rebuild using gcc-3.2-0.1
  187. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  188. - automated rebuild
  189. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  190. - automated rebuild
  191. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 3.70-1
  192. - patch to build with gcc 3.x
  193. - build with -fPIC
  194. * Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com>
  195. - update to 3.70
  196. * Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 3.69-1
  197. - pull in from upstream tarball
  198. * Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com>
  199. - merge the main and -devel packages into one .spec file
  200. - use globbing to shorten the file lists
  201. - don't define name, version, and release as macros (RPM does this by default)
  202. - use the License: tag instead of Copyright: (equivalent at the package level,
  203. but License: reflects the intent of the tag better)
  204. - use a URL to point to the source of the source tarball
  205. - add BuildRequires: openssl-devel (libwvcrypto uses libcrypto)
  206. - move the buildroot to be under %%{_tmppath}, so that it can be moved by
  207. altering RPM's configuration
  208. * Tue Jan 29 2002 Patrick Patterson <ppatters@nit.ca>
  209. - Initial Release of WvStreams