kgrab-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. %define kdeversion 4.4.0
  2. Name: kgrab
  3. Summary: A screen grabbing utility
  4. Summary(ja): スクリーンキャプチャユーティリティ
  5. Version: 0.1.1
  6. Release: 25%{?_dist_release}
  7. Group: Applications/Accessories
  8. License: GPLv2+
  9. URL: http://extragear.kde.org
  10. Source0: ftp://ftp.kde.org/pub/kde/stable/%{kdeversion}/src/extragear/%{name}-%{version}-kde%{kdeversion}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: kdelibs4-devel >= 4
  13. BuildRequires: cmake
  14. BuildRequires: desktop-file-utils
  15. BuildRequires: gettext
  16. #{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
  17. %description
  18. kgrab is a screen grabbing utility for KDE4.
  19. %description -l ja
  20. KDE4 向けのスクリーンキャプチャユーティリティです.
  21. %prep
  22. %setup -qn %{name}-%{version}-kde%{kdeversion}
  23. %build
  24. mkdir -p %{_target_platform}
  25. pushd %{_target_platform}
  26. %cmake \
  27. -DCMAKE_BUILD_TYPE=release \
  28. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  29. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  30. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  31. ..
  32. popd
  33. make %{?_smp_mflags} -C %{_target_platform}
  34. %install
  35. rm -rf $RPM_BUILD_ROOT
  36. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  37. # validate desktop file
  38. desktop-file-install --vendor "" \
  39. --dir $RPM_BUILD_ROOT%{_datadir}/applications/kde4 \
  40. $RPM_BUILD_ROOT%{_datadir}/applications/kde4/%{name}.desktop
  41. %find_lang %{name}
  42. %clean
  43. rm -rf $RPM_BUILD_ROOT
  44. %post
  45. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  46. %postun
  47. if [ $1 -eq 0 ] ; then
  48. update-desktop-database -q &> /dev/null
  49. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  50. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  51. fi
  52. %posttrans
  53. update-desktop-database -q &> /dev/null
  54. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  55. %files -f %{name}.lang
  56. %defattr(-,root,root,-)
  57. %doc COPYING COPYING.DOC COPYING.LIB
  58. %{_bindir}/kgrab
  59. %{_datadir}/applications/kde4/kgrab.desktop
  60. %{_datadir}/dbus-1/interfaces/org.kde.kgrab.xml
  61. %{_datadir}/icons/hicolor/*/apps/kgrab.*
  62. %{_datadir}/kde4/apps/kgrab/
  63. %changelog
  64. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.1-25
  65. - rebuild with gcc-5.4.0
  66. * Fri Jan 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-24
  67. - rebuilt on current VineSeed
  68. * Sat Jan 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.1.1-23
  69. - initial build for Vine Linux
  70. - added Japanese summary
  71. * Fri Feb 12 2010 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-22
  72. - 4.4.0
  73. - drop kgrab-0.1.1-X11_libs.patch (already included)
  74. * Tue Nov 24 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-21
  75. - rebuild for Qt 4.6.0 RC1 in F13 (was built against Beta 1 with unstable ABI)
  76. * Thu Nov 05 2009 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-20
  77. - 4.3.3
  78. - optimize scriptlets
  79. * Tue Sep 01 2009 Sebastian Vahl <svahl@fedoraproject.org> - 0.1.1-19
  80. - 4.3.1
  81. * Tue Aug 04 2009 Than Ngo <than@redhat.com> - 0.1.1-18
  82. - 4.3.0
  83. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-17
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  85. * Tue Jun 10 2009 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-16
  86. - 4.2.4
  87. * Tue May 12 2009 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-15
  88. - 4.2.3
  89. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-14
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  91. * Fri Jan 23 2009 Than Ngo <than@redhat.com> - 0.1.1-13
  92. - 4.2.0
  93. * Fri Dec 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.1.1-12
  94. - rebuild for fixed kde-filesystem (macros.kde4) (get rid of rpaths)
  95. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.1.1-11
  96. - Include /usr/share/kde4/apps/kgrab directory.
  97. * Sat Oct 04 2008 Than Ngo <than@redhat.com> 0.1.1-10
  98. - 4.1.2
  99. * Fri Aug 29 2008 Than Ngo <than@redhat.com> 0.1.1-9
  100. - 4.1.1
  101. * Thu Aug 28 2008 Sebastian Vahl <fedora@deadbabylon.de> 0.1.1-8
  102. - 4.1 (final)
  103. * Mon May 26 2008 Than Ngo <than@redhat.com> 0.1.1-7.kde4.0.80
  104. - 4.1 beta1
  105. * Thu Apr 03 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-6
  106. - rebuild (again) for the fixed %%{_kde4_buildtype}
  107. * Mon Mar 31 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.1.1-5
  108. - rebuild for NDEBUG and _kde4_libexecdir
  109. * Thu Feb 14 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-4
  110. - remove reference to KDE 4 in summary and description
  111. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-3
  112. - added Requires: kdelibs4 >= 4
  113. - added Requires: oxygen-icon-theme
  114. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-2
  115. - added requires xdg-utils, kde4-macros(api)
  116. * Wed Feb 13 2008 Sebastian Vahl <fedora@deadbabylon.de> - 0.1.1-1
  117. - initial version