kdegames3-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526
  1. # These games are already in KDE 4.
  2. %define donotcompilelist katomic kbattleship kblackbox kbounce kgoldrunner kjumpingcube klines klickety kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ktron ktuberling kwin4 lskat
  3. Name: kdegames3
  4. Summary: KDE 3 Games not ported to KDE 4
  5. Summary(ja): KDE 4 に移植されていない KDE 3 ゲーム集
  6. Version: 3.5.10
  7. Release: 4%{?_dist_release}
  8. License: GPLv2
  9. Group: Applications/Games
  10. URL: http://www.kde.org/
  11. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdegames-%{version}.tar.bz2
  12. Patch0: kdegames-3.5.10-trademarks.patch
  13. # fix FTBFS with the new stricter ld in F13 (#565113)
  14. Patch2: kdegames-3.5.10-ftbfs.patch
  15. # fixes to common KDE 3 autotools machinery
  16. # tweak autoconfigury so that it builds with autoconf 2.64 or 2.65
  17. Patch300: kde3-acinclude.patch
  18. # remove flawed and obsolete automake version check in admin/cvs.sh
  19. Patch301: kde3-automake-version.patch
  20. # fix build failure with automake 1.13: add the --add-missing --copy flags
  21. # also add --force-missing to get aarch64 support (#925029/#925627)
  22. Patch302: kde3-automake-add-missing.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: automake libtool
  25. BuildRequires: kdelibs3-devel >= %{version}
  26. Requires: kdelibs3 >= %{version}
  27. Requires: hicolor-icon-theme
  28. %description
  29. Games and gaming libraries for KDE which have not been ported to KDE 4 yet.
  30. Included with this package are: atlantik, kasteroids, kbackgammon, kboxpush,
  31. kenolaba, kfouleggs, kpoker, ksirtet, ksmiletris, ksnake.
  32. %package devel
  33. Summary: Development files for kdegames3
  34. Summary(ja): kdegames3 の開発用ファイル
  35. Group: Development/Libraries
  36. License: LGPLv2
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: kdelibs3-devel >= %{version}
  39. %description devel
  40. Development files for the KDE gaming libraries.
  41. Install kdegames-devel if you wish to develop or compile games for the
  42. KDE desktop.
  43. %prep
  44. %setup -q -n kdegames-%{version}
  45. %patch0 -p1
  46. %patch2 -p1 -b .ftbfs
  47. export DO_NOT_COMPILE="%{donotcompilelist}"
  48. %patch300 -p1 -b .acinclude
  49. %patch301 -p1 -b .automake-version
  50. %patch302 -p1 -b .automake-add-missing
  51. make -f admin/Makefile.common cvs
  52. %build
  53. unset QTDIR || : ; . /etc/profile.d/qt.sh
  54. export DO_NOT_COMPILE="%{donotcompilelist}"
  55. %configure \
  56. --with-qt-libraries=$QTDIR/lib \
  57. --enable-new-ldflags \
  58. --disable-dependency-tracking \
  59. --disable-rpath \
  60. --enable-final \
  61. --disable-debug \
  62. --disable-warnings \
  63. --includedir=%{_includedir}/kde \
  64. --disable-setgid
  65. make %{?_smp_mflags}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. export DO_NOT_COMPILE="%{donotcompilelist}"
  69. make DESTDIR=$RPM_BUILD_ROOT install
  70. # locales
  71. %find_lang %{name} || touch %{name}.lang
  72. HTML_DIR=$(kde-config --expandvars --install html)
  73. if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
  74. for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
  75. if [ -d $lang_dir ]; then
  76. # remove documentation for games we don't ship
  77. pushd $lang_dir
  78. for i in *; do
  79. case "%{donotcompilelist}" in
  80. *$i*)
  81. # $i is listed in %{donotcompilelist}, zap
  82. [ -d $i ] && rm -rf $i
  83. ;;
  84. esac
  85. done
  86. rm -rf kdegames-apidocs
  87. popd
  88. lang=$(basename $lang_dir)
  89. echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
  90. # replace absolute symlinks with relative ones
  91. pushd $lang_dir
  92. for i in *; do
  93. [ -d $i -a -L $i/common ] && ln -nsf ../common $i/common
  94. done
  95. popd
  96. fi
  97. done
  98. fi
  99. # rpmdocs
  100. for dir in atlantik k* ; do
  101. case "%{donotcompilelist}" in
  102. *$dir*)
  103. # $dir is listed in %{donotcompilelist}, skip
  104. ;;
  105. *)
  106. for file in AUTHORS ChangeLog README TODO ; do
  107. test -s "$dir/$file" && install -p -m644 -D "$dir/$file" "rpmdocs/$dir/$file"
  108. done
  109. ;;
  110. esac
  111. done
  112. # remove libkdegames devel stuff, not used by anything and conflicts with KDE 4
  113. rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/k* $RPM_BUILD_ROOT%{_libdir}/libkdegames.so
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %post
  117. /sbin/ldconfig
  118. for f in crystalsvg hicolor ; do
  119. touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
  120. gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
  121. done
  122. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  123. %postun
  124. /sbin/ldconfig
  125. for f in crystalsvg hicolor ; do
  126. touch --no-create %{_datadir}/icons/$f 2> /dev/null ||:
  127. gtk-update-icon-cache -q %{_datadir}/icons/$f 2> /dev/null ||:
  128. done
  129. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  130. %files
  131. %defattr(-,root,root)
  132. %doc %{_datadir}/doc/HTML/en/*
  133. %{_bindir}/*
  134. %{_libdir}/lib*.so.*
  135. %{_libdir}/lib*.la
  136. %{_libdir}/kde3/*
  137. %{_datadir}/applications/kde/*.desktop
  138. %{_datadir}/apps/*
  139. %{_datadir}/config.kcfg/*
  140. %{_datadir}/icons/crystalsvg/*/*/*
  141. %{_datadir}/icons/hicolor/*/*/*
  142. %{_datadir}/services/*
  143. %files devel
  144. %defattr(-,root,root)
  145. %{_includedir}/kde/*
  146. %{_libdir}/lib*.so
  147. %changelog
  148. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.10-4
  149. - rebuild with gcc-5.4.0
  150. * Wed Oct 8 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-3
  151. - rebuilt with current VineSeed
  152. - added Patch300, 301 and 302 from FC
  153. - dropt Patch1
  154. * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-2
  155. - dropt klickety
  156. * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
  157. - updated to 3.5.10 based on FC
  158. - built with new toolchain
  159. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
  160. - renamed kdegames3
  161. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  162. - applied new versioning policy, spec in UTF-8
  163. * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  164. - rebuild for VineSeed
  165. * Mon Oct 22 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  166. - new upstream release
  167. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  168. - rebuild for VineSeed
  169. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  170. - new upstream release
  171. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  172. - new upstream release
  173. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  174. - added --with-qt-libraries and --enable-libsuffix option
  175. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  176. - rebuild for VineSeed
  177. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  178. - new upstream release
  179. * Mon Sep 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-0vl3
  180. - changed Group to Applications/Games
  181. - added Japanese summary
  182. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  183. - rebuild for VineSeed
  184. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  185. - new upstream release
  186. * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  187. - rebuild for VineSeed
  188. * Tue May 30 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  189. - new upstream release
  190. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  191. - rebuild for VineSeed
  192. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  193. - new upstream release
  194. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  195. - rebuild for VineSeed
  196. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  197. - new upstream release
  198. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  199. - rebuild for VineSeed
  200. * Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  201. - new upstream release
  202. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  203. - new upstream release
  204. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  205. - new upstream release
  206. * Wed Sep 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  207. - new upstream release
  208. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  209. - rebuild for VineSeed
  210. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  211. - new upstream release
  212. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  213. - build for VineSeed
  214. - add --disable-rpath to configure option
  215. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  216. - new upstream release
  217. - use %%{?_smp_mflags} for make option
  218. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  219. - rebuild for VineSeed
  220. * Mon Mar 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  221. - new upstream release
  222. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  223. - new upstream release (3.4.0-rc1)
  224. - update %%files
  225. * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  226. - rebuild for VineSeed
  227. * Sat Dec 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  228. - source upgrade
  229. - build for Vine Linux 3.1
  230. * Thu Oct 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  231. - source upgrade
  232. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  233. - rebuild with qt32
  234. * Sun Jun 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  235. - source upgrade
  236. - remove lines about vine26
  237. - add URL: http://www.kde.org/
  238. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  239. - source upgrade
  240. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  241. - move *.so to main package
  242. * Tue Mar 9 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  243. - source upgrade
  244. * Thu Feb 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  245. - source upgrade
  246. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  247. - rebuild for VineSeedPlus
  248. * Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  249. - source upgrade
  250. - build for VinePlus/2.6
  251. - (VinePlus/2.6) BuildPrereq: autoconf258
  252. * Fri Dec 26 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  253. - build for VineSeed with new toolchain and qt-3.2.3
  254. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  255. - rebuild with qt-3.2.1-0.26vl3
  256. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  257. - rebuild with qt-3.2.1-0vl3
  258. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  259. - source upgrade
  260. - build with gcc-3.2.3
  261. * Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  262. - source upgrade
  263. - change spec to build with gcc295
  264. - change make option for SMP and add script
  265. * Tue Jun 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  266. - change spec to build with g++-2.95.3
  267. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  268. - source upgrade
  269. - built with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
  270. * Sat Mar 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  271. - source upgrade
  272. - change spec to build both VineSeed and Vine2.5/2.6
  273. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0vl1
  274. - source upgrade to 3.1-stable
  275. * Mon Jan 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1-0.rc7vl1
  276. - source upgrade to 3.1rc7
  277. - stop using objprelink2, it does not work with gcc3
  278. - change spec to make monolithic package only
  279. - move %{_libdir}/*.la and %{_libdir}/*.so to devel package
  280. - add %{_libdir}/kde3/*
  281. - cleanup spec
  282. * Sun Dec 29 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.5a-0vl1
  283. - source upgrade
  284. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  285. - objprelink2 support only ix86 (add %ifarch %{ix86} ... )
  286. - add Prereq: ldconfig
  287. - add Requires: XFree86-libs XFree86-gl freetype2 libjpeg libmng libpng zlib
  288. - add Requires: qt >= 3.0.5 arts >= 1:1.0.4 kdelibs >= %{version}
  289. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  290. - source upgrade
  291. - BuildPrereq: autoconf253 objprelink2
  292. * Mon Sep 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  293. - source upgrade
  294. * Fri Jul 5 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  295. - source upgrade
  296. * Fri Jun 7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-0vl1
  297. - source update to 3.0.1
  298. * Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl2
  299. - source update to 3.0
  300. - add configure option `--with-xinerama --enable-final'
  301. - add kbounce
  302. * Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0-1vl1
  303. - merged with rawhide 3.0.0-0.cvs20020306.1
  304. - source update to cvs-20020329
  305. - add BuildPrereq: autoconf252 automake15
  306. - There is Vine's previous changes, hacked for Vine
  307. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
  308. - update to 2.2.2
  309. -- Fri Nov 30 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
  310. - Delete Epoch
  311. - Change BuildRequires and Requires
  312. - objprelink (i386 only)
  313. - Build for VineSeed
  314. * Wed Mar 6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020306.1
  315. - Fix packaging glitch in monolithic version
  316. * Tue Mar 5 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020305.1
  317. - Make splits a buildtime option (off by default) on request
  318. * Mon Jan 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020107.1
  319. - Update to work with latest kdelibs changes
  320. * Wed Dec 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011226.1
  321. - Update
  322. - Add missing %{_bindir}/kbattleship
  323. * Sat Dec 15 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20011215.1
  324. - Update
  325. - Split into several packages (one package per game)
  326. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  327. - Update
  328. - Work around ia64 breakages
  329. - Add build requirements (#48977)
  330. * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  331. - Fix problem when changing the card type (Bug #28824)
  332. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  333. - 2.1-respin
  334. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - 2.1
  336. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  337. - don't use make -j CPU, it's broken
  338. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  339. - Run ldconfig in %%post and %%postun to make libkdegames happy
  340. - Replace absolute symlinks with relative symlinks (#24787)
  341. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  342. - Update
  343. - includedir=/usr/include/kde,
  344. now that libkdegames installs kcarddeck.h
  345. * Wed Jan 17 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  346. - Get rid of the gcc bug workaround, it's no longer needed
  347. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  348. - Update
  349. - Don't exclude ia64
  350. * Wed Nov 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  351. - Update to HEAD
  352. * Sat Oct 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  353. - Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
  354. * Mon Oct 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  355. - 2.0 final
  356. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  357. - 2.0
  358. * Mon Oct 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  359. - new CVS
  360. - work around g++ bugs (in kjumpingcube)
  361. * Thu Aug 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  362. - 1.93
  363. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  364. - new version
  365. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  366. - fix docdir
  367. - rebuild 16 July snapshot
  368. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  369. - SMPify
  370. - don't hardcode QTDIR
  371. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  372. - use gcc 2.96
  373. - new snapshot
  374. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  375. - new snapshot
  376. - ExcludeArch ia64 for now
  377. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  378. - new snapshot
  379. - move it to /usr, where it belongs
  380. * Fri Oct 22 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  381. - 2.0 snapshot
  382. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  383. - mark doc files as such
  384. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  385. - 1.1.2 release.
  386. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  387. - snapshot, includes kde 1.1.1 + fixes
  388. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  389. - last snapshot before release
  390. - ripped out asteroids and sirtet
  391. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  392. - latest stable snapshot
  393. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  394. - Injected new description and group.
  395. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  396. - upgraded to KDE 1.1 final.
  397. * Fri Feb 05 1999 Preston Brown <pbrown@redhat.com>
  398. - rebuilt for new libstdc++ etc.
  399. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  400. - re-merged updates from Duncan Haldane, change /opt/kde --> /usr