icu-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define sover 66
  3. %define minorver 1
  4. Summary: International Components for Unicode
  5. Summary(ja): ユニコード用国際化コンポーネント
  6. Name: icu
  7. Version: %{sover}.%{minorver}
  8. Release: 1%{?_dist_release}
  9. Group: Development/Tools
  10. License: MIT
  11. URL: http://icu-project.org/
  12. Source0: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
  13. Source1: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: unzip perl
  17. Requires: libicu%{sover} = %{version}-%{release}
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. ICU is a C++ and C library that provides robust and full-featured Unicode
  22. support. This package contains the Unicode character database and derived
  23. properties, along with converters and time zones data.
  24. %package -n libicu%{sover}
  25. Summary: International Components for Unicode (library)
  26. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  27. Group: System Environment/Libraries
  28. Provides: libicu = %{version}-%{release}
  29. %description -n libicu%{sover}
  30. ICU is a C++ and C library that provides robust and full-featured Unicode
  31. support. This package contains the runtime libraries for ICU. It does not
  32. contain any of the data files needed at runtime.
  33. %package -n libicu-devel
  34. Summary: Header files, libraries and development documentation for libicu
  35. Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
  36. Group: Development/Libraries
  37. Requires: libicu%{sover} = %{version}-%{release}
  38. %description -n libicu-devel
  39. This package contains the header files, static libraries for %{name}.
  40. If you like to develop programs using %{name}, you will need to install
  41. %{name}-devel.
  42. %package -n libicu-doc
  43. Summary: Documentation for International Components for Unicode
  44. Summary(ja): ユニコード用国際化コンポーネントのドキュメント
  45. Group: Applications/Documentation
  46. Requires: libicu%{sover} = %{version}-%{release}
  47. %description -n libicu-doc
  48. This package contains the development documentation for %{name}.
  49. # compat32
  50. %if %{build_compat32}
  51. %package -n compat32-libicu%{sover}
  52. Summary: International Components for Unicode (library)
  53. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  54. Group: System Environment/Libraries
  55. Provides: compat32-libicu = %{version}-%{release}
  56. %description -n compat32-libicu%{sover}
  57. ICU is a C++ and C library that provides robust and full-featured Unicode
  58. support. This package contains the runtime libraries for ICU. It does not
  59. contain any of the data files needed at runtime.
  60. %endif
  61. %prep
  62. %setup -q -n icu
  63. find . -name CVS -o -name .cvsignore | xargs -r rm -rf
  64. perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
  65. mkdir docs
  66. pushd docs
  67. unzip %{SOURCE1}
  68. popd
  69. %build
  70. cd source
  71. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  72. export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  73. %configure --disable-static --with-data-packaging=library --disable-samples
  74. make %{?_smp_mflags}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make -C source install DESTDIR=$RPM_BUILD_ROOT
  78. cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
  79. chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
  80. %ifarch x86_64
  81. %check || :
  82. make %{?_smp_mflags} -C source check
  83. %endif
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post -n libicu%{sover} -p /sbin/ldconfig
  87. %postun -n libicu%{sover} -p /sbin/ldconfig
  88. %files
  89. %defattr(-, root, root, 0755)
  90. %license LICENSE
  91. %doc license.html readme.html
  92. %{_bindir}/derb
  93. %{_bindir}/genbrk
  94. %{_bindir}/gencfu
  95. %{_bindir}/gencnval
  96. %{_bindir}/gendict
  97. %{_bindir}/genrb
  98. %{_bindir}/icuinfo
  99. %{_bindir}/makeconv
  100. %{_bindir}/pkgdata
  101. %{_bindir}/uconv
  102. %{_sbindir}/*
  103. %{_mandir}/man?/*
  104. %exclude %{_mandir}/man1/icu-config.1*
  105. %files -n libicu%{sover}
  106. %license LICENSE
  107. %defattr(-, root, root, 0755)
  108. %{_libdir}/*.so.*
  109. %files -n libicu-devel
  110. %license LICENSE
  111. %defattr(-, root, root, 0755)
  112. %{_bindir}/icu-config
  113. %{_includedir}/unicode
  114. %{_libdir}/*.so
  115. %{_libdir}/%{name}
  116. %{_libdir}/pkgconfig/*.pc
  117. %{_mandir}/man1/icu-config.1*
  118. %{_datadir}/%{name}
  119. %files -n libicu-doc
  120. %license LICENSE
  121. %defattr(-,root,root,-)
  122. %doc docs/*
  123. %if %{build_compat32}
  124. %files -n compat32-libicu%{sover}
  125. %license LICENSE
  126. %defattr(-, root, root, 0755)
  127. %{_libdir}/*.so.*
  128. %endif
  129. %changelog
  130. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 66.1-1
  131. - updated to 66.1.
  132. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-2
  133. - made to build compat32-* package.
  134. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-1
  135. - updated to 65.1.
  136. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.3-1
  137. - updated to 60.3.
  138. - disabled tests on i686.
  139. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.2-1
  140. - updated to 60.2.
  141. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-2
  142. - rebuild with gcc-5.4.0
  143. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-1
  144. - update to 56.1
  145. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 54.1-1
  146. - update to 54.1
  147. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 52.1-1
  148. - new upstream release
  149. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 51.2-1
  150. - update to 51.2
  151. * Tue Apr 13 2010 Shu KONNO <owa@bg.wakwak.com> 4.4-2
  152. - install libicutest.so*
  153. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4-1
  154. - new upstream release
  155. - built with new toolchain
  156. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
  157. - new upstream release
  158. - updated URL
  159. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
  160. - applied new versioning policy, spec in utf-8
  161. * Tue Sep 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
  162. - updated to 3.6
  163. - removed ".so ver" from libicu package name
  164. - changed Group to Development/Tools
  165. - changed libicu-doc Group to Applications/Documentation
  166. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
  167. - updated to 3.4.1
  168. * Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
  169. - updated to 3.2 based on Fedora extra
  170. - new subpackage libicu-doc for API document
  171. * Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
  172. - Build for Vine Linux
  173. - add developers document to devel package
  174. - add Japanese summary
  175. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
  176. - Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
  177. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
  178. - Initial package. (using DAR)