pugixml-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. Name: pugixml
  2. Version: 1.4
  3. Release: 1%{?_dist_release}
  4. Summary: A light-weight C++ XML processing library
  5. Group: Development/Libraries
  6. License: MIT
  7. URL: http://pugixml.org
  8. Source0: http://github.com/zeux/pugixml/releases/download/v%{version}/pugixml-%{version}.tar.gz
  9. # Add pugixml-config.cmake
  10. # https://github.com/zeux/pugixml/pull/7
  11. Patch0: pugixml-export.patch
  12. BuildRequires: cmake
  13. %description
  14. pugixml is a light-weight C++ XML processing library.
  15. It features:
  16. - DOM-like interface with rich traversal/modification capabilities
  17. - Extremely fast non-validating XML parser which constructs the DOM tree from
  18. an XML file/buffer
  19. - XPath 1.0 implementation for complex data-driven tree queries
  20. - Full Unicode support with Unicode interface variants and automatic encoding
  21. conversions
  22. %package devel
  23. Summary: Development files for %{name}
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. Development files for package %{name}
  28. %package docs
  29. Summary: Documentation for %{name}
  30. Group: Documentation
  31. BuildArch: noarch
  32. %description docs
  33. Documentation for package %{name}
  34. %prep
  35. %setup -q
  36. %patch0 -p1 -b .export
  37. %build
  38. mkdir -p ./build && pushd build
  39. %cmake -DCMAKE_INSTALL_LIBDIR=%{_lib} ../scripts
  40. make
  41. %install
  42. make -C build install DESTDIR=%{buildroot}
  43. mkdir -p %{buildroot}%{_datadir}/%{name}/contrib
  44. install -p -m 0644 contrib/* %{buildroot}%{_datadir}/%{name}/contrib/
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files
  48. %doc readme.txt
  49. %{_libdir}/*.so.*
  50. %files devel
  51. %{_libdir}/*.so
  52. %{_libdir}/cmake/%{name}/
  53. %{_datadir}/%{name}
  54. %{_includedir}/*.hpp
  55. %files docs
  56. %doc docs/*
  57. %changelog
  58. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4-1
  59. - initial build for Vine Linux
  60. * Wed Sep 03 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4-1
  61. - Update to 1.4
  62. - Split documentation out into -doc sub-package
  63. - Add cmake export information
  64. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-8
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  66. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-7
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  68. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-6
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  70. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-5
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  72. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-4
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  74. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  76. * Thu Jan 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0-2
  77. - Rebuild for GCC 4.7.0.
  78. * Fri Jul 08 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0-1
  79. - Initial Release