OpenImageIO-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229
  1. %global subname oiio
  2. Name: OpenImageIO
  3. Version: 1.4.15
  4. Release: 1%{?_dist_release}
  5. Summary: Library for reading and writing images
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: https://sites.google.com/site/openimageio/home
  9. Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
  10. # Images for test suite
  11. #Source1: oiio-images.tar.gz
  12. Patch0: oiio-Release-1.4.15-sign-compare.patch
  13. BuildRequires: cmake
  14. BuildRequires: txt2man
  15. BuildRequires: qt4-devel
  16. BuildRequires: libboost-devel
  17. BuildRequires: libboost-python
  18. BuildRequires: libboost-filesystem
  19. BuildRequires: glew-devel
  20. BuildRequires: OpenEXR-devel ilmbase-devel
  21. BuildRequires: python-devel
  22. BuildRequires: openssl-devel
  23. BuildRequires: libpng-devel libtiff-devel openjpeg-devel giflib-devel
  24. BuildRequires: libwebp-devel
  25. BuildRequires: Field3D-devel
  26. BuildRequires: hdf5-devel
  27. BuildRequires: zlib-devel
  28. BuildRequires: jasper-devel
  29. BuildRequires: LibRaw-devel
  30. BuildRequires: pugixml-devel
  31. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  32. # If an ABI incompatible update is done in one, the other also needs to be
  33. # rebuilt.
  34. BuildRequires: OpenColorIO-devel
  35. # We don't want to provide private python extension libs
  36. %{?filter_setup:
  37. %filter_provides_in %{python_sitearch}/.*\.so$
  38. %filter_setup
  39. }
  40. %description
  41. OpenImageIO is a library for reading and writing images, and a bunch of related
  42. classes, utilities, and applications. Main features include:
  43. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  44. writing 2D images that is format agnostic.
  45. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  46. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  47. PNM/PPM/PGM/PBM, Field3d.
  48. - An ImageCache class that transparently manages a cache so that it can access
  49. truly vast amounts of image data.
  50. %package utils
  51. Summary: Command line utilities for %{name}
  52. Requires: %{name} = %{version}-%{release}
  53. %description utils
  54. Command-line tools to manipulate and get information on images using the
  55. %{name} library.
  56. %package iv
  57. Summary: %{name} based image viewer
  58. Requires: %{name} = %{version}-%{release}
  59. %description iv
  60. A really nice image viewer, iv, based on %{name} classes (and so will work
  61. with any formats for which plugins are available).
  62. %package devel
  63. Summary: Documentation for %{name}
  64. Group: Development/Libraries
  65. Requires: %{name} = %{version}-%{release}
  66. %description devel
  67. Development files for package %{name}
  68. %prep
  69. %setup -q -n oiio-Release-%{version}
  70. %patch0 -p1
  71. # Remove bundled pugixml
  72. rm -f src/include/pugixml.hpp \
  73. src/include/pugiconfig.hpp \
  74. src/libutil/pugixml.cpp
  75. # Remove bundled tbb
  76. rm -rf src/include/tbb
  77. # Install test images
  78. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  79. #tar --strip-components=1 -xzf %{SOURCE1}
  80. %build
  81. rm -rf build/linux && mkdir -p build/linux && pushd build/linux
  82. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  83. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  84. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  85. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  86. -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
  87. -DPYLIB_INSTALL_DIR:PATH=%{python_sitearch} \
  88. -DINSTALL_DOCS:BOOL=FALSE \
  89. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  90. -DUSE_TBB:BOOL=FALSE \
  91. %ifarch ppc ppc64
  92. -DNOTHREADS:BOOL=FALSE \
  93. %endif
  94. -DVERBOSE=TRUE \
  95. ../../
  96. make %{?_smp_mflags}
  97. %install
  98. pushd build/linux
  99. make DESTDIR=%{buildroot} install
  100. # Move man pages to the right directory
  101. mkdir -p %{buildroot}%{_mandir}/man1
  102. cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files
  106. %doc CHANGES LICENSE
  107. %{_libdir}/libOpenImageIO.so.*
  108. %{_libdir}/libOpenImageIO_Util.so.*
  109. %{python_sitearch}/OpenImageIO.so
  110. %files utils
  111. %exclude %{_bindir}/iv
  112. %{_bindir}/*
  113. %exclude %{_mandir}/man1/iv.1.gz
  114. %{_mandir}/man1/*.1.gz
  115. %files iv
  116. %{_bindir}/iv
  117. %{_mandir}/man1/iv.1.gz
  118. %files devel
  119. %doc src/doc/*.pdf
  120. %{_libdir}/libOpenImageIO.so
  121. %{_libdir}/libOpenImageIO_Util.so
  122. %{_includedir}/*
  123. %changelog
  124. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  125. - initial build for Vine Linux
  126. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  127. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  128. - rebuild (openexr)
  129. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  130. - Update to latest upstream release.
  131. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  132. - Update to latest upstream release.
  133. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  134. - Rebuild for Field3D 1.4.3.
  135. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  136. - Rebuild for pugixml 1.4
  137. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  139. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  140. - Update to latest upstream release.
  141. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  143. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  144. - Rebuild for boost 1.55.0
  145. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  146. - rebuild for boost 1.55.0
  147. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  148. - Update to latest upstream release.
  149. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  150. - Update to latest upstream release.
  151. - Add libgif as build requirement.
  152. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  153. - rebuild (openexr)
  154. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  155. - rebuilt for GLEW 1.10
  156. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  157. - Update to latest upstream release.
  158. - Fix ppc builds (BZ#1021977).
  159. - Add conditionals to build requirements for EPEL 6.
  160. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  161. - Update to latest upstream release.
  162. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  163. - rebuild (ilmbase/openexr)
  164. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  165. - Update to latest upstream release.
  166. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  167. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  168. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  169. - Rebuild for boost 1.54.0