sbcl-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define pkg_name sbcl
  2. %define pkg_version 1.3.4
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Steel Bank Common Lisp
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: A mixture of BSD-style and public domain
  9. Group: Applications/Languages
  10. URL: http://www.sbcl.org/
  11. SOURCE: sbcl-%{version}-source.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: clisp
  14. BuildRequires: texinfo
  15. %if %{?_dist_release} == "vl6"
  16. BuildRequires: texlive-common
  17. BuildRequires: texlive-collection-texinfo
  18. %endif
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: ara_t
  22. %description
  23. Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
  24. It is open source / free software, with a permissive license.
  25. In addition to the compiler and runtime system for ANSI Common Lisp,
  26. it provides an interactive environment including a debugger,
  27. a statistical profiler, a code coverage tool, and many other extensions.
  28. %prep
  29. %{__rm} -rf ${RPM_BUILD_ROOT}
  30. %setup -q
  31. %build
  32. sh make.sh "clisp" --prefix=%{_usr}
  33. cd doc/manual
  34. %{__make} html info
  35. %if %{?_dist_release} == "vl6"
  36. %{__make} pdf
  37. %endif
  38. %install
  39. export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
  40. sh install.sh
  41. %{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
  42. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
  43. ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
  44. %{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
  45. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  46. %post
  47. for doc in asdf sbcl; do
  48. file=%{_infodir}/${doc}.info.gz
  49. if [ -e ${file} ]; then
  50. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  51. fi
  52. done
  53. %preun
  54. if [ $1 = 0 ]; then
  55. for doc in asdf sbcl; do
  56. file=%{_infodir}/${doc}.info.gz
  57. if [ -e ${file} ]; then
  58. /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
  59. fi
  60. done
  61. fi
  62. %clean
  63. %{__rm} -rf ${RPM_BUILD_ROOT}
  64. %files
  65. %defattr(-, root, root)
  66. %{_bindir}/
  67. /usr/lib/sbcl/
  68. %{_docdir}/sbcl-%{version}
  69. %{_infodir}/
  70. %{_mandir}/man1/
  71. %changelog
  72. * Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
  73. - new package