ModemManager-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. #define ppp_version 2.4.7
  4. %define glib2_version 2.40
  5. Name: ModemManager
  6. Summary: Mobile broadband modem management service
  7. Summary(ja): Mobile broadband modem management service
  8. Version: 1.4.14
  9. Release: 1%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: libgudev-devel
  25. BuildRequires: automake autoconf intltool libtool
  26. BuildRequires: gobject-introspection-devel
  27. BuildRequires: polkit-devel
  28. BuildRequires: gtk-doc
  29. # for xsltproc
  30. BuildRequires: libxslt
  31. Requires: dbus-glib
  32. %description
  33. The ModemManager service manages WWAN modems and provides a consistent API for
  34. interacting with these devices to client applications.
  35. %package devel
  36. Summary: Development tools for %{name}
  37. Summary(ja): %{name} の開発環境
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description devel
  42. Header files and libraries for building a extension library for the %{name}.
  43. %package glib
  44. Summary: Libraries for adding ModemManager support to applications that use glib.
  45. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  46. Group: System Environment/Libraries
  47. Requires: glib2 >= %{glib2_version}
  48. %description glib
  49. This package contains the libraries that make it easier to use some ModemManager
  50. functionality from applications that use glib.
  51. %package glib-devel
  52. Summary: Development tools for %{name}-glib
  53. Summary(ja): %{name}-glib の開発環境
  54. Group: Development/Libraries
  55. Requires: %{name}-glib = %{version}-%{release}
  56. Requires: %{name}-devel = %{version}-%{release}
  57. Requires: glib2-devel
  58. Requires: pkgconfig
  59. %description glib-devel
  60. Header files and libraries for building a extension library for the %{name}-glib.
  61. %prep
  62. %setup -q
  63. %patch0 -p1 -b .pty
  64. %build
  65. aclocal
  66. autoconf
  67. automake
  68. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  69. %configure \
  70. --disable-static \
  71. --enable-gtk-doc=yes \
  72. --enable-vala=no \
  73. --enable-more-warnings=yes \
  74. --with-udev-base-dir=/lib/udev \
  75. --without-mbim \
  76. --without-qmi \
  77. --with-dist-version=%{version}-%{release}
  78. make %{?_smp_mflags}
  79. %check
  80. make check
  81. %install
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  84. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  85. %find_lang %{name}
  86. %post
  87. /sbin/ldconfig
  88. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  89. %postun
  90. /sbin/ldconfig
  91. if [ $1 -eq 0 ]; then
  92. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  94. fi
  95. %posttrans
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  97. %post glib -p /sbin/ldconfig
  98. %postun glib -p /sbin/ldconfig
  99. %files -f %{name}.lang
  100. %defattr(-,root, root,-)
  101. %doc COPYING README
  102. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  103. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  104. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  105. %attr(0755,root,root) %{_sbindir}/ModemManager
  106. %attr(0755,root,root) %{_bindir}/mmcli
  107. %dir %{_libdir}/%{name}
  108. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  109. /lib/udev/rules.d/*
  110. %{_datadir}/dbus-1/interfaces/*.xml
  111. %{_datadir}/icons/hicolor/22x22/apps/*.png
  112. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  113. %{_mandir}/man8/*
  114. %files devel
  115. %defattr(-,root,root,-)
  116. %{_includedir}/ModemManager/*.h
  117. %dir %{_datadir}/gtk-doc/html/%{name}
  118. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  119. %{_datadir}/gtk-doc/html/%{name}/*
  120. %{_libdir}/pkgconfig/%{name}.pc
  121. %files glib
  122. %defattr(-,root,root,-)
  123. %{_libdir}/libmm-glib.so.*
  124. %files glib-devel
  125. %defattr(-,root,root,-)
  126. %{_libdir}/libmm-glib.so
  127. %dir %{_includedir}/libmm-glib
  128. %{_includedir}/libmm-glib/*.h
  129. %{_libdir}/pkgconfig/mm-glib.pc
  130. %dir %{_datadir}/gtk-doc/html/libmm-glib
  131. %{_datadir}/gtk-doc/html/libmm-glib/*
  132. %changelog
  133. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  134. - new upstream release
  135. - change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
  136. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
  137. - fix spec file
  138. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  139. - fix spec file
  140. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  141. - new upstream release
  142. - add BuildRequires: gobject-introspection-devel, polkit-devel
  143. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  144. - new upstream release
  145. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  146. - new upstream release
  147. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  148. - new upstream release
  149. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  150. - new upstream release
  151. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  152. - new upstream release
  153. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  154. - moved ModemManager-glib to System Environment/Libraries Group
  155. - removed BR: ppp, ppp-devel and dbus-glib-devel
  156. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  157. - new upstream release
  158. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  159. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  160. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  161. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  162. - new upstream release
  163. - update Patch0
  164. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  165. - update to 0.7.991 snapshot
  166. - fix spec file based on FC package
  167. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  168. - Update to 0.7.991 snapshot
  169. - Fix SMS validity parsing
  170. - Allow registration changes to 'searching' without disconnecting
  171. - Fix reading SMS messages from some QMI-based devices
  172. - Increase connection timeout for Novatel E362
  173. - Fix PIN retries checking when unlocking Ericsson devices
  174. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  175. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  176. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  177. - new upstream release
  178. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  179. - new upstream release
  180. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  181. - delete Patch20
  182. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  183. - update Patch20 (ModemManager-0.4-git20110428.patch)
  184. - delete Patch21,22
  185. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  186. - update to 0.4
  187. - add Patch20 (ModemManager-0.4-git20100720.patch)
  188. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  189. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  190. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  191. - initial build for Vine Linux
  192. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  193. - core: ignore some failures on disconnect (rh #578280)
  194. - core: add support for platform serial devices
  195. - gsm: better Blackberry DUN support
  196. - gsm: periodically poll access technology
  197. - cdma: prevent crash on modem removal (rh #571921)
  198. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  199. - novatel: better signal strength reporting on CDMA cards
  200. - novatel: add access technology and mode preference support on GSM cards
  201. - zte: fix mode preference retrieval
  202. - longcheer: add support for Zoom modems (4595, 4596, etc)
  203. - longcheer: add access technology and mode preference support
  204. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  205. - Silence %%post
  206. - Update scripts
  207. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  208. - gsm: fix parsing Blackberry supported character sets response
  209. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  210. - mbm: fix retrieval of current allowed mode
  211. - gsm: fix initialization issues with some devices (like Blackberries)
  212. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  213. - core: fix detection of some generic devices (rh #579247)
  214. - core: fix detection regression of some Huawei devices in 0.3-5
  215. - cdma: periodically poll registration state and signal quality
  216. - cdma: really fix registration detection on various devices (rh #569067)
  217. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  218. - core: fix PPC/SPARC/etc builds
  219. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  220. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  221. - cdma: handle signal quality requests while connected for more devices
  222. - cdma: handle serving system requests while connected for more devices
  223. - gsm: determine current access technology earlier
  224. - huawei: work around automatic registration issues on some devices
  225. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  226. - core: ensure enabled modems are disabled when MM stops
  227. - core: better capability detection for Blackberry devices (rh #573510)
  228. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  229. - gsm: don't block modem when it requires PIN2
  230. - option: fix access technology updates
  231. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  232. - mbm: add device IDs for C3607w
  233. - mbm: fail earlier during connection failures
  234. - mbm: fix username/password authentication when checked by the network
  235. - hso: implement asynchronous signal quality updates
  236. - option: implement asynchronous signal quality updates
  237. - novatel: correctly handle CDMA signal quality
  238. - core: basic PolicyKit support
  239. - core: fix direct GSM registration information requests
  240. - core: general GSM PIN/PUK unlock fixes
  241. - core: poll GSM registration state internally for quicker status updates
  242. - core: implement GSM 2G/3G preference
  243. - core: implement GSM roaming allowed/disallowed preference
  244. - core: emit signals on access technology changes
  245. - core: better handling of disconnections
  246. - core: fix simple CDMA status requests
  247. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  248. - core: startup speed improvements
  249. - core: GSM PIN checking improvements
  250. - huawei: fix EVDO-only connections on various devices (rh #553199)
  251. - longcheer: add support for more devices
  252. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  253. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  254. - core: fix crashes when devices are unplugged during operation (rh #553953)
  255. - cdma: prefer primary port for status/registration queries
  256. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  257. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  258. - gsm: fix Nokia N80 network scan parsing
  259. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  260. - core: fix apparent hangs by limiting retried serial writes
  261. - gsm: ensure modem state is reset when disabled
  262. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  263. - sierra: fix CDMA registration detection in some cases (rh #547513)
  264. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  265. - sierra: ensure CDMA device is powered up when trying to use it
  266. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  267. - zte: handle unsolicited messages better during probing
  268. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  269. - cdma: fix signal strength reporting on some devices
  270. - cdma: better registration state detection when dialing (ex Sierra 5275)
  271. - option: always use the correct tty for dialing commands
  272. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  273. - core: fix reconnect after manual disconnect (rh #541314)
  274. - core: fix various segfaults during registration
  275. - core: fix probing of various modems on big-endian architectures (ie PPC)
  276. - core: implement modem states to avoid duplicate operations
  277. - hso: fix authentication for Icera-based devices like iCON 505
  278. - zte: use correct port for new devices
  279. - nozomi: fix detection
  280. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  281. - Update to latest git
  282. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  283. - cdma: wait for network registration before trying to connect
  284. - gsm: add cell access technology reporting
  285. - gsm: allow longer-running network scans
  286. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  287. - nokia: don't power down phones on disconnect
  288. - hso: fix disconnection/disable
  289. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  290. - Fixes for Motorola and Ericsson devices
  291. - Fixes for CDMA "serving-system" command parsing
  292. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  293. - Fix a typo in one of the udev rules files
  294. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  295. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  296. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  297. - Fix source repo location
  298. - Fix directory ownership
  299. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  300. - Initial version