nginx-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. %define nginx_user nginx
  4. %define nginx_group %{nginx_user}
  5. %define nginx_home %{_localstatedir}/lib/nginx
  6. %define nginx_home_tmp %{nginx_home}/tmp
  7. %define nginx_home_cache %{nginx_home}/cache
  8. %define nginx_logdir %{_localstatedir}/log/nginx
  9. %define nginx_confdir %{_sysconfdir}/nginx
  10. %define nginx_datadir %{_datadir}/nginx
  11. %define nginx_webroot %{nginx_datadir}/html
  12. Summary: Robust, small and high performance http and reverse proxy server
  13. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  14. Name: nginx
  15. Version: 1.0.6
  16. Release: 1%{?_dist_release}
  17. Group: System Environment/Daemons
  18. # BSD License (two clause)
  19. # http://www.freebsd.org/copyright/freebsd-license.html
  20. License: BSD
  21. URL: http://nginx.net/
  22. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  23. Source1: %{name}.init
  24. Source2: %{name}.logrotate
  25. Source3: nginx-virtual.conf.template
  26. Source4: nginx-ssl.conf
  27. Source5: %{name}.sysconfig
  28. Source10: nginx-vine.conf
  29. Source11: nginx-default-vine
  30. Source20: proxy_cache.conf
  31. Source100: nginx-index.html
  32. Source101: poweredby-vine.png
  33. Source102: nginx-logo.png
  34. Source103: nginx-50x.html
  35. Source104: nginx-404.html
  36. %define ngx_fancyindex_version 0.3
  37. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  38. %define nginx_accept_language_module_version 02262ce
  39. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  40. %define passenger_version 3.0.5
  41. Source1020: passenger-%{passenger_version}.tar.gz
  42. %define upstream_fair_version 2131c73
  43. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  44. %define upstream_keepalive_version 2ee28064a04a
  45. Source1040: ngx_http_upstream_keepalive-%{upstream_keepalive_version}.tar.gz
  46. %define mod_wsgi_version 6975f0ec7eeb
  47. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  48. # removes -Werror in upstream build scripts. -Werror conflicts with
  49. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  50. Patch0: nginx-auto-cc-gcc.patch
  51. # configuration patch to match all the Vine Linux paths for logs, pid files
  52. # etc.
  53. Patch1: nginx-conf.patch
  54. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  55. BuildRequires: pcre-devel
  56. BuildRequires: zlib-devel
  57. BuildRequires: openssl-devel
  58. BuildRequires: gd-devel
  59. BuildRequires: perl
  60. BuildRequires: perl(ExtUtils::Embed)
  61. BuildRequires: libxml2-devel
  62. BuildRequires: libxslt-devel
  63. BuildRequires: curl-devel
  64. %if "%{?_dist_release}" == "vl4"
  65. Requires: perl >= 5.8.6
  66. %else
  67. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  68. %endif
  69. # for /usr/sbin/useradd
  70. Requires(pre): shadow-utils
  71. Requires(post): chkconfig
  72. # for /sbin/service
  73. Requires(preun): chkconfig, initscripts
  74. Requires(postun): initscripts
  75. Provides: webserver
  76. Vendor: Project Vine
  77. Distribution: Vine Linux
  78. Packager: daisuke
  79. %description
  80. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  81. proxy server written by Igor Sysoev.
  82. %description -l ja
  83. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  84. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  85. - HTTP(S) サーバ
  86. - HTTP(S) リバースプロキシサーバ
  87. - IMAP/POP3 プロキシサーバ
  88. %package passenger
  89. Summary: Nginx with mod_passenger support
  90. Summary(ja): Passenger サポート入りの Nginx
  91. Group: System Environment/Daemons
  92. BuildRequires: ruby, rubygems, rubygem-rake
  93. Requires: nginx
  94. %description passenger
  95. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  96. This package contains nginx server with passenger support.
  97. %description -l ja passenger
  98. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  99. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  100. - HTTP(S) サーバ
  101. - HTTP(S) リバースプロキシサーバ
  102. - IMAP/POP3 プロキシサーバ
  103. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  104. %prep
  105. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 -a 1040 %{?with_wsgi:-a 2000}
  106. %patch0 -p0
  107. %patch1 -p1
  108. %build
  109. # nginx does not utilize a standard configure script. It has its own
  110. # and the standard configure options cause the nginx configure script
  111. # to error out. This is is also the reason for the DESTDIR environment
  112. # variable. The configure script(s) have been patched (Patch1 and
  113. # Patch2) in order to support installing into a build environment.
  114. export DESTDIR=%{buildroot}
  115. ## build with passenger
  116. ./configure \
  117. --user=%{nginx_user} \
  118. --group=%{nginx_group} \
  119. --prefix=%{nginx_datadir} \
  120. --sbin-path=%{_sbindir}/%{name} \
  121. --conf-path=%{nginx_confdir}/%{name}.conf \
  122. --error-log-path=%{nginx_logdir}/error.log \
  123. --http-log-path=%{nginx_logdir}/access.log \
  124. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  125. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  126. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  127. --pid-path=%{_localstatedir}/run/%{name}.pid \
  128. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  129. --with-file-aio \
  130. --with-ipv6 \
  131. --with-http_ssl_module \
  132. --with-http_realip_module \
  133. --with-http_addition_module \
  134. --with-http_xslt_module \
  135. --with-http_image_filter_module \
  136. --with-http_sub_module \
  137. --with-http_dav_module \
  138. --with-http_flv_module \
  139. --with-http_gzip_static_module \
  140. --with-http_random_index_module \
  141. --with-http_secure_link_module \
  142. --with-http_stub_status_module \
  143. --with-http_perl_module \
  144. --with-mail \
  145. --with-mail_ssl_module \
  146. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  147. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  148. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  149. --add-module=ngx_http_upstream_keepalive-%{upstream_keepalive_version} \
  150. %if %{with wsgi}
  151. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  152. %endif
  153. --add-module=passenger-%{passenger_version}/ext/nginx \
  154. %ifarch i686
  155. --with-cpu-opt=pentiumpro \
  156. --with-zlib-asm=pentiumpro \
  157. --with-md5-asm \
  158. --with-sha1-asm \
  159. %endif
  160. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  161. make %{?_smp_mflags}
  162. mv objs/nginx objs/nginx.passenger
  163. ## build without passenger
  164. ./configure \
  165. --user=%{nginx_user} \
  166. --group=%{nginx_group} \
  167. --prefix=%{nginx_datadir} \
  168. --sbin-path=%{_sbindir}/%{name} \
  169. --conf-path=%{nginx_confdir}/%{name}.conf \
  170. --error-log-path=%{nginx_logdir}/error.log \
  171. --http-log-path=%{nginx_logdir}/access.log \
  172. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  173. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  174. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  175. --pid-path=%{_localstatedir}/run/%{name}.pid \
  176. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  177. --with-file-aio \
  178. --with-ipv6 \
  179. --with-http_ssl_module \
  180. --with-http_realip_module \
  181. --with-http_addition_module \
  182. --with-http_xslt_module \
  183. --with-http_image_filter_module \
  184. --with-http_sub_module \
  185. --with-http_dav_module \
  186. --with-http_flv_module \
  187. --with-http_gzip_static_module \
  188. --with-http_random_index_module \
  189. --with-http_secure_link_module \
  190. --with-http_stub_status_module \
  191. --with-http_perl_module \
  192. --with-mail \
  193. --with-mail_ssl_module \
  194. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  195. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  196. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  197. --add-module=ngx_http_upstream_keepalive-%{upstream_keepalive_version} \
  198. %if %{with wsgi}
  199. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  200. %endif
  201. %ifarch i686
  202. --with-cpu-opt=pentiumpro \
  203. --with-zlib-asm=pentiumpro \
  204. --with-md5-asm \
  205. --with-sha1-asm \
  206. %endif
  207. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  208. make %{?_smp_mflags}
  209. %install
  210. rm -rf %{buildroot}
  211. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  212. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  213. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  214. find %{buildroot} -type f -empty -exec rm -f {} \;
  215. find %{buildroot} -type f -exec chmod 0644 {} \;
  216. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  217. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  218. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  219. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  220. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  221. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  222. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  223. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  224. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  225. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  226. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  227. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
  228. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
  229. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  230. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  231. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  232. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  233. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  234. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  235. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  236. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  237. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  238. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  239. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  240. %if %{with wsgi}
  241. %{__install} -p -m 0644 \
  242. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  243. %{buildroot}%{nginx_confdir}
  244. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  245. %endif
  246. # upstream fair module document
  247. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  248. # upstream keepalive module document and sample
  249. mkdir -p upstream_keepalive_example
  250. cp -f ngx_http_upstream_keepalive-%{upstream_keepalive_version}/README README.upstream_keepalive
  251. cp -f ngx_http_upstream_keepalive-%{upstream_keepalive_version}/t/* upstream_keepalive_example
  252. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  253. # convert to UTF-8 all files that give warnings.
  254. for textfile in CHANGES
  255. do
  256. mv $textfile $textfile.old
  257. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  258. rm -f $textfile.old
  259. done
  260. %clean
  261. rm -rf %{buildroot}
  262. %pre
  263. if [ $1 == 1 ]; then
  264. %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
  265. fi
  266. %post
  267. if [ $1 == 1 ]; then
  268. /sbin/chkconfig --add %{name}
  269. fi
  270. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  271. %post passenger
  272. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  273. %preun
  274. if [ $1 = 0 ]; then
  275. /sbin/service %{name} stop >/dev/null 2>&1
  276. /sbin/chkconfig --del %{name}
  277. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  278. fi
  279. %preun passenger
  280. if [ $1 = 0 ]; then
  281. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  282. fi
  283. %postun
  284. if [ $1 == 2 ]; then
  285. /sbin/service %{name} upgrade || :
  286. fi
  287. %files
  288. %defattr(-,root,root,-)
  289. %doc LICENSE CHANGES README
  290. %doc README.upstream_fair
  291. %doc README.upstream_keepalive upstream_keepalive_example/
  292. %doc %{?with_wsgi:README.mod_wsgi}
  293. %{nginx_datadir}/
  294. %{_sbindir}/%{name}.normal
  295. %{_mandir}/man3/%{name}.3pm.gz
  296. %{_initrddir}/%{name}
  297. %dir %{nginx_confdir}
  298. %dir %{nginx_confdir}/conf.d
  299. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  300. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  301. %config(noreplace) %{nginx_confdir}/sites.d/*
  302. %config(noreplace) %{nginx_confdir}/win-utf
  303. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  304. %config(noreplace) %{nginx_confdir}/mime.types.default
  305. %config(noreplace) %{nginx_confdir}/fastcgi_params
  306. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  307. %config(noreplace) %{nginx_confdir}/koi-win
  308. %config(noreplace) %{nginx_confdir}/koi-utf
  309. %config(noreplace) %{nginx_confdir}/%{name}.conf
  310. %config(noreplace) %{nginx_confdir}/mime.types
  311. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  312. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  313. %config(noreplace) %{nginx_confdir}/scgi_params
  314. %config(noreplace) %{nginx_confdir}/scgi_params.default
  315. %config(noreplace) %{nginx_confdir}/uwsgi_params
  316. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  317. %if %{with wsgi}
  318. %config(noreplace) %{nginx_confdir}/wsgi_vars
  319. %endif
  320. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  321. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  322. %dir %{perl_vendorarch}/auto/%{name}
  323. %{perl_vendorarch}/%{name}.pm
  324. %{perl_vendorarch}/auto/%{name}/%{name}.so
  325. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  326. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  327. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  328. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  329. %files passenger
  330. %defattr(-,root,root,-)
  331. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  332. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  333. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  334. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  335. %doc passenger-%{passenger_version}/doc/template
  336. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  337. %doc passenger-%{passenger_version}/doc/images
  338. %{_sbindir}/%{name}.passenger
  339. %changelog
  340. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  341. - update to 1.0.6
  342. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  343. - update to 1.0.4
  344. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  345. - add gnosek-nginx-upstream-fair module
  346. - add ngx_http_upstream_keepalive module
  347. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  348. - add nginx-passenger sub pakckage
  349. - use alternatives to choose nginx with or without passenger
  350. - add BR: ruby, rubygems, rubygem-rake
  351. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  352. - update to 1.0.2
  353. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  354. - update to 1.0.1
  355. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  356. - add bcond_with wsgi for mod_wsgi
  357. - add bcond_with passenger
  358. - you need to install rake.gem to build with this option.
  359. - add Provides: webserver
  360. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  361. - new upstream release 1.0.0!
  362. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  363. - rebuild with perl-5.12.3
  364. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  365. - update to 0.8.54
  366. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  367. - update to 0.8.53
  368. - add nginx_accept_language_module
  369. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  370. - update to 0.8.50
  371. - update ngx-fancyindex to 0.3
  372. - add BR: libxml2-devel, libxslt-devel
  373. - add scgi_params* and uwsgi_params* to %%files
  374. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  375. - update to 0.8.35 (development version)
  376. - add sites.d/ to store vitualhost settings
  377. - split out default server settings to sites.d/default
  378. - add fancyindex module
  379. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  380. - new upstream release
  381. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  382. - update to 0.7.62 (included security fix: VU#180065)
  383. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  384. - fix typo
  385. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  386. - add translated descriptions
  387. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  388. - update 404.html/50x.html to use powered by vine logo.
  389. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  390. - initial build for Vine Linux
  391. - update to 0.7.61
  392. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  393. - init script updates from Gena Makhomed
  394. - remove nginx-upstream-fair
  395. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  396. - update to 0.6.36
  397. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  398. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  399. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  400. - rebuild
  401. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  402. - update to 0.6.35
  403. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  404. - rebuild with new openssl
  405. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  406. - update to 0.6.34
  407. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  408. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  409. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  410. - update to 0.6.33
  411. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  412. - update to 0.6.32
  413. - nginx now supports DESTDIR so removed the patches that enabled it
  414. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  415. - init script fixes
  416. - resolve 'listen 80 default' [#447873]
  417. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  418. - update to 0.6.31
  419. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  420. - upate to new upstream stable branch 0.6
  421. - added 3rd party module nginx-upstream-fair
  422. - added default webpages
  423. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  424. - update init script to match recommended guidelines
  425. - add /etc/nginx/conf.d support [#443280]
  426. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  427. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  428. - add Requires for versioned perl (libperl.so)
  429. - drop silly file Requires
  430. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  431. - Autorebuild for GCC 4.3
  432. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  433. - update to 0.5.35
  434. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  435. - update to 0.5.34
  436. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  437. - Rebuild for deps
  438. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  439. - update to 0.5.33
  440. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  441. - updated to 0.5.32
  442. - fixed rpmlint UTF-8 complaints.
  443. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  444. - added --with-http_stub_status_module build option.
  445. - added --with-http_sub_module build option.
  446. - added use of pcre-config --cflags
  447. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  448. - Update to 0.5.31
  449. - specify license is BSD
  450. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  451. - Add BuildRequires: perl-devel - fixing rawhide build
  452. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  453. - Update to 0.5.30
  454. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  455. - Update to 0.5.29
  456. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  457. - Update to 0.5.28
  458. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  459. - Update to 0.5.27
  460. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  461. - Update to 0.5.26
  462. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  463. - Update to 0.5.19
  464. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  465. - Update to 0.5.17
  466. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  467. - Update to 0.5.16
  468. - add ownership of /usr/share/nginx/html (#233950)
  469. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  470. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  471. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  472. - fixed package review bugs (#233522) given by kevin@tummy.com
  473. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  474. - create patches to assist with building for Fedora
  475. - initial packaging for Fedora