vala-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446
  1. %global api_ver 0.48
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A modern programming language for GNOME
  4. Summary(ja): GNOME 用のモダンなプログラミング言語
  5. Name: vala
  6. # LTS 0.48
  7. Version: 0.48.15
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  13. License: LGPLv2+ and BSD
  14. URL: https://wiki.gnome.org/Projects/Vala
  15. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  16. Source0: https://download.gnome.org/sources/vala/%{shortver}/vala-%{version}.tar.xz
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: glib2-devel
  19. BuildRequires: gobject-introspection-devel
  20. BuildRequires: flex
  21. BuildRequires: bison
  22. BuildRequires: libxslt
  23. BuildRequires: graphviz-devel
  24. Requires: %{name}-libs = %{version}-%{release}
  25. Obsoletes: %{name}-tools < 0.48.15
  26. Provides: %{name}-tools = %{version}-%{release}
  27. Provides: vala(api) = %{api_ver}
  28. %description
  29. Vala is a new programming language that aims to bring modern programming
  30. language features to GNOME developers without imposing any additional
  31. runtime requirements and without using a different ABI compared to
  32. applications and libraries written in C.
  33. valac, the Vala compiler, is a self-hosting compiler that translates
  34. Vala source code into C source and header files. It uses the GObject
  35. type system to create classes and interfaces declared in the Vala source
  36. code. It's also planned to generate GIDL files when gobject-
  37. introspection is ready.
  38. The syntax of Vala is similar to C#, modified to better fit the GObject
  39. type system.
  40. %package libs
  41. Summary: Vala compiler library
  42. Summary(ja): Valaコンパイラの共有ライブラリ
  43. Group: system,programming
  44. Provides: libvala = %{version}-%{release}
  45. %description libs
  46. Vala is a new programming language that aims to bring modern programming
  47. language features to GNOME developers without imposing any additional
  48. runtime requirements and without using a different ABI compared to
  49. applications and libraries written in C.
  50. This package contains the shared libvala library.
  51. %package devel
  52. Summary: Development files for %{name}
  53. Summary(ja): %{name} の開発用ファイル
  54. Group: programming
  55. Requires: %{name}-libs = %{version}-%{release}
  56. Requires: pkgconfig
  57. Provides: libvala-devel = %{version}-%{release}
  58. %description devel
  59. Vala is a new programming language that aims to bring modern programming
  60. language features to GNOME developers without imposing any additional
  61. runtime requirements and without using a different ABI compared to
  62. applications and libraries written in C.
  63. This package contains development files for %{name}. This is not necessary for
  64. using the %{name} compiler.
  65. %package doc
  66. Summary: Documentation for %{name}
  67. Summary(ja): %{name} のドキュメント
  68. Group: documentation
  69. License: LGPLv2+
  70. BuildArch: noarch
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: devhelp
  73. Provides: %{name}-docs = %{version}-%{release}
  74. Obsoletes: %{name}-docs < %{version}-%{release}
  75. %description doc
  76. Vala is a new programming language that aims to bring modern programming
  77. language features to GNOME developers without imposing any additional
  78. runtime requirements and without using a different ABI compared to
  79. applications and libraries written in C.
  80. This package contains documentation in a devhelp HTML book.
  81. %package -n valadoc
  82. Summary: Vala documentation generator
  83. Summary(ja): Valaのドキュメントジェネレータ
  84. Group: programming
  85. License: LGPLv2+
  86. Requires: vala = %{version}-%{release}
  87. %description -n valadoc
  88. Valadoc is a documentation generator for generating API documentation from Vala
  89. source code.
  90. %package -n valadoc-devel
  91. Summary: Development files for valadoc
  92. Summary(ja): valadocを利用した開発のためのファイル群
  93. Group: programming
  94. License: LGPLv2+
  95. Requires: valadoc = %{version}-%{release}
  96. %description -n valadoc-devel
  97. Valadoc is a documentation generator for generating API documentation from Vala
  98. source code.
  99. The valadoc-devel package contains libraries and header files for
  100. developing applications that use valadoc.
  101. %debug_package
  102. %prep
  103. %setup -q
  104. %build
  105. %configure --enable-vapigen
  106. # Don't use rpath!
  107. sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
  108. make %{?_smp_mflags}
  109. %install
  110. rm -rf $RPM_BUILD_ROOT
  111. make install DESTDIR=$RPM_BUILD_ROOT
  112. find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
  113. %check
  114. make check
  115. %files
  116. %defattr(-,root,root,-)
  117. %license COPYING
  118. %doc AUTHORS ChangeLog NEWS README THANKS
  119. %{_bindir}/vala
  120. %{_bindir}/valac
  121. %{_bindir}/vala-%{api_ver}
  122. %{_bindir}/valac-%{api_ver}
  123. %{_bindir}/vala-gen-introspect
  124. %{_bindir}/vala-gen-introspect-%{api_ver}
  125. %{_bindir}/vapigen
  126. %{_bindir}/vapigen-%{api_ver}
  127. %{_datadir}/aclocal/vala.m4
  128. %{_datadir}/aclocal/vapigen.m4
  129. %{_datadir}/vala
  130. %{_datadir}/vala-%{api_ver}
  131. %{_libdir}/pkgconfig/vapigen.pc
  132. %{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
  133. %{_libdir}/vala-%{api_ver}
  134. %{_mandir}/*/valac*
  135. %{_mandir}/*/*gen*
  136. %files libs
  137. %{_libdir}/libvala-%{api_ver}.so.*
  138. %files devel
  139. %defattr(-,root,root,-)
  140. %{_includedir}/vala-%{api_ver}
  141. %{_libdir}/libvala-%{api_ver}.so
  142. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  143. %files doc
  144. %defattr(-,root,root,-)
  145. %{_datadir}/devhelp/books/vala-%{api_ver}
  146. %files -n valadoc
  147. %defattr(-,root,root,-)
  148. %{_bindir}/valadoc*
  149. %{_libdir}/libvaladoc-%{api_ver}.so.*
  150. %{_libdir}/valadoc-%{api_ver}
  151. %{_datadir}/valadoc-%{api_ver}
  152. %{_mandir}/*/valadoc*
  153. %files -n valadoc-devel
  154. %{_libdir}/libvaladoc-%{api_ver}.so
  155. %{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
  156. %{_includedir}/valadoc-%{api_ver}
  157. %changelog
  158. * Tue Mar 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.15-1
  159. - new upstream release.
  160. - dropped ldconfig scriptlets.
  161. - unified vala-tools into main package.
  162. - separated libvala as vala-libs.
  163. * Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.13-1
  164. - new upstream release.
  165. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.8-1
  166. - new upstream release.
  167. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.44.7-1
  168. - new upstream release.
  169. * Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
  170. - new upstream release (LTS 0.40).
  171. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
  172. - new upstream release.
  173. - added subpackages "valadoc" and "valadoc-devel".
  174. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
  175. - new upstream release
  176. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
  177. - new upstream release
  178. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
  179. - new upstream release
  180. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
  181. - new upstream release
  182. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
  183. - new upstream release
  184. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
  185. - new upstream release
  186. - moved tools subpackage to Development/Tools Group
  187. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  188. - new upstream release
  189. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  190. - new upstream release
  191. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  192. - new upstream release
  193. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  194. - new upstream release
  195. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  196. - new upstream release
  197. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  198. - new upstream release
  199. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  200. - new upstream release
  201. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  202. - new upstream release
  203. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  204. - new upstream release
  205. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  206. - new upstream release
  207. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  208. - new upstream release
  209. - remove BuildRequires: gtk2-devel, xulrunner-devel
  210. - add BuildRequires: glib2-devel, libxslt
  211. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  212. - new upstream release
  213. - remove BuildRequires: devhelp
  214. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  215. - new upstream release
  216. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  217. - new upstream release
  218. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  219. - new upstream release
  220. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  221. - rebuilt with rpm-4.8.1 for pkg-config
  222. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  223. - new upstream release
  224. - made -doc subpackage noarch
  225. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  226. - new upstream release
  227. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  228. - new upstream release
  229. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  230. - new upstream release
  231. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  232. - new upstream release
  233. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  234. - new upstream release
  235. - change BuildRequires: gecko-libs -> xulrunner-devel
  236. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  237. - new upstream release
  238. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  239. - new upstream release
  240. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  241. - new upstream release
  242. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  243. - initial build for Vine Linux
  244. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  245. - Update to 0.7.5
  246. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  247. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  248. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  249. - Patch broken ModuleInit attribute (upstream bug 587444)
  250. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  251. - Update to 0.7.4
  252. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  253. - Update to 0.7.3
  254. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  255. - Update to 0.6.1
  256. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  257. - Update to 0.5.7
  258. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  259. - Update to 0.5.6
  260. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  261. - Update to 0.5.3
  262. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  263. - Fix bug in Emacs version detection
  264. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  265. - Use buildsystem variables to determine available Emacs version
  266. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  267. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  268. - Update to 0.5.2
  269. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  270. - Update to 0.5.1
  271. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  272. - Update to 0.3.5
  273. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  274. - Add vala-mode for editing Vala code in Emacs
  275. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  276. - Update to 0.3.4
  277. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  278. - Update to 0.3.3
  279. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  280. - Update to 0.3.2
  281. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  282. - Update to 0.2.0
  283. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  284. - Update to 0.1.7
  285. - -tool subpackage now requires gnome-common, intltool and libtoolize
  286. for out-of-the-box vala-gen-project support
  287. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  288. - Autorebuild for GCC 4.3
  289. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  290. - Update to 0.1.6
  291. - Revert vapi addition, needed declarations have been inlined (r846)
  292. - Rename -docs subpackage to -doc, to comply with guidelines
  293. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  294. - Manually add Gee vapi file to package (bz #428692)
  295. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  296. - Backport patch to autodetect location of automake shared files
  297. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  298. - Add build dependency on gtk2-devel
  299. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  300. - Enable project generator tool
  301. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  302. - Update to 0.1.5
  303. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  304. - Add build dependency on devhelp
  305. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  306. - Update to 0.1.4
  307. - Put newly-added documentation in its own subpackage (depends on devhelp)
  308. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  309. - vapigen subpackage: add missing Require: on perl-XML-Twig
  310. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  311. - Split -vapigen subpackage. It is functionally self-contained and the license
  312. is more restricted
  313. - Updated license declarations
  314. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  315. - Licensing and URL updates
  316. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  317. - Enable binding generation tools
  318. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  319. - Update to 0.1.3
  320. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  321. - Update to 0.0.8
  322. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  323. - Update to 0.0.7
  324. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  325. - Update to 0.0.6
  326. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  327. - Initial package