vala-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445
  1. %global api_ver 0.44
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A modern programming language for GNOME
  4. Summary(ja): GNOME 用のモダンなプログラミング言語
  5. Name: vala
  6. Version: 0.44.7
  7. Release: 1%{?_dist_release}
  8. Group: Development/Languages
  9. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  10. License: LGPLv2+ and BSD
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. URL: http://live.gnome.org/Vala
  14. %define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
  15. Source0: http://download.gnome.org/sources/vala/%{major_minor}/vala-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: glib2-devel
  18. BuildRequires: gobject-introspection-devel
  19. BuildRequires: flex
  20. BuildRequires: bison
  21. BuildRequires: libxslt
  22. BuildRequires: graphviz-devel
  23. %description
  24. Vala is a new programming language that aims to bring modern programming
  25. language features to GNOME developers without imposing any additional
  26. runtime requirements and without using a different ABI compared to
  27. applications and libraries written in C.
  28. valac, the Vala compiler, is a self-hosting compiler that translates
  29. Vala source code into C source and header files. It uses the GObject
  30. type system to create classes and interfaces declared in the Vala source
  31. code. It's also planned to generate GIDL files when gobject-
  32. introspection is ready.
  33. The syntax of Vala is similar to C#, modified to better fit the GObject
  34. type system.
  35. %package devel
  36. Summary: Development files for %{name}
  37. Summary(ja): %{name} の開発用ファイル
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description devel
  42. Vala is a new programming language that aims to bring modern programming
  43. language features to GNOME developers without imposing any additional
  44. runtime requirements and without using a different ABI compared to
  45. applications and libraries written in C.
  46. This package contains development files for %{name}. This is not necessary for
  47. using the %{name} compiler.
  48. %package tools
  49. Summary: Tools for creating projects and bindings for %{name}
  50. Summary(ja): %{name} のプロジェクト作成やバインディングのためのツール集
  51. Group: Development/Tools
  52. License: LGPLv2+
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: gnome-common intltool libtool
  55. Provides: %{name}-vapigen = %{version}-%{release}
  56. Obsoletes: %{name}-vapigen < %{version}-%{release}
  57. %description tools
  58. Vala is a new programming language that aims to bring modern programming
  59. language features to GNOME developers without imposing any additional
  60. runtime requirements and without using a different ABI compared to
  61. applications and libraries written in C.
  62. This package contains tools to generate Vala projects, as well as API bindings
  63. from existing C libraries, allowing access from Vala programs.
  64. %package doc
  65. Summary: Documentation for %{name}
  66. Summary(ja): %{name} のドキュメント
  67. Group: Documentation
  68. License: LGPLv2+
  69. BuildArch: noarch
  70. Requires: %{name} = %{version}-%{release}
  71. Requires: devhelp
  72. Provides: %{name}-docs = %{version}-%{release}
  73. Obsoletes: %{name}-docs < %{version}-%{release}
  74. %description doc
  75. Vala is a new programming language that aims to bring modern programming
  76. language features to GNOME developers without imposing any additional
  77. runtime requirements and without using a different ABI compared to
  78. applications and libraries written in C.
  79. This package contains documentation in a devhelp HTML book.
  80. %package -n valadoc
  81. Summary: Vala documentation generator
  82. Summary(ja): Valaのドキュメントジェネレータ
  83. Group: Development/Tools
  84. License: LGPLv2+
  85. Requires: vala = %{version}-%{release}
  86. %description -n valadoc
  87. Valadoc is a documentation generator for generating API documentation from Vala
  88. source code.
  89. %package -n valadoc-devel
  90. Summary: Development files for valadoc
  91. Summary(ja): valadocを利用した開発のためのファイル群
  92. Group: Development/Libraries
  93. License: LGPLv2+
  94. Requires: valadoc = %{version}-%{release}
  95. %description -n valadoc-devel
  96. Valadoc is a documentation generator for generating API documentation from Vala
  97. source code.
  98. The valadoc-devel package contains libraries and header files for
  99. developing applications that use valadoc.
  100. %prep
  101. %setup -q
  102. %build
  103. %configure --enable-vapigen
  104. # Don't use rpath!
  105. sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
  106. make %{?_smp_mflags}
  107. %install
  108. rm -rf $RPM_BUILD_ROOT
  109. make install DESTDIR=$RPM_BUILD_ROOT
  110. find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
  111. %check
  112. make check
  113. %clean
  114. rm -rf $RPM_BUILD_ROOT
  115. %post -p /sbin/ldconfig
  116. %postun -p /sbin/ldconfig
  117. %files
  118. %defattr(-,root,root,-)
  119. %license COPYING
  120. %doc AUTHORS ChangeLog NEWS README THANKS
  121. %{_bindir}/vala
  122. %{_bindir}/valac
  123. %{_bindir}/vala-%{api_ver}
  124. %{_bindir}/valac-%{api_ver}
  125. %{_datadir}/vala-%{api_ver}
  126. %{_datadir}/vala
  127. %{_libdir}/libvala-%{api_ver}.so.*
  128. %{_mandir}/*/valac*
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_includedir}/vala-%{api_ver}
  132. %{_libdir}/libvala-%{api_ver}.so
  133. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  134. %{_datadir}/aclocal/vala.m4
  135. %{_datadir}/aclocal/vapigen.m4
  136. %{_libdir}/pkgconfig/vapigen.pc
  137. %{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
  138. %{_datadir}/vala/Makefile.vapigen
  139. %files tools
  140. %defattr(-,root,root,-)
  141. %{_bindir}/vala-gen-introspect
  142. %{_bindir}/vapigen
  143. %{_bindir}/vala-gen-introspect-%{api_ver}
  144. %{_bindir}/vapigen-%{api_ver}
  145. %{_libdir}/vala-%{api_ver}
  146. %{_mandir}/*/*gen*
  147. %files doc
  148. %defattr(-,root,root,-)
  149. %{_datadir}/devhelp/books/vala-%{api_ver}
  150. %files -n valadoc
  151. %defattr(-,root,root,-)
  152. %{_bindir}/valadoc*
  153. %{_libdir}/libvaladoc-%{api_ver}.so.*
  154. %{_libdir}/valadoc
  155. %{_datadir}/valadoc
  156. %{_mandir}/*/valadoc*
  157. %files -n valadoc-devel
  158. %{_libdir}/libvaladoc-%{api_ver}.so
  159. %{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
  160. %{_includedir}/valadoc-%{api_ver}
  161. %changelog
  162. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.44.7-1
  163. - new upstream release.
  164. * Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
  165. - new upstream release (LTS 0.40).
  166. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
  167. - new upstream release.
  168. - added subpackages "valadoc" and "valadoc-devel".
  169. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
  170. - new upstream release
  171. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
  172. - new upstream release
  173. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
  174. - new upstream release
  175. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
  176. - new upstream release
  177. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
  178. - new upstream release
  179. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
  180. - new upstream release
  181. - moved tools subpackage to Development/Tools Group
  182. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  183. - new upstream release
  184. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  185. - new upstream release
  186. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  187. - new upstream release
  188. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  189. - new upstream release
  190. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  191. - new upstream release
  192. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  193. - new upstream release
  194. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  195. - new upstream release
  196. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  197. - new upstream release
  198. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  199. - new upstream release
  200. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  201. - new upstream release
  202. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  203. - new upstream release
  204. - remove BuildRequires: gtk2-devel, xulrunner-devel
  205. - add BuildRequires: glib2-devel, libxslt
  206. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  207. - new upstream release
  208. - remove BuildRequires: devhelp
  209. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  210. - new upstream release
  211. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  212. - new upstream release
  213. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  214. - new upstream release
  215. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  216. - rebuilt with rpm-4.8.1 for pkg-config
  217. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  218. - new upstream release
  219. - made -doc subpackage noarch
  220. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  221. - new upstream release
  222. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  223. - new upstream release
  224. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  225. - new upstream release
  226. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  227. - new upstream release
  228. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  229. - new upstream release
  230. - change BuildRequires: gecko-libs -> xulrunner-devel
  231. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  232. - new upstream release
  233. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  234. - new upstream release
  235. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  236. - new upstream release
  237. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  238. - initial build for Vine Linux
  239. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  240. - Update to 0.7.5
  241. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  243. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  244. - Patch broken ModuleInit attribute (upstream bug 587444)
  245. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  246. - Update to 0.7.4
  247. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  248. - Update to 0.7.3
  249. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  250. - Update to 0.6.1
  251. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  252. - Update to 0.5.7
  253. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  254. - Update to 0.5.6
  255. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  256. - Update to 0.5.3
  257. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  258. - Fix bug in Emacs version detection
  259. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  260. - Use buildsystem variables to determine available Emacs version
  261. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  262. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  263. - Update to 0.5.2
  264. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  265. - Update to 0.5.1
  266. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  267. - Update to 0.3.5
  268. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  269. - Add vala-mode for editing Vala code in Emacs
  270. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  271. - Update to 0.3.4
  272. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  273. - Update to 0.3.3
  274. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  275. - Update to 0.3.2
  276. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  277. - Update to 0.2.0
  278. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  279. - Update to 0.1.7
  280. - -tool subpackage now requires gnome-common, intltool and libtoolize
  281. for out-of-the-box vala-gen-project support
  282. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  283. - Autorebuild for GCC 4.3
  284. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  285. - Update to 0.1.6
  286. - Revert vapi addition, needed declarations have been inlined (r846)
  287. - Rename -docs subpackage to -doc, to comply with guidelines
  288. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  289. - Manually add Gee vapi file to package (bz #428692)
  290. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  291. - Backport patch to autodetect location of automake shared files
  292. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  293. - Add build dependency on gtk2-devel
  294. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  295. - Enable project generator tool
  296. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  297. - Update to 0.1.5
  298. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  299. - Add build dependency on devhelp
  300. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  301. - Update to 0.1.4
  302. - Put newly-added documentation in its own subpackage (depends on devhelp)
  303. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  304. - vapigen subpackage: add missing Require: on perl-XML-Twig
  305. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  306. - Split -vapigen subpackage. It is functionally self-contained and the license
  307. is more restricted
  308. - Updated license declarations
  309. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  310. - Licensing and URL updates
  311. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  312. - Enable binding generation tools
  313. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  314. - Update to 0.1.3
  315. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  316. - Update to 0.0.8
  317. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  318. - Update to 0.0.7
  319. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  320. - Update to 0.0.6
  321. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  322. - Initial package