curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.65.3
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # improve handling of gss_init_sec_context() failures
  15. Patch1: 0001-curl-7.65.3-negotiate-fails.patch
  16. # avoid reporting spurious error in the HTTP2 framing layer (#1690971)
  17. Patch2: 0002-curl-7.65.3-h2-framing-layer-error.patch
  18. # patch making libcurl multilib ready
  19. Patch101: 0101-curl-7.32.0-multilib.patch
  20. # prevent configure script from discarding -g in CFLAGS (#496778)
  21. Patch102: 0102-curl-7.36.0-debug.patch
  22. # migrate tests/http_pipe.py to Python 3
  23. Patch103: 0103-curl-7.59.0-python3.patch
  24. # use localhost6 instead of ip6-localhost in the curl test-suite
  25. Patch104: 0104-curl-7.19.7-localhost6.patch
  26. # prevent valgrind from reporting false positives on x86_64
  27. Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: openssl-devel
  30. BuildRequires: gnutls-devel
  31. BuildRequires: libidn-devel zlib-devel
  32. BuildRequires: openldap-devel
  33. BuildRequires: openssh-server
  34. BuildRequires: openssh-clients
  35. BuildRequires: pkgconfig
  36. %if "%{?_dist_release}" != "vl6"
  37. BuildRequires: libssh2-devel
  38. %endif
  39. %if 0%{?with_http2}
  40. BuildRequires: libnghttp2-devel
  41. %endif
  42. Requires: ca-certificates
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. Packager: daisuke
  46. %description
  47. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  48. Dict servers, using any of the supported protocols. cURL is designed
  49. to work without user interaction or any kind of interactivity. cURL
  50. offers many useful capabilities, like proxy support, user
  51. authentication, FTP upload, HTTP post, and file transfer resume.
  52. %package devel
  53. Summary: Files needed for building applications with libcurl.
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: openssl-devel libidn-devel zlib-devel
  57. %description devel
  58. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  59. Dict servers, using any of the supported protocols. The curl-devel
  60. package includes files needed for developing applications which can
  61. use cURL's capabilities internally.
  62. #'
  63. ## to build compat32 for x86_64 architecture support
  64. %package -n compat32-%{name}
  65. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  66. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  67. Group: System Environment/Libraries
  68. %description -n compat32-%{name}
  69. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  70. Dict servers, using any of the supported protocols. cURL is designed
  71. to work without user interaction or any kind of interactivity. cURL
  72. offers many useful capabilities, like proxy support, user
  73. authentication, FTP upload, HTTP post, and file transfer resume.
  74. %package -n compat32-%{name}-devel
  75. Summary: Files needed for building applications with libcurl.
  76. Group: Development/Libraries
  77. %description -n compat32-%{name}-devel
  78. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  79. Dict servers, using any of the supported protocols. The curl-devel
  80. package includes files needed for developing applications which can
  81. use cURL's capabilities internally.
  82. #'
  83. %prep
  84. %setup -q
  85. # upstream patches
  86. %patch1 -p1
  87. %patch2 -p1
  88. # Fedora patches
  89. %patch101 -p1
  90. %patch102 -p1
  91. #patch103 -p1
  92. %patch104 -p1
  93. %patch105 -p1
  94. # make tests/*.py use Python 3
  95. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  96. # regenerate Makefile.in files
  97. aclocal -I m4
  98. automake
  99. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  100. # with errno 98: Address already in use' in Koji environment), and test 1801
  101. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  102. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  103. # <https://github.com/curl/curl/pull/2705>
  104. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  105. # disable test 1319 on ppc64 (server times out)
  106. %ifarch ppc64
  107. echo "1319" >> tests/data/DISABLED
  108. %endif
  109. # temporarily disable test 582 on s390x (client times out)
  110. %ifarch s390x
  111. echo "582" >> tests/data/DISABLED
  112. %endif
  113. # adapt test 323 for updated OpenSSL
  114. sed -e 's/^35$/35,52/' -i tests/data/test323
  115. %build
  116. %configure \
  117. --with-ssl=%{_prefix} \
  118. --with-libidn \
  119. --enable-ipv6 \
  120. --enable-threaded-resolver \
  121. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  122. %if "%{?_dist_release}" != "vl6"
  123. --with-libssh2 \
  124. %endif
  125. %if 0%{?with_http2}
  126. --with-nghttp2 \
  127. %endif
  128. --enable-ldaps \
  129. --disable-static \
  130. --enable-hidden-symbols
  131. make %{?_smp_mflags}
  132. %install
  133. rm -rf $RPM_BUILD_ROOT
  134. make DESTDIR=$RPM_BUILD_ROOT install
  135. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  136. %clean
  137. rm -rf $RPM_BUILD_ROOT
  138. %post -p /sbin/ldconfig
  139. %postun -p /sbin/ldconfig
  140. %files
  141. %defattr(-,root,root)
  142. %{!?_licensedir:%global license %%doc}
  143. %license COPYING
  144. %doc CHANGES README
  145. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  146. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  147. %doc docs/TheArtOfHttpScripting docs/TODO
  148. %{_bindir}/curl
  149. #{_datadir}/curl/*
  150. %{_libdir}/*.so.*
  151. %{_mandir}/man1/*.1*
  152. %files devel
  153. %defattr(-,root,root)
  154. %{_bindir}/curl-config
  155. %{_includedir}/curl
  156. %{_libdir}/*.so
  157. %{_libdir}/pkgconfig/*.pc
  158. %{_mandir}/man1/curl-config.1*
  159. %{_mandir}/man3/*
  160. %{_datadir}/aclocal/libcurl.m4
  161. ## to build compat32 for x86_64 architecture support
  162. %if %{build_compat32}
  163. %files -n compat32-%{name}
  164. %defattr(-,root,root)
  165. %{_libdir}/*.so.*
  166. %files -n compat32-%{name}-devel
  167. %defattr(-,root,root)
  168. %{_libdir}/*.so
  169. %{_libdir}/pkgconfig/*.pc
  170. %endif
  171. %changelog
  172. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  173. - new upstream release.
  174. - updated patches.
  175. - imported Patch1, 2 and 105 from rawhide.
  176. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  177. - new upstream release.
  178. - imported patches from rawhide.
  179. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  180. - new upstream release.
  181. - imported Patch1 and 103 from rawhide.
  182. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  183. - new upstream release with security fix
  184. - update patch101
  185. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  186. - new upstream release.
  187. - updated Patch101-104.
  188. - dropped Patch107.
  189. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  190. - new upstream release.
  191. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  192. - new upstream release.
  193. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  194. - new upstream release.
  195. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  196. - new upstream release.
  197. - disabled HTTP/2 on Vine6.
  198. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  199. - added HTTP/2 support.
  200. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  201. - new upstream release with security fix.
  202. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  203. - new upstream release.
  204. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  205. - new upstream release
  206. - built with openssl 1.0.2g
  207. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  208. - new upstream release with security fix .
  209. - removed Patch108 (fixed in upstream).
  210. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  211. - new upstream release with security fix
  212. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  213. - new upstream release
  214. - add libcurl.m4 to -devel package
  215. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  216. - new upstream release
  217. - import upstream/fedora patches
  218. - disable libssh2 on Vine Linux 6
  219. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  220. - new upstream reelase
  221. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  222. - update to 7.28.0
  223. - add configure options
  224. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  225. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  226. - use ca-certificates package
  227. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  228. - R: ca-certificates
  229. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  230. - new upstream release
  231. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  232. - add patch100 for fix CVE-2011-2192 (gssapi)
  233. - add Vendor/Distri tags
  234. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  235. - rebuild with openssl-1.0.0c
  236. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  237. - rebuilt with rpm-4.8.1 for pkg-config
  238. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  239. - new upstream release
  240. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  241. - new upstream release with security fix
  242. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  243. - added compat32 subpackages
  244. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  245. - new upstream release
  246. - use "_smp_mflags" flag
  247. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  248. - rebuild with openldap-2.4.11
  249. - add BR: openldap-devel
  250. - remove static library
  251. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  252. - new upstream release with security fix (CVE-2009-0037)
  253. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  254. - new upstream release
  255. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  256. - new upstream release
  257. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  258. - new upstream release
  259. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  260. - new upstream release
  261. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  262. - new upstream release
  263. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  264. - rebuilt with openssl-0.9.8e
  265. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  266. - new upstream release
  267. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  268. - new upstream release
  269. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  270. - new upstream release
  271. - add pkgconfig file to devel package
  272. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  273. - new upstream release
  274. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  275. - new upstream release
  276. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  277. - new upstream release
  278. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  279. - added libidn, zlib in Requires
  280. - added libidn-devel, zlib-devel in BuildPrereq
  281. - added zlib-devel in curl-devel's Requires
  282. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  283. - added openssl-devel, libidn-devel in curl-devel's Requires
  284. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  285. - new upstream release
  286. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  287. - new upstream release
  288. - rebuild with openssl-0.9.7d
  289. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  290. - upstream release
  291. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  292. - add %%{_datadir}/curl/* to %%files section
  293. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  294. - source upgrade
  295. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  296. - source upgrade
  297. - add PreReq: ldconfig
  298. - add %%{_libdir}/*.la to %%files devel section
  299. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  300. - build for VineSeed
  301. - add Requires: openssl
  302. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  303. - automated rebuild
  304. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  305. - 7.9.2
  306. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  307. - include curl-config in curl-devel
  308. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  309. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  310. - added openssl-devel build req
  311. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  312. - built for the distro
  313. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  314. - upgrade to curl-7.7.2.
  315. - enable IPv6.
  316. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  317. - rebuilt against openssl-0.9.6-1
  318. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  319. - fixed mising ldconfigs
  320. - updated to 7.5.2, bug fixes
  321. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  322. - updated to 7.5.1
  323. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  324. - update to 7.4.1 to fix bug #20337, problems with curl -c
  325. - not using patch anymore, it's included in the new source. Keeping
  326. for reference
  327. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  328. - fix bogus req in -devel package
  329. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  330. - devel package needed defattr so that root owns the files
  331. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  332. - update to 7.3
  333. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  334. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  335. - enable SSL support
  336. - fix packager tag
  337. - move buildroot to %%{_tmppath}
  338. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  339. - fixed vendor tag for bug #15028
  340. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  341. - rebuilt
  342. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  343. - workaround alpha build problems with optimizations
  344. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  345. - rebuilt
  346. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  347. - put man pages in correct place
  348. - use %%makeinstall
  349. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  350. - updated to 6.5.2
  351. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  352. - updated sources to 6.2
  353. - gzip man page
  354. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  355. - changed group
  356. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  357. - changelog started
  358. - general cleanups, changed prefix to /usr, added manpage to files section
  359. - including in Powertools