geany-plugins-vl.spec 31 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915
  1. %global geany_plug_docdir %{_defaultdocdir}/%{name}-%{version}
  2. %global req_geany_ver 0.21
  3. Name: geany-plugins
  4. Version: 1.22
  5. Release: 1%{?_dist_release}
  6. Summary: Plugins for Geany
  7. Summary(ja): Geany のプラグイン集
  8. Group: Development/Tools
  9. License: GPLv3
  10. URL: http://plugins.geany.org/
  11. Source0: http://plugins.geany.org/geany-plugins/geany-plugins-%{version}.tar.bz2
  12. Patch0: fix_installation_path_of_geanylatex_documents.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: ctpl-devel >= 0.2
  15. #BuildRequires: devhelp-devel
  16. BuildRequires: enchant-devel
  17. BuildRequires: geany-devel >= %{req_geany_ver}
  18. BuildRequires: gettext
  19. BuildRequires: gdk-pixbuf2-devel
  20. BuildRequires: glib2-devel
  21. BuildRequires: gpgme-devel
  22. BuildRequires: gtk2-devel
  23. BuildRequires: gtkspell-devel
  24. BuildRequires: intltool
  25. BuildRequires: libtool
  26. BuildRequires: libsoup-devel >= 2.4
  27. BuildRequires: lua-devel
  28. BuildRequires: libxml2-devel >= 2.6.27
  29. BuildRequires: pango-devel
  30. BuildRequires: pkgconfig
  31. BuildRequires: python-docutils
  32. BuildRequires: vala-devel
  33. BuildRequires: vte-devel
  34. BuildRequires: WebKit-gtk-devel
  35. Requires: %{name}-addons %{name}-geanydoc %{name}-geanylatex
  36. Requires: %{name}-geanylipsum %{name}-geanylua %{name}-geanyprj %{name}-geanysendmail
  37. Requires: %{name}-geanyvc %{name}-shiftcolumn %{name}-spellcheck
  38. Requires: %{name}-codenav %{name}-treebrowser %{name}-geanyextrasel
  39. Requires: %{name}-geanyinsertnum %{name}-pretty-printer %{name}-geanygendoc
  40. Requires: %{name}-updatechecker %{name}-webhelper
  41. Requires: %{name}-debugger %{name}-xmlsnippets %{name}-geanymacro %{name}-geanynumberedbookmarks
  42. Requires: %{name}-geanypg %{name}-gproject %{name}-tableconvert
  43. Requires: %{name}-geanyminiscript %{name}-geniuspaste %{name}-multiterm
  44. %description
  45. Plugins for Geany. Plugins included are:
  46. * Addons (Various small Addons)
  47. * Code navigation (Navigate through your source code easily)
  48. * Debugger (Enables debugging in Geany)
  49. * Geanydoc (Call specific documentation from within Geany)
  50. * Geanyextrasel (Additional features for selecting code)
  51. * GeanyGenDoc (Automatically generate documentation source code)
  52. #* GeanyGDB (Integration with GDB)
  53. * Geanyinsertnum (Insert huge number ranges with small efforts)
  54. * GeanyLaTeX (Improved Support for LaTeX documents)
  55. * GeanyLipsum (Inserting blocks of Lorem Ipsum text)
  56. * Geanylua (Support for Scripting with Lua)
  57. * GeanyMacro (User defined Macros for Geany)
  58. * GeanyNumberedBookmarks (Provide users with 10 numbered Bookmarks)
  59. * GeanyPG (Encrypt, decrypt and verify signatures with GnuPG)
  60. * Geanyprj (Alternate project management for Geany)
  61. * GeanySendMail (Sending of documents from within Geany)
  62. * GeanyVC (Support for various Version Control Systems)
  63. * GProject (Extension of Geany's Project Management)
  64. * Pretty-Print (XML Pretty Printer)
  65. * Shiftcolumn (Moving blocks of text horizontally)
  66. * Spellcheck (Spell checking of documents or marked text)
  67. * Tableconvert (Helps on converting a tabulator separated selection into a table)
  68. * Treebrowser (Alternate file browser with tree view of folders)
  69. * Updatechecker (Automatically check for Geany updates)
  70. * Webhelper (Preview and Debug Web documents from within Geany using WebKit)
  71. * XMLSnippets (Extends XML/HTML tag autocompletion provided by Geany)
  72. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  73. * GeniusPaste (Paste your code on your favorite pastebin)
  74. * MultiTerm (Multi-tabbed virtual terminal emulator)
  75. This package is meta package to install all geany-plugins.
  76. %description -l ja
  77. Geany のプラグインです。プラグインには以下のものが含まれています。
  78. * Addons (色々と小さなアドオン)
  79. * Code navigation (ソースコード間を簡単に移動)
  80. * Debugger (Geany でデバッグを有効化)
  81. * Geanydoc (geany から固有のドキュメントを呼び出す)
  82. * Geanyextrasel (コード選択のための追加機能)
  83. * GeanyGenDoc (ソースコードから自動的にドキュメントの元を生成)
  84. #* GeanyGDB (GDB 統合環境を提供)
  85. * GeanyLaTex (LaTeX ドキュメントのサポートを改善)
  86. * GeanyLipsum (Lorem Ipsum テキストのブロックを挿入)
  87. * GeanySendMail (Geany からドキュメントの送信を許可)
  88. * GeanyVC (色々なバージョン管理システムのサポート)
  89. * GProject (Geany のプロジェクト管理拡張)
  90. * Geanyinsertnum (僅かな労力で膨大な範囲の番号を挿入)
  91. * Geanylua (lua スクリプトのサポートを提供)
  92. * GeanyMacro (Geany のユーザー定義マクロ)
  93. * GeanyNumberedBookmarks (ユーザーに 10 個の番号付ブックマークを提供)
  94. * GeanyPG (GnuPG で暗号化・復号化及び署名を検証する)
  95. * Geanyprj (geany の代替プロジェクト管理)
  96. * Shiftcolumn (テキストブロックを水平方向に移動)
  97. * Spellcheck (ドキュメントのスペルチェック)
  98. * Tableconvert (テーブルにタブで区切られた選択項目を変換する際役立つ)
  99. * Treebrowser (フォルダの内容をツリービューする代替ファイルブラウザ)
  100. * Pretty-Print (XML Pretty Printer)
  101. * Updatechecker (Geany の更新を自動的にチェック)
  102. * Webhelper (WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行)
  103. * XMLSnippets (Geany により提供される拡張 XML/HTML タグの自動補完)
  104. * GeanyMiniScript (A tool to apply a script on a text selection or current document(s))
  105. * GeniusPaste (お気に入りの pastebin からコードを貼り付け)
  106. * MultiTerm (マルチタブの仮想端末エミュレーター)
  107. このパッケージは、geany-plugins をすべてインストールするための
  108. メタパッケージです。
  109. %package common
  110. Summary: Common files used by all geany plugins
  111. Summary(ja): すべての Geany プラグインに用いられる共通ファイル
  112. Group: Development/Tools
  113. Requires: geany >= %{req_geany_ver}
  114. %description common
  115. This package contains some common files which are used by every Geany plugin,
  116. e.g. language translations.
  117. %description common -l ja
  118. このパッケージには、例えば翻訳ファイルなどの
  119. すべての Geany プラグイン で用いられる共通ファイルが含まれています。
  120. %package addons
  121. Summary: Miscellaneous Addons for Geany
  122. Summary(ja): Geany のその他のアドオン
  123. Group: Development/Tools
  124. Requires: geany >= %{req_geany_ver}
  125. Requires: geany-plugins-common = %{version}-%{release}
  126. Obsoletes: geany-plugin-addons
  127. %description addons
  128. This plugins consists of various small addons too small to justify their own
  129. plugin, but are useful to have. The following functionality is implemented:
  130. * Doclist: This addon places a new item in the toolbar and when clicked offers
  131. a menu listing all open files plus the 'Close All' and 'Close Other
  132. Documents' menu items. This can be useful to quickly access open files and
  133. switch to them.
  134. * OpenURI: Adds 'Open URI' and 'Copy URI' menu items to the editor menu when
  135. the word under the cursor looks like a URI. 'Open URI' uses the browser
  136. command configured in Geany to open it.
  137. * Tasks:The tasks plugin goes through a file being edited and picks out lines
  138. with "TODO" or "FIXME" in them. It collects the text after those words and
  139. puts them in a new "Tasks" tab in the message window. Clicking on a task in
  140. that tab takes you to the line in the file where the task was defined.
  141. * Systray: Adds a status icon to the notification area (systray) and provides
  142. a simple popup menu with some basic actions. It can also be used to quickly
  143. show and hide the Geany main window.
  144. %package codenav
  145. Summary: Navigate through your source code easily
  146. Summary(ja): ソースコード間を簡単に移動
  147. Group: Development/Tools
  148. Requires: geany >= %{req_geany_ver}
  149. Requires: geany-plugins-common = %{version}-%{release}
  150. %description codenav
  151. This plugin adds some facilities for navigating in the code.
  152. Actually, it will make it possible to:
  153. - switch between header and implementation
  154. - go to a file by typing its name
  155. %package debugger
  156. Summary: enables debugging in Geany
  157. Group: Development/Tools
  158. Requires: geany-plugins-common = %{version}-%{release}
  159. Requires: vte >= 0.24
  160. Obsoletes: geany-plugin-gdb
  161. Obsoletes: geany-plugins-geanygdb < %{version}-%{release}
  162. %description debugger
  163. Plugin enables debugging in Geany. Currently supports GDB only, but was
  164. developed with multiple debuggers support in mind, so the other backends
  165. support is planned as well.
  166. %package geanydoc
  167. Summary: Call documentation from within Geany
  168. Summary(ja): Geany 内からドキュメントを呼び出す
  169. Group: Development/Tools
  170. Requires: geany >= %{req_geany_ver}
  171. Requires: geany-plugins-common = %{version}-%{release}
  172. %description geanydoc
  173. Geanydoc allows you to execute specific commands on the word under the cursor.
  174. This word is passed as an argument to the command. The output of the command
  175. can either be placed into a special buffer called "DOC" or can be used to
  176. execute an external program. Geanydoc is intended to be used for searching
  177. through API documentation.
  178. %package geanyextrasel
  179. Summary: Additional features for selecting code
  180. Summary(ja): コード選択のための追加機能
  181. Group: Development/Tools
  182. Requires: geany >= %{req_geany_ver}
  183. Requires: geany-plugins-common = %{version}-%{release}
  184. %description geanyextrasel
  185. Geanyextrasel provides some special features for selecting code, e.g. from
  186. opening brace to closed brace and so on. This plugin will be very useful for
  187. you if you're a programmer and working with much sourcecodes.
  188. #%package geanygdb
  189. #Summary: Debugger Plugin for Geany using GDB
  190. #Summary(ja): GDB を使った Geany のデバッガプラグイン
  191. #Group: Development/Tools
  192. #Requires: geany >= %{req_geany_ver}
  193. #Requires: geany-plugins-common = %{version}-%{release}
  194. #Requires: gdb
  195. #Obsoletes: geany-plugin-gdb
  196. #%description geanygdb
  197. #GeanyGDB plugin provides an integrated debugging environment for the
  198. #GNU debugger (gdb).
  199. #%description geanygdb -l ja
  200. #GeanyGDB プラグインは GNU debugger (gdb) のための
  201. #統合的デバッグ環境を提供します。
  202. %package geanygendoc
  203. Summary: Automatically generate documentation source code
  204. Group: Development/Tools
  205. Requires: geany >= %{req_geany_ver}
  206. Requires: geany-plugins-common = %{version}-%{release}
  207. %description geanygendoc
  208. GeanyGenDoc is a plugin for Geany that aims to automatically generate
  209. documentation comment basis from the source code.
  210. You may also want to install the following packages which enable
  211. some extra features:
  212. - Docutils (http://docutils.sourceforge.net/) -- or another implementation of
  213. rst2html -- is needed to (re)generate the HTML manual.
  214. %package geanyinsertnum
  215. Summary: Insert huge number ranges with small efforts
  216. Summary(ja): 僅かな労力で膨大な範囲の番号を挿入
  217. Group: Development/Tools
  218. Requires: geany >= %{req_geany_ver}
  219. Requires: geany-plugins-common = %{version}-%{release}
  220. %description geanyinsertnum
  221. Geanyinsertnum replaces a (possibly zero-width) rectangular selection with
  222. integer numbers, using start/step/base etc. specified by the user. For
  223. practical reasons, the number of lines is limited to 500000.
  224. %package geanylatex
  225. Summary: to improve LaTeX support plugin for Geany
  226. Summary(ja): Geany のための LaTeX サポート改善プラグイン
  227. Group: Development/Tools
  228. Requires: geany >= %{req_geany_ver}
  229. Requires: geany-plugins-common = %{version}-%{release}
  230. Requires: texlive
  231. Obsoletes: geany-plugin-latex
  232. %description geanylatex
  233. This plugin improves LaTeX support in Geany. It provides several templates for
  234. new documents, help with adding labels and inserting special characters,
  235. and much more.
  236. %description geanylatex -l ja
  237. このプラグインは Geany で LaTeX のサポートを改善するプラグインです。
  238. 新しい文書のためのいくつかのテンプレート、
  239. ラベルの追加や特殊文字の挿入機能などを提供します。
  240. %package geanylipsum
  241. Summary: Lorem Ipsum generator for Inserting Placeholder Text
  242. Group: Development/Tools
  243. Requires: geany >= %{req_geany_ver}
  244. Requires: geany-plugins-common = %{version}-%{release}
  245. %description geanylipsum
  246. GeanyLipsum is a Lorem Ipsum generator for inserting placeholder text into a
  247. document.
  248. %package geanylua
  249. Summary: Support developing Lua Scripting for Geany
  250. Summary(ja): Geany で Lua スクリプト開発をサポート
  251. Group: Development/Tools
  252. Requires: geany >= %{req_geany_ver}
  253. Requires: geany-plugins-common = %{version}-%{release}
  254. Requires: lua
  255. %description geanylua
  256. This plugin provides extensive support for developing in the lua programming
  257. language.
  258. %description geanylua -l ja
  259. このプラグインは、lua プログラミング言語で開発するための
  260. 広範なサポートを提供します。
  261. %package geanymacro
  262. Summary: User defined Macros for Geany
  263. Group: Development/Tools
  264. Requires: geany-plugins-common = %{version}-%{release}
  265. %description geanymacro
  266. GeanyMacro is a plugin to provide user defined macros for Geany. It started
  267. out as part of the ConText feature parity plugin, which was split into
  268. individual plugins to better suit Geany's ethos of being as light as
  269. possible while allowing users to select which features they want to add to
  270. the core editor. The idea was taken from a Text Editor for Windows called
  271. ConText.
  272. This plugin alows you to record and use your own macros. Macros are
  273. sequences of actions that can then be repeated with a single key
  274. combination. So if you had dozens of lines where you wanted to delete the
  275. last 2 characters, you could simple start recording, press End, Backspace,
  276. Backspace, down line and then stop recording. Then simply trigger the macro
  277. and it would automaticaly edit the line and move to the next. You could then
  278. just repeatedly trigger the macro to do as many lines as you want.
  279. %package geanyminiscript
  280. Summary: Geany Mini-Script filter plugin
  281. Group: Development/Tools
  282. Requires: geany-plugins-common = %{version}-%{release}
  283. %description geanyminiscript
  284. gms is a Geany Mini-Script filter plugin.
  285. %package geanynumberedbookmarks
  286. Summary: Provide users 10 numbered Bookmarks
  287. Group: Development/Tools
  288. Requires: geany-plugins-common = %{version}-%{release}
  289. %description geanynumberedbookmarks
  290. GeanyNumberedBookmarks is a plugin to provide users with 10 numbered
  291. bookmarks (in addition to the usual bookmarks). It started out as part of
  292. the ConText feature parity plugin, which was split into individual plugins
  293. to better suit Geany's ethos of being as light as possible while allowing
  294. users to select which features they want to add to the core editor. The idea
  295. was taken from a Text Editor for Windows called ConText.
  296. Normally if you had more than one bookmark, you would have to cycle through
  297. them until you reached the one you wanted. With this plugin you can go
  298. straight to the bookmark that you want with a single key combination.
  299. %package geanypg
  300. Summary: encrypt, decrypt and verify signatures with GnuPG
  301. Group: Development/Tools
  302. Requires: geany-plugins-common = %{version}-%{release}
  303. Requires: gpgme
  304. %description geanypg
  305. GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt and
  306. verify signatures with GnuPG.
  307. %package geanyprj
  308. Summary: Provides an alternate project management tool for Geany
  309. Summary(ja): Geany で代替プロジェクト管理ツールを提供
  310. Group: Development/Tools
  311. Requires: geany >= %{req_geany_ver}
  312. Requires: geany-plugins-common = %{version}-%{release}
  313. %description geanyprj
  314. Geanyprj provides an alternate project management approach to Geany's built-in
  315. project facility. The idea is to be less a "session manager" as the built-in
  316. project management does: It allows/requires you to manually open and close
  317. project and allows you to store project files in different locations from
  318. project sources.
  319. Geanyprj takes a different approach:
  320. It never saves session information, so that project files can be stored in
  321. version control without constant noise from changes of opened files or cursor
  322. position. You also will never have to open/close projects manually. If a
  323. *.geanyprj file is found somewhere up in path it will be opened automatically.
  324. %package geanysendmail
  325. Summary: Send E-Mails from within Geany
  326. Summary(ja): Geany 内から E-Mail を送信するプラグイン
  327. Group: Development/Tools
  328. Requires: geany >= %{req_geany_ver}
  329. Requires: geany-plugins-common = %{version}-%{release}
  330. %description geanysendmail
  331. GeanySendMail is a little plugin to send a document as attachment using the
  332. preferred mail client from inside Geany. It is similar to the envelope symbol
  333. of most office tools and requires a mail client that supports remote calls.
  334. %package geanyvc
  335. Summary: Version Control plugin for Geany
  336. Summary(ja): Geany のバージョン管理プラグイン
  337. Group: Development/Tools
  338. Requires: geany >= %{req_geany_ver}
  339. Requires: geany-plugins-common = %{version}-%{release}
  340. Obsoletes: geany-plugin-vc
  341. Provides: geanyvc = %{version}-%{release}
  342. %description geanyvc
  343. Geanyvc is a plugin that provides a uniform way of accessing different version
  344. control systems from within the Geany IDE. Currently, support for the following
  345. version control systems is provided:
  346. * Bazaar
  347. * Git
  348. * Mercurial
  349. * Subversion
  350. * SVK
  351. * CVS
  352. %description geanyvc -l ja
  353. Geanyvc は Geany IDE から異なるバージョン管理システムにアクセスする
  354. 均一的方法を提供するプラグインです。
  355. 現在、サポートするバージョン管理システムは以下の通りです。
  356. * Bazaar
  357. * Git
  358. * Mercurial
  359. * Subversion
  360. * SVK
  361. * CVS
  362. %package geniuspaste
  363. Summary: allows the user to paste the code from Geany into five different pastebins
  364. Group: Development/Tools
  365. Requires: geany-plugins-common = %{version}-%{release}
  366. %description geniuspaste
  367. This plugin allows the user to paste the code from Geany into five different
  368. pastebins. At the moment it supports this services:
  369. * codepad.org
  370. * tinypaste.com
  371. * pastebin.geany.org
  372. * dpaste.de
  373. * sprunge.us
  374. %package gproject
  375. Summary: Extension of Geany's project management
  376. Group: Development/Tools
  377. Requires: geany-plugins-common = %{version}-%{release}
  378. %description gproject
  379. GProject is an extension of Geany's project management displaying a tree of
  380. files belonging to the project in the sidebar. In addition, it enables quick
  381. swapping between header and source files, searching project files by name
  382. and more. The plugin was created with big projects in mind so everything
  383. works fast enough even with projects consisting of hundreds of thousands of
  384. files.
  385. %package multiterm
  386. Summary: supports multiple terminals
  387. Group: Development/Tools
  388. Requires: geany-plugins-common = %{version}-%{release}
  389. %description multiterm
  390. MultiTerm is similar to Geany's built-in VTE terminal except that it
  391. supports multiple terminals in tabs and supports different shells in
  392. each of the terminal tabs.
  393. %package pretty-printer
  394. Summary: XML pretty printing plugin for Geany
  395. Group: Development/Tools
  396. Requires: geany >= %{req_geany_ver}
  397. Requires: geany-plugins-common = %{version}-%{release}
  398. Requires: libxml2 >= 2.6.27
  399. Obsoletes: %{name}-pretty-print
  400. %description pretty-printer
  401. Plugin for Geany to easily beautify XML code.
  402. %package shiftcolumn
  403. Summary: Move Blocks of Text horizontally
  404. Summary(ja): テキストブロックを水平方向に移動
  405. Group: Development/Tools
  406. Requires: geany >= %{req_geany_ver}
  407. Requires: geany-plugins-common = %{version}-%{release}
  408. %description shiftcolumn
  409. Shiftcolumn allows you to move blocks of text horizontally in Geany.
  410. %description shiftcolumn -l ja
  411. Shiftcolumn は Geany 内でテキストブロックを水平方向に移動させることが
  412. できます。
  413. %package spellcheck
  414. Summary: Spellcheck Text in Geany using the Enchant Library
  415. Summary(ja): Enchant ライブラリを使い Geany でスペルチェック
  416. Group: Development/Tools
  417. Requires: geany >= %{req_geany_ver}
  418. Requires: geany-plugins-common = %{version}-%{release}
  419. Requires: enchant
  420. %description spellcheck
  421. Spellcheck checks the selected text (or the whole document) with the spellcheck
  422. library Enchant.
  423. %description spellcheck -l ja
  424. Spellcheck は、選択したテキスト(または文書全体)のスペルチェックを
  425. スペルチェックライブラリの Enchant で行います。
  426. %package treebrowser
  427. Summary: Alternate file browser plugin providing a tree view of directories.
  428. Summary(ja): ディレクトリのツリービューを提供する代替ファイルブラウザプラグイン
  429. Group: Development/Tools
  430. Requires: geany >= %{req_geany_ver}
  431. Requires: geany-plugins-common = %{version}-%{release}
  432. %description treebrowser
  433. The tree browser plugin for Geany provides an alternate way to browse through
  434. your files. It displays files and directories in a tree view and has more
  435. features than the file browser plugin delivered with Geany itself.
  436. %package tableconvert
  437. Summary: Helps on converting a tabulator separated selection into a table
  438. Group: Development/Tools
  439. Requires: geany-plugins-common = %{version}-%{release}
  440. %description tableconvert
  441. Tableconvert is a plugin which helps on converting a tabulator separated
  442. selection into a table.
  443. %package updatechecker
  444. Summary: Automatically check for Geany updates
  445. Summary(ja): Geany の更新を自動的にチェック
  446. Group: Development/Tools
  447. Requires: geany-plugins-common = %{version}-%{release}
  448. %description updatechecker
  449. UpdateChecker is a plugin for Geany, which is able to check whether there is
  450. a more recent version of Geany available.
  451. %package webhelper
  452. Summary: Preview and Debug Web documents from within Geany using WebKit
  453. Summary(ja): WebKit を使い Geany から Web ドキュメントのプレビューとデバッグを実行
  454. Group: Development/Tools
  455. Requires: geany-plugins-common = %{version}-%{release}
  456. %description webhelper
  457. WebHelper is a plugin for Geany that provides some web development
  458. facilities, such as a web page preview and some debugging tools (web
  459. inspector).
  460. Prominent features:
  461. * A basic web view, allowing to display any web page (using WebKit)
  462. * Possible automatic reloading of the web view upon document saving
  463. * A web inspector/debugging tool for the web view's content (including a
  464. JavaScript console, a viewer and editor of processed HTML and CSS, a network
  465. usage analysis tool and many more, thanks to WebKit).
  466. %package xmlsnippets
  467. Summary: Extends XML/HTML tag autocompletion provided by Geany
  468. Group: Development/Tools
  469. Requires: geany-plugins-common = %{version}-%{release}
  470. %description xmlsnippets
  471. This plugin extends XML/HTML tag autocompletion provided by Geany. It
  472. automatically inserts a matching snippet after you type an opening tag.
  473. %prep
  474. %setup -q
  475. %patch0 -p1
  476. %build
  477. %configure --docdir=%{geany_plug_docdir}
  478. make %{?_smp_mflags}
  479. %install
  480. rm -rf $RPM_BUILD_ROOT
  481. make install -p DESTDIR=$RPM_BUILD_ROOT
  482. # Remove static library *.la files
  483. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' \;
  484. # Remove zero-length files
  485. find $RPM_BUILD_ROOT -type f -empty -delete
  486. # copy geanylatex document images
  487. cp -pr geanylatex/doc/img/ $RPM_BUILD_ROOT%{geany_plug_docdir}/geanylatex/
  488. %find_lang %{name}
  489. %clean
  490. rm -rf $RPM_BUILD_ROOT
  491. %files
  492. %files common -f %{name}.lang
  493. %defattr(-,root,root,-)
  494. %dir %{_libdir}/%{name}/
  495. %dir %{_datadir}/%{name}/
  496. %files addons
  497. %defattr(-,root,root,-)
  498. %doc %{geany_plug_docdir}/addons
  499. %{_libdir}/geany/addons.so
  500. %files codenav
  501. %defattr(-,root,root,-)
  502. %doc %{geany_plug_docdir}/codenav
  503. %{_libdir}/geany/codenav.so
  504. %files debugger
  505. %defattr(-,root,root,-)
  506. %doc %{geany_plug_docdir}/debugger
  507. %{_datadir}/%{name}/debugger/
  508. %{_libdir}/geany/debugger.so
  509. %files geanydoc
  510. %defattr(-,root,root,-)
  511. %doc %{geany_plug_docdir}/geanydoc/
  512. %{_libdir}/geany/geanydoc.so
  513. %files geanyextrasel
  514. %defattr(-,root,root,-)
  515. %doc %{geany_plug_docdir}/geanyextrasel/
  516. %{_libdir}/geany/geanyextrasel.so
  517. #%files geanygdb
  518. #%defattr(-,root,root,-)
  519. #%doc %{geany_plug_docdir}/geanygdb/
  520. #%{_libdir}/geany/geanygdb.so
  521. #%{_libexecdir}/geany-plugins/geanygdb/ttyhelper
  522. %files geanygendoc
  523. %defattr(-,root,root,-)
  524. %doc %{geany_plug_docdir}/geanygendoc/
  525. %{_libdir}/geany/geanygendoc.so
  526. %{_datadir}/%{name}/geanygendoc/
  527. %files geanyinsertnum
  528. %defattr(-,root,root,-)
  529. %doc %{geany_plug_docdir}/geanyinsertnum/
  530. %{_libdir}/geany/geanyinsertnum.so
  531. %files geanylatex
  532. %defattr(-,root,root,-)
  533. %doc %{geany_plug_docdir}/geanylatex/
  534. %{_libdir}/geany/geanylatex.so
  535. %files geanylipsum
  536. %defattr(-,root,root,-)
  537. %doc %{geany_plug_docdir}/geanylipsum/
  538. %{_libdir}/geany/geanylipsum.so
  539. %files geanylua
  540. %defattr(-,root,root,-)
  541. %doc %{geany_plug_docdir}/geanylua/
  542. %{_libdir}/geany/geanylua.so
  543. %{_datadir}/%{name}/geanylua/
  544. %{_libdir}/%{name}/geanylua/
  545. %files geanymacro
  546. %defattr(-,root,root,-)
  547. %doc %{geany_plug_docdir}/geanymacro/
  548. %{_libdir}/geany/geanymacro.so
  549. %files geanyminiscript
  550. %defattr(-,root,root,-)
  551. %doc %{geany_plug_docdir}/geanyminiscript/
  552. %{_libdir}/geany/geanyminiscript.so
  553. %files geanynumberedbookmarks
  554. %defattr(-,root,root,-)
  555. %doc %{geany_plug_docdir}/geanynumberedbookmarks/
  556. %{_libdir}/geany/geanynumberedbookmarks.so
  557. %files geanypg
  558. %defattr(-,root,root,-)
  559. %doc %{geany_plug_docdir}/geanypg/
  560. %{_libdir}/geany/geanypg.so
  561. %files geanyprj
  562. %defattr(-,root,root,-)
  563. %doc %{geany_plug_docdir}/geanyprj/
  564. %{_libdir}/geany/geanyprj.so
  565. %files geanysendmail
  566. %defattr(-,root,root,-)
  567. %doc %{geany_plug_docdir}/geanysendmail/
  568. %{_libdir}/geany/geanysendmail.so
  569. %files gproject
  570. %defattr(-,root,root,-)
  571. %doc %{geany_plug_docdir}/gproject/
  572. %{_datadir}/icons/hicolor/16x16/apps/gproject-*.png
  573. %{_libdir}/geany/gproject.so
  574. %files geanyvc
  575. %defattr(-,root,root,-)
  576. %doc %{geany_plug_docdir}/geanyvc/
  577. %{_libdir}/geany/geanyvc.so
  578. %files geniuspaste
  579. %defattr(-,root,root,-)
  580. %doc %{geany_plug_docdir}/geniuspaste/
  581. %{_libdir}/geany/geniuspaste.so
  582. %files multiterm
  583. %defattr(-,root,root,-)
  584. %doc %{geany_plug_docdir}/multiterm/
  585. %{_libdir}/geany/multiterm.so
  586. %files pretty-printer
  587. %defattr(-,root,root,-)
  588. %{_libdir}/geany/pretty-printer.so
  589. %files shiftcolumn
  590. %defattr(-,root,root,-)
  591. %doc %{geany_plug_docdir}/shiftcolumn/
  592. %{_libdir}/geany/shiftcolumn.so
  593. %files spellcheck
  594. %defattr(-,root,root,-)
  595. %doc %{geany_plug_docdir}/spellcheck/
  596. %{_libdir}/geany/spellcheck.so
  597. %files tableconvert
  598. %defattr(-,root,root,-)
  599. %doc %{geany_plug_docdir}/tableconvert/
  600. %{_libdir}/geany/tableconvert.so
  601. %files treebrowser
  602. %defattr(-,root,root,-)
  603. %doc %{geany_plug_docdir}/treebrowser/
  604. %{_libdir}/geany/treebrowser.so
  605. %files updatechecker
  606. %defattr(-,root,root,-)
  607. %doc %{geany_plug_docdir}/updatechecker/
  608. %{_libdir}/geany/updatechecker.so
  609. %files webhelper
  610. %defattr(-,root,root,-)
  611. %doc %{geany_plug_docdir}/webhelper/
  612. %{_libdir}/geany/webhelper.so
  613. %files xmlsnippets
  614. %defattr(-,root,root,-)
  615. %doc %{geany_plug_docdir}/xmlsnippets/
  616. %{_libdir}/geany/xmlsnippets.so
  617. %changelog
  618. * Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  619. - new upstream release
  620. - added BuildRequires: vala-devel
  621. - added new plugins
  622. - GeanyMiniScript, GeniusPaste, MultiTerm
  623. - added Patch0 to fix installation path of geanylatex documents
  624. - renamed pretty-print to pretty-printer
  625. - obsoleted geany-plugins-geanygdb to provide same function as geany-plugins-debugger
  626. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-2
  627. - added BuildRequires: vte-devel, WebKit-gtk-devel, gtk2-devel, glib2-devel,
  628. gdk-pixbuf2-devel, pango-devel, python-docutils
  629. - fixed %%changelog in Sat Oct 29 2011
  630. * Sat Oct 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.21-1
  631. - new upstream release
  632. - added new plugins
  633. - Debugger, GeanyPG, GeanyMacro, GeanyNumberedBookmarks, GProject, Tableconvert, XMLSnippets
  634. - added BuildRequires: gpgme-devel
  635. * Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.20-1
  636. - new upstream release
  637. - added geany-plugins-updatechecker and geany-plugins-webhelper
  638. * Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-3
  639. - added geany-plugins-geanygendoc
  640. - added BuildRequires: ctpl-devel >= 0.2
  641. - changed geany-plugins-latex Requires: tetex to Requires: texlive
  642. - removed zero-length documentation files
  643. * Sun Jul 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-2
  644. - correct license to GPLv3+
  645. - added BuildRequires: libxml2-devel >= 2.6.27
  646. - added Requires: geany-plugins-codenav, geany-plugins-treebrowser,
  647. geany-plugins-geanyextrasel, geany-plugins-geanyinsertnum, geany-plugins-pretty-print
  648. * Mon Jun 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.19-1
  649. - new upstream release
  650. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-3
  651. - fixed Requires geany-plugins
  652. - applied new naming policy to spec
  653. * Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-2
  654. - fixed Obsoletes geany-plugin-addons, geany-plugin-gdb, geany-plugin-latex, geany-plugin-vc
  655. (see [BTS:VineLinux:0894])
  656. - proved Summary(ja)
  657. * Wed Nov 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.18-1
  658. - initial build for Vine Linux (instead of now provided some geany-plugins)
  659. * Sat Oct 31 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.18-1
  660. - update to new upstream release
  661. * Sat Aug 16 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-6
  662. - build against and require geany 0.18
  663. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.17.1-5
  664. - Use bzipped upstream tarball.
  665. * Sat Jul 25 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-4
  666. - write BuildRequires at the beginning of this file
  667. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-3
  668. - remove Requires: geany from the main package
  669. - change Group to Development/Tools
  670. - add release to the geanyvc Provides
  671. - entirely remove %%files stanza for the main package
  672. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-2
  673. - fix the required geany version also in the subpackages
  674. - remove the requires to sub-packages to avoid building the metapackage since
  675. all geany plugins also can be installed by something like
  676. 'yum install geany-plugins-*'
  677. - fix the requires of geany-plugins-common to include the release
  678. * Wed Jul 22 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17.1-1
  679. - bump upstream version to 0.17.1
  680. - fix required geany version to be 0.16 at the present
  681. * Sat Jul 18 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-5
  682. - add Requires for metapackage
  683. - rename subpackages back to geany-plugins-* instead of geany-plugin-*
  684. * Fri Jul 17 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-4
  685. - readd the geany_plug_docdir global to fix the versioned directory issue for
  686. documentation files
  687. - replace geany-plugins with %%{name} to be more consistent with macro usage
  688. - remove zero-length documentation files
  689. - fix the changelog
  690. - remove static *.la-files
  691. - split up packages
  692. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-3
  693. - add %%{_datadir}/geany-plugins/geanylua/ to %%files-section
  694. * Wed Jul 15 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-2
  695. - fix %%files-section again, thanks to Jonathan for the hint.
  696. * Tue Jul 14 2009 Dominic Hopf <dmaphy@fedoraproject.org> 0.17-1
  697. - update URL to plugins.geany.org
  698. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.2
  699. - Add Obsoletes for geanyvc
  700. - Add more BuildRequires and Requires
  701. * Tue Jul 14 2009 Jonathan G. Underwood <jonathan.underwood@gmail.com> - 0.17-0.1
  702. - Update to 0.17 (first upstream release of tarball)
  703. - Fix handling of docs
  704. - Spec file cleanups
  705. * Mon Jun 22 2009 Pingou <pingou@pingoured.fr> 0.1-1
  706. - First RPM for Fedora