texlive-collection-genericrecommended-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
  3. ## tlpdb2rpmspec collection-genericrecommended
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %define aliasttfdir %{texmfsysvar}/fonts/truetype/vine
  8. %define texmfsysconfig %{_sysconfdir}/texmf
  9. %define texmfsysvar %{_var}/lib/texmf
  10. %define vartexfonts %{texmfsysvar}/fonts
  11. %define tex_destdir %{_datadir}
  12. %define texmf %{tex_destdir}/texmf
  13. %define texlive_src %{tex_destdir}/texlive-sources
  14. %define build_tex_destdir %{buildroot}%{tex_destdir}
  15. %define build_texmf %{buildroot}%{texmf}
  16. ## use some macros for %post, %posttrans
  17. %define touch_run(%1) %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
  18. }
  19. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
  20. %{_sbindir}/update-defaultfont 2> /dev/null
  21. %define exec_texhash [ -e /var/run/texlive/run-texhash ] && ( \\\
  22. [ -x %{_bindir}/texhash ] && \\\
  23. echo -n " "; echo -n "Running texhash... "; \\\
  24. %{_bindir}/texhash 2> /dev/null; \\\
  25. echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
  26. %define exec_mtxrun [ -e /var/run/texlive/run-mtxrun ] && ( \\\
  27. [ -x %{_bindir}/mtxrun ] && \\\
  28. echo -n " "; echo -n "Running mtxrun... "; \\\
  29. export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
  30. %{_bindir}/mtxrun --generate &> /dev/null; \\\
  31. echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
  32. %define exec_fmtutil [ -e /var/run/texlive/run-fmtutil ] && ( \\\
  33. [ -x %{_bindir}/fmtutil-sys ] && \\\
  34. echo -n " "; echo -n "Running fmtutil-sys... "; \\\
  35. %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
  36. echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
  37. %define exec_updmap [ -e /var/run/texlive/run-updmap ] && ( \\\
  38. [ -x %{_bindir}/updmap-sys ] && \\\
  39. echo -n " "; echo -n "Running updmap-sys... "; \\\
  40. %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
  41. echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
  42. Summary: TeX Live: Recommended generic packages
  43. Summary(ja): TeX Live: Recommended generic packages
  44. Name: texlive-collection-genericrecommended
  45. Version: 2012
  46. Release: 1%{?_dist_release}
  47. License: Public Domain, GPL+, LPPL, Freely redistributable without restriction
  48. Group: Applications/Publishing
  49. URL:http://www.tug.org/texlive/
  50. Requires: texlive = %{version}
  51. Requires: texlive-collection-basic = %{version}
  52. Requires(post): texlive = %{version}
  53. Requires(postun): texlive = %{version}
  54. #BuildRequires: texlive-sources = %{version}
  55. BuildArch: noarch
  56. Buildroot: %{_tmppath}/%{name}-%{version}-root
  57. Vendor: Project Vine
  58. Distribution: Vine Linux
  59. Packager: munepi
  60. %description
  61. The TeX Live software distribution offers a complete TeX system for a
  62. variety of Unix, Macintosh, Windows and other platforms. It
  63. encompasses programs for editing, typesetting, previewing and printing
  64. of TeX documents in many different languages, and a large collection
  65. of TeX macros and font libraries.
  66. The distribution includes extensive general documentation about TeX,
  67. as well as the documentation for the included software packages.
  68. This package is a collection of Recommended generic packages:
  69. Recommended packages that work with multiple formats.
  70. This package contains the following CTAN packages:
  71. epsf: Simple macros for EPS inclusion.
  72. fontname: Scheme for naming fonts in TeX.
  73. genmisc:
  74. kastrup:
  75. multido: A loop facility for Generic TeX.
  76. path: Typeset paths, making them breakable.
  77. tex-ps: TeX to PostScript generic macros and add-ons.
  78. ulem: Package for underlining.
  79. %description -l ja
  80. TeX Live ソフトウェアディストリビューションは、
  81. さまざまな Unix, Macintosh, Windows、および
  82. 他のプラットホームに対して完全な TeX システムを提供します。
  83. 多くの異なった言語を含む TeX ドキュメントの
  84. 編集、組版、閲覧、印刷するためのプログラム、
  85. そして、TeX マクロやフォントライブラリの大きなコレクションを
  86. 同梱しています。
  87. このディストリビューションは
  88. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  89. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  90. このパッケージは以下のようなパッケージ集です。
  91. Recommended generic packages:
  92. Recommended packages that work with multiple formats.
  93. このパッケージは以下の CTAN パッケージを含んでいます:
  94. epsf: Simple macros for EPS inclusion.
  95. fontname: Scheme for naming fonts in TeX.
  96. genmisc:
  97. kastrup:
  98. multido: A loop facility for Generic TeX.
  99. path: Typeset paths, making them breakable.
  100. tex-ps: TeX to PostScript generic macros and add-ons.
  101. ulem: Package for underlining.
  102. %package doc
  103. Summary: TeX Live: Documentation files of %{name}
  104. Group: Applications/Publishing
  105. Requires: %{name} = %{version}-%{release}
  106. %description doc
  107. This package contains documentation files of %{name}.
  108. %prep
  109. %build
  110. %install
  111. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  112. PREF=%{buildroot}%{tex_destdir}
  113. manifest=(
  114. texmf-dist/doc/generic/epsf/LICENSE
  115. texmf-dist/doc/generic/epsf/Makefile
  116. texmf-dist/doc/generic/epsf/README
  117. texmf-dist/doc/generic/epsf/bboxgrid.ps
  118. texmf-dist/doc/generic/epsf/epsf-doc.pdf
  119. texmf-dist/doc/generic/epsf/epsf-doc.tex
  120. texmf-dist/doc/generic/epsf/fndbadps
  121. texmf-dist/doc/generic/epsf/okay/teps.eps
  122. texmf-dist/doc/generic/epsf/okay/tepsf.eps
  123. texmf-dist/doc/generic/epsf/okay/tepsf1.dvi
  124. texmf-dist/doc/generic/epsf/okay/tepsf2.dvi
  125. texmf-dist/doc/generic/epsf/okay/tepsf3.dvi
  126. texmf-dist/doc/generic/epsf/teps.eps
  127. texmf-dist/doc/generic/epsf/tepsf.eps
  128. texmf-dist/doc/generic/epsf/tepsf1.tex
  129. texmf-dist/doc/generic/epsf/tepsf2.ltx
  130. texmf-dist/doc/generic/epsf/tepsf3.tex
  131. texmf-dist/tex/generic/epsf/epsf.sty
  132. texmf-dist/tex/generic/epsf/epsf.tex
  133. texmf-dist/doc/fonts/fontname/8a.html
  134. texmf-dist/doc/fonts/fontname/8r.html
  135. texmf-dist/doc/fonts/fontname/Adobe-fonts.html
  136. texmf-dist/doc/fonts/fontname/Apple-fonts.html
  137. texmf-dist/doc/fonts/fontname/Bitstream-fonts.html
  138. texmf-dist/doc/fonts/fontname/ChangeLog
  139. texmf-dist/doc/fonts/fontname/DTC-fonts.html
  140. texmf-dist/doc/fonts/fontname/Encodings.html
  141. texmf-dist/doc/fonts/fontname/Filenames-for-fonts.html
  142. texmf-dist/doc/fonts/fontname/Font-legalities.html
  143. texmf-dist/doc/fonts/fontname/Font-name-lists.html
  144. texmf-dist/doc/fonts/fontname/History.html
  145. texmf-dist/doc/fonts/fontname/ITC-fonts.html
  146. texmf-dist/doc/fonts/fontname/Introduction.html
  147. texmf-dist/doc/fonts/fontname/Linotype-fonts.html
  148. texmf-dist/doc/fonts/fontname/Long-names.html
  149. texmf-dist/doc/fonts/fontname/Long-naming-scheme.html
  150. texmf-dist/doc/fonts/fontname/Makefile
  151. texmf-dist/doc/fonts/fontname/Monotype-fonts.html
  152. texmf-dist/doc/fonts/fontname/Name-mapping-file.html
  153. texmf-dist/doc/fonts/fontname/References.html
  154. texmf-dist/doc/fonts/fontname/Standard-PostScript-fonts.html
  155. texmf-dist/doc/fonts/fontname/Suppliers.html
  156. texmf-dist/doc/fonts/fontname/Typefaces.html
  157. texmf-dist/doc/fonts/fontname/URW-fonts.html
  158. texmf-dist/doc/fonts/fontname/Variants.html
  159. texmf-dist/doc/fonts/fontname/Weights.html
  160. texmf-dist/doc/fonts/fontname/Widths.html
  161. texmf-dist/doc/fonts/fontname/bitstrea.aka
  162. texmf-dist/doc/fonts/fontname/cork.html
  163. texmf-dist/doc/fonts/fontname/dvips.html
  164. texmf-dist/doc/fonts/fontname/fontname.aux
  165. texmf-dist/doc/fonts/fontname/fontname.cp
  166. texmf-dist/doc/fonts/fontname/fontname.html
  167. texmf-dist/doc/fonts/fontname/fontname.pdf
  168. texmf-dist/doc/fonts/fontname/fontname.texi
  169. texmf-dist/doc/fonts/fontname/fontname.toc
  170. texmf-dist/doc/fonts/fontname/index.html
  171. texmf-dist/doc/fonts/fontname/texmext.html
  172. texmf-dist/doc/fonts/fontname/texmital.html
  173. texmf-dist/doc/fonts/fontname/texmsym.html
  174. texmf-dist/doc/fonts/fontname/texnansi.html
  175. texmf-dist/doc/fonts/fontname/texnansx.html
  176. texmf-dist/doc/fonts/fontname/xl2.html
  177. texmf-dist/doc/fonts/fontname/xt2.html
  178. texmf-dist/fonts/map/fontname/adobe.map
  179. texmf-dist/fonts/map/fontname/apple.map
  180. texmf-dist/fonts/map/fontname/bitstrea.map
  181. texmf-dist/fonts/map/fontname/dtc.map
  182. texmf-dist/fonts/map/fontname/itc.map
  183. texmf-dist/fonts/map/fontname/linot-cd.map
  184. texmf-dist/fonts/map/fontname/linotype-cd.map
  185. texmf-dist/fonts/map/fontname/linotype.map
  186. texmf-dist/fonts/map/fontname/monotype.map
  187. texmf-dist/fonts/map/fontname/skey1250.map
  188. texmf-dist/fonts/map/fontname/skey1555.map
  189. texmf-dist/fonts/map/fontname/softkey-1250.map
  190. texmf-dist/fonts/map/fontname/softkey-1555.map
  191. texmf-dist/fonts/map/fontname/softkey.map
  192. texmf-dist/fonts/map/fontname/special.map
  193. texmf-dist/fonts/map/fontname/supplier.map
  194. texmf-dist/fonts/map/fontname/texfonts.map
  195. texmf-dist/fonts/map/fontname/typeface.map
  196. texmf-dist/fonts/map/fontname/urw.map
  197. texmf-dist/fonts/map/fontname/variant.map
  198. texmf-dist/fonts/map/fontname/weight.map
  199. texmf-dist/fonts/map/fontname/width.map
  200. texmf-dist/fonts/map/fontname/yandy.map
  201. texmf-dist/tex/generic/genmisc/anti.tex
  202. texmf-dist/tex/generic/genmisc/apldef.tex
  203. texmf-dist/tex/generic/genmisc/arabic.tex
  204. texmf-dist/tex/generic/genmisc/backgrnd.tex
  205. texmf-dist/tex/generic/genmisc/balancedquotes.sty
  206. texmf-dist/tex/generic/genmisc/chessmin.tex
  207. texmf-dist/tex/generic/genmisc/compare.tex
  208. texmf-dist/tex/generic/genmisc/cropmark.sty
  209. texmf-dist/tex/generic/genmisc/cropmark.tex
  210. texmf-dist/tex/generic/genmisc/croptest.tex
  211. texmf-dist/tex/generic/genmisc/dayofweek.tex
  212. texmf-dist/tex/generic/genmisc/daytime.sty
  213. texmf-dist/tex/generic/genmisc/default.sty
  214. texmf-dist/tex/generic/genmisc/dow.tex
  215. texmf-dist/tex/generic/genmisc/emtrees.tex
  216. texmf-dist/tex/generic/genmisc/endnote.tex
  217. texmf-dist/tex/generic/genmisc/fakebold.tex
  218. texmf-dist/tex/generic/genmisc/hep.tex
  219. texmf-dist/tex/generic/genmisc/hexdump.sty
  220. texmf-dist/tex/generic/genmisc/inscrutable.tex
  221. texmf-dist/tex/generic/genmisc/laps.tex
  222. texmf-dist/tex/generic/genmisc/letterspacing.tex
  223. texmf-dist/tex/generic/genmisc/longdiv.tex
  224. texmf-dist/tex/generic/genmisc/mandel.tex
  225. texmf-dist/tex/generic/genmisc/mathlig.tex
  226. texmf-dist/tex/generic/genmisc/nth.sty
  227. texmf-dist/tex/generic/genmisc/outerhbox.sty
  228. texmf-dist/tex/generic/genmisc/pagereference.tex
  229. texmf-dist/tex/generic/genmisc/quotation.tex
  230. texmf-dist/tex/generic/genmisc/ragged.sty
  231. texmf-dist/tex/generic/genmisc/random.tex
  232. texmf-dist/tex/generic/genmisc/ruler.tex
  233. texmf-dist/tex/generic/genmisc/selectpage.tex
  234. texmf-dist/tex/generic/genmisc/shadebox.tex
  235. texmf-dist/tex/generic/genmisc/swrule.sty
  236. texmf-dist/tex/generic/genmisc/underlin.tex
  237. texmf-dist/tex/generic/genmisc/undertilde.tex
  238. texmf-dist/tex/generic/genmisc/verbatim.tex
  239. texmf-dist/tex/generic/genmisc/weekday.sty
  240. texmf-dist/tex/generic/genmisc/wiggly.tex
  241. texmf-dist/tex/generic/genmisc/zip.tex
  242. texmf-dist/doc/generic/kastrup/binhex.pdf
  243. texmf-dist/source/generic/kastrup/binhex.drv
  244. texmf-dist/source/generic/kastrup/binhex.dtx
  245. texmf-dist/source/generic/kastrup/binhex.ins
  246. texmf-dist/tex/generic/kastrup/binhex.tex
  247. texmf-dist/doc/generic/multido/Changes
  248. texmf-dist/doc/generic/multido/multido-doc.pdf
  249. texmf-dist/doc/generic/multido/multido-doc.tex
  250. texmf-dist/doc/generic/multido/multido.pdf
  251. texmf-dist/source/generic/multido/Makefile
  252. texmf-dist/tex/generic/multido/multido.tex
  253. texmf-dist/tex/latex/multido/multido.sty
  254. texmf-dist/doc/generic/path/path-doc.pdf
  255. texmf-dist/doc/generic/path/path-doc.tex
  256. texmf-dist/tex/generic/path/path.sty
  257. texmf-dist/doc/generic/tex-ps/cmyk-hax/README
  258. texmf-dist/doc/generic/tex-ps/cmyk-hax/cmyk-doc.pdf
  259. texmf-dist/doc/generic/tex-ps/cmyk-hax/fountain.eps
  260. texmf-dist/doc/generic/tex-ps/cmyk-hax/gdansk.eps
  261. texmf-dist/doc/generic/tex-ps/cmyk-hax/rules.tex
  262. texmf-dist/doc/generic/tex-ps/cmyk-hax/sam1-sep.bat
  263. texmf-dist/doc/generic/tex-ps/cmyk-hax/sample1.tex
  264. texmf-dist/doc/generic/tex-ps/cmyk-hax/sample2.tex
  265. texmf-dist/doc/generic/tex-ps/cmyk-hax/sample3.tex
  266. texmf-dist/doc/generic/tex-ps/cmyk-hax/sample4.tex
  267. texmf-dist/doc/generic/tex-ps/cmyk-hax/screen.eps
  268. texmf-dist/doc/generic/tex-ps/poligraf/README
  269. texmf-dist/doc/generic/tex-ps/poligraf/kol-cmyk.eps
  270. texmf-dist/doc/generic/tex-ps/poligraf/sample.tex
  271. texmf-dist/doc/generic/tex-ps/poligraf/samplelx.tex
  272. texmf-dist/dvips/tex-ps/crops.pro
  273. texmf-dist/dvips/tex-ps/mirr.hd
  274. texmf-dist/dvips/tex-ps/separate.pro
  275. texmf-dist/tex/generic/tex-ps/cmyk-hax.tex
  276. texmf-dist/tex/generic/tex-ps/epsfx.tex
  277. texmf-dist/tex/generic/tex-ps/poligraf.sty
  278. texmf-dist/tex/generic/tex-ps/trans.tex
  279. texmf-dist/doc/generic/ulem/README
  280. texmf-dist/doc/generic/ulem/ulem.ltx
  281. texmf-dist/doc/generic/ulem/ulem.pdf
  282. texmf-dist/tex/generic/ulem/ulem.sty
  283. )
  284. %__mkdir_p ${PREF}/texmf-dist
  285. for i in "${manifest[@]}"; do
  286. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  287. done
  288. ## make symlinks of core script utils
  289. mk_symlinks=(
  290. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  291. texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
  292. texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
  293. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  294. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  295. texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
  296. texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
  297. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  298. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  299. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  300. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  301. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  302. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  303. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  304. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  305. texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
  306. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  307. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  308. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  309. texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
  310. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  311. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  312. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  313. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  314. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  315. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  316. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  317. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  318. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  319. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  320. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  321. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  322. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  323. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  324. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  325. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  326. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  327. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  328. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  329. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  330. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  331. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  332. texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
  333. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  334. texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
  335. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  336. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  337. texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
  338. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  339. texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
  340. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  341. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  342. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  343. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  344. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  345. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  346. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  347. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  348. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  349. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  350. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  351. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  352. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  353. texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
  354. texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
  355. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  356. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  357. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  358. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  359. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  360. texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
  361. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  362. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  363. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  364. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  365. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  366. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  367. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  368. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  369. texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
  370. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  371. texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
  372. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  373. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  374. texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
  375. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  376. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  377. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  378. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  379. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  380. texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
  381. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  382. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  383. )
  384. %__mkdir_p %{buildroot}%{_bindir}
  385. pushd %{buildroot}%{_bindir}
  386. for i in "${mk_symlinks[@]}"; do
  387. tlc=$(/bin/echo $i | cut -f 1 -d",")
  388. lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  389. rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  390. [ "%{name}" = "$tlc" ] || continue
  391. [ -f $rlnk ] || exit 1
  392. %__ln_s $rlnk $lnk || exit 1
  393. done
  394. popd
  395. ## Files list
  396. find %{buildroot} -type f -or -type l | \
  397. %__sed -e "s|%{buildroot}||g" > filelist.full
  398. find %{buildroot}%{texmf}-dist -type d | \
  399. %__sed -e "s|^%{buildroot}|%dir |" \
  400. -e "s|$|/|" >> filelist.full
  401. ## subpackages
  402. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  403. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  404. %__mv -f filelist.tmp filelist.full
  405. %clean
  406. %__rm -rf %{buildroot}
  407. %post
  408. %touch_run texhash
  409. %touch_run mtxrun
  410. exit 0
  411. %postun
  412. if [ "$1" = 0 ]; then
  413. %touch_run texhash
  414. fi
  415. exit 0
  416. %posttrans
  417. %{exec_texhash}
  418. %{exec_mtxrun}
  419. %{exec_updmap}
  420. %{exec_fmtutil}
  421. exit 0
  422. %files -f filelist.full
  423. %defattr(-,root,root,-)
  424. %files -f filelist.doc doc
  425. %defattr(-,root,root,-)
  426. %changelog
  427. * Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  428. - generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-genericrecommended
  429. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  430. - generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-genericrecommended
  431. - set external dependencies (texlive-collection-binextra,
  432. texlive-collection-fontutils)
  433. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  434. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-genericrecommended
  435. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  436. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-genericrecommended
  437. - make symlinks of core script utils (texlive-collection-binextra,
  438. texlive-collection-context, texlive-collection-fontutils,
  439. texlive-collection-langgreek, texlive-collection-langindic,
  440. texlive-collection-latex, texlive-collection-latexextra,
  441. texlive-collection-latexrecommended, texlive-collection-pictures,
  442. texlive-collection-pstricks, texlive-collection-science)
  443. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  444. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-genericrecommended
  445. - improved %%post
  446. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  447. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-genericrecommended
  448. - removed arch dependent binaries (texlive-collection-latexextra)
  449. - fixed perl path
  450. - improved updmap process in %%post and %%postun
  451. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  452. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-genericrecommended