texlive-collection-documentation-japanese-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
  3. ## tlpdb2rpmspec collection-documentation-japanese
  4. %global _use_internal_dependency_generator 0
  5. %global __find_provides %{nil}
  6. %global __find_requires %{nil}
  7. %define aliasttfdir %{texmfsysvar}/fonts/truetype/vine
  8. %define texmfsysconfig %{_sysconfdir}/texmf
  9. %define texmfsysvar %{_var}/lib/texmf
  10. %define vartexfonts %{texmfsysvar}/fonts
  11. %define tex_destdir %{_datadir}
  12. %define texmf %{tex_destdir}/texmf
  13. %define texlive_src %{tex_destdir}/texlive-sources
  14. %define build_tex_destdir %{buildroot}%{tex_destdir}
  15. %define build_texmf %{buildroot}%{texmf}
  16. ## use some macros for %post, %posttrans
  17. %define touch_run(%1) %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
  18. }
  19. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
  20. %{_sbindir}/update-defaultfont 2> /dev/null
  21. %define exec_texhash [ -e /var/run/texlive/run-texhash ] && ( \\\
  22. [ -x %{_bindir}/texhash ] && \\\
  23. echo -n " "; echo -n "Running texhash... "; \\\
  24. %{_bindir}/texhash 2> /dev/null; \\\
  25. echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
  26. %define exec_mtxrun [ -e /var/run/texlive/run-mtxrun ] && ( \\\
  27. [ -x %{_bindir}/mtxrun ] && \\\
  28. echo -n " "; echo -n "Running mtxrun... "; \\\
  29. export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
  30. %{_bindir}/mtxrun --generate &> /dev/null; \\\
  31. echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
  32. %define exec_fmtutil [ -e /var/run/texlive/run-fmtutil ] && ( \\\
  33. [ -x %{_bindir}/fmtutil-sys ] && \\\
  34. echo -n " "; echo -n "Running fmtutil-sys... "; \\\
  35. %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
  36. echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
  37. %define exec_updmap [ -e /var/run/texlive/run-updmap ] && ( \\\
  38. [ -x %{_bindir}/updmap-sys ] && \\\
  39. echo -n " "; echo -n "Running updmap-sys... "; \\\
  40. %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
  41. echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
  42. Summary: TeX Live: Japanese documentation
  43. Summary(ja): TeX Live: Japanese documentation
  44. Name: texlive-collection-documentation-japanese
  45. Version: 2012
  46. Release: 1%{?_dist_release}
  47. License: GPL+
  48. Group: Applications/Publishing
  49. URL:http://www.tug.org/texlive/
  50. Requires: texlive = %{version}
  51. Requires(post): texlive = %{version}
  52. Requires(postun): texlive = %{version}
  53. #BuildRequires: texlive-sources = %{version}
  54. BuildArch: noarch
  55. Buildroot: %{_tmppath}/%{name}-%{version}-root
  56. Vendor: Project Vine
  57. Distribution: Vine Linux
  58. Packager: munepi
  59. %description
  60. The TeX Live software distribution offers a complete TeX system for a
  61. variety of Unix, Macintosh, Windows and other platforms. It
  62. encompasses programs for editing, typesetting, previewing and printing
  63. of TeX documents in many different languages, and a large collection
  64. of TeX macros and font libraries.
  65. The distribution includes extensive general documentation about TeX,
  66. as well as the documentation for the included software packages.
  67. This package is a collection of Japanese documentation:
  68. This package contains the following CTAN packages:
  69. lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
  70. %description -l ja
  71. TeX Live ソフトウェアディストリビューションは、
  72. さまざまな Unix, Macintosh, Windows、および
  73. 他のプラットホームに対して完全な TeX システムを提供します。
  74. 多くの異なった言語を含む TeX ドキュメントの
  75. 編集、組版、閲覧、印刷するためのプログラム、
  76. そして、TeX マクロやフォントライブラリの大きなコレクションを
  77. 同梱しています。
  78. このディストリビューションは
  79. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  80. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  81. このパッケージは以下のようなパッケージ集です。
  82. Japanese documentation:
  83. このパッケージは以下の CTAN パッケージを含んでいます:
  84. lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
  85. %prep
  86. %build
  87. %install
  88. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  89. PREF=%{buildroot}%{tex_destdir}
  90. manifest=(
  91. texmf-dist/doc/latex/lshort-japanese/00README
  92. texmf-dist/doc/latex/lshort-japanese/CHANGES.jp
  93. texmf-dist/doc/latex/lshort-japanese/READ.ME
  94. texmf-dist/doc/latex/lshort-japanese/jlshort-1.00.src.tar.gz
  95. texmf-dist/doc/latex/lshort-japanese/jlshort.pdf
  96. )
  97. %__mkdir_p ${PREF}/texmf-dist
  98. for i in "${manifest[@]}"; do
  99. %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
  100. done
  101. ## make symlinks of core script utils
  102. mk_symlinks=(
  103. texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
  104. texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
  105. texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
  106. texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
  107. texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
  108. texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
  109. texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
  110. texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
  111. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  112. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  113. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  114. texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
  115. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  116. texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
  117. texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
  118. texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
  119. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  120. texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
  121. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  122. texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
  123. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  124. texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
  125. texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
  126. texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
  127. texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
  128. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  129. texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
  130. texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
  131. texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
  132. texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
  133. texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
  134. texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
  135. texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
  136. texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
  137. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  138. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  139. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  140. texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
  141. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  142. texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
  143. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  144. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  145. texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
  146. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  147. texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
  148. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  149. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  150. texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
  151. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  152. texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
  153. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  154. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  155. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  156. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  157. texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
  158. texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
  159. texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
  160. texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
  161. texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
  162. texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
  163. texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
  164. texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
  165. texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
  166. texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
  167. texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
  168. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  169. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
  170. texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
  171. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  172. texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
  173. texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
  174. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  175. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  176. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
  177. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  178. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  179. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  180. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  181. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  182. texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
  183. texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
  184. texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
  185. texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
  186. texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
  187. texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
  188. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  189. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
  190. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
  191. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  192. texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
  193. texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
  194. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
  195. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  196. )
  197. %__mkdir_p %{buildroot}%{_bindir}
  198. pushd %{buildroot}%{_bindir}
  199. for i in "${mk_symlinks[@]}"; do
  200. tlc=$(/bin/echo $i | cut -f 1 -d",")
  201. lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  202. rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  203. [ "%{name}" = "$tlc" ] || continue
  204. [ -f $rlnk ] || exit 1
  205. %__ln_s $rlnk $lnk || exit 1
  206. done
  207. popd
  208. ## Files list
  209. find %{buildroot} -type f -or -type l | \
  210. %__sed -e "s|%{buildroot}||g" > filelist.full
  211. find %{buildroot}%{texmf}-dist -type d | \
  212. %__sed -e "s|^%{buildroot}|%dir |" \
  213. -e "s|$|/|" >> filelist.full
  214. %clean
  215. %__rm -rf %{buildroot}
  216. %post
  217. %touch_run texhash
  218. %touch_run mtxrun
  219. exit 0
  220. %postun
  221. if [ "$1" = 0 ]; then
  222. %touch_run texhash
  223. fi
  224. exit 0
  225. %posttrans
  226. %{exec_texhash}
  227. %{exec_mtxrun}
  228. %{exec_updmap}
  229. %{exec_fmtutil}
  230. exit 0
  231. %files -f filelist.full
  232. %defattr(-,root,root,-)
  233. %changelog
  234. * Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  235. - generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-documentation-japanese
  236. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  237. - generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-documentation-japanese
  238. - set external dependencies (texlive-collection-binextra,
  239. texlive-collection-fontutils)
  240. * Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  241. - generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-japanese
  242. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  243. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-japanese
  244. - make symlinks of core script utils (texlive-collection-binextra,
  245. texlive-collection-context, texlive-collection-fontutils,
  246. texlive-collection-langgreek, texlive-collection-langindic,
  247. texlive-collection-latex, texlive-collection-latexextra,
  248. texlive-collection-latexrecommended, texlive-collection-pictures,
  249. texlive-collection-pstricks, texlive-collection-science)
  250. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  251. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-japanese
  252. - improved %%post
  253. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  254. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-japanese
  255. - removed arch dependent binaries (texlive-collection-latexextra)
  256. - fixed perl path
  257. - improved updmap process in %%post and %%postun
  258. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  259. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-japanese