self-build-x264-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define pkgname x264
  2. %define name self-build-%{pkgname}
  3. %define version 0.0.0
  4. %define date 20110322
  5. %define time 2245
  6. %define release 15.%{date}%{?_dist_release}
  7. #define sourceurl0 ftp://ftp.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
  8. %define sourceurl0 http://www.videolan.org/pub/videolan/x264/snapshots/%{pkgname}-snapshot-%{date}-%{time}.tar.bz2
  9. Summary: Package to automatically build %{pkgname} rpm package
  10. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. Source0: %{pkgname}-vl.spec
  15. Source1: %{pkgname}.desktop
  16. Source111: %{pkgname}-shared.patch
  17. Source112: %{pkgname}-nostrip.patch
  18. License: GPLv2+
  19. Group: Restricted Software
  20. Obsoletes: x264 < %{version}-%{release}
  21. Obsoletes: self-build-x264 < %{version}-%{release}
  22. Requires(post): self-build-setup >= 0.9.9
  23. # (build)requies of target package.
  24. %ifarch x86_64 %{ix86}
  25. Requires(post): yasm
  26. %endif
  27. Requires(post): self-build-gpac
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Packager: munepi
  30. %description
  31. x264 is a free library for encoding H264/AVC video streams, written from
  32. scratch.
  33. If you install this package, it automaticaly downloads source
  34. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  35. And the created rpm packages are automatically installed
  36. if installation is executed by apt-get command or synaptic
  37. package manager.
  38. [Note]
  39. This package requires many other packages to compile
  40. targetsoftware. So it consume more disk space than usual.
  41. Also installation takes logner time because of compilation.
  42. (This will take a few minutes to quarter or half of an hour,
  43. depends on building environment)
  44. [About self-build package]
  45. For some kind of software, distributing of binary package
  46. may viorate the patent or law. Therefore we chose self-build
  47. packge, create binary package on your machine, for such kind
  48. of softwares instead of distributing binary package.
  49. Please obey the national law when you use the created binary
  50. packages. And if you want to use the softwares using patented
  51. thechnology, it may be required to get a permission, make an
  52. agreement or purchas a license. Please consider it with your
  53. purpose or way of use and take appropriate action.
  54. %description -l ja
  55. x264 はスクラッチから書かれた H264/AVC ビデオストリームをエン
  56. コードするためのフリーなライブラリです.
  57. このパッケージをインストールすると、自動的にソースコードを
  58. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  59. パッケージを作成します。
  60. また apt-get コマンドや synaptic パッケージマネージャから実行
  61. した場合は、作成された rpm パッケージのインストールも自動的に
  62. 行います。
  63. [注意]
  64. コンパイルに必要な多くの関連パッケージを要求するので通常より
  65. ディスクの領域を多く消費します。
  66. またインストール時にコンパイルを行うため、通常より時間がかか
  67. る場合があります。(環境にもよりますが数分から数十分程度)
  68. [self-build パッケージについて]
  69. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  70. 違反する可能性があるものがあります。その為、このような問題が
  71. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  72. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  73. ジという方法を採っています。
  74. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  75. アのライセンス、および利用する国の各種法令に従ってください。
  76. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  77. センスの購入などが必要となる場合がありますので、利用する目的
  78. や形態に応じて各自で判断し適切な対応を取ってください。
  79. %prep
  80. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  81. %install
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  84. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  85. %{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  86. %{__install} -m 644 %{SOURCE111} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  87. %{__install} -m 644 %{SOURCE112} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  88. %clean
  89. %{__rm} -rf ${RPM_BUILD_ROOT}
  90. %posttrans
  91. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 19000
  92. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  93. %{pkgname}-devel-%{version}-%{release}
  94. %files
  95. %defattr(-,root,root)
  96. %{_datadir}/%{name}
  97. %changelog
  98. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-15.20110322
  99. - updated source snapshot 20110322
  100. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-14.20100625
  101. - updated source snapshot 20100625
  102. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-13.20100216
  103. - renamed %%{Source0} to x264-vl.spec
  104. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-12.20100216
  105. - updated source snapshot 20100216
  106. - applied to link x264 binary to the shared library from RPM Fusion development
  107. * Mon Sep 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.0.0-11.20090522
  108. - changed to download from http://www.videolan.org/pub/videolan/x264/snapshots in %%sourceurl0
  109. - check version between original spec and self-build spec in %%prep
  110. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-10.20090522
  111. - dropped BuildArch: noarch
  112. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-9.20090522
  113. - 20090522 snapshot
  114. - updated x264-vine.patch
  115. - added BuildArch: noarch
  116. - avoided to execute self-build-rpm.sh on RPM transaction
  117. - moved %%post actions to %%posttrans
  118. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-8.20090110
  119. - corrected release number in x264.spec
  120. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.0-7.20090110
  121. - enable asm on x86/x86_64 arch. (fix typo?)
  122. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-6.20090110
  123. - added PreReq: self-build-gpac
  124. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-5.20090110
  125. - dropped PreReq: nasm for x86
  126. - added PreReq: yasm for x86
  127. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-4.20090110
  128. - 20090110 snapshot
  129. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-3.20081001
  130. - fixed License: GPLv2+
  131. - added BuildRequires: gettext
  132. - source updated
  133. - fixed x264-rpm.patch (merged x264-rpm.patch from RPM Fusion)
  134. and added x264-vine.patch
  135. #- changed version from 0.0.0-1.20080225 to 0.0.0-20081111.1
  136. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-2.20080225vl1
  137. - spec in utf8
  138. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.0.0-1.20080225
  139. - run pre-allocate-rpm.sh in %%post
  140. - set PreReq: self-build-setup >= 0.8
  141. - apply new versioning policy
  142. * Wed Feb 27 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.0.0-0.20080225vl1
  143. - initial build for Vine Linux 4.2
  144. ### end of file