gsm-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. Summary: Shared libraries for GSM speech compressor
  2. Name: gsm
  3. Version: 1.0.12
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: MIT
  7. URL: http://kbs.cs.tu-berlin.de/~jutta/toast.html
  8. Source: http://kbs.cs.tu-berlin.de/~jutta/gsm/%{name}-%{version}.tar.gz
  9. Patch0: %{name}-makefile.patch
  10. Patch1: %{name}-warnings.patch
  11. Patch2: %{name}-64bit.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. %define srcver 1.0-pl12
  14. %description
  15. Contains runtime shared libraries for libgsm, an implementation of
  16. the European GSM 06.10 provisional standard for full-rate speech
  17. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  18. excitation/long term prediction) coding at 13 kbit/s.
  19. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  20. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  21. with typical UNIX applications, our implementation turns frames of 160
  22. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  23. The quality of the algorithm is good enough for reliable speaker
  24. recognition; even music often survives transcoding in recognizable
  25. form (given the bandwidth limitations of 8 kHz sampling rate).
  26. The interfaces offered are a front end modelled after compress(1), and
  27. a library API. Compression and decompression run faster than realtime
  28. on most SPARCstations. The implementation has been verified against the
  29. ETSI standard test patterns.
  30. %package tools
  31. Summary: GSM speech compressor tools
  32. Group: Applications/Multimedia
  33. %description tools
  34. Contains command line utilities for libgsm, an implementation of
  35. the European GSM 06.10 provisional standard for full-rate speech
  36. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  37. excitation/long term prediction) coding at 13 kbit/s.
  38. %package devel
  39. Summary: Header files and development libraries for libgsm
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. %description devel
  43. Contains header files and development libraries for libgsm, an
  44. implementation of the European GSM 06.10 provisional standard for
  45. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  46. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  47. %prep
  48. %setup -n gsm-%{srcver} -q
  49. %patch0 -p1 -b .mk
  50. %patch1 -p1 -b .warn
  51. %patch2 -p1 -b .64bit
  52. %build
  53. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
  54. make %{?_smp_mflags} all
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  58. mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
  59. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  60. mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
  61. make install \
  62. INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
  63. GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
  64. GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
  65. cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}
  66. ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
  67. ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
  68. # some apps look for this in /usr/include
  69. ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  71. %check
  72. # This is to ensure that the patch creates the proper library version.
  73. [ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{version} ]
  74. make addtst
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %files
  80. %defattr(-,root,root,-)
  81. %doc ChangeLog COPYRIGHT MACHINES README
  82. %{_libdir}/libgsm.so.*
  83. %files tools
  84. %{_bindir}/tcat
  85. %{_bindir}/toast
  86. %{_bindir}/untoast
  87. %{_mandir}/man1/toast.1*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %dir %{_includedir}/gsm
  91. %{_includedir}/gsm/gsm.h
  92. %{_includedir}/gsm.h
  93. %{_libdir}/libgsm.so
  94. %{_mandir}/man3/*
  95. %changelog
  96. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
  97. - rebuilt with current VineSeed
  98. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  99. - initial build for Vine Linux
  100. * Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
  101. - Rebuild for GCC 4.3
  102. * Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
  103. - install symlinks instead of binaries in -devel
  104. * Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
  105. - rebuild for BuildID
  106. - specfile cleanups
  107. * Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
  108. - fix parallel make
  109. * Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
  110. - fix some warnings
  111. - fix 64bit testsuite issue as described at gsm homepage
  112. - add compatibility header symlink
  113. - split off binaries into a separate package
  114. * Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
  115. - Update to Release 1.0 Patchlevel 12.
  116. - Build with -fPIC not just for non-ix86.
  117. - Add check section to ensure proper library version.
  118. - Remove static library.
  119. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
  120. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  121. * Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
  122. - 1.0.10-11
  123. - rebuild for FC6
  124. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  125. - switch to new release field
  126. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  127. - add dist
  128. * Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
  129. - 1.0.10-0.lvn.10: Clean up installation
  130. * Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  131. - 1.0.10-0.lvn.9: mv libgsm.a only when needed
  132. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  133. - 1.0.10-0.lvn.8: Use -fPIC on non ix86
  134. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  135. - 1.0.10-0.lvn.7: moved to rpm.livna.org
  136. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  137. - 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
  138. * Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  139. - 0:1.0.10-0.fdr.6: remove second makeinstall
  140. * Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  141. - 0:1.0.10-0.fdr.5
  142. - added back epochs, I surrender
  143. - fix RPM_OPT_FLAGS hackery
  144. * Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  145. - 1.0.10-0.fdr.4: remove epoch mentions
  146. * Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  147. - 1.0.10-0.fdr.3
  148. - pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
  149. - fix group
  150. - -p'ize ldconfig
  151. * Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  152. - 1.0.10-0.fdr.2
  153. - Fix libgsm.so.* being files instead of symlinks
  154. * Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  155. - 0:1.0.10-0.fdr.1: initial RPM release