kate-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221
  1. Name: kate
  2. Summary: Advanced Text Editor
  3. Summary(ja): 高機能なテキストエディタ
  4. Version: 4.7.4
  5. Release: 1%{?_dist_release}
  6. # kwrite LGPLv2+
  7. # kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
  8. # ktexteditor: LGPLv2
  9. # katepart: LGPLv2
  10. License: LGPLv2 and LGPLv2+ and GPLv2+
  11. Group: Applications/Editors
  12. URL: https://projects.kde.org/projects/kde/kdebase/kate
  13. Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: kdelibs4-devel >= %{version}
  17. BuildRequires: soprano-devel
  18. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  19. Requires: %{name}-part = %{version}-%{release}
  20. Requires: %{name}-libs = %{version}-%{release}
  21. %description
  22. %{summary}.
  23. %package devel
  24. Summary: Development files for %{name}
  25. Summary(ja): %{name} の開発用ファイル
  26. Group: Development/Libraries
  27. Requires: %{name}-libs = %{version}-%{release}
  28. Requires: kdelibs4-devel
  29. %description devel
  30. %{summary}.
  31. %package libs
  32. Summary: Runtime files for %{name}
  33. Summary(ja): %{name} のランタイムライブラリ
  34. Group: System Environment/Libraries
  35. # when split occurred
  36. Conflicts: kdesdk4-libs < 4.6.95-10
  37. #Requires: %{name} = %{version}-%{release}
  38. %description libs
  39. %{summary}.
  40. %package part
  41. Summary: Kate kpart plugin
  42. Summary(ja): Kate kpart プラグイン
  43. License: LGPLv2
  44. Group: Applications/Editors
  45. # when split occurred
  46. Conflicts: kdelibs4 < 4.6.95-10
  47. %description part
  48. %{summary}.
  49. %package -n kwrite
  50. Summary: Text Editor
  51. Summary(ja): テキストエディタ
  52. License: LGPLv2+
  53. Group: Applications/Editors
  54. # when split occurred
  55. Conflicts: kdebase4 < 4.6.95-10
  56. Requires: %{name}-part = %{version}-%{release}
  57. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  58. %description -n kwrite
  59. %{summary}.
  60. %prep
  61. %setup -q
  62. %build
  63. mkdir -p %{_target_platform}
  64. pushd %{_target_platform}
  65. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  66. %cmake \
  67. -DCMAKE_BUILD_TYPE=release \
  68. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  69. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  70. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  71. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  72. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  73. ..
  74. popd
  75. make %{?_smp_mflags} -C %{_target_platform}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  79. # move devel symlinks (that would otherwise conflict with kdelibs3-devel)
  80. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
  81. pushd $RPM_BUILD_ROOT%{_libdir}
  82. for i in lib*.so
  83. do
  84. case "$i" in
  85. libkate*interfaces.so)
  86. linktarget=`readlink "$i"`
  87. rm -f "$i"
  88. ln -sf "../../$linktarget" "kde4/devel/$i"
  89. ;;
  90. esac
  91. done
  92. popd
  93. ## unpackaged files
  94. # playground artsticomment -devel bits
  95. rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
  96. rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
  97. %check
  98. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  99. desktop-file-validate $f
  100. done
  101. %post
  102. touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
  103. %posttrans
  104. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  105. update-mime-database %{_datadir}/mime >& /dev/null
  106. %postun
  107. if [ $1 -eq 0 ] ; then
  108. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  109. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  110. update-mime-database %{_datadir}/mime >& /dev/null
  111. fi
  112. %post part -p /sbin/ldconfig
  113. %postun part -p /sbin/ldconfig
  114. %files
  115. %doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/NEWS kate/README kate/TODO
  116. %{_bindir}/kate
  117. %{_libdir}/libkdeinit4_kate.so
  118. %{_datadir}/applications/kde4/kate.desktop
  119. %{_datadir}/kde4/apps/kate/
  120. %{_datadir}/kde4/apps/katexmltools/
  121. %{_datadir}/kde4/apps/kconf_update/kate*.upd
  122. %{_datadir}/icons/hicolor/*/*/*
  123. %{_mandir}/man1/kate.1.gz
  124. %{_datadir}/config/katerc
  125. %{_datadir}/config/katefiletemplates.knsrc
  126. %{_datadir}/kde4/services/kate*.desktop
  127. %{_libdir}/kde4/kate*plugin.so
  128. %{_libdir}/kde4/katefiletemplates.so
  129. %{_datadir}/kde4/apps/katepart/
  130. %{_datadir}/kde4/apps/ktexteditor_*/
  131. %{_datadir}/kde4/services/ktexteditor_*.desktop
  132. %{_libdir}/kde4/ktexteditor_*.so
  133. %{_datadir}/kde4/services/plasma-applet-katesession.desktop
  134. %{_datadir}/kde4/servicetypes/kateplugin.desktop
  135. %{_libdir}/kde4/plasma_applet_katesession.so
  136. %{_libdir}/kde4/kate_kttsd.so
  137. # snippets plugin
  138. %{_bindir}/ktesnippets_editor
  139. %{_datadir}/applications/kde4/ktesnippets_editor.desktop
  140. %{_datadir}/config/ktexteditor_codesnippets_core.knsrc
  141. # these should *probably* be moved to hicolor -- rex
  142. %{_datadir}/icons/oxygen/*/actions/*
  143. %{_datadir}/mime/packages/ktesnippets.xml
  144. %{_datadir}/doc/HTML/en/kate/
  145. %files libs
  146. %{_libdir}/libkateinterfaces.so.4*
  147. %{_libdir}/libktexteditor_codesnippets_core.so.0*
  148. %files devel
  149. %{_libdir}/kde4/devel/libkateinterfaces.so
  150. %{_libdir}/kde4/devel/libkatepartinterfaces.so
  151. %{_libdir}/libktexteditor_codesnippets_core.so
  152. %{_includedir}/kde4/kate_export.h
  153. %{_includedir}/kde4/kate/
  154. %{_includedir}/kde4/ktexteditor_codesnippets_core/
  155. %files part
  156. %doc part/AUTHORS part/ChangeLog part/COPYING.LIB
  157. %doc part/INDENTATION part/NEWS part/README* part/TODO*
  158. %{_libdir}/kde4/katepart.so
  159. %{_libdir}/libkatepartinterfaces.so.4*
  160. %{_datadir}/config/katemoderc
  161. %{_datadir}/config/katepartpluginsrc
  162. %{_datadir}/kde4/services/katepart.desktop
  163. %files -n kwrite
  164. %{_bindir}/kwrite
  165. %{_datadir}/kde4/apps/kwrite
  166. %{_libdir}/libkdeinit4_kwrite.so
  167. %{_datadir}/applications/kde4/kwrite.desktop
  168. %{_datadir}/doc/HTML/en/kwrite/
  169. %changelog
  170. * Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  171. - new upstream release
  172. * Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
  173. - new upstream release
  174. * Mon Aug 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
  175. - Initial build for Vine Linux
  176. * Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
  177. - 4.7.0
  178. * Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
  179. - first try