openssl-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 10
  3. %define version 1.0.1e
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. # Source6: openssl-%{version}.pc
  14. Patch0: openssl-1.0.0-soversion.patch
  15. Patch2: openssl-1.0.0-rpm_opt.patch
  16. Patch4: openssl-1.0.0-enginesdir.patch
  17. Patch5: openssl-0.9.8j-version-add-engines.patch
  18. # security fix
  19. # nothing ;-)
  20. License: BSDish
  21. Group: System Environment/Libraries
  22. URL: http://www.openssl.org/
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl, sed
  25. BuildRequires: zlib-devel, krb5-devel
  26. Requires: mktemp
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: daisuke, iwamoto
  30. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  31. %description
  32. The OpenSSL certificate management tool and the shared libraries that
  33. provide various cryptographic algorithms and protocols.
  34. %package devel
  35. Summary: OpenSSL libraries and development headers.
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: krb5-devel
  39. %description devel
  40. The static libraries and include files needed to compile apps
  41. with support for various the cryptographic algorithms and protocols
  42. supported by OpenSSL.
  43. Patches for many networking apps can be found at:
  44. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  45. %package static
  46. Summary: Libraries for static linking of applications which will use OpenSSL
  47. Group: Development/Libraries
  48. Requires: %{name}-devel = %{version}-%{release}
  49. %description static
  50. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  51. package contains static libraries needed for static linking of
  52. applications which support various cryptographic algorithms and
  53. protocols.
  54. %package perl
  55. Summary: OpenSSL scripts which require Perl.
  56. Group: Applications/Internet
  57. Requires: perl
  58. Requires: %{name} = %{version}-%{release}
  59. %description perl
  60. Perl scripts provided with OpenSSL for converting certificates and keys
  61. from other formats to those used by OpenSSL.
  62. ## to build compat32 for x86_64 architecture support
  63. %package -n compat32-%{name}
  64. Summary: Secure Sockets Layer Toolkit
  65. Group: System Environment/Libraries
  66. Requires: %{name} = %{version}-%{release}
  67. %description -n compat32-%{name}
  68. The OpenSSL certificate management tool and the shared libraries that
  69. provide various cryptographic algorithms and protocols.
  70. %package -n compat32-%{name}-devel
  71. Summary: OpenSSL libraries and development headers.
  72. Group: Development/Libraries
  73. Requires: compat32-%{name} = %{version}-%{release}
  74. Requires: compat32-krb5-devel
  75. %description -n compat32-%{name}-devel
  76. The static libraries and include files needed to compile apps
  77. with support for various the cryptographic algorithms and protocols
  78. supported by OpenSSL.
  79. %prep
  80. %setup -q -n openssl-%{version}
  81. %patch0 -p1 -b .soversion
  82. %patch2 -p1 -b .rpm_opt
  83. %patch4 -p1 -b .enginesdir
  84. %patch5 -p1 -b .version-add-engines
  85. # security fix
  86. # nothing ;-)
  87. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  88. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  89. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  90. chmod 644 doc/ssleay.txt
  91. # Link the configuration header to the one we're going to make.
  92. ln -sf ../../crypto/opensslconf.h include/openssl/
  93. %build
  94. PATH=${PATH}:${PWD}/bin
  95. TOPDIR=${PWD}
  96. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  97. # Modify the various perl scripts to reference perl in the right location.
  98. perl util/perlpath.pl `dirname %{__perl}`
  99. # Generate a table with the compile settings for my perusal.
  100. touch Makefile
  101. make TABLE PERL=%{__perl}
  102. # Figure out which flags we want to use.
  103. # default
  104. sslarch=%{_os}-%{_target_cpu}
  105. #
  106. %ifarch %ix86
  107. sslarch=linux-elf
  108. if ! echo %{_target} | grep -q i686 ; then
  109. sslflags="no-asm 386"
  110. fi
  111. %endif
  112. %ifarch sparcv9
  113. sslarch=linux-sparcv9
  114. sslflags=no-asm
  115. %endif
  116. %ifarch sparc64
  117. sslarch=linux64-sparcv9
  118. sslflags=no-asm
  119. %endif
  120. %ifarch alpha alphaev56 alphaev6 alphaev67
  121. sslarch=linux-alpha-gcc
  122. %endif
  123. %ifarch s390 sh3eb sh4eb
  124. sslarch="linux-generic32 -DB_ENDIAN"
  125. %endif
  126. %ifarch s390x
  127. sslarch="linux64-s390x"
  128. %endif
  129. %ifarch %{arm} sh3 sh4
  130. sslarch=linux-generic32
  131. %endif
  132. # ia64/x86_64/ppc\ppc64 are OK by default.
  133. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  134. # usable on all platforms. The Configure script already knows to use -fPIC and
  135. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  136. ./Configure \
  137. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  138. zlib-dynamic enable-camellia enable-seed enable-tlsext \
  139. enable-rfc3779 enable-cms enable-md2 \
  140. --enginesdir=%{_libdir}/openssl/engines \
  141. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  142. shared ${sslarch}
  143. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  144. # marked as not requiring an executable stack.
  145. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  146. make depend
  147. make all build-shared
  148. # Generate hashes for the included certs.
  149. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  150. export LD_LIBRARY_PATH
  151. make rehash build-shared
  152. # Verify that what was compiled actually works.
  153. make -C test apps tests
  154. # Relink the main binary to get it dynamically linked.
  155. rm apps/openssl
  156. make all build-shared
  157. %install
  158. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  159. # Install OpenSSL.
  160. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  161. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  162. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  163. # added for lib64
  164. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  165. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
  166. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  167. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  168. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  169. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  170. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  171. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  172. chmod 755 ${lib}
  173. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  174. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  175. done
  176. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  177. # Install a makefile for generating keys and self-signed certs, and a script
  178. # for generating them on the fly.
  179. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  180. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  181. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  182. # Make sure we actually include the headers we built against.
  183. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  184. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  185. install -m644 include/openssl/`basename ${header}` ${header}
  186. fi
  187. done
  188. # Rename man pages so that they don't conflict with system man pages. We used
  189. # to change the file extensions, but that only prevents file conflicts. The
  190. # man viewer still can't select either of the two unless we physically change
  191. # the directory.
  192. for section in 1 2 3 4 5 6 7 8 ; do
  193. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  194. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  195. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  196. fi
  197. done
  198. # Pick a CA script.
  199. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  200. mv CA.sh CA
  201. popd
  202. # Install root CA stuffs.
  203. cat %{SOURCE3} > ca-bundle.crt
  204. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  205. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  206. # Fix libdir.
  207. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  208. # sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  209. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  210. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  211. # cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  212. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  213. # rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  214. # remove file
  215. ## moved docdir in openssl-perl sub package from 1.0.0c-3
  216. %__rm -f $RPM_BUILD_ROOT%{_datadir}/ssl/misc/tsget
  217. %clean
  218. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  219. %files
  220. %defattr(-,root,root)
  221. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  222. %doc doc/README doc/c-indentation.el doc/openssl.txt
  223. %doc doc/openssl_button.html doc/openssl_button.gif
  224. %doc doc/ssleay.txt
  225. %dir %{_datadir}/ssl
  226. %{_datadir}/ssl/certs
  227. %{_datadir}/ssl/cert.pem
  228. %{_datadir}/ssl/misc/CA
  229. %{_datadir}/ssl/misc/c_*
  230. %{_datadir}/ssl/private
  231. %config(noreplace) %{_datadir}/ssl/openssl.cnf
  232. %attr(0755,root,root) %{_bindir}/openssl
  233. %attr(0755,root,root) /%{_lib}/*.so.*
  234. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  235. %attr(0755,root,root) %dir %{_mandir}/man1*
  236. %attr(0644,root,root) %{_mandir}/man1*/*
  237. %attr(0755,root,root) %dir %{_mandir}/man5*
  238. %attr(0644,root,root) %{_mandir}/man5*/*
  239. %attr(0755,root,root) %dir %{_mandir}/man7*
  240. %attr(0644,root,root) %{_mandir}/man7*/*
  241. %files devel
  242. %defattr(-,root,root)
  243. %{_prefix}/include/openssl
  244. %exclude %{_libdir}/lib*.a
  245. %attr(0755,root,root) %{_libdir}/*.so
  246. %attr(0755,root,root) %dir %{_mandir}/man3*
  247. %attr(0644,root,root) %{_mandir}/man3*/*
  248. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  249. %files static
  250. %defattr(-,root,root)
  251. %attr(0644,root,root) %{_libdir}/*.a
  252. %files perl
  253. %defattr(-,root,root)
  254. %attr(0755,root,root) %{_bindir}/c_rehash
  255. %attr(0755,root,root) %dir %{_mandir}/man1*
  256. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  257. %{_datadir}/ssl/misc/*.pl
  258. # %{_datadir}/ssl/misc/tsget
  259. %doc apps/tsget
  260. ## to build compat32 for x86_64 architecture support
  261. %if %{build_compat32}
  262. %files -n compat32-%{name}
  263. %defattr(-,root,root)
  264. %attr(0755,root,root) /%{_lib}/*.so.*
  265. %files -n compat32-%{name}-devel
  266. %defattr(-,root,root)
  267. %exclude %{_libdir}/lib*.a
  268. %attr(0755,root,root) %{_libdir}/*.so
  269. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  270. %endif
  271. %post -p /sbin/ldconfig
  272. %postun -p /sbin/ldconfig
  273. %post -n compat32-%{name} -p /sbin/ldconfig
  274. %postun -n compat32-%{name} -p /sbin/ldconfig
  275. %changelog
  276. * Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
  277. - update to 1.0.1e
  278. - 1.0.1d has major regressions from 1.0.1c
  279. * Sat Feb 9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
  280. - remove tsget script to delete dependency perl(WWW::Curl::Easy)
  281. - openssl-perl package contains it in docdir
  282. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
  283. - new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
  284. - fixed %%files
  285. * Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
  286. - update to 1.0.1c
  287. - enable configure options:
  288. enable-camellia enable-seed enable-tlsext enable-rfc3779
  289. enable-cms enable-md2
  290. - remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  291. - generate a table with the compile settings before configure
  292. * Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
  293. - new upstream release with security fix (CVE-2012-0050)
  294. * Fri Jan 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
  295. - new upstream release with security fix
  296. (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
  297. * Wed Sep 7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
  298. - new upstream release with security fix (CVE-2011-3207, 3210)
  299. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  300. - rebuild with krb5-libs 1.8
  301. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  302. - new upstream release with security fix
  303. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  304. - use upstream openssl.pc instead of vine original one (SOURCE6)
  305. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  306. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  307. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  308. - add R: krb5-devel into devel pkg
  309. - add R: compat32-krb5-devel into compat32-devel pkg
  310. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  311. - new upstream release 1.0.0x
  312. - separate static libs into static package
  313. - change configure options
  314. - change so version 10
  315. - add tsget into perl package
  316. - update all patches
  317. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  318. - fix changelog typo...
  319. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  320. - new upstream release with security fix (CVE-2010-4180)
  321. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  322. - new upstream release with security fix (CVE-2010-3864)
  323. - drop patches included in new release
  324. - update patch4
  325. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  326. - add patch12 for fix CVE-2009-3555 (renegotiation)
  327. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  328. - add patch11 for fix CVE-2009-4355 (memory leak)
  329. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  330. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  331. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  332. - removed unnecessary %%if %{build_compat32} statements
  333. - removed lib*.a from devel package
  334. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  335. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  336. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  337. - new upstream release with security fix (CVE-2008-5077)
  338. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  339. - new upstream release
  340. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  341. - new upstream release
  342. - new versioning policy
  343. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  344. - new upstream release
  345. - drop patch10,20 which is merged in upstream
  346. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  347. - add security patch in advance for CVE-2007-5135
  348. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  349. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  350. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  351. - add security patch for CVE-2007-3108
  352. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  353. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  354. - new upstream release
  355. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  356. - update (fix) openssl.pc <BTS:437>
  357. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  358. - new upstream release (with security fix)
  359. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  360. - new upstream release
  361. - add patch2 to use RPM_OPT macro
  362. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  363. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  364. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  365. - added compat32-* packages for x86_64 architecture support
  366. - added openssl-0.9.7i.Configure-compat32.patch
  367. - changed '/lib' to '/%{_lib}'
  368. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  369. - new upstream release
  370. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  371. - rebuild on VineSeed
  372. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  373. - added a security patch from Gentoo.
  374. - Patch1: openssl-0.9.7c-tempfile.patch
  375. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  376. - sslarch for ppc was missing... added.
  377. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  378. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  379. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  380. - new upstream version
  381. - clean up of spec file
  382. -- removed old patches
  383. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  384. - new upstream release
  385. - SECURITY fix.
  386. - http://www.openssl.org/news/secadv_20040317.txt
  387. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  388. - new upstream release
  389. - [Security fix]
  390. - Vulnerabilities in ASN.1 parsing
  391. http://www.openssl.org/news/secadv_20030930.txt
  392. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  393. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  394. - add openssl.pc for pkgconfig
  395. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  396. - New upstream version
  397. - dropped patch10, 11
  398. -- merged upstream version
  399. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  400. - rebuild for VineSeed
  401. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  402. - [Security Fix]
  403. - Timing-based attacks on RSA keys
  404. http://www.openssl.org/news/secadv_20030317.txt
  405. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  406. http://www.openssl.org/news/secadv_20030317.txt
  407. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  408. - new upstream release 0.9.6i
  409. - [Security Fix]
  410. - build for Vine Linux 2.6 errata
  411. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  412. - new upstream release 0.9.6h
  413. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  414. - new upstream release 0.9.6g
  415. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  416. - SECURITY: CAN-2002-0659 fixed
  417. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  418. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  419. - update asn patch to fix accidental reversal of a logic check
  420. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  421. - update asn patch to reduce chance that compiler optimization will remove
  422. one of the added tests
  423. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  424. - rebuild
  425. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  426. - add patch to fix ASN.1 vulnerabilities
  427. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  428. - rename spec file name
  429. - SECURITY: CA-2002-23 fixed
  430. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  431. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  432. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  433. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  434. - added ${PATH} in LD_LIBRARY_PATH
  435. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  436. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  437. - remove --no-<cipher>
  438. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  439. - add Patch10 for mipsel shared ( Configure )
  440. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  441. - build for Vine Linux
  442. - use openssl-engine-0.9.6b.tar.gz
  443. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  444. - update to 0.9.6b
  445. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  446. - move .so symlinks back to %%{_libdir}
  447. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  448. - move shared libraries to /lib (#38410)
  449. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  450. - switch to engine code base
  451. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  452. - add a script for creating dummy certificates
  453. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  454. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  455. - add s390x support
  456. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  457. - change two memcpy() calls to memmove()
  458. - don't define L_ENDIAN on alpha
  459. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  460. - make subpackages depend on the main package
  461. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  462. - adjust the hobble script to not disturb symlinks in include/ (fix from
  463. Joe Orton)
  464. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  465. - drop the m2crypo patch we weren't using
  466. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  467. - configure using "shared" as well
  468. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  469. - update to 0.9.6a
  470. - use the build-shared target to build shared libraries
  471. - bump the soversion to 2 because we're no longer compatible with
  472. our 0.9.5a packages or our 0.9.6 packages
  473. - drop the patch for making rsatest a no-op when rsa null support is used
  474. - put all man pages into <section>ssl instead of <section>
  475. - break the m2crypto modules into a separate package
  476. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  477. - use BN_LLONG on s390
  478. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  479. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  480. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  481. - move c_rehash to the perl subpackage, because it's a perl script now
  482. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  483. - update to 0.9.6
  484. - enable MD2
  485. - use the libcrypto.so and libssl.so targets to build shared libs with
  486. - bump the soversion to 1 because we're no longer compatible with any of
  487. the various 0.9.5a packages circulating around, which provide lib*.so.0
  488. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  489. - change hobble-openssl for disabling MD2 again
  490. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  491. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  492. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  493. apps built against a version of the library without it
  494. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  495. - disable some inline assembly, which on x86 is Pentium-specific
  496. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  497. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  498. - fix s390 patch
  499. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  500. - added support s390
  501. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  502. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  503. - add the CA.pl man page to the perl subpackage
  504. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  505. - always build with -mcpu=ev5 on alpha
  506. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  507. - add a symlink from cert.pem to ca-bundle.crt
  508. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  509. - add a ca-bundle file for packages like Samba to reference for CA certificates
  510. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  511. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  512. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  513. - add unzip as a buildprereq (#17662)
  514. - update m2crypto to 0.05-snap4
  515. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  516. - fix some issues in building when it's not installed
  517. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  518. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  519. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  520. - add Richard Henderson's patch for BN on ia64
  521. - clean up the changelog
  522. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  523. - fix the building of python modules without openssl-devel already installed
  524. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  525. - byte-compile python extensions without the build-root
  526. - adjust the makefile to not remove temporary files (like .key files when
  527. building .csr files) by marking them as .PRECIOUS
  528. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  529. - break out python extensions into a subpackage
  530. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  531. - tweak the makefile some more
  532. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  533. - disable MD2 support
  534. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  535. - disable MDC2 support
  536. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  537. - tweak the disabling of RC5, IDEA support
  538. - tweak the makefile
  539. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  540. - strip binaries and libraries
  541. - rework certificate makefile to have the right parts for Apache
  542. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  543. - use %%{_perl} instead of /usr/bin/perl
  544. - disable alpha until it passes its own test suite
  545. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  546. - move the passwd.1 man page out of the passwd package's way
  547. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  548. - update to 0.9.5a, modified for U.S.
  549. - add perl as a build-time requirement
  550. - move certificate makefile to another package
  551. - disable RC5, IDEA, RSA support
  552. - remove optimizations for now
  553. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  554. - Bero told me to move the Makefile into this package
  555. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  556. - add lib*.so symlinks to link dynamically against shared libs
  557. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  558. - update to 0.9.5
  559. - run ldconfig directly in post/postun
  560. - add FAQ
  561. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  562. - Fix build on non-x86 platforms
  563. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  564. - move /usr/share/ssl/* from -devel to main package
  565. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  566. - inital packaging
  567. - changes from base:
  568. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  569. - handle RPM_OPT_FLAGS