rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 0.13.3
  8. Release: 4%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-0.13.3-git20110809.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: avahi-glib-devel >= 0.6
  17. BuildRequires: brasero-devel >= 2.32.0
  18. BuildRequires: dbus-devel >= 1.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gnome-vfs2-devel >= 2.18.0
  21. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  22. BuildRequires: gstreamer-python-devel
  23. BuildRequires: json-glib-devel
  24. BuildRequires: libSM-devel
  25. BuildRequires: libffi-devel
  26. BuildRequires: libgnome-keyring-devel >= 2.30.0
  27. BuildRequires: libgnome-media-profiles-devel
  28. BuildRequires: libgnomeui-devel >= 2.18.0
  29. BuildRequires: libgpod-devel
  30. BuildRequires: libgudev1-devel
  31. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  32. BuildRequires: libnotify-devel
  33. BuildRequires: libsexy-devel
  34. BuildRequires: libsoup-devel
  35. BuildRequires: popt-devel
  36. BuildRequires: python-devel, pygtk2-devel
  37. BuildRequires: sqlite3-devel
  38. BuildRequires: totem-pl-parser-devel
  39. BuildRequires: WebKit3-gtk-devel
  40. BuildRequires: libpeas-devel
  41. BuildRequires: clutter-gtk-devel
  42. BuildRequires: clutter-gst-devel
  43. BuildRequires: libmx-devel
  44. BuildRequires: check >= 0.8.2
  45. BuildRequires: gettext, rarian-compat
  46. BuildRequires: gnome-doc-utils >= 0.3.2
  47. BuildRequires: intltool >= 0.35.0
  48. BuildRequires: libmtp-devel
  49. BuildRequires: lirc
  50. Requires: libgpod
  51. Requires: libnotify
  52. Requires: libsexy
  53. Requires: lirc
  54. Requires: libmtp
  55. Requires: libgnomeui
  56. Requires: brasero
  57. Requires: gnome-python gnome-vfs2
  58. Requires: gnome-themes
  59. Requires: libgnome-keyring
  60. Requires: gstreamer-python
  61. %if %{enable_DLNA_UPnP}
  62. Requires: python-Coherence
  63. %endif
  64. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  65. Requires: scrollkeeper GConf2
  66. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  67. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  68. # # respectively.
  69. # Requires: self-build-gstreamer-plugins-ffmpeg
  70. # Requires: self-build-gstreamer-plugins-ugly
  71. Vendor: Project Vine
  72. Distribution: Vine Linux
  73. %description
  74. Rhythmbox is an integrated music management application based on the powerful
  75. GStreamer media framework. It has a number of features, including an easy to
  76. use music browser, searching and sorting, comprehensive audio format support
  77. through GStreamer, Internet Radio support, playlists and more.
  78. Rhythmbox is extensible through a plugin system.
  79. %description -l ja
  80. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  81. 統合音楽管理アプリケーションです。
  82. 見やすいユーザインターフェースを備え、検索や整列ができ、
  83. GStreamer により数多くの音声フォーマットをサポート、
  84. インターネットラジオをサポート、プレイリスト管理などの
  85. 数多くの特徴を持ちます。
  86. %package devel
  87. Summary: Development tools for rhythmbox applications.
  88. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  89. Group: Development/Libraries
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: pkgconfig
  92. Requires: glib2-devel
  93. Requires: gtk2-devel
  94. Requires: libsoup-devel
  95. Requires: libgnome-media-profiles-devel
  96. Requires: totem-pl-parser-devel
  97. Requires: gstreamer-devel
  98. %description devel
  99. Header files and libraries for building a extension library for the rhythmbox.
  100. %description devel -l ja
  101. %prep
  102. %setup -q
  103. %patch0 -p1 -b .git20110730
  104. tar xjf %{SOURCE101}
  105. # Use the installed louie, not the one in Coherence
  106. find plugins/coherence/upnp_coherence/ -type f \
  107. -exec %__sed -i 's/coherence.extern.louie as louie/louie/' '{}' ';'
  108. %build
  109. # work around a gstreamer bug
  110. /usr/bin/gst-inspect-0.10 --print-all >& /dev/null || :
  111. libtoolize --force --copy
  112. autoreconf
  113. %configure --with-ipod \
  114. --with-mtp \
  115. --with-mdns=avahi \
  116. --with-libnautilus-burn \
  117. --enable-lirc \
  118. --enable-python \
  119. --disable-vala \
  120. --disable-browser-plugin \
  121. --disable-static \
  122. --disable-scrollkeeper \
  123. --disable-schemas-install \
  124. --without-hal
  125. %__make %{?_smp_mflags}
  126. %install
  127. %__rm -rf $RPM_BUILD_ROOT
  128. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  129. %__make install DESTDIR=$RPM_BUILD_ROOT
  130. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  131. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  132. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  133. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  134. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  135. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  136. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  137. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  138. ## Don't package DLNA/UPnP plugin
  139. %if !%{enable_DLNA_UPnP}
  140. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  141. %endif
  142. %find_lang %{name}
  143. # Don't package api docs
  144. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  145. # Don't package scrollkeeper catalogs
  146. %__rm -rf $RPM_BUILD_ROOT%{_localstatedir}
  147. # And don't package vala
  148. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  149. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  150. # save space by linking identical images in translated docs
  151. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  152. for f in $helpdir/C/figures/*.png; do
  153. b="$(basename $f)"
  154. for d in $helpdir/*; do
  155. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  156. g="$d/figures/$b"
  157. if [ -f "$g" ]; then
  158. if cmp -s $f $g; then
  159. %__rm "$g"; ln -s "../../C/figures/$b" "$g"
  160. fi
  161. fi
  162. fi
  163. done
  164. done
  165. %clean
  166. %__rm -rf $RPM_BUILD_ROOT
  167. %post
  168. /sbin/ldconfig
  169. update-desktop-database -q
  170. scrollkeeper-update -q
  171. touch --no-create %{_datadir}/icons/hicolor
  172. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  173. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  174. fi
  175. %postun
  176. /sbin/ldconfig
  177. update-desktop-database -q
  178. scrollkeeper-update -q
  179. touch --no-create %{_datadir}/icons/hicolor
  180. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  181. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  182. fi
  183. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  184. %posttrans
  185. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  186. %files -f %{name}.lang
  187. %defattr(-, root, root)
  188. %doc AUTHORS COPYING ChangeLog README NEWS
  189. %{_bindir}/*
  190. %{_libdir}/girepository-1.0/*.typelib
  191. %{_libdir}/lib*.so.*
  192. %{_libdir}/rhythmbox/plugins
  193. %{_datadir}/applications/rhythmbox.desktop
  194. %{_datadir}/applications/rhythmbox-device.desktop
  195. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox.service
  196. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  197. %{_datadir}/gnome/help/rhythmbox
  198. %{_datadir}/icons/*
  199. %{_datadir}/omf/rhythmbox
  200. %{_datadir}/rhythmbox
  201. %{_mandir}/man1/*
  202. %{_libexecdir}/rhythmbox-metadata
  203. %files devel
  204. %defattr(-, root, root)
  205. %{_includedir}/%{name}/*
  206. %{_libdir}/*.so
  207. %{_libdir}/pkgconfig/*.pc
  208. %{_datadir}/gir-1.0/*.gir
  209. %changelog
  210. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  211. - rebuild with cogl-0.8.0
  212. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  213. - rebuild with libnotify-0.7
  214. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  215. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  216. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  217. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  218. - add Source101 (rhythmbox-png.tar.bz2)
  219. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  220. - add BuildRequires: json-glib-devel
  221. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  222. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  223. - new upstream release
  224. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  225. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  226. - new upstream release
  227. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  228. - rebuild with brasero-2.32.0
  229. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  230. - rebuild with rpm-4.8.1 for pkg-config file
  231. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  232. - new upstream release
  233. - fix %files (add rhythmbox-device.desktop)
  234. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  235. - new upstream release
  236. - change BuildRequires: gnome-media-devel instead of gnome-media
  237. - add devel package
  238. - drop Patch0
  239. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  240. - new upstream release
  241. - drop Patch1, Patch2, Patch3
  242. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  243. - change Requires: nautilus-cd-burner -> brasero
  244. - change BuildRequires: hal-devel -> libgudev1-devel
  245. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  246. - change Requires: gnome-keyring -> libgnome-keyring
  247. - add configure option (--without-hal)
  248. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  249. - rebuilt with new environment
  250. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  251. - new upstream release
  252. - dropped upstreamed/obsolete patches
  253. - added patches applied Fedora development
  254. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  255. - new upstream release
  256. - added configure options:
  257. --disable-vala
  258. --disable-browser-plugin
  259. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  260. - added Japanese description
  261. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  262. - new upstream release
  263. - dropped rb-disable-power-plugin-by-default.patch
  264. - added BuildRequires:
  265. - libSM-devel
  266. - gnome-media
  267. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  268. - rebuild with libgpod-0.7.2
  269. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  270. - new upstream release
  271. - corrected License tag
  272. - dropped rhythmbox-0.11.6-libmtp.patch
  273. - added BuildRequires:
  274. - sqlite3-devel
  275. - libffi-devel
  276. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  277. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  278. - applied rhythmbox-0.11.6-libmtp.patch
  279. - added Requires:
  280. - libgpod
  281. - libnotify
  282. - libsexy
  283. - lirc
  284. - libmtp
  285. - libgnomeui
  286. - nautilus-cd-burner
  287. - gstreamer-python
  288. - gnome-vfs2
  289. - gnome-themes
  290. - gnome-keyring
  291. - python-Coherence, if enable_DLNA_UPnP = 1
  292. - added BuildRequires:
  293. - libnotify-devel
  294. - libsexy-devel
  295. - lirc
  296. - libmtp-devel
  297. - gnome-vfs2-devel, instead of gnome-vfs2
  298. - gnome-keyring-devel
  299. - dropped --with-internal-libsexy in configure options
  300. - added in configure options:
  301. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  302. - added %%preun to remove the schema
  303. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  304. - new upstream release
  305. - changed to --with-metadata-helper in configure options
  306. - added BuildRequires:
  307. - gstreamer-python
  308. - intltool >= 0.35.0
  309. - popt-devel
  310. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  311. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  312. - rebuilt with python-2.5.2
  313. - applied new versioning policy
  314. - spec in utf-8
  315. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  316. - rebuilt with libgpod-0.6.0
  317. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  318. - new upstream release
  319. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  320. - new upstream release
  321. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  322. - rebuilt with new toolchain and libgpod-0.4.2
  323. - add BuildRequires: dbus-glib-devel
  324. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  325. - new upstream release
  326. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  327. - rebuilt for VineSeed
  328. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  329. - new upstream release
  330. - added --enable-python option to %%configure
  331. - added Requires: gnome-python
  332. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  333. - new upstream release
  334. - built with libsoup 2.2.99
  335. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  336. - added --with-cd-burner to configure
  337. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  338. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  339. - add BuildRequires:
  340. - gnome-doc-utils >= 0.3.2
  341. - python-devel
  342. - pygtk2-devel
  343. - check >= 0.8.2
  344. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  345. - rebuild with gnutls-1.4.1
  346. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  347. - new upstream release
  348. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  349. - new upstream release
  350. - run scrollkeeper-update at %post and %postun
  351. - added BuildRequires: libnotify-devel
  352. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  353. - new upstream release (dropped patch0)
  354. - added --without-metadata-helper at configure
  355. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  356. - Initial build for Vine Linux based on FC pacakge
  357. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  358. - add patch from James "Doc" Livingston to stop a hang
  359. for new users (bug 183883)
  360. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  361. - bump again for double-long bug on ppc(64)
  362. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  363. - rebuilt for new gcc4.1 snapshot and glibc changes
  364. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  365. - Update to 0.9.3.1
  366. - Use gstreamer (0.10)
  367. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  368. - Remove hack for 173869, as its no longer needed.
  369. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  370. - 0.9.3
  371. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  372. - Newer CVS snapshot
  373. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  374. - Update to latest CVS
  375. - Add hack to workaround bug #173869
  376. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  377. - Rebuild, now that gstreamer08-plugins has been fixed
  378. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  379. - bonobo multilib issue (bug 156982)
  380. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  381. - rebuild with ipod support
  382. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  383. - rebuilt again
  384. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  385. - rebuilt
  386. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  387. - rebuild
  388. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  389. - rebuild for new dbus
  390. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  391. - Update to 0.9.2
  392. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  393. - Update to 0.9.1
  394. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  395. - Add configure flags --with-bonobo --with-dbus
  396. - BR nautilus-cd-burner-devel
  397. - New upstream CVS snapshot for testing
  398. - Drop IDL file and ui .xml
  399. - Add dbus service file
  400. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  401. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  402. * Fri Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  403. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  404. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  405. cell renderer for playback icon (no longer necessary) and
  406. changes the rating renderer to work with non-b&w icons
  407. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  408. - Rebuild for GCC4
  409. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  410. - New upstream version
  411. - Remove librb-nautilus-context-menu.so, killed upstream
  412. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  413. - PreReq desktop-file-utils >= 0.9
  414. * Sat Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  415. - New upstream version
  416. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  417. - Fix postun to use correct syntax, thanks Nils Philippsen
  418. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  419. - New upstream version
  420. - Call update-desktop-database in post and postun
  421. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  422. - New upstream version
  423. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  424. - rebuilt
  425. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  426. - New upstream version
  427. - Remove backported patches
  428. - Gratuitiously bump various BuildRequires versions
  429. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  430. - Remove code to unregister GConf schema for now (Closes: #122532)
  431. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  432. - Apply tiny patch from 0.8 arch to fix GConf key used
  433. for initial sorting
  434. * Thu May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  435. - Apply patch from 0.8 arch tree to fix a number of memleaks
  436. * Thu May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  437. - Update to 0.8.3: fixes showstopper bug with internet radio
  438. * Thu Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  439. - Update to 0.8.2
  440. - Fix Source url
  441. - Add smp_mflags
  442. - Bump BuildRequires on gstreamer to 0.8.1
  443. * Tue Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  444. - Uninstall GConf schemas on removal
  445. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  446. - Update to 0.8.1
  447. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  448. - Update to 0.8.0
  449. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  450. - Update to 0.7.2
  451. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  452. - Remove BuildRequires on autoconf and libvorbis-devel
  453. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  454. - New major version - I know we are past major version slush, but
  455. this should have been done two weeks ago along with the GNOME 2.6
  456. upload. As upstream author as well, I believe this version is
  457. good enough for FC2.
  458. - Remove --disable-mp3
  459. - Remove id3, flac variables
  460. - Remove GStreamer major version patch
  461. - Fix typo in description
  462. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  463. - rebuild for new gstreamer
  464. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  465. - update to 0.6.8
  466. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  467. - rebuilt
  468. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  469. - update to 0.6.7
  470. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  471. - rebuilt
  472. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  473. - New upstream version
  474. - Don't re-run the autotools; upstream incorporates newer versions.
  475. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  476. - new version
  477. - remove smp_flags
  478. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  479. - remove the initial iradio channels as they all are mp3 based.
  480. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  481. - Fix category from Development/Libraries to Applications/Multimedia.
  482. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  483. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  484. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  485. - Removed unnecessary date expansion define.
  486. - Updated description, including mp3 reference removal.
  487. - Added libid3tag and flac optional support for convenient rebuild.
  488. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  489. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  490. - new version
  491. - use %{_sysconfdir} instead of /etc
  492. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  493. - rebuilt
  494. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  495. - gave up on other archs for the Beta
  496. - new version
  497. - remove werror and add missing files
  498. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  499. - update to newer cvs snap
  500. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  501. - update to cvs snap
  502. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  503. - use %%(lang)
  504. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  505. - fix post to actually install the schema
  506. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  507. - Added gconf file
  508. - Added i18n directory
  509. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  510. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  511. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  512. - removed bonobo dependency
  513. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  514. - created new spec file