wine-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793
  1. %define pkg_major_version 1.6.1
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. # explain how to use wine with pulseaudio
  35. Source402: README-FEDORA-PULSEAUDIO
  36. Patch400: http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
  37. Patch401: http://art.ified.ca/downloads/winepulse-0.30.patch
  38. Patch402: http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
  39. Patch0: wine-prefixfonts.patch
  40. Patch1: wine-1.1.28-rpath.patch
  41. Patch2: wine-1.6-x86_64_gstreamer.patch
  42. # ADD ja
  43. Source801: wine_README.ja
  44. Source802: README-FEDORA-PULSEAUDIO.ja
  45. Source803: wine-README-Fedora.ja
  46. Source804: wine_README_add.ja
  47. Source805: fonts-replace-list.txt
  48. Source806: ja_fonts_replace-js2ipa.reg
  49. Source807: ja_fonts_replace-js2vl.reg
  50. Source808: ja_fonts_replace-ms2ipa.reg
  51. Source809: ja_fonts_replace-ms2vl.reg
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: daisuke, Takemikaduchi
  55. ExclusiveArch: %{ix86} x86_64
  56. #--------------------------------------------------------------------
  57. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  58. #--------------------------------------------------------------------
  59. ## FedoraCore ##
  60. BuildRequires: bison, flex
  61. BuildRequires: audiofile, audiofile-devel
  62. BuildRequires: alsa-lib-devel
  63. BuildRequires: freeglut-devel, lcms-devel
  64. ## BuildRequires: libieee1284-devel
  65. BuildRequires: libjpeg-devel, libpng-devel
  66. BuildRequires: libstdc++-devel
  67. BuildRequires: libusb-devel
  68. BuildRequires: libxml2-devel, libxslt-devel
  69. BuildRequires: openldap-devel, ncurses-devel
  70. BuildRequires: unixODBC-devel, openssl-devel
  71. # BuildRequires: sane-devel
  72. BuildRequires: zlib-devel
  73. BuildRequires: desktop-file-utils
  74. BuildRequires: fontforge
  75. ## BuildRequires: gphoto2, gphoto2-devel
  76. ## BuildRequires: jack-audio-connection-kit-devel
  77. ## BuildRequires: isdn4k-utils-devel
  78. BuildRequires: cups-devel
  79. BuildRequires: dbus-devel
  80. BuildRequires: gstreamer-plugins-base-devel
  81. ## Requires: %{_bindir}/xmessage
  82. ## X modular(fc) > X 7.2
  83. BuildRequires: libX11-devel
  84. BuildRequires: mesa-libGL-devel, mesa-libGLU-devel
  85. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  86. BuildRequires: libXrandr-devel
  87. BuildRequires: libXrender-devel
  88. BuildRequires: libXext-devel
  89. BuildRequires: libXinerama-devel
  90. BuildRequires: libXcomposite-devel
  91. BuildRequires: libXmu-devel
  92. BuildRequires: libXi-devel
  93. BuildRequires: libXcursor-devel
  94. BuildRequires: fontconfig-devel
  95. BuildRequires: giflib-devel
  96. BuildRequires: libtiff-devel
  97. BuildRequires: pkgconfig
  98. BuildRequires: libicu-devel
  99. BuildRequires: freetype2-devel
  100. %ifarch x86_64
  101. BuildRequires: compat32-glibc-devel
  102. BuildRequires: compat32-glibc-devel
  103. BuildRequires: compat32-libX11-devel
  104. BuildRequires: compat32-libxcb-devel
  105. BuildRequires: compat32-freetype2-devel
  106. BuildRequires: compat32-libSM-devel
  107. BuildRequires: compat32-libXext-devel
  108. BuildRequires: compat32-libXrender-devel
  109. BuildRequires: compat32-mesa-libGL-devel
  110. BuildRequires: compat32-mesa-libGLU-devel
  111. BuildRequires: compat32-libxml2-devel
  112. BuildRequires: compat32-libxslt-devel
  113. BuildRequires: compat32-openssl-devel
  114. BuildRequires: compat32-libjpeg-devel
  115. BuildRequires: compat32-libpng-devel
  116. BuildRequires: compat32-zlib-devel
  117. BuildRequires: compat32-alsa-lib-devel
  118. BuildRequires: compat32-dbus-devel
  119. BuildRequires: compat32-lcms-devel
  120. BuildRequires: compat32-cups-devel
  121. BuildRequires: compat32-gnutls-devel
  122. BuildRequires: compat32-gstreamer-devel
  123. BuildRequires: compat32-gstreamer-plugins-base-devel
  124. ## extension
  125. BuildRequires: compat32-libXcursor-devel
  126. BuildRequires: compat32-libXi-devel
  127. BuildRequires: compat32-libXxf86vm-devel
  128. BuildRequires: compat32-libXrandr-devel
  129. BuildRequires: compat32-libXinerama-devel
  130. BuildRequires: compat32-libXcomposite-devel
  131. BuildRequires: compat32-ncurses-devel
  132. BuildRequires: compat32-fontconfig-devel
  133. BuildRequires: compat32-libtiff-devel
  134. BuildRequires: compat32-openldap-devel
  135. Requires: compat32-freetype2
  136. Requires: compat32-ncurses
  137. %endif
  138. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  139. Requires(post): desktop-file-utils >= 0.8
  140. Requires(preun): /sbin/chkconfig, /sbin/service
  141. Requires(postun): /sbin/ldconfig
  142. Requires(postun): desktop-file-utils >= 0.8
  143. #--------------------------------------------------------------------
  144. %description
  145. (WINE Is Not an Emulator)
  146. While Wine is usually thought of as a Windows(TM) emulator,
  147. the Wine developers would prefer that users thought of
  148. Wine as a Windows compatibility layer for UNIX.
  149. This package includes a program loader, which allows
  150. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  151. x86_64 Unixes.
  152. Wine does not require MS Windows, but it can use native
  153. system .dll files if they are available.
  154. %description -l ja
  155. (WINE Is Not an Emulator)
  156. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  157. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  158. 互換レイヤー」と考えてくれる事を好むでしょう。
  159. このパッケージはプログラムローダーを含み、これは未修正の
  160. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  161. させます。
  162. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  163. Windows システムの .dll ファイルが存在するのならば、それを使用する
  164. 事もできます
  165. #--------------------------------------------------------------------
  166. %package devel
  167. Summary: Wine development environment
  168. Summary(ja): WINE の開発ファイルです
  169. Group: System Environment/Libraries
  170. Requires: wine = %{version}-%{release}
  171. %description devel
  172. This RPM contains the header files and development tools
  173. for the WINE libraries.
  174. %description devel -l ja
  175. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  176. アプリケーション(例:winebuild)のパッケージです
  177. (development packages)
  178. #--------------------------------------------------------------------
  179. %package init
  180. Summary: WINE binfmt_misc kernel function used for init file.
  181. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  182. Group: System Environment/Libraries
  183. Requires: wine = %{version}-%{release}
  184. %description init
  185. WINE binfmt_misc kernel function used for init file.
  186. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  187. (init.d packages)
  188. ** example **
  189. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  190. from the usual binary Linux as "$ /file/to/path/arege.exe"
  191. and just be able to run.
  192. Of course, please be mindful of security.
  193. %description init -l ja
  194. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  195. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  196. ようにします。
  197. (init.d packages)
  198. ※ 例 ※
  199. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  200. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  201. だけで実行できるようになります。
  202. 無論、セキュリティに留意して下さい。
  203. #--------------------------------------------------------------------
  204. %prep
  205. %setup -q -n %{name}-%{version}
  206. %ifarch x86_64
  207. %patch2 -p1
  208. %endif
  209. %patch401 -p1
  210. %build
  211. autoreconf -if
  212. %ifarch x86_64
  213. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  214. ./configure \
  215. --prefix=%{_prefix} \
  216. --libdir=%{_libdir} \
  217. --with-x \
  218. --without-jack \
  219. --without-capi \
  220. --without-gphoto \
  221. --without-hal \
  222. --without-mpg123 \
  223. --without-sane
  224. %else
  225. export CFLAGS="$RPM_OPT_FLAGS"
  226. %{configure} \
  227. --prefix=%{_prefix} \
  228. --with-x \
  229. --without-jack \
  230. --without-capi \
  231. --without-gphoto \
  232. --without-hal \
  233. --without-mpg123 \
  234. --without-sane
  235. %endif
  236. grep "have_x=yes" config.log || exit 1
  237. %{__make} depend
  238. %{__make} %{?_smp_mflags}
  239. %install
  240. rm -rf ${RPM_BUILD_ROOT}
  241. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  242. #-----------------------------------------------------------FC9
  243. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  244. # Allow users to launch Windows programs by just clicking on the .exe file...
  245. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  246. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  247. # add wine dir to desktop
  248. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  249. install -p -m 644 %{SOURCE200} \
  250. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  251. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  252. install -p -m 644 %{SOURCE201} \
  253. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  254. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  255. ## %%{_datadir}/applications
  256. # install desktop files
  257. desktop-file-install \
  258. --vendor=vine \
  259. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  260. %{SOURCE100}
  261. desktop-file-install \
  262. --vendor=vine \
  263. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  264. %{SOURCE101}
  265. desktop-file-install \
  266. --vendor=vine \
  267. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  268. %{SOURCE102}
  269. desktop-file-install \
  270. --vendor=vine \
  271. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  272. %{SOURCE103}
  273. desktop-file-install \
  274. --vendor=vine \
  275. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  276. %{SOURCE104}
  277. desktop-file-install \
  278. --vendor=vine \
  279. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  280. %{SOURCE105}
  281. desktop-file-install \
  282. --vendor=vine \
  283. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  284. %{SOURCE106}
  285. desktop-file-install \
  286. --vendor=vine \
  287. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  288. %{SOURCE107}
  289. desktop-file-install \
  290. --vendor=vine \
  291. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  292. --delete-original \
  293. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  294. #mime-types
  295. desktop-file-install \
  296. --vendor=vine \
  297. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  298. %{SOURCE300}
  299. ## other files
  300. cp %{SOURCE3} README-Fedora
  301. cp %{SOURCE803} README-Fedora.ja
  302. cp %{SOURCE801} documentation/README.ja
  303. cp %{SOURCE804} documentation/README_add.ja
  304. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  305. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  306. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  307. # deploy pulseaudio readme (802jp)
  308. cp %{SOURCE402} .
  309. cp %{SOURCE802} .
  310. # check desktop files
  311. %check
  312. desktop-file-validate \
  313. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  314. desktop-file-validate \
  315. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  316. desktop-file-validate \
  317. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  318. desktop-file-validate \
  319. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  320. desktop-file-validate \
  321. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  322. desktop-file-validate \
  323. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  324. desktop-file-validate \
  325. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  326. desktop-file-validate \
  327. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  328. desktop-file-validate \
  329. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  330. #--------------------------------------------------------------------
  331. %clean
  332. rm -rf ${RPM_BUILD_ROOT}
  333. %post
  334. /sbin/ldconfig
  335. update-desktop-database &>/dev/null || :
  336. ### add vinelinux
  337. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  338. echo "WINEのシステムフォントをリプレースするには"
  339. echo " fonts-replace-list.txt をお読み下さい。"
  340. else
  341. echo "You need to Japanese fonts name replace, "
  342. echo "See fonts-replace-list.txt ."
  343. fi
  344. %postun
  345. /sbin/ldconfig
  346. update-desktop-database &>/dev/null || :
  347. %post init
  348. if [ $1 = 1 ]; then
  349. /sbin/chkconfig --add wine
  350. /sbin/chkconfig --level 2345 wine on
  351. /sbin/service wine start &>/dev/null || :
  352. fi
  353. ### add vinelinux
  354. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  355. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  356. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  357. echo "(ファイル名は /etc/init.d/wine です)"
  358. echo "起動時にファイルシステムのマウントが必要です。"
  359. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  360. echo "(削除も手動でお願いします)"
  361. echo ""
  362. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  363. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  364. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  365. else
  366. echo "WINE binfmt_misc feature from the boot files "
  367. echo "to be installed and enabled 2,3,4,5 runlevel."
  368. echo "(File name in the /etc/init.d/wine )"
  369. echo "Filesystem mounted at boot time is required."
  370. echo "Root privileges using the following command in the /etc/fstab"
  371. echo "please Addenda.(Please delete manually.)"
  372. echo ""
  373. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  374. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  375. echo "See also(en)http://www.linux.com/articles/56032 "
  376. fi
  377. %preun init
  378. if [ $1 = 0 ]; then
  379. /sbin/service wine stop >/dev/null 2>&1
  380. /sbin/chkconfig --del wine
  381. fi
  382. #--------------------------------------------------------------------
  383. ## deleted /usr/share/applications/wine.desktop
  384. %files
  385. %defattr(-,root,root,-)
  386. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  387. %doc README VERSION
  388. %doc README-FEDORA-PULSEAUDIO
  389. %doc README-FEDORA-PULSEAUDIO.ja
  390. %doc README-Fedora
  391. %doc README-Fedora.ja
  392. %doc documentation/README* documentation/ChangeLog*
  393. %doc documentation/ja_fonts_replace*
  394. %doc documentation/fonts-replace-list.txt
  395. ### %{_bindir}/*
  396. %{_bindir}/msiexec
  397. %{_bindir}/regedit
  398. %{_bindir}/regsvr32
  399. %{_bindir}/wine
  400. %{_bindir}/wineboot
  401. %{_bindir}/wineconsole
  402. ## %{_bindir}/wineprefixcreate
  403. %{_bindir}/winecfg
  404. %{_bindir}/wine-preloader
  405. # winelauncher --> Remove
  406. %{_bindir}/wineserver
  407. %{_bindir}/notepad
  408. %{_bindir}/winedbg
  409. %{_bindir}/winedump
  410. %{_bindir}/winefile
  411. %{_bindir}/winemaker
  412. %{_bindir}/winemine
  413. %{_bindir}/winepath
  414. ## winhelp -> renamed winhlp32.exe
  415. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  416. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  417. %{_libdir}/libwine.so.1*
  418. %dir %{_libdir}/wine
  419. %{_libdir}/wine/*.cpl.so
  420. %{_libdir}/wine/*.exe.so
  421. %{_libdir}/wine/*.exe16.so
  422. %{_libdir}/wine/*.dll.so
  423. %{_libdir}/wine/*.dll16.so
  424. %{_libdir}/wine/*.drv.so
  425. %{_libdir}/wine/*.drv16.so
  426. %{_libdir}/wine/*.mod16.so
  427. ## %{_libdir}/wine/*.*16
  428. %{_libdir}/wine/*.ds.so
  429. %{_libdir}/wine/*.ocx.so
  430. %{_libdir}/wine/*.vxd.so
  431. %{_libdir}/wine/*.acm.so
  432. %{_libdir}/wine/*.sys.so
  433. %{_libdir}/wine/*.tlb.so
  434. %dir %{_libdir}/wine/fakedlls
  435. %{_libdir}/wine/fakedlls/*
  436. %dir %{_datadir}/wine
  437. %{_datadir}/wine/*
  438. %{_datadir}/applications/vine-wine-mime-msi.desktop
  439. %{_datadir}/applications/vine-wine.desktop
  440. %{_datadir}/applications/vine-wine-regedit.desktop
  441. %{_datadir}/applications/vine-wine-uninstaller.desktop
  442. %{_datadir}/applications/vine-wine-winecfg.desktop
  443. %{_datadir}/applications/vine-wine-wineboot.desktop
  444. %{_datadir}/applications/vine-wine-notepad.desktop
  445. %{_datadir}/applications/vine-wine-winefile.desktop
  446. %{_datadir}/applications/vine-wine-winemine.desktop
  447. %{_datadir}/applications/vine-wine-winhelp.desktop
  448. %{_datadir}/desktop-directories/Wine.directory
  449. %{_mandir}/man1/wine.1.*
  450. %{_mandir}/man1/wineserver.1*
  451. %{_mandir}/man1/msiexec.1*
  452. %{_mandir}/man1/notepad.1*
  453. %{_mandir}/man1/regedit.1*
  454. %{_mandir}/man1/regsvr32.1*
  455. %{_mandir}/man1/wineboot.1*
  456. %{_mandir}/man1/winecfg.1*
  457. %{_mandir}/man1/wineconsole.1*
  458. %{_mandir}/man1/winefile.1*
  459. %{_mandir}/man1/winemine.1*
  460. %{_mandir}/man1/winepath.1*
  461. ## %{_mandir}/man1/wineprefixcreate.1*
  462. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  463. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  464. %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
  465. #--------------------------------------------------------------------
  466. %files devel
  467. %defattr(-,root,root,-)
  468. %{_bindir}/function_grep.pl
  469. %{_bindir}/widl
  470. %{_bindir}/winebuild
  471. %{_bindir}/winecpp
  472. %{_bindir}/winedump
  473. %{_bindir}/wineg++
  474. %{_bindir}/winegcc
  475. %{_bindir}/winemaker
  476. %{_bindir}/wmc
  477. %{_bindir}/wrc
  478. %{_includedir}/wine
  479. %{_libdir}/*.so
  480. %{_libdir}/wine/*.a
  481. %{_libdir}/wine/*.def
  482. %{_mandir}/man1/widl.1*
  483. %{_mandir}/man1/winebuild.1*
  484. %{_mandir}/man1/winecpp.1*
  485. %{_mandir}/man1/winedump.1*
  486. %{_mandir}/man1/winegcc.1*
  487. %{_mandir}/man1/winemaker.1*
  488. %{_mandir}/man1/wmc.1*
  489. %{_mandir}/man1/wrc.1*
  490. %{_mandir}/man1/winedbg.1*
  491. %{_mandir}/man1/wineg++.1*
  492. #--------------------------------------------------------------------
  493. %files init
  494. %defattr(-,root,root,-)
  495. %{_initrddir}/wine
  496. %doc documentation/README_add.ja
  497. #--------------------------------------------------------------------
  498. %changelog
  499. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  500. - new upstream release
  501. * Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  502. - new upstream release
  503. - remove Patch1000 (wine-1.4.1-vine.patch)
  504. - update Patch2 (wine-1.6-x86_64_gstreamer.patch)
  505. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
  506. - update to 1.5.17
  507. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  508. - new upstream release
  509. - update Patch1000 (wine-1.4.1-vine.patch)
  510. * Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
  511. - new upstream release
  512. - add Patch2 (wine-1.4-x86_64_gstreamer.patch)
  513. - add BuildRequires: gstreamer-plugins-base-devel
  514. * Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  515. - update to 1.2.3
  516. - add Requires: compat32-freetype2 (x86_64 only)
  517. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  518. - new upstream release
  519. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  520. - new upstream release
  521. - drop Patch1
  522. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  523. - new upstream release
  524. - fix %configure (add configu:e and gcc option of x86_64)
  525. - fix %install (remove wine.desktop and change make install option)
  526. - add ExclusiveArch: %{ix86} x86_64
  527. - add BuildRequires for x86_64 (compat32 packages)
  528. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  529. - update to 1.2-rc2
  530. - fix spec file
  531. - if [ "$LANG" = "ja_JP.eucJP" ];
  532. + if [ "$LANG" = "ja_JP.UTF-8" ];
  533. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  534. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  535. - fix %files
  536. - drop patches (Patch0, Patch400, Patch402)
  537. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  538. - update BRs
  539. - remove freetype-devel
  540. - remove libungif-devel, add giflib-devel
  541. - remove gphoto2-devel, add libgphoto2-devel
  542. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  543. - update to 1.1.29
  544. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  545. - update to 1.1.28
  546. - update winepulse patches
  547. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  548. - update to 1.1.23
  549. - spec in utf-8
  550. - add patch1000 to enable FontSmoothing by deafult.
  551. - update pulseaudio patches
  552. - remove invalid Provides: Wine HQ
  553. - remove unneeded patches
  554. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  555. - Wine development release 1.1.0.
  556. - Updated specfile (for VineSeed)
  557. #--------------------------------------------------------------------
  558. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  559. - added "ja_fonts_replace-*.reg" files.
  560. - Updated specfile
  561. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  562. - version upgrade
  563. - Updated specfile
  564. - Update to 1.0
  565. - fix wine.desktop mime types (fc)
  566. - add desktop package including desktop files and binary handler (fc)
  567. - pull in some wine alsa/pulseaudio patches (fc)
  568. -- NEWS "June 17, 2008: Wine 1.0 Released"
  569. -- read http://www.winehq.org/?issue=348
  570. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  571. - Updated specfile
  572. - Update to 1.0-rc4
  573. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  574. -- ntdll: Add local defines for VIF and VIP flags.
  575. -- wininet: Include openssl/ssl.h before Windows headers.
  576. -- shell32: Fixed the French about box.
  577. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  578. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  579. -- ....others , read ChangeLog
  580. --- Bug fixes only, we are in code freeze.
  581. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  582. - Updated specfile
  583. - Update to 1.0-rc3
  584. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  585. -- The default version is now Windows XP.
  586. -- Many Richedit improvements.
  587. -- Beginning of jscript dll support.
  588. -- Shell folders now respect XDG directory configuration.
  589. -- Many translation updates.
  590. -- Lots of bug fixes.
  591. -- * Bug fixes only, we are in code freeze.
  592. --- kernel32: Add a builtin 16-bit winhelp.exe.
  593. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  594. --- executables.
  595. ---- winhelp -> renamed winhlp32.exe
  596. ---- programs: Remove winelauncher from install rules.
  597. * Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
  598. - Updated specfile
  599. - Update to 0.9.59
  600. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  601. -- * Improved support for the .NET framework.
  602. -- * Better services handling through a separate services.exe process.
  603. -- * Support for ATI fragment shader.
  604. -- * Better support for http proxies.
  605. -- * Window management fixes.
  606. -- * Pre-compiled fonts are now available in the source tree.
  607. -- * Lots of bug fixes.
  608. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  609. - Updated specfile (split wine-init package)
  610. - Update to 0.9.58
  611. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  612. -- * The default version is now Windows XP.
  613. -- * Many Richedit improvements.
  614. -- * Beginning of jscript dll support.
  615. -- * Shell folders now respect XDG directory configuration.
  616. -- * Many translation updates.
  617. -- * Lots of bug fixes.
  618. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  619. - Updated specfile (*.desktop file %check .)
  620. - Update to 0.9.57
  621. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  622. -- * Support for multiple OpenGL pixel formats.
  623. -- * Improved support for color profiles.
  624. -- * Many window management fixes.
  625. -- * Better fullscreen support.
  626. -- * Lots of bug fixes.
  627. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  628. - Updated specfile
  629. - ("Build Tool" from the wine-package to move to devel-packages)
  630. - Update to 0.9.56
  631. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  632. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  633. -- * Stubs for all the d3dx9_xx dlls.
  634. -- * Several graphics optimizations.
  635. -- * Many installer fixes.
  636. -- * Improved MIME message support.
  637. -- * Lots of bug fixes.
  638. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  639. - Updated specfile (cf. VineLinux .spec file format)
  640. - Add Installed messages for "binfmt_misc" .
  641. - *.desktop file "Name" change to japanese. (UTF8)
  642. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  643. - Import WINE - Packager: Babasaki
  644. - Updated specfile (SUSE base + FC9 cfg)
  645. - Update to 0.9.55
  646. - Update to 0.9.54 from FC9
  647. - Update to 0.9.53 from Private package
  648. # FC9 ------------------------------------------------------------- FC9
  649. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  650. - 0.9.55-1
  651. - version upgrade
  652. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  653. - 0.9.54-1
  654. - version upgrade
  655. - remove default pulseaudio workaround (#429420,#428745)
  656. - improve pulseaudio readme
  657. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  658. - 0.9.53-2
  659. - add some missing BR
  660. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  661. - 0.9.53-1
  662. - version upgrade
  663. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  664. - 0.9.52-2
  665. - fix menu bug (#393641)
  666. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  667. - 0.9.52-1
  668. - version upgrade
  669. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  670. - 0.9.51-3
  671. - add -n Wine to pulseaudio workaround
  672. - try to fix menu bug #393641
  673. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  674. - 0.9.51-2
  675. - add fix for #344281 pulseaudio workaround
  676. - fix #253474: wine-jack should require jack-audio-connection-kit
  677. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  678. - 0.9.51-1
  679. - version upgrade
  680. # ---- abbreviatio ----------------------------------------------------#
  681. # ----------and suse.
  682. # * Fri Mar 17 2006 - meissner@suse.de
  683. # - Avoid ulimit leading to out of memory situations by using
  684. # the compat address space layout personality. #152115