ocaml-labltk-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. #%ifarch %{ocaml_native_compiler}
  2. #%global native_compiler 1
  3. #%else
  4. #%global native_compiler 0
  5. #%endif
  6. Name: ocaml-labltk
  7. Version: 8.06.0
  8. Release: 1%{?_dist_release}
  9. Summary: Tcl/Tk interface for OCaml
  10. Summary(ja): OCaml の Tk インターフェース
  11. License: LGPLv2+ with exceptions
  12. Group: Development/Languages
  13. URL: https://forge.ocamlcore.org/projects/labltk/
  14. Source0: https://forge.ocamlcore.org/frs/download.php/1455/labltk-%{version}.tar.gz
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: ocaml
  17. BuildRequires: tcl-devel
  18. BuildRequires: tk-devel
  19. %description
  20. labltk or mlTk is a library for interfacing OCaml with the scripting
  21. language Tcl/Tk (all versions since 8.0.3, but no betas).
  22. %package devel
  23. Summary: Development files for %{name}
  24. Summary(ja): %{name} の開発用ファイル
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. %description devel
  28. labltk or mlTk is a library for interfacing OCaml with the scripting
  29. language Tcl/Tk (all versions since 8.0.3, but no betas).
  30. This package contains the development files.
  31. %prep
  32. %setup -q -n labltk-%{version}
  33. #patch1 -p1
  34. # Remove version control files which might get copied into documentation.
  35. find -name .gitignore -delete
  36. %build
  37. ./configure
  38. #%if !%{native_compiler}
  39. #make %{?_smp_mflags} byte
  40. #%else
  41. make %{?_smp_mflags} all
  42. make %{?_smp_mflags} opt
  43. #%endif
  44. %install
  45. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  46. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/labltk
  47. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
  48. make install \
  49. BINDIR=$RPM_BUILD_ROOT%{_bindir} \
  50. INSTALLDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/labltk \
  51. STUBLIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
  52. # The *.o files are not installed by the Makefile. AIUI
  53. # that prevents linking with native code programs.
  54. install -m 0644 camltk/*.o $RPM_BUILD_ROOT%{_libdir}/ocaml/labltk
  55. %files
  56. %doc Changes README.mlTk
  57. %dir %{_libdir}/ocaml/labltk
  58. %{_libdir}/ocaml/labltk/*.cmi
  59. %{_libdir}/ocaml/labltk/*.cma
  60. %{_libdir}/ocaml/labltk/*.cmo
  61. %{_libdir}/ocaml/stublibs/dlllabltk.so
  62. %files devel
  63. %doc README.mlTk
  64. %doc examples_camltk
  65. %doc examples_labltk
  66. %{_bindir}/labltk
  67. %{_bindir}/ocamlbrowser
  68. %{_libdir}/ocaml/labltk/labltktop
  69. %{_libdir}/ocaml/labltk/pp
  70. %{_libdir}/ocaml/labltk/tkcompiler
  71. %{_libdir}/ocaml/labltk/*.a
  72. #if %{native_compiler}
  73. %{_libdir}/ocaml/labltk/*.cmxa
  74. %{_libdir}/ocaml/labltk/*.cmx
  75. %{_libdir}/ocaml/labltk/*.o
  76. #endif
  77. %{_libdir}/ocaml/labltk/*.mli
  78. %changelog
  79. * Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 8.06.0-1
  80. - Initial build for Vine Linux (splitted from ocaml package)
  81. * Sat Aug 30 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.7.beta1
  82. - ocaml-4.02.0 final rebuild.
  83. * Fri Aug 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.6.beta1
  84. - ocaml-4.02.0+rc1 rebuild.
  85. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.02-0.5.beta1
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  87. * Fri Aug 01 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.4.beta1
  88. - ocaml-4.02.0-0.8.git10e45753.fc22 rebuild.
  89. * Tue Jul 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.3.beta1
  90. - OCaml 4.02.0 beta rebuild.
  91. * Tue Jul 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.2.beta1
  92. - Enable debugging.
  93. - Move labltk to -devel package.
  94. - Enable _smp_flags.
  95. * Tue Jul 22 2014 Richard W.M. Jones <rjones@redhat.com> - 4.02-0.1.beta1
  96. - Initial packaging of new out-of-tree ocaml-labltk.