python-docutils-vl.spec 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111
  1. %define srcname docutils
  2. Summary: an open-source text processing system written in Python
  3. Summary(ja): Pythonで書かれたテキスト処理システム
  4. Name: python-%{srcname}
  5. Version: 0.6
  6. Release: 2%{?_dist_release}
  7. Group: Development/Languages
  8. License: Public Domain and MIT and Python and GPLv2
  9. URL: http://docutils.sourceforge.net/
  10. Source0: http://prdownloads.sourceforge.net/%{srcname}/%{srcname}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: python-devel
  14. BuildRequires: python-setuptools
  15. Requires: python
  16. Requires: python-imaging
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: shaolin, munepi, owa
  20. Provides: docutils = %{version}-%{release}
  21. Obsoletes: docutils <= 0.5
  22. %description
  23. Docutils is an open-source text processing system for processing
  24. plaintext documentation into useful formats, such as HTML or LaTeX.
  25. It includes reStructuredText, the easy to read, easy to use,
  26. what-you-see-is-what-you-get plaintext markup language.
  27. %description -l ja
  28. Docutilsはオープンソースのテキスト処理システムで、プレーンテキストの
  29. 文書をHTMLやLaTeXなどの使いやすいフォーマットに変換するものです。
  30. 読みやすく使いやすくWYSIWYGなプレーンテキストのマークアップ言語である
  31. reStructuresTextを含んでいます。
  32. %prep
  33. %setup -q -n %{srcname}-%{version}
  34. # Remove a shebang from one of the library files
  35. %__sed -i -e '/#! *\/usr\/bin\/.*python.*/{1D}' docutils/readers/python/pynodes.py
  36. %build
  37. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
  38. %install
  39. %__rm -rf $RPM_BUILD_ROOT
  40. %{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
  41. for file in %{buildroot}/%{_bindir}/*.py; do
  42. mv $file `dirname $file`/`basename $file .py`
  43. ln -sf `basename $file .py` `dirname $file`/`basename $file`
  44. done
  45. # We want the licenses but don't need this build file
  46. %__rm -f licenses/docutils.conf
  47. # docutils only installs this if its not already on the system. Due to the
  48. # possibility that a previous version of docutils may be installed, we install
  49. # it manually here.
  50. install -D -m644 extras/roman.py ${RPM_BUILD_ROOT}/%{python_sitelib}/roman.py
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %files
  54. %defattr(-,root,root)
  55. %doc BUGS.txt HISTORY.txt RELEASE-NOTES.txt docs COPYING.txt THANKS.txt FAQ.txt README.txt
  56. %doc licenses docs tools/editors
  57. %{_bindir}/*
  58. %{python_sitelib}/%{srcname}/
  59. %{python_sitelib}/roman.*
  60. %{python_sitelib}/docutils-*.egg-info
  61. %changelog
  62. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.6-2
  63. - changed package-name to python-docutils from docutils
  64. - added Provides: docutils = %%{version}-%%{release}
  65. - added Obsoletes: docutils <= 0.5
  66. - added BR: python-setuptools
  67. - added RQ: python-imaging
  68. (merged from '* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> python-docutils-0.6-1')
  69. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.5-3
  70. - rebuilt with python-2.6.4
  71. * Thu Aug 6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5-2
  72. - rename /usr/bin/*.py to /usr/bin/*
  73. (keep symlinking to *.py for compatibility - should be removed in the future)
  74. * Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.5-1
  75. - updated docutils to 0.5
  76. - added BuildArch: noarch
  77. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
  78. - rebuilt with python-2.5.2
  79. - applied new versioning policy and spec in utf-8
  80. * Thu Jan 31 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-0vl4
  81. - defined python_sitelib by using distutils.sysconfig.get_python_lib()
  82. - updated module directory with platform-independent path
  83. - added script to install extras/roman.py (missing if it's already on the system)
  84. * Sun Sep 9 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.4-0vl2
  85. - initial build for Vine Linux