123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313 |
- Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
- Summary(ja): GNOME から GTK+/KDE のアプリケーションで設定を共有するためのデーモン
- Name: gnome-settings-daemon
- Version: 2.30.2
- Release: 2%{?_dist_release}
- Group: System Environment/Daemons
- License: GPLv2+
- URL: http://ftp.gnome.org/pub/gnome/sources/%{name}
- Source0: http://ftp.gnome.org/pub/gnome/sources/%{name}/2.26/%{name}-%{version}.tar.bz2
- # from fedora
- # https://bugzilla.gnome.org/show_bug.cgi?id=596136
- Patch0: 0002-Use-a-rounded-instead-of-curved-rectangle.patch
- Patch1: 0003-Improve-the-media-keys-overlay-design.patch
- # https://bugzilla.gnome.org/show_bug.cgi?id=567249
- Patch4: 0001-Fix-bluriness-in-level-bar-and-popup.patch
- # https://bugzilla.redhat.com/show_bug.cgi?id=498249
- Patch2: left-handed-touchpad.patch
- # change font rendering
- Patch3: slight-hinting.patch
- # vine
- Patch100: gnome-settings-daemon-2.28.1-default-font-setting.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Requires(pre): GConf2 >= 2.14
- Requires(preun): GConf2 >= 2.14
- Requires(post): GConf2 >= 2.14
- BuildRequires: dbus-glib-devel
- BuildRequires: GConf2-devel
- BuildRequires: gtk2-devel
- BuildRequires: gnome-desktop-devel >= 2.30.0
- BuildRequires: libgnome-devel
- BuildRequires: xorg-x11-proto-devel
- BuildRequires: libXrandr-devel
- BuildRequires: fontconfig-devel
- BuildRequires: gstreamer-devel
- BuildRequires: gstreamer-plugins-base-devel
- BuildRequires: pulseaudio-libs-devel
- BuildRequires: libgnomekbd-devel >= 2.30.0
- BuildRequires: libxklavier-devel >= 5.0
- BuildRequires: libnotify-devel >= 0.4.3
- BuildRequires: gettext
- BuildRequires: perl-XML-Parser
- BuildRequires: libSM-devel
- %description
- A daemon to share settings from GNOME to other applications. It also
- handles global keybindings, as well as a number of desktop-wide settings.
- %package devel
- Summary: Development files for %{name}
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- Requires: dbus-glib-devel
- %description devel
- The %{name}-devel package contains libraries and header files for
- developing applications that use %{name}.
- %prep
- %setup -q
- ## %patch4 -p1 -b .blurry
- ## %patch0 -p1 -b .osd-rounded-rectangle
- ## %patch1 -p1 -b .osd-visual-refresh
- ## %patch2 -p1 -b .left-handed-touchpad
- %patch3 -p1 -b .slight-hinting
- %patch100 -p1 -b .defaults
- %build
- %configure --enable-static=no --enable-profiling --disable-esd
- make %{?_smp_mflags}
- # strip unneeded translations from .mo files
- # ideally intltool (ha!) would do that for us
- # http://bugzilla.gnome.org/show_bug.cgi?id=474987
- cd po
- grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
- mv POTFILES.keep POTFILES.in
- intltool-update --pot
- for p in *.po; do
- msgmerge $p %{name}.pot > $p.out
- msgfmt -o `basename $p .po`.gmo $p.out
- done
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
- %find_lang %{name} --with-gnome
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
- gconftool-2 --makefile-install-rule \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
- %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
- >& /dev/null || :
- touch %{_datadir}/icons/hicolor
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
- fi
-
- %pre
- if [ "$1" -gt 1 ]; then
- export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
- if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
- >& /dev/null || :
- fi
- export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
- if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
- >& /dev/null || :
- fi
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
- %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
- >& /dev/null || :
- fi
- %preun
- if [ "$1" -eq 0 ]; then
- export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
- if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
- >& /dev/null || :
- fi
- if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
- >& /dev/null || :
- fi
- gconftool-2 --makefile-uninstall-rule \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
- %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
- %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
- %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
- >& /dev/null || :
- fi
- %postun
- touch %{_datadir}/icons/hicolor
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
- fi
-
- %files -f %{name}.lang
- %defattr(-,root,root,-)
- %doc AUTHORS COPYING NEWS
- %{_sysconfdir}/gconf/schemas/*
- %{_sysconfdir}/xdg/autostart/gnome-settings-daemon.desktop
- %{_libdir}/gnome-settings-daemon-2.0
- %{_libexecdir}/gnome-settings-daemon
- %{_libexecdir}/gsd-locate-pointer
- %{_datadir}/gnome-settings-daemon/
- %{_datadir}/dbus-1/services/org.gnome.SettingsDaemon.service
- %{_datadir}/icons/hicolor/*/apps/gsd-xrandr.*
- %{_datadir}/icons/hicolor/*/actions/touchpad*
- %{_datadir}/gnome-control-center/keybindings/*.xml
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/gnome-settings-daemon-2.0
- %{_libdir}/pkgconfig/gnome-settings-daemon.pc
- %changelog
- * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
- - rebuild with rpm-4.8.1 for pkg-config file
- * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
- - new upstream release
- * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
- - new upstream release
- * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
- - new upstream release
- - add BuildRequires: libSM-devel
- - drop Patch0, Patch1
- * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
- - new upstream release
- - drop Patch2, Patch4
- * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
- - new upstream release
- - updated Patch100
- * Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
- - import patches from fedora
- - Patch10: listen for DeviceAdded
- - Patch11,12: add support touchpads
- - Patch13: Make custom keybindings work better
- - Patch14: Don't rely on _BACKUP property for xkb initialization
- * Wed Apr 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.1-1
- - new upstream release
- * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
- - update Patch10
- - change hinting type to "none" instead of "medium"
- * Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
- - add Patch10 to set default dpi
- * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
- - new upstream release
- * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
- - new upstream release
- * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
- - new upstream release
- * Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
- - build with pulseaudio
- - add patch6 to ignore the legacy ESD GConf preference if compiled
- to use Pulseaudio
- * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.2.1-1
- - new upstream release
- * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.1-1vl5
- - new upstream release
- * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
- - Initial build for Vine Linux
- * Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.1-0.2008.03.26.3
- - Add patch for the mouse plugin not to eat multimedia key events (#438942)
- * Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.2
- - Rebuild
- * Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.1
- - Update to snapshot
- - Enable profiling
- * Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
- - apps_gnome_settings_daemon_default_editor.schemas is obsolete (#438937)
- * Thu Mar 20 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-2
- - Fix interaction between "Locate Pointer" and volume keys
- * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-1
- - Update to 2.22.0
- * Sun Mar 9 2008 Ray Strode <rstrode@redhat.com> - 2.21.92-3
- - Don't set keyboard model on startup from gconf if evdev is being used.
- Evdev needs to use its own keyboard model to work right.
- * Sun Mar 2 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.92-2
- - Update randr patch to handle video key
- * Fri Feb 29 2008 Jon McCann <jmccann@redhat.com> - 2.21.92-1
- - Update to 2.21.92
- * Tue Feb 12 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.91-3
- - Add patch to make the xrandr plugin listen for client messages from
- the control panel and reread the configuration file.
- * Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-2
- - Remove obsolete control-center translations
- * Mon Feb 11 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.91-1
- - Update to 2.21.91
- - Remove obsolete patches
- * Thu Feb 7 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.90.1-3
- - Load xkb settings initially
- * Thu Jan 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-2
- - Fix the path for g-s-d, from upstream patch
- * Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-1
- - Update to 2.21.90.1
- * Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90-1
- - Update to 2.21.90
- * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-2
- - Incorporate review feedback (#428833)
- * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-1
- - Update to 2.21.5.2
- * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.1-1
- - Update to 2.21.5.1
- - Fix up BuildRequires
- * Thu Dec 06 2007 - Bastien Nocera <bnocera@redhat.com> - 2.21.5-1
- - First package
|