usermode-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615
  1. # VINE: 1.110 or upper drops halt/poweroff/reboot helpers
  2. # VINE: to upgrade 1.110+, we need to use systemd.
  3. Summary: Tools for certain user account management tasks.
  4. Summary(ja): ユーザアカウント管理用ツール
  5. Name: usermode
  6. Version: 1.109
  7. Release: 2%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/System
  10. URL: https://fedorahosted.org/usermode/
  11. Source: https://fedorahosted.org/releases/u/s/usermode/usermode-%{version}.tar.xz
  12. ## Vine Source(s)/Patch(es)
  13. Source10: usermode-1.107-ja.po
  14. Patch10: usermode-1.37-halt-p.patch
  15. Patch1000: usermode-major.patch
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: daisuke
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: desktop-file-utils, glib2-devel, gtk2-devel
  21. BuildRequires: libglade2-devel, libuser-devel, pam-devel, util-linux-ng, libwnck-devel
  22. BuildRequires: libblkid-devel
  23. BuildRequires: perl-XML-Parser, libSM-devel, startup-notification-devel, gettext
  24. Requires: util-linux, pam >= 0.75, passwd
  25. Conflicts: SysVinit < 2.74-14
  26. %description
  27. The usermode package contains the userhelper program, which can be
  28. used to allow configured programs to be run with superuser privileges
  29. by ordinary users.
  30. %description -l ja
  31. usermode パッケージには、一般ユーザが設定されたプログラムをスーパーユー
  32. ザとして実行できるようにするユーザヘルパープログラムが含まれています。
  33. %package gtk
  34. Summary: Graphical tools for certain user account management tasks.
  35. Summary(ja): ユーザアカウント管理用グラフィカルツール
  36. Group: Applications/System
  37. Requires: %{name} = %{version}-%{release}
  38. %description gtk
  39. The usermode-gtk package contains several graphical tools for users:
  40. userinfo, usermount and userpasswd. Userinfo allows users to change
  41. their finger information. Usermount lets users mount, unmount, and
  42. format filesystems. Userpasswd allows users to change their
  43. passwords.
  44. Install the usermode-gtk package if you would like to provide users with
  45. graphical tools for certain account management tasks.
  46. %description gtk -l ja
  47. usermode-gtk には userinfo, usermount, userpasswd といったユーザ用
  48. グラフィカルツールも収められています。userinfo を使うと一般ユーザが自
  49. 分のアカウントの finger 情報を変更することが出来ます.
  50. usermount は一般ユーザがファイルシステムのマウント/アンマウント/初期化を
  51. 行うことを可能にします.userpasswd は一般ユーザが自分のパスワードを
  52. 変更するのに使います.
  53. 一般ユーザ向けに,アカウント管理用グラフィカルツールを提供したい場合は
  54. usermode パッケージをインストールして下さい.
  55. %prep
  56. %setup -q
  57. cp -f po/ja.po po/ja.po.orig
  58. cp -f %{SOURCE10} po/ja.po
  59. %patch10 -p1 -b .halt-p
  60. %patch1000 -p1
  61. %build
  62. intltoolize --force --copy
  63. autoreconf
  64. %configure
  65. make -C po usermode.pot
  66. make -C po update-po
  67. make
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. # We set up the shutdown programs to be wrapped in this package. Other
  72. # packages are on their own....
  73. mkdir -p $RPM_BUILD_ROOT/etc/pam.d $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
  74. for wrappedapp in halt reboot poweroff ; do
  75. ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/${wrappedapp}
  76. install -m644 $wrappedapp $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/${wrappedapp}
  77. cp shutdown.pamd $RPM_BUILD_ROOT/etc/pam.d/${wrappedapp}
  78. done
  79. cat <<EOF > $RPM_BUILD_ROOT/etc/security/console.apps/config-util
  80. USER=root
  81. UGROUPS=wheel
  82. EOF
  83. for desktopfile in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  84. do
  85. mv $desktopfile ${desktopfile/redhat-/}
  86. done
  87. %find_lang %{name}
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %attr(4711,root,root) /usr/sbin/userhelper
  93. %{_bindir}/consolehelper
  94. %{_mandir}/man8/userhelper.8*
  95. %{_mandir}/man8/consolehelper.8*
  96. # PAM console wrappers
  97. %{_bindir}/halt
  98. %{_bindir}/reboot
  99. %{_bindir}/poweroff
  100. %{_bindir}/shutdown
  101. %config(noreplace) /etc/pam.d/halt
  102. %config(noreplace) /etc/pam.d/reboot
  103. %config(noreplace) /etc/pam.d/poweroff
  104. %config(noreplace) /etc/security/console.apps/config-util
  105. %config /etc/security/console.apps/halt
  106. %config /etc/security/console.apps/reboot
  107. %config /etc/security/console.apps/poweroff
  108. %files gtk
  109. %defattr(-,root,root)
  110. %{_bindir}/usermount
  111. %{_mandir}/man1/usermount.1*
  112. %{_bindir}/userinfo
  113. %{_mandir}/man1/userinfo.1*
  114. %{_bindir}/userpasswd
  115. %{_mandir}/man1/userpasswd.1*
  116. %{_bindir}/consolehelper-gtk
  117. %{_mandir}/man8/consolehelper-gtk.8*
  118. %{_bindir}/pam-panel-icon
  119. %{_mandir}/man1/pam-panel-icon.1*
  120. %{_datadir}/%{name}
  121. %{_datadir}/pixmaps/*
  122. %{_datadir}/applications/*
  123. %changelog
  124. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.109-2
  125. - rebuilt with current environment.
  126. - added Patch1000.
  127. * Wed Jul 02 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.109-1
  128. - update to 1.109
  129. * Sat Jun 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.107-1
  130. - update to 1.107
  131. - add UGROUPS=wheel to config-util
  132. - update ja.po for better authentication dialog
  133. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.106.1-1
  134. - new upstream release
  135. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.98-1
  136. - new upstream release
  137. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.86-1vl5
  138. - applied new versioning policy, spec in utf-8
  139. * Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.86-0vl3
  140. - rebuilt with libwnck 2.20.2
  141. - added Patch100 for avoiding desktop-file-install failure
  142. - fixed *.desktop.in files
  143. * Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl2
  144. - fix Patch12
  145. - The old patch changes the application's locale by mistake.
  146. * Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl1
  147. - new upstream release
  148. - add Patch12 to fix broken messages in consolehelper-gtk (<BTS:181>)
  149. - update ja.po
  150. * Thu Jun 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.85-0vl1
  151. - new upstream release
  152. * Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.81-0vl1
  153. - new upstream release
  154. - rebuild with new libwnck
  155. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl3
  156. - rebuild with new libwnck
  157. * Sat Jul 3 2004 Tomoya TAKA <taka@vinelinux.org> 1.70-4vl2
  158. - fix lack of %%{_bindir}/shutdown
  159. * Mon Jun 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl1
  160. - new upstream release
  161. - fixed spec's kanji code.
  162. - split gui related utilities to usermode-gtk subpackage.
  163. * Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.69-1vl1
  164. - new upstream release
  165. * Thu Oct 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.68-0vl1
  166. - new upstream release
  167. * Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.65-1vl1
  168. - merged with Vine Linux package 1.42-1vl5
  169. * Sat Aug 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.42-1vl5
  170. - enable system authentication even if %%{build6x} is set to 0
  171. (for compatibility with previous version)
  172. * Mon Aug 05 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl4
  173. - reinstated /usr/bin/shutdown
  174. * Fri Aug 02 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl3
  175. - rebuild with pam-0.75-39vl1
  176. - set build6x to 0
  177. * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1vl2
  178. - rebuild to remove rpmlib dependancy
  179. * Fri Jun 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  180. - 1.42-1vl1
  181. - based on 1.42-1 from Rawhide and merged some from 1.37-2vl2
  182. - %%define build6x 1 for Vine
  183. * Mon Jan 20 2003 Nalin Dahyabhai <nalin@redhat.com> 1.65-1
  184. - pass-through DESKTOP_STARTUP_ID
  185. * Mon Jan 6 2003 Nalin Dahyabhai <nalin@redhat.com> 1.64-1
  186. - set the requesting user PAM item to the invoking user's name (#81255)
  187. * Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-2
  188. - remove directory names from PAM config files, allowing the same config
  189. files to work for both arches on multilib boxes
  190. - translation updates
  191. * Wed Sep 4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-1
  192. - userhelper: swallow the exec'd program's exit stauts, which would be
  193. misinterpreted by consolehelper anyway
  194. * Tue Sep 3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.62-1
  195. - consolehelper: suppress dialog on successful execution
  196. - userhelper: return 0 on success, not 1 (what was I *thinking*?)
  197. * Mon Sep 2 2002 Nalin Dahyabhai <nalin@redhat.com> 1.61-1
  198. - userinfo: exit properly on escape. handle site_info field properly. go
  199. insensitive while running child process.
  200. - userpasswd: exit properly on cancel.
  201. - all of the above: reap the child instead of checking for pipe close -- this
  202. way is more robust (#68578,72684).
  203. - usermount: run mount/umount synchronously. capture stderr and display in a
  204. dialog. desensitize action buttons when no filesystems are selected.
  205. - consolehelper: display errors if we're attempting to run bogus programs
  206. (#72127)
  207. - translation updates (#70278)
  208. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.60-1
  209. - reconnect the "cancel" and "ok" buttons in userinfo
  210. - heed the cancel button when prompting for passwords in userinfo (#68578)
  211. - translation update
  212. * Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-2
  213. - change "forget password" to "forget authorization", because we don't actually
  214. remember the password (that would be scary, #71476)
  215. - translation update
  216. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-1
  217. - pam-panel-icon: overhaul, change the 'locked' icon to keyring-small, nix the
  218. 'unlocked' icon
  219. - consolehelper-gtk: properly set up the dialog buttons (should be 'cancel/ok'
  220. when we're asking questions, was always 'close')
  221. - disappear pam_timestamp_init
  222. * Wed Aug 7 2002 Nalin Dahyabhai <nalin@redhat.com> 1.58-2
  223. - install the new 'unlocked' icon
  224. * Tue Aug 6 2002 Jonathan Blandford <jrb@redhat.com>
  225. - New version.
  226. * Mon Aug 5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.57-1
  227. - add support for BANNER and BANNER_DOMAIN in the userhelper configuration
  228. * Mon Aug 5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-4
  229. - mark strings in the .glade file as translatable (#70278)
  230. - translation updates
  231. * Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-3
  232. - add icons for userpasswd and usermount
  233. * Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-2
  234. - actually include the icons
  235. - translation updates
  236. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-1
  237. - userinfo: prevent users from selecting "nologin" as a shell (#68579)
  238. - don't strip binaries by default; leave that to the buildroot policy
  239. - use desktop-file-install
  240. * Wed Jun 19 2002 Havoc Pennington <hp@redhat.com>
  241. - put pam-panel-icon in file list
  242. * Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-2
  243. - don't strip binaries which have no special privileges
  244. * Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-1
  245. - remove the pixmap we don't use any more (we use stock pixmaps now)
  246. - update translations
  247. * Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 1.54-1
  248. - suppress even error messages from Xlib when consolehelper calls
  249. gtk_init_check() to see if the display is available
  250. * Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-2
  251. - refresh translations
  252. * Thu Apr 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-1
  253. - refresh shell variable code from authconfig (#63175)
  254. * Tue Apr 9 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-2
  255. - refresh translations
  256. * Mon Apr 1 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-1
  257. - attempt to make prompts at the console more meaningful
  258. - when falling back, reset the entire environment to the user's
  259. * Thu Mar 28 2002 Nalin Dahyabhai <nalin@redhat.com>
  260. - stop giving the user chances to enter the right password if we get a
  261. conversation error reading a response (appears to be masked by libpam)
  262. (#62195)
  263. - always center consolehelper dialog windows
  264. * Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 1.51-1
  265. - patch to make gettext give us UTF-8 strings (which GTK needs) from ynakai
  266. * Fri Mar 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-6
  267. - update translations
  268. - actually include the glade files (#61665)
  269. * Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-5
  270. - update translations
  271. * Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-4
  272. - rebuild
  273. * Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-3
  274. - update translations
  275. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-2
  276. - rebuild to fix dependencies
  277. * Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-1
  278. - fix userpasswd dialog message being incorrect for password changes
  279. - use a dumb conversation function when text mode is invoked without a tty -- if
  280. the service's configuration doesn't call for prompts, then it'll still work
  281. - port from pwdb to libuser
  282. - catch child-exit errors correctly again
  283. - fix keyboard-grabbing
  284. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-3
  285. - add default locations for certain binaries to configure.in
  286. * Thu Jan 3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-2
  287. - munge glade file to use stock items for buttons where possible
  288. * Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 1.49-1
  289. - the console.apps configs shouldn't be missingok
  290. - fix buildprereqs for gtk2/libglade2
  291. * Tue Dec 4 2001 Nalin Dahyabhai <nalin@redhat.com>
  292. - more gtk2 changes
  293. - split off a -gtk subpackage with all of the gtk-specific functionality
  294. * Wed Nov 28 2001 Nalin Dahyabhai <nalin@redhat.com>
  295. - the grand libglade/gtk2 overhaul
  296. - allow disabling display of GUI windows by setting "GUI=false" in the
  297. console.apps configuration file (default: TRUE)
  298. - allow disabling display of GUI windows by recognizing a magic option
  299. on the command-line of the program being wrapped (NOXOPTION, no default)
  300. * Fri Nov 9 2001 Nalin Dahyabhai <nalin@redhat.com> 1.46-1
  301. - restore the previous XAUTHORITY setting before opening PAM sessions
  302. * Fri Nov 2 2001 Nalin Dahyabhai <nalin@redhat.com> 1.45-1
  303. - propagate environment variables from libpam to applications
  304. * Wed Oct 3 2001 Nalin Dahyabhai <nalin@redhat.com> 1.44-1
  305. - only try to call gtk_main_quit() if we've got a loop to get out of (#54109)
  306. - obey RPM_OPT_FLAGS, obey
  307. * Tue Aug 28 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 1.43-1
  308. - Update translations
  309. * Mon Aug 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  310. - add build requirements on glib-devel, gtk+-devel, pam-devel (#49726)
  311. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  312. - Bump release + rebuild.
  313. * Wed Feb 14 2001 Preston Brown <pbrown@redhat.com>
  314. - final translation merge.
  315. * Wed Feb 14 2001 Nalin Dahyabhai <nalin@redhat.com>
  316. - clear the supplemental groups list before running binaries as root (#26851)
  317. * Wed Feb 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  318. - set XAUTHORITY if we fall back to regular behavior (#26343)
  319. - make the suid helper 04711 instead of 04755
  320. * Mon Feb 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  321. - refresh translations
  322. * Mon Jan 29 2001 Preston Brown <pbrown@redhat.com>
  323. - use lang finding script.
  324. * Thu Jan 25 2001 Yukihiro Nakai <ynakai@redhat.com>
  325. - Some fix for Japanese environment.
  326. - Use gtk_set_locale() instead of setlocale()
  327. - Copyright update.
  328. * Sun Jan 7 2001 Yukihiro Nakai <ynakai@redhat.com>
  329. - Add gettextized
  330. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  331. - fix segfault in userhelper (#20027)
  332. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  333. - /sbin/shutdown, not /usr/sbin/shutdown (#19034)
  334. * Fri Oct 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  335. - don't pass on arguments to halt and reboot, because they error out
  336. * Thu Oct 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  337. - fix the /usr/bin/shutdown wrapper so that root can call shutdown
  338. - only include the /usr/bin/shutdown wrapper on 6.x
  339. - also sanitize LC_MESSAGES
  340. - tweak sanitizing checks (from mkj)
  341. * Wed Oct 4 2000 Jakub Jelinek <jakub@redhat.com>
  342. - fix a security bug with LC_ALL/LANG variables (#18046)
  343. * Mon Aug 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  344. - mark defined strings translateable (#17006)
  345. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  346. - fix incorrect user name
  347. - add a shell wrapper version of /usr/bin/shutdown
  348. - build for 6.x errata
  349. - bump revision to upgrade the errata
  350. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  351. - fix stdin/stdout redirection shenanigans (#11706)
  352. - fix authentication and execution as users other than root
  353. - make sure the right descriptors are terminals before dup2()ing them
  354. - cut out an extra-large CPU waster that breaks GUI apps
  355. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  356. - fix typo (#16664)
  357. * Sun Aug 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  358. - previous fix, part two
  359. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  360. - fix inadvertent breakage of the shell-changing code
  361. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  362. - fix the "run unprivileged" option
  363. * Mon Aug 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  364. - actually use the right set of translations
  365. * Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  366. - remove the shutdown command from the list of honored commands
  367. * Wed Aug 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  368. - merge in updated translations
  369. - set XAUTHORITY after successful authentication (#11006)
  370. * Wed Aug 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  371. - install translations
  372. - fixup a messy text string
  373. - make "Mount"/"Unmount" translatable
  374. - stop prompting for passwords to shut down -- we can hit ctrl-alt-del anyway,
  375. and gdm users can just shut down without logging in
  376. * Mon Jul 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  377. - attempt to add i18n support
  378. * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  379. - attempt to get a usable icon for userhelper-wrap (#13616, #13768)
  380. * Wed Jul 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  381. - fix them right this time
  382. * Mon Jul 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  383. - fix verbosity problems
  384. * Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  385. - strip all binaries by default
  386. - add the name of the program being run to the userhelper dialog
  387. - add a graphic to the userhelper-wrap package
  388. - add a button to jump straight to nonprivileged operation when supported
  389. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  390. - rebuilt to see if we get stripped binaries
  391. * Mon Jun 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  392. - move man pages to %%{_mandir}
  393. * Thu Jun 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  394. - modify PAM setup to use system-auth
  395. - bzip2 compress tarball
  396. * Fri Mar 17 2000 Ngo Than <than@redhat.de>
  397. - fix problem with LANG and LC_ALL
  398. - compress source with bzip2
  399. * Thu Mar 09 2000 Nalin Dahyabhai <nalin@redhat.com>
  400. - fix problem parsing userhelper's -w flag with other args
  401. * Wed Mar 08 2000 Nalin Dahyabhai <nalin@redhat.com>
  402. - ignore read() == 0 because the child exits
  403. * Tue Mar 07 2000 Nalin Dahyabhai <nalin@redhat.com>
  404. - queue notice messages until we get prompts in userhelper to fix bug #8745
  405. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  406. - free trip through the build system
  407. * Tue Jan 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  408. - grab keyboard input focus for dialogs
  409. * Fri Jan 07 2000 Michael K. Johnson <johnsonm@redhat.com>
  410. - The root exploit fix created a bug that only showed up in certain
  411. circumstances. Unfortunately, we didn't test in those circumstances...
  412. * Mon Jan 03 2000 Michael K. Johnson <johnsonm@redhat.com>
  413. - fixed local root exploit
  414. * Thu Sep 30 1999 Michael K. Johnson <johnsonm@redhat.com>
  415. - fixed old complex broken gecos parsing, replaced with simple working parsing
  416. - can now blank fields (was broken by previous fix for something else...)
  417. * Tue Sep 21 1999 Michael K. Johnson <johnsonm@redhat.com>
  418. - FALLBACK/RETRY in consolehelper/userhelper
  419. - session management fixed for consolehelper/userhelper SESSION=true
  420. - fix memory leak and failure to close in error condition (#3614)
  421. - fix various bugs where not all elements in userinfo got set
  422. * Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
  423. - set $HOME when acting as consolehelper
  424. - rebuild against new pwdb
  425. * Tue Sep 14 1999 Michael K. Johnson <johnsonm@redhat.com>
  426. - honor "owner" flag to mount
  427. - ask for passwords with username
  428. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  429. - import pam_console wrappers from SysVinit, since they require usermode
  430. * Mon Apr 12 1999 Michael K. Johnson <johnsonm@redhat.com>
  431. - even better check for X availability
  432. * Wed Apr 07 1999 Michael K. Johnson <johnsonm@redhat.com>
  433. - better check for X availability
  434. - center windows to make authentication easier (improve later with
  435. transients and embedded windows where possible)
  436. - applink -> applnk
  437. - added a little padding, especially important when running without
  438. a window manager, as happens when running from session manager at
  439. logout time
  440. * Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
  441. - hm, need to be root...
  442. * Fri Mar 19 1999 Michael K. Johnson <johnsonm@redhat.com>
  443. - updated userhelper.8 man page for consolehelper capabilities
  444. - moved from wmconfig to desktop entries
  445. * Thu Mar 18 1999 Michael K. Johnson <johnsonm@redhat.com>
  446. - added consolehelper
  447. - Changed conversation architecture to follow PAM spec
  448. * Wed Mar 17 1999 Bill Nottingham <notting@redhat.com>
  449. - remove gdk_input_remove (causing segfaults)
  450. * Tue Jan 12 1999 Michael K. Johnson <johnsonm@redhat.com>
  451. - fix missing include files
  452. * Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
  453. - strip binaries
  454. - use defattr
  455. - fix spec file ( rm -rf $(RPM_BUILD_ROOT) is a stupid thing to do ! )
  456. * Tue Oct 06 1998 Preston Brown <pbrown@redhat.com>
  457. - fixed so that the close button on window managers quits the program properly
  458. * Thu Apr 16 1998 Erik Troan <ewt@redhat.com>
  459. - use gtk-config during build
  460. - added make archive rule to Makefile
  461. - uses a build root
  462. * Fri Nov 7 1997 Otto Hammersmith <otto@redhat.com>
  463. - new version that fixed memory leak bug.
  464. * Mon Nov 3 1997 Otto Hammersmith <otto@redhat.com>
  465. - updated version to fix bugs
  466. * Fri Oct 17 1997 Otto Hammersmith <otto@redhat.com>
  467. - Wrote man pages for userpasswd and userhelper.
  468. * Tue Oct 14 1997 Otto Hammersmith <otto@redhat.com>
  469. - Updated the packages... now includes userpasswd for changing passwords
  470. and newer versions of usermount and userinfo. No known bugs or
  471. misfeatures.
  472. - Fixed the file list...
  473. * Mon Oct 6 1997 Otto Hammersmith <otto@redhat.com>
  474. - Created the spec file.