sed-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %ifos linux
  2. %define _bindir /bin
  3. %endif
  4. Summary: A GNU stream text editor.
  5. Summary(ja): GNU ストリームテキストエディタ
  6. Name: sed
  7. Version: 4.8
  8. Release: 1%{?_dist_release}
  9. Group: Applications/Text
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: GPLv2+
  13. URL: http://www.gnu.org/software/sed/
  14. Source0: https://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.xz
  15. #Patch0: sed-4.2.1-dummyparam.diff
  16. #Patch1: sed-4.2.1-multibyte.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: glibc-devel
  19. BuildRequires: libacl-devel
  20. Requires(post): /sbin/install-info
  21. Requires(preun): /sbin/install-info
  22. %description
  23. The sed (Stream EDitor) editor is a stream or batch (non-interactive)
  24. editor. Sed takes text as input, performs an operation or set of
  25. operations on the text and outputs the modified text. The operations
  26. that sed performs (substitutions, deletions, insertions, etc.) can be
  27. specified in a script file or from the command line.
  28. %description -l ja
  29. sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
  30. エディタです。sed は入力としてテキストを用い、テキストの操作または
  31. 操作のセットをテキストとに対して行い、修正されたテキストを出力します。
  32. sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
  33. コマンドラインから指定されます。
  34. %prep
  35. %setup -q
  36. #%patch0 -p1
  37. #%patch1 -p1 -b .mb
  38. %build
  39. export LANG=C
  40. %configure --without-included-regex
  41. make %{_smp_mflags}
  42. %check
  43. echo ====================TESTING=========================
  44. make check
  45. echo ====================TESTING END=====================
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. %makeinstall
  49. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  50. %find_lang %{name}
  51. %post
  52. /sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
  53. %preun
  54. if [ $1 = 0 ]; then
  55. /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
  56. fi
  57. %clean
  58. rm -rf ${RPM_BUILD_ROOT}
  59. %files -f %{name}.lang
  60. %defattr(-,root,root)
  61. %license COPYING
  62. %doc NEWS THANKS README AUTHORS
  63. %{_bindir}/sed
  64. %{_infodir}/*.info*
  65. %{_mandir}/man*/*
  66. %changelog
  67. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.8-1
  68. - new upstream release.
  69. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.2.2-2
  70. - rebuild with VineSeed environment
  71. * Sat Jul 20 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.2.2-1
  72. - new upstream release
  73. - deleted all patches
  74. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-3
  75. - rebuilt with current VineSeed
  76. * Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
  77. - added Patch1 from Debian (#551075)
  78. Apply patch from WANG Yunfeng to treat incomplete multibyte
  79. sequences as a single-byte character.
  80. * Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
  81. - new upstream release, dropped Patch1 and 2
  82. - added Patch0 from Fedora
  83. * Mon Jun 29 2009 Jiri Moskovcak <jmoskovc@redhat.com>
  84. - added patch to maintain backwards compatibility for scripts using -c/--copy
  85. - Resolves: #502934
  86. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
  87. - rebuilt against current toolchain
  88. - spec in UTF-8
  89. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
  90. - dropped Patch0
  91. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
  92. - added Patch0-2 from Fedora
  93. * Mon Sep 4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
  94. - Fix handling of relative symlinks (#205122)
  95. * Wed Aug 3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
  96. - remove superfluous multibyte processing in str_append for UTF-8
  97. encoding (thanks Paolo Bonzini, #177246)
  98. * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
  99. - #185374:
  100. - Follow symlinks before rename (avoid symlink overwrite)
  101. - Add -c flag for copy instead of rename (avoid ownership change)
  102. * Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
  103. - new upstream release
  104. - run 'make check' on non-English locale
  105. * Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
  106. - s/Copyright/License/
  107. - rebuilt for x86_64 architecture support
  108. * Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
  109. - new upstream release
  110. * Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
  111. - new upstream release
  112. - remove obsolete patch
  113. * Mon Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
  114. - rebuilt for Vine
  115. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
  116. - if not -n, print current buffer after N command on the last line
  117. unless POSIXLY_CORRECT (#112952)
  118. - adjust XFAIL_TESTS for the improved glibc regex implementation
  119. (#112642)
  120. * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
  121. - enable --without-included-regex again
  122. - use fastmap for regex searching
  123. * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  124. - update to 4.0.8
  125. - simplify specfile
  126. - disable --without-included-regex to pass the testsuite
  127. * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  128. - update to 4.0.7
  129. - use "--without-included-regex"
  130. - do not gzip info pages in spec file, "TODO" is not present anymore
  131. * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
  132. - update to 4.0.5
  133. * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
  134. - rebuilt to fix x86-64 miscompilation
  135. - run make check in %%build
  136. * Fri Apr 5 2002 Jakub Jelinek <jakub@redhat.com>
  137. - Remove stale URLs from documentation (#62519)
  138. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  139. - Bump release + rebuild.
  140. * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
  141. - Update to 2000.11.28 patch
  142. - Rebuild for 7.1 tree
  143. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  144. - FHS packaging.
  145. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  146. - compress man pages.
  147. * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
  148. - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
  149. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
  150. - mb patch updated to 1.09
  151. * Tue May 29 2001 <sagami@vinelinux.org>
  152. - 3.02_mb1.08-1vl2: use better macros
  153. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  154. - 3.02_mb1.08-1vl1
  155. - modified %files section to handle compressed man page(s)
  156. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  157. - auto rebuild in the new build environment (release 4)
  158. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  159. - update to 3.02
  160. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  161. - update to 3.01
  162. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  163. - translations modified for de, fr, tr
  164. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  165. - removed references to the -g option from the man page that we add
  166. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  167. - spec file cleanups
  168. - added BuildRoot
  169. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  170. - built against glibc