mpfr-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. Summary: A C library for multiple-precision floating-point computations
  2. Name: mpfr
  3. Version: 4.0.2
  4. Release: 1%{?_dist_release}
  5. Group: System Environment/Libraries
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: inagaki, kenta
  9. License: LGPLv3+
  10. URL: https://www.mpfr.org/
  11. Source0: https://www.mpfr.org/mpfr-%{version}/mpfr-%{version}.tar.xz
  12. # https://gforge.inria.fr/scm/viewvc.php/mpfr?revision=13499&view=revision
  13. # https://www.mpfr.org/mpfr-4.0.2/patch01
  14. Patch0: rev13499.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gmp-devel
  17. Requires: gmp >= 4.2.3
  18. %description
  19. The MPFR library is a C library for multiple-precision floating-point
  20. computations with "correct rounding". The MPFR is efficient and
  21. also has a well-defined semantics. It copies the good ideas from the
  22. ANSI/IEEE-754 standard for double-precision floating-point arithmetic
  23. (53-bit mantissa). MPFR is based on the GMP multiple-precision library.
  24. %package devel
  25. Summary: Development tools A C library for mpfr library
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: gmp-devel >= 4.2.3
  29. Requires(post): /sbin/install-info
  30. Requires(preun): /sbin/install-info
  31. %description devel
  32. The static libraries, header files and documentation for using the MPFR
  33. multiple-precision floating-point library in applications.
  34. If you want to develop applications which will use the MPFR library,
  35. you'll need to install the mpfr-devel package. You'll also need to
  36. install the mpfr package.
  37. %prep
  38. %autosetup -p1
  39. %build
  40. %configure --disable-assert --disable-static
  41. # Get rid of undesirable hardcoded rpaths; workaround libtool reordering
  42. # -Wl,--as-needed after all the libraries.
  43. sed -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
  44. -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
  45. -e 's|CC="\(g..\)"|CC="\1 -Wl,--as-needed"|' \
  46. -i libtool
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. %make_install
  51. rm -f %{buildroot}%{_libdir}/*.la
  52. rm -f %{buildroot}%{_infodir}/dir
  53. #these go into licenses, not doc
  54. rm -f %{buildroot}%{_datadir}/doc/COPYING{,.LESSER}
  55. %check
  56. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
  57. make %{?_smp_mflags} check
  58. %post -p /sbin/ldconfig
  59. %postun -p /sbin/ldconfig
  60. %post devel
  61. /sbin/install-info %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
  62. %preun devel
  63. if [ "$1" = 0 ]; then
  64. /sbin/install-info --delete %{_infodir}/mpfr.info.gz %{_infodir}/dir || :
  65. fi
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %files
  69. %defattr(-,root,root,-)
  70. %license COPYING COPYING.LESSER
  71. %doc NEWS README
  72. %{_libdir}/libmpfr.so.*
  73. %{_datadir}/doc/mpfr
  74. %files devel
  75. %defattr(-,root,root,-)
  76. %{_libdir}/libmpfr.so
  77. %{_libdir}/pkgconfig/*
  78. %{_includedir}/*.h
  79. %{_infodir}/mpfr.info*
  80. %changelog
  81. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-1
  82. - new upstream release.
  83. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  84. - update to 3.1.4
  85. * Sun Dec 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  86. - rebuild with VineSeed environment
  87. * Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
  88. - update to 3.1.2
  89. * Sun Oct 30 2011 NAKAMURA Kenta <kenta@vinelinux.org> 3.1.0-1
  90. - new upstream release
  91. * Tue Apr 19 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-2
  92. - rebuild for Vine 6
  93. * Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-1
  94. - new upstream release
  95. - add Requires: gmp-devel (devel package)
  96. * Sat Nov 28 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
  97. - new upstream release
  98. * Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.1-1
  99. - new upstream release
  100. - applied new versioning policy
  101. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.0-1vl1
  102. - initial build for Vine Linux
  103. * Thu Sep 20 2007 Ivana Varekova <varekova@redhat.com> 2.3.0-1
  104. - update to 2.3.0
  105. - fix license flag
  106. * Mon Aug 20 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-2
  107. - spec file cleanup (#253440)
  108. * Tue Jan 16 2007 Ivana Varekova <varekova@redhat.com> 2.2.1-1
  109. - started